My NSLU2 is a brick?

Discussion in 'Cisco/Linksys Network Storage Devices' started by cosmic, Feb 5, 2006.

  1. cosmic

    cosmic Network Guru Member

    My NSLU2 (2.3 R.63) behaved strangely in different ways, and since I had also misconfigured it, I decided to wipe everything out and start all over. I also wanted to have a FAT32 partition, so I used the Fat32Format tool (thanks for tips, Frusti!) ( and formatted my Maxtor 250 GB drive in Windows XP. Worked like a charm, and disk is perfectly readable and writable when attached directly to a USB port in WinXp.

    The NSLU2 is the problem. It sees the disk, and I can see the files on it. HDD_1_1_1 is defined as a R/W share. Disk is reported as Formatted (FAT 16/32), 100% free space.
    But that's about all I can do. I can't scan the disk - I get message "No disk found". I can't redefine the password.
    I can see the NSLU2 in the network neighbourhood in Explorer , but don't get access to the disk. It asks for a password, but whatever I try as a password, it doesn't take it.

    This is the only disk attached to the NSLU2 (on USB port 1 - I also tried port 2, but no difference).

    I have resetted and/or restarted the NSLU a lot of times. I reflashed with same firmware version (R.63). No difference.

    Question is: have I overlooked something obvious, or is the slug a brick??
  2. d__l

    d__l Network Guru Member

    When only a Fat32 HD is attached to the NSLU2, its functionality is really limited. It only scans ext3 drives and won't scandisk a FAT32 drive. Also the Administration password should have dropped back to admin/admin. This is fixed and can't be changed with only a FAT32 HD attached.

    Under Administration/System, do you have Guest logins and convert failed logins enabled? Also have you set a password for guest accounts when no ext3 disk is available? I've forgotten whether this password even works or not but try to set it.

    Once you finally get access to the FAT32 drive, it will only be Public access.
  3. AtillaThePun

    AtillaThePun Network Guru Member

    I'm having the same issue with a brand new NSLU2 and every disk I've tried to put on it. I have just plugged in a disk to the Disk 1 port and had the NSLU2 format it, still No Disk when I try to set up users and passwords. I tried to set up some shares but they told me there were no folders in the path I specified (true enough, it's a freshly formatted disk) but I have no way to make directories on that disk either, unless I plug it into the USB port on my PC directly and do it there. Then the NSLU2 will read it fine, but won't let me write to it.


    As a footnote, I'm working with 3 HDDs in 2 NexStar enclosures. they all read and write fine when plugged directly into the PC (XP Pro SP2), so the problem is NOT with the drives.

    However it DOES occur to me that I'm accessing the NSLU2 through Firefox. I can't immagine that LinkSys would make such a huge gaffe but I will try it with Internet Explorer when I get home just to make sure the browser is NOT the issue.
  4. cosmic

    cosmic Network Guru Member

    Quite correct, this made the trick. Obviously guest account has to be activated. The "password for guest accounts when no ext3 disk is available" setting seems to make no difference in behavious. God knows the working of this one.

    I really like the idea of running the NSLU2 with a 250 GB FAT32 partition. It works, even though it is irritating that I have to enter login info every time I shift between Administration and User Log in in the web interface. This behavious has also changed with FAT32.

    I don't need a lot of shares, users and groups. 4 folders created in Explorer is enough for me. But what I am concerned about is security, with the default password and enabled guest login and all. Is my disk easily hacked from outside now? Is my firewall, enabled in the router, making its job, also protecting the NSLU2 disks?
    But what about if I want to set it up as FTP server? No password=no protection?

  5. d__l

    d__l Network Guru Member

    I'd say your NSLU2 is as secure as your computer is behind your router. Look to your router settings to make it as secure as possible.

    When you use FAT32, it should either be for LAN usage only or nothing you put on the HD should be of value to you when you make it available to anyone in the public realm.

    Also and probably even more importently, anyone with malicious intent that accesses your NSLU2 GUI from the internet and guesses that the administration ID/PW is admin/admin could reboot your NSLU2 or even worse, reformat your HD to ext3 and then set their own ID/PW as administrator locking you out.

    You can either set a password for FTP guest accounts or the ID/PW is fixed on guest/guest. I forget which, but I think it is the later. So at least there is some password. One thing, FTP anonymous access is not available on FAT32 drives.
  6. AtillaThePun

    AtillaThePun Network Guru Member


    The NSLU makes you enable the Guest account to use it. Disabling that PoS is the first thing any competent admin does after installing Windows...........

    I am astounded beyond belief at this breech of security. What was LinkSys thinking? or were they? Looks like I'll be moving to a 3rd party firmware soon.
  7. d__l

    d__l Network Guru Member

    That is the Guest account on the NSLU2, not on Windows, and you only have to use that IF you make the NSLU2 use its non-native file format!

    I don't believe that the 3rd party firmwares are going to change this functionality much. Mostly they seem to involve adding features to the NSLU2, not revision of existing feature operations.
  8. AtillaThePun

    AtillaThePun Network Guru Member

    Ok, guess I'll have to play with this a bit. I did enable both guest accounts at the same time so I couldn't tell you which one allowed me access. But I did NOT have access with the attached HDD formatted EXT3 (by the NSLU2 itself) until I enabled the Guest accounts. I can't (or rather won't) test this right now because I'm moving my My Docunments folder over to the NSLU2 and that's taking about an hour.
  9. global_dev

    global_dev Guest

    I have pretty good success with the NSLU2 fresh from the box. I did notice that i logged in as guest if I didn't use other user name/credentials options when mapping to that drive.

    since the nslu2 is only as fast as the network it defitnitely will be 1/4 as fast as the drive allows. I tried to move 40 gigs from a usb2 external ntfs hdd straight t my computer and it took a while. I imagine that the NSLU2 connection it would be 1/4 as slow as this. best thing might be to load a live linux cd, mount the hdds and transfer that way.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice