my WAG354G won't let me open a specific https site

Discussion in 'Networking Issues' started by kiwiblade, Dec 9, 2005.

  1. kiwiblade

    kiwiblade Network Guru Member

    Hi all,

    Opening https sites works fine generally from my laptop, wireless connected to my WAG354G. However ... when I try to open a very specific https site (sorry: can't disclose it) via my own WAG354G (v 1.01.03), I cannot connect to it ("the connection has timed out").

    When I then switch to the unsecured network of my neighbour :D leaving everything the same on the laptop, I CAN connect to this specific site. Spooky.

    A suggestion from my IP collegues was: " ... something with DNS settings when the site tries to open another url".

    I've gone through some checks on the router: disabling firewall etc. I think there's nothing too fancy about the setup. Still ... I haven't found the magic checkbox that does the trick.

    Any suggestions (other than keep on using the neighbours network, which is Belkin b.t.w.)?


  2. Funmeister

    Funmeister Network Guru Member

    I'm not familiar with this particular router, but I have seen where some secure sites (personal experience with a very tight email server) will time out if your MTU is not optimized. Does this particular router have an MTU setting on it?

    If so, I would determine your ideal MTU setting and see if that makes a difference.

    To determine your ideal MTU, ensure you are connected through your router, and do the following.
    Open a command prompt:

    PING "Your Internet Provider's URL" –f –l 1492 and press ENTER key

    If you see "Packet needs to be fragmented but DF set." then
    reduce the value by 8 until you no longer get this message. Once you get an accepted value try adding 2 to the value and repeating the test until the message above reappears. Retest at the last accepted value to confirm. Write it down.

    Go to your routers set up page and set the MTU to this value.

    Now try the secure site.

    This is a condensed version of setting your MTU taken from

    Hope it works for you.

  3. simax

    simax Network Guru Member

    If you can't disclose it but can connect to it through your neighbor's unsecured network probably you can live with it.

  4. kiwiblade

    kiwiblade Network Guru Member


    Thanks for the tip. I gave it a try immediately, but no avail. It is a laptop setting anyway, and the laptop was an unchanged factor. I still suspect something (hidden for me) in the WAG354G.


    I sure have a workaround :thumbup: . However, "something's wrong and I'm determined to find it out".

    An extra hint: from a PC that's on my LAN I could reach the site before the linksys was installed (we had a CJT modem back then). After installation it is the same story as for the laptop.

    Weird ... any suggestions remain appreciated.

  5. Funmeister

    Funmeister Network Guru Member

    Are you absolutley sure there is no MTU setting on the router side? I know that computers have their own, but the router is the one that matters. I would look harder for it :thumb:
    I don't think I've seen a linksys router that didn't have that setting. I checked the linksys site though and can't find any info on the WAG354G to be able to check the manual.

    Aside from that, I have no other helpful ideas :sad:

  6. simax

    simax Network Guru Member

    You are really happy and/or you did not get me right.

    What I was trying to say is that it sounds not friendly to say "I can't disclose the website". There's quite educated people around here. Don't understimate this forum.

    Now, concerning the problem it self, a simple troubleshooting analysis.

    1. You said that it USED to work until you installed the Linksys. Your ISP could be ruled out then.
    Still, I would check that the ISP hasn't changed in the mean time. Go back to the old modem and see if you can access the site.
    2. You said you have the same problem connecting through a wired computer on the LAN (not WLAN). This rules the WLAN encryption and packet handling as the problem (which could have been very much the cause).
    3. The error on timing out could certainly be a complete lack of connection to the site. Check your local DNS caches etc. See if you can access the site using some different protocols (http, icmp, etc).


    I'll be less friendly this time: It is absolutely LAME -not to mention from the professional evaluation on security standpoint- to have a website which you can't disclose BUT you can access through your neighbor's open wireless network :thumbdown:


    No offense. Just think a little.
  7. kiwiblade

    kiwiblade Network Guru Member


    I'll check the router once again, more thoroughly. Thanks for your input.


    1. I'm gonna give that a try to see if the ISP hasn't changed anything.
    2. The WLAN part could be ruled out already, since I could reach the site via the neighbours WLAN.
    3. The site can be reach through ping (and traceroute). At first I suspected that some TCP portnumers were blocked. I used etherreal to look into this, but on both routers the portnumbers changed constantly.

    {ERROR: slap_accept_mode is OFF}

    I highly regard users of this forum, especially those who take the time (you included) to try to help less (network) educated ones (like me). In the same way, I hope users respect the fact that I have a good reason not to disclose this specific site, although it can be reached via public internet. Please be assured that I have made the consideration whether or not to disclose it.

    So, I was a bit offended, but hey ... in general I'm a fairly happy guy.


  8. kiwiblade

    kiwiblade Network Guru Member

    I disconnected the linksys WAG354G and connected my old CJ adsl modem. Everything fine, site could be opened.

    Then I reconnected the linksys and ... everything fine. Both from the PC and the laptop, wired and wireless.

    I'm not sure what solved the problem, but a power off/on of the WAG354G somehow solved it.


  9. calum

    calum Network Guru Member

    Irrelevant now, but the 354G certainly does have its own MTU setting... it's right there on the front page of the web interface.
  10. kiwiblade

    kiwiblade Network Guru Member

    I wonder how I could have missed that one!

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice