My Wrt54G gets not showed under My Network Places (UPNP)

Discussion in 'Cisco/Linksys Wireless Routers' started by rfsat, Oct 6, 2005.

  1. rfsat

    rfsat Network Guru Member

    I have just installed a new WRT54G on my Network. I have installed the UPNP Software in Windows XP Sp2 but the router gets not visible in the My Network Places like my older router did.

    Why is that? Why can the WRT54G not be accessed in the My Network Places?
  2. Diavonex

    Diavonex Network Guru Member

    1. You got to enable UPnP on router

    2. You got to enable UPnP on computer

    Enable UPnP on your computer

    Go to Start>Control Panel>Add/Remove programs, click on Add/Remove Windows Components, scroll down to Networking Services, and check Universal Plug and Play.

    Start UPnP.

    Step 1 Right-click on My Computer and click Manage.

    Step 2 Double-click on Services and Applications.

    Step 3 Double-click on Services.

    Step 4 In the right pane, locate the service named Universal Plug and Play Device Host. Right-click the service and select Properties.

    Step 5 Make sure that the Startup type is set to Automatic.

    Step 6 Click Start and then click on OK once the service has finished starting.

    Step 7 Locate the service named SSDP Discovery Service, right-click the service, and select Properties.

    Step 8 Repeat Steps 5 and 6 for the SSDP Discovery Service.

    Run UPnP test:
  3. rfsat

    rfsat Network Guru Member

    Thanks for your help, but I had all that already done. UPNP works but the router isn't visible as a device under My Network Places like my older Router was. It is still not visible there.

    On activating UPNP with my old Router did popup a samll icon in the tray icon about a new found a new Internet Gatway device and after that it was listed in My Network Places. With the WRT54G this "UPNP device found" popup comes not and it isn't visible.

    Again: UPNP works perfect with it but it is simply not visible in MNP.
  4. mstombs

    mstombs Network Guru Member

    same upnp issue here with wrt54gs - and theres a long thread somewhere here with others who also experience it

    could sometimes get the icon but it then dissapears.

    I think the issue is to do with xp firewall & linksys firmware but never got to the bottom of it.
  5. dcorban

    dcorban Network Guru Member

    I had the problem of the router (WRT54G 2.2) disappearing from My Network Places as well. Although, I also had UPnP stop working. Rebooting the router always fixed both issues. A random amount of time later (between 10 minutes and overnight), the router would again stop responding to UPnP and disappear from My Network Places. It has nothing to do with the WinXP firewall. The last firmware I tried was around version 3.0, but I assume the problem still exists since there is no mention of a fix in the newer firmware.

    Are you absolutely sure that UPnP is working?
  6. rfsat

    rfsat Network Guru Member

    Yes 100% as it is listed under Network Connections as Internet Gateway and in tis propety page I can see the openen Ports if I use Mssenger Remote Desktop or any other Messenger function like Voice.

    I have alos run the Intel UPNP DeviceSpy tool and DeviceValidator to test its UPNP functionality. Both tools are reporting no errors and all seems to work as expected. But DeviceValidator delivers one warning for the MX Value test. See this log:

    WARNING: Device not choosing Random interval based on MX value <<Standard Deviation: 0.005823>>
    NOTIFY <<upnp:rootdevice>> OK
    NOTIFY <<urn:schemas-upnp-org:device:WANConnectionDevice:1>> OK
    NOTIFY <<uuid:0014-bf36-20530200cddc>> OK
    NOTIFY <<urn:schemas-upnp-org:service:WANIPConnection:1>> OK
    NOTIFY <<urn:schemas-upnp-org:service:WANPPPConnection:1>> OK
    NOTIFY <<urn:schemas-upnp-org:device:WANDevice:1>> OK
    NOTIFY <<uuid:0014-bf36-20530100cddc>> OK
    NOTIFY <<urn:schemas-upnp-org:service:WANCommonInterfaceConfig:1>> OK
    NOTIFY <<urn:schemas-upnp-org:device:InternetGatewayDevice:1>> OK
    NOTIFY <<uuid:0014-bf36-20530000cddc>> OK
    NOTIFY <<urn:schemas-upnp-org:service:Layer3Forwarding:1>> OK
    MSEARCH <<ssdp:all / upnp:rootdevice>> OK
    MSEARCH <<ssdp:all / uuid:0014-bf36-20530200cddc>> OK
    MSEARCH <<ssdp:all / urn:schemas-upnp-org:device:WANConnectionDevice:1>> OK
    MSEARCH <<ssdp:all / urn:schemas-upnp-org:service:WANIPConnection:1>> OK
    MSEARCH <<ssdp:all / urn:schemas-upnp-org:service:WANPPPConnection:1>> OK
    MSEARCH <<ssdp:all / uuid:0014-bf36-20530100cddc>> OK
    MSEARCH <<ssdp:all / urn:schemas-upnp-org:device:WANDevice:1>> OK
    MSEARCH <<ssdp:all / urn:schemas-upnp-org:service:WANCommonInterfaceConfig:1>> OK
    MSEARCH <<ssdp:all / uuid:0014-bf36-20530000cddc>> OK
    MSEARCH <<ssdp:all / urn:schemas-upnp-org:device:InternetGatewayDevice:1>> OK
    MSEARCH <<ssdp:all / urn:schemas-upnp-org:service:Layer3Forwarding:1>> OK
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice