My WRT54G v3.1 a brick after upgrade to v23.b2?

Discussion in 'DD-WRT Firmware' started by Linksysinformer, Dec 14, 2005.

  1. Linksysinformer

    Linksysinformer Network Guru Member

    I needed to go from hyperwrt to dd-wrt so I flashed it to ddwrt mini generic version v.23b2 without any problem.

    After that was successful, I upgraded it to v23 std b2, the screen says upgrade complete, but right now I am not getting a DHCP ip address from the unit.

    How do I know if it's dead? How do I rescue it now?! Is this just a continuation of a string of bad lucks I am having?
  2. brucebeh

    brucebeh Network Guru Member

    give it a few minutes, then unplug the power and plug it back in.

    it worked for me :cheer:
  3. gaster

    gaster Network Guru Member

    no problem, DHCP doesn't always work so you need to check the box for DSNmasq on the main setup page

    also people say DHCP and DNSmasq are both slow so be patient:

    if you don't get an IP you could set one yourself that will be appropriate....say the router is then set your computer to or something like that
    then open your browser and try
    then check the box for DNSmasq on the main setup page and save
    it reboots and you should be good to go
    don't forget to change the IP address on your computer back to the automatic settings
  4. gaster

    gaster Network Guru Member

    or just connect wirelessly and make that change
    that might be easier
    this is assuming it isn't a brick, it just seems that way since you can't get an IP
  5. Linksysinformer

    Linksysinformer Network Guru Member

    oh no, this might just be a brick.

    I have tried manually resetting ethernet card to 192.168.1.x but pinging via cable or through wireless both do not yield any login screen or password prompt.

    It seems like a more "invasive" method of pin shorting, which I have never ever do in my life, is required to "resurrect" my poor WRT54G?
  6. zazc

    zazc Guest

    recover from brick

    Had the same problem as you, was able to recover from bricked router WRT54G.

    I downloaded the stock linksys firmware (4.20.7 i belive) and it has a built in upload wizard; pretty easy actually!

    The first time i tried it it failed. well alot ;)

    So I reset router several times until finally it started to upload the linksys stock firmware! And since then no problems!

    Basically what I think got the linksys firmware back from being bricked was that right after the power light stopped flashing from reseting router I clicked on upgrade button and started. Please note this took several tries... reseting / sometimes powering on and off and then clicking on upgrade! Very tiresome but it did work which was the end result and my router be fine now :)

    Good luck! Let me know if it works for you as well!
  7. dellsweig

    dellsweig Network Guru Member

    I upgraded my V2 (54G) tfrom 12/12 to 12/14

    Bricked solid - NONE of the revival methods worked.

    I will wait to see if there is a re-release - this is not good
  8. Linksysinformer

    Linksysinformer Network Guru Member

    Re: recover from brick

    Thanks for the tip zazc, did you set the ethernet card on your PC to "obtain IP automatically" or 192.168.1.x like was suggested here by someone else?
  9. Linksysinformer

    Linksysinformer Network Guru Member

    I have tried zazc's method, yes the linksys auto firmware upgrade utility v4.20.7 is getting me closer, but not quite there.

    By clicking on "next" many times right after the power stops flashing and dismissing the "can't find the router" dialog box whenever it popped up, I was able to get to the page where there is an "upgrade" button to press.

    After pressing on "upgrade", the firmware process starts but after 1% it would stop and give message "unable to get response from server"

    I have tried this more than two dozen times, and not a single time did it go past 1% progress, any more suggestions, guys?

    I have tried setting the ethernet card to from 100 to 10Mbps (half duplex), no difference. I have also tried setting ethernet to "obtain IP automatically" or a manual IP, both same results.

    Throughout this entire process, I notice there are outgoing packets from the ethernet card, but nothing receiving from the router, so any hope left without voiding my warranty or opening the box? There is a big sticker spanning the edge of the box, if I attempt to open the box to put it in "fail-safe" mode, I will definitely break warranty.

    I have also even tried sticking the ethernet cable to the WAN port, nothing works so far.
  10. Linksysinformer

    Linksysinformer Network Guru Member

    To hell and back!!!

    Following gaster's advice on

    And then followed by linksys "management mode" procedure:**&p_li=&p_topview=1

    I was able to REVIVE my deadly bricked WRT54G!!! :clap:

    I am NOT using DD-WRT v23 ever again after this episode of hell, with all due respect. DD-WRT v22 was excellent, I am gonna wait until the final version DD-WRT v23/v24 this time.
  11. Gene

    Gene Guest

    A newbie, three new WRT54G units, version 3.1

    I just bought the three units. Now I want to upgrade them with DD-WRT so that I can do a WDS network.

    I have upgraded firmware in Linksys boxes before, but never have I run any Linux firmware upgrades. What is the safest version to use?

    Thanks for any direction.

    The project is for a personal demo in an RV park.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice