NAS200 FAQ (Frequently Asked Questions)

Discussion in 'Cisco/Linksys Network Storage Devices' started by jac_goudsmit, Dec 24, 2009.

  1. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    This message is the "official" Frequently Asked/Answered Questions list for the Linksys NAS200. If you asked a question in a forum and someone answered with a link to this thread, it means your question was asked and answered before. Please don't feel insulted.

    If you would like a question/answer to be added to the list, post a message in this thread and I will consider adding it.

    H1. What hardware is in the NAS200?
    The NAS200 has an RDC 3210 System On Chip. This basically emulates a headless PC running a 486SX processor at 133MHz, but according to the Bogomips value the performance is closer to 100MHz.

    Here's a list of some of the other hardware inside the NAS200:
    • RAM: 32MB MIRA P2V56S40BTP or ProMOS V54C3256164VD. There is an unpopulated location for a second RAM chip.
    • Flash: 8MB Intel JS28F640P (1.75MB kernel, 6MB root filesystem, 128K configuration, 128K bootloader)
    • SATA: InterSIL SiL3512ECTU128
    • Ethernet: RDC R6040 MAC (on board the RDC3210), IC+ IP101A PHY
    • Real Time Clock: Seiko S35390A

    The off-the-shelf firmware is based on Linux kernel 2.6.19 but contains many patches for the RDC chip and its network controllers. The RDC gained official support in the mainline kernel in version 2.6.27.

    H2. Why is my NAS200 so slow? How can I make it faster?
    The NAS200 is intended as a cheap bring-your-own-disk NAS for use at home. Linksys tried very hard to make it as cheap as possible and one of the decisions they made was to use low-performance hardware. There's really not much that you can do in software to make it faster, except change the file system from journaled to non-journaled (by reformatting the disks).

    The slow speed becomes obvious especially with large hard disks installed: formatting a large disk takes many hours, booting with a full 1TeB drive takes a half hour because the quota check takes extremely long even if you didn't assign any quotas. When running my firmware, extra time is needed on the first boot to generate the encryption keys.

    H3. Is it possible to overclock the CPU in the NAS200?
    According to the data sheet, it's possible and not very hard (basically a few resistors to pull a few lines high or low during reset) to overclock it from 133MHz to 150MHz but no-one has tried this yet. It probably won't do you much good. You might get a much better result if you just replace the motherboard with a small PC motherboard like a Via Nano (but at the time of this writing, all Nano mobos only have one SATA port). If you do so, be sure to take pictures!

    H4. Can I solder an extra RAM chip onto the unpopulated location?
    You can (if you have steady hands!), but it probably won't help you. First of all, no-one outside Linksys really knows if that location is meant for another 32MB chip or if it's in the layout for cases where two 16MB chips would be cheaper than one 32MB chip. Secondly, it's unknown if all the necessary logic is available to select a second RAM chip when necessary. Thirdly, there is no BIOS and the RAM memory table is hard coded in the boot loader, so even if you get the hardware to work you will have to make a software change too.

    D1. How are the hard disks formatted?
    Since version V34R75, the firmware lets you choose between journaled and non-journaled format, at the time you format your disks. You can't change this without reformatting. The XFS file system is used in journaled mode, and ext2 is used in non-journaled mode. Journaled mode is about 50% slower than non-journaled mode (4MB/s vs. 6MB/s) but with journaled mode you're much less likely to lose files in case of a power failure.

    When you format a hard disk from the web GUI, the disk is also partitioned: the first partition contains data, the second contains configuration information and the third partition is a swap partition. The only partition that's visible to the user via the web GUI, FTP and Windows networking is the data partition. The size of the data partition depends on the size of the disk, but the configuration partition and the swap partition are always the same size: 240975 and 120487 blocks respectively.

    The firmware uses mdadm to set up RAID partitions. When the disks are set up in RAID mode, the config partitions are used in RAID mode too.

    D2. If my NAS200 would ever break down, would it be possible to access the data on the disks from a PC?
    The NAS200 uses a standard DOS style MBR to partition the disks, and it uses standard Linux file systems and RAID software to store its files, so if you have a Linux PC, it shouldn't be hard to access your data.

    From Windows it's a lot more difficult; there are programs such as ext2ifs to access ext2 (non-journaled) partitions but there's no Windows software to access partitions formatted in XFS (journaled) -- you may find broken links to an old program that could do XFS but it was reputed to be extremely unstable and I'm not even going to mention its name here.

    The easiest way to get to your disks directly by connecting them to a PC via SATA or eSATA is to download SytemRescueCD, create a bootable CD-ROM or USB stick from it and boot it up. SystemRescueCD is a Gentoo-based Live Linux CD that contains a number of disk tools such as gPartEd that are intended to set up a PC, backup and restore a PC's hard disks and restore a non-working PC to working order. It understands all the file systems that the NAS200 uses, including RAID configurations (I didn't test RAID). I used it successfully to transfer a large amount of data between my two NAS200 disks (one formatted in XFS, one formatted in ext2) and to/from my Windows computer's hard disk (NTFS).

    Note, I still recommend making backups! If your NAS200 dies, there's no guarantee that you will be able to get to your data.

    D3. I pulled a hard disk out of my Windows PC but the NAS200 doesn't recognize it. What's wrong?
    The NAS200 insists on using its own partitioning scheme and file system. You have to use the Format option in the web GUI to set up your disks, which will erase all data that's already on there. The only way to put the data on there with the standard firmware is to copy the data over the network.

    You can install an alternative firmware to access your data on a "foreign" disk from the command line by manually mounting partitions. However, the NTFS driver in most firmware versions (such as JacX) is read-only. Also, the Linksys firmware won't share a "foreign" drive through the web GUI unless you mount it on a directory that's on another disk that's not foreign. Post a question to the forum and we'll see if we can find a solution for your specific situation.

    D4. I saw somewhere that the NAS doesn't support hard disks that are bigger than 750GeB. Is that true?
    When the NAS was developed, there were no disks larger than 750GeB so they kept the specs safe and said that nothing larger would be supported. However several people have reported success with larger drives, and no-one has reported any problems with larger disks. The only problems with large drives is that they take a LONG time to format: for example my 1TeB Western Digital Green Caviar took the most part of a day to format.

    D5. I have a large hard disk and I'm having trouble formatting it, what can I do?
    Be patient, large disks take a long time to format. My 1TeB drive took the better part of a day to format in Separate Disk mode, in RAID1 mode it's going to take even longer because the RAID management software copies every sector from one disk to another.

    D6a. My disks run very hot! What can I do?
    D6b. My unit worked fine at first but now it's getting flaky / it stopped working / I can access the web GUI but not my files. What's going on?
    The stock fan in the NAS200 is unfortunately grossly under-dimensioned, and it's unable to keep the unit cool if your disks run hot. If the disks run too hot, they will stop working, hopefully they will start working again when they cool down.

    Several people have replaced the fan in the NAS with a bigger type, by using a Dremel to open up some fake holes on the side and to cut a hole in the interior that's big enough for a 50mm or 60mm fan (Google for "nas200 replace fan" without the quotes). If you only have one drive, you may be able to stick a fan in the other drive bay (you will have to find a way to power it though, and you won't be able to do that without breaking the "Warranty Void" stickers). Depending on the fan you get, it may even make your system quieter!

    Using cool-running "green" type hard disks in the NAS200 is highly recommended. They stay cooler (though my WD Caviar Green still gets pretty toasty!), they run quieter and they use less electricity. They run at a lower RPM to do all this, but you won't notice the difference in access times on the NAS200 because the motherboard hardware is the bottleneck, not the hard disk.

    D7. My external hard disk (or memory stick or whatever) doesn't work on a USB port. Why?
    The NAS200 stock firmware only supports Mass Storage devices, which must have a single FAT/FAT32 or NTFS partition. If your disk is NTFS formatted, the NAS won't be able to write to it. Hubs are also not supported. Neither are printers (see question F1).

    Windows problems
    W1. Why don't I see my shared directories? Why do I get an "out of resources" error?
    Go to the web GUI of your NAS and on the System Options, turn off the "Convert Failed Logins to Guest Logins" option near the bottom of the page. The problem is that Windows will submit your Windows login credentials (username and scrambled password) to the NAS when you connect to it initially. If your user name and password don't match and the option is enabled, you will be logged in as guest without knowing it. If you switch the option off, the NAS will send an error back to your Windows machine which will prompt you for your user name and password.

    The "out of resources" error message doesn't make sense but is caused by the same problem.

    W2. Why do Vista and Windows 7 display an Exclamation point in Device Manager?
    Windows Vista and Windows 7 think that they need a driver for the NAS but no such driver exists, and none is needed. You can ignore the exclamation mark in the device manager or you can switch off the UPnP server in the NAS so it won't get detected.

    W3. I'm having trouble using Offline Files with Vista / Windows 7?
    For this feature, the Opportunistic Locking feature in Samba needs to be disabled (source: this thread on the Microsoft discussion boards and other locations). Unfortunately this is not possible with the standard firmware, but with my firmware you can create a custom script that automatically adds options to the Samba configuration at startup time:

    # Save this as /harddisk/volume_*/data/rc.d/rc.sambaconf
    # The volume number depends on your configuration
    # Helper subroutine, to save some typing
    echo $1 >>/etc/samba/user_smb.conf
    # These options help to make offline files in Vista and Windows 7 work.
    samba_option "oplocks = yes"
    samba_option "level2 oplocks = yes"
    samba_option "kernel oplocks = no"
    # In addition, the following 4 options may be needed to make offline 
    # files work, depending on your requirements.
    # The "map * = yes" options store the given attribute in one of the 
    # Linux access bits which are normally used for other purposes 
    # (read the Samba man page for more information). This is a useful
    # feature if you're the only user of the NAS or if you trust everyone
    # on your network, but it may cause problems in cases where file
    # protection is important.
    # The "create mask" option is needed if the "map" options are used.
    #samba_option "create mask = 777"
    #samba_option "map archive = yes"
    #samba_option "map system = yes"
    #samba_option "map hidden = yes"
    # See question W4 for more info about following option
    samba_option "use sendfile = no"
    Thanks griffag for verifying this!

    W4. When I copy a lot of files to my NAS200, the transfers seem to go slower and slower and eventually I get disconnected. What's going on?
    It's not exactly clear why this happens, but it's a known problem. Apparently whenever you copy a lot of files to the NAS via Samba (Windows Networking), Samba slowly but surely uses up all the memory of the NAS. If you disconnect, the Samba daemon stops and frees up the memory.

    It looks like the problem can be alleviated by adding the "use sendfile = no" option to the Samba configuration (use the script from question W3).

    Furthermore it helps to symlink the /var/log and /var/lock directories to the hard disk so that they don't use up any memory (they're mounted in RAM and seem to grow indefinitely). On my firmware you can create a script similar to this:

    # Save this as /harddisk/volume_*/data/rc.d/rc.relocate
    # The volume number depends on your configuration
    # Helper subroutine to save some typing
    rm -Rf $1
    mkdir -p $1
    rm -Rf $2
    ln -s $1 $2
    # replace volume_1 by volume_3 if you're running in RAID mode!
    relocate_ramdir /harddisk/volume_1/conf/.varlock /var/lock
    relocate_ramdir /harddisk/volume_1/conf/.varlog /var/log
    relocate_ramdir /harddisk/volume_1/conf/.vartwonkymedia /var/twonkymedia
    Media Player Trouble
    M1. Why does my (insert media player here) not work with the NAS200?
    The NAS200 uses the Twonky media server but the version on board the stock firmware is out of date. You can install my firmware and follow the instructions that come with it, to run an updated Twonky server from the hard disk.

    Unfortunately the latest Twonky servers (5.1 and higher) don't work with current versions of my firmware (as of January 2010) because they require newer versions of the libraries than the NAS200 has on-board.

    F1. How about adding a printer server on the USB ports?
    This is not very difficult to implement, but it would be a support nightmare for me. Most printers nowadays are multi-function (with built-in scanners and faxes and whatnot) or at least require a two-way connection to Windows because the driver wants to keep track of the status of the ink cartridges. I would prefer to work on a remote USB server that allows you to share printers, scanners, webcams, and other cool hardware via a virtual USB port that all computers on your network can connect to.

    F2. I'm trying to run (insert application name) on JacX and it doesn't work. Why?
    Because the libraries are old and not all libraries are there (particularly the libstdc++ library). You could set up something similar to what I did with Jungle Disk Server Edition (JDSE): figure out what libraries your program needs, pack them all up and copy them to the same location as your program, then use an LD_LIBRARY_PATH override or even a direct startup of* (like I did with JDSE).

    F3. Is it possible to run (OpenWRT/Gentoo/Debian/Whatever) on the NAS200?
    Sure... All you need to do is configure and build a kernel, test it until it works and... Hello? Are you still there?

    Seriously, once you have a kernel that runs on the NAS200 you can pretty much run any Linux distro. Just keep in mind that:
    • There is no video card and there is no keyboard or mouse. The console is the serial port.
    • All the cool stuff that goes on with the LEDs and buttons happens in customized parts of the kernel.
    • If you flash a Linux that doesn't have the Linksys software (web server, web pages, closed-source libraries...), it will be difficult to switch back to the stock firmware. Tip: take a look at my /init script to find out how to loop-mount a Linksys firmware image at initialization time; this will allow you to start the Linksys firmware from another location (e.g. CD-ROM, USB or hard disk) and use the web GUI to flash another firmware into the ROM.

    If you are seriously interested in this, ask a question in the forum. You will probably need to build a serial port (and void your warranty) to get started.

    On the other hand, you can probably get quite far by just unpacking a root filesystem of a working (i386) Linux to the root of one of your NAS200 hard disks (make sure the access rights are correct). Then you mount the proc filesystem, bind-mount the /dev directory and chroot to the directory from an SSH prompt. Most software will run just fine inside a chroot but you may run into problems with programs that require security (like PAM), or need a GUI, or interface with some sort of device in a subtle way that's not supported.

    F4. I'm 7331 & I figrd out how 2 h4x0r N2 Redboot. Then I typdz "flash" on teh Redboot cmd just 4 gits & shigglz, nothing hapd but Ftr I reb00tz, it don wokrz no moar, teh litez stay on & therez no beep.
    You're so 'leet you erased your boot loader. Go look up the word "JTAG" and meet me in the forum, I'll help you revive it, I've done it too. But you will have to type full sentences like your momma told you, and if you talk "leet speak" I will answer in Dutch.

    X1. (In a personal message) My NAS is broken, can you help me?
    Please don't send me or anyone else private messages about a problem you're having with the NAS200. Let others learn from your problems and our solutions by posting your questions in the forums.

    X2. My NAS stopped working. What's wrong?
    That's not how it works. YOU tell us WHAT's wrong and we'll try to tell you WHY. Give us a clear idea of what you see and hear, what you did before it broke, what error messages or light patterns or beeps you see or hear, and what you've already tried to fix the problem. Thanks!

  2. Still_Awake

    Still_Awake Networkin' Nut Member

    More info on the fan, that needs to be stickied.

    The NAS200's fan has 2-speeds controlled by the on-board transistor-type speed controller. This is switched by a thermister somewhere. Or rather, there are three speeds if you consider Off, as well as Low and High.

    When the fan breaks down physically, operation at the lowest speed is lost. This is why most NAS200s become noisy: As the system heats up, the low speed should come on to keep things cool. However the fan remains inoperative, and the system continues to heat up to high levels. The High (or 'emergency') fan speed is then brought on to prevent damage occurring to the disks, This speed is very noisy and unpleasant. Once the system has cooled down to a normal operating temperature, the high speed will be de-activated and the fan return to Low-speed mode (at which the fan jams again) so the system heats up again. This cycle repeats, effectively causing a continuous on/off of the fan which is most unpleasant.

    How fast each fan fails depends on heat, use, dirt and humidity, but looking at it and other fans I'd give it a year of 24x7 operation at the outside. :). Note that by design, the NAS200 only uses the fan when the system is being used as the disks spin down and create no heat- the low power functionality of the device is one of its great strengths.

    It is hard for anyone to see who has one with a noisy fan, but once one removes the lower case sections so the fans can breathe in the open, especially with low power drives, low heat operation is easy to achieve. Mine has no fan and green 2TB disks- the disks are bare drives bolted together with parts of an old drive rack. Soon I may 'fashion up' a slightly less utilitarian rack out of 2 old Celeron heatsinks- not so much to provide maximum cooling, more to provide maximum 'cool'
  3. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Hi Still_Awake,

    How did you find out the fan has 2 speeds? As far as I can tell the fan only has one speed (if you don't count "off" as a speed :)

  4. xooxoo

    xooxoo Networkin' Nut Member

    Installation printers

    Hi jac.
    I am trying install USB redirector on my NAS200, with JAC4, (question F1) but don't having success.
    I follow the instruction into, and get the msg:
    *** Installating USB Redirector for Linux 2.1.1
    *** Destination dir: /usr/local/usb-redirector
    *** Checking installation...
    *** Detectingsystem...
    *** distribution: debian
    *** kernel: 2.6.19
    *** Clearning up installation...
    *** Installation failed!
    ??? Can not parse kernel version.

    Well, I'm a newbie on Linux and would like your help to solution this question. How to install the USB redirector?

  5. xooxoo

    xooxoo Networkin' Nut Member

    What's distro run on my NAS200?

    What's distro run in NAS200?
    How to discover this?
  6. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The NAS200 runs a custom version for Linux 2.6.19 (x86). Sercomm made the firmware for the NAS200.

  7. chaulis

    chaulis Networkin' Nut Member

    Hey there Jac, I just installed the firmware and attempted to use SSH with root/root but could not log in. Is there a method to check to see if the keys were generated which kicks off changing the root password to root? Or do you know of an alternative root password which may have been used. I know the firmware installed because SSH and twonky are running (per nmap) which wasn't present before. Thanks in advance!
  8. jag_mex

    jag_mex Networkin' Nut Member

    Hi Jac,

    currently I'm running my NAS200 with the standard firmware ver.3.4R79 and RAID1 config. Now, that I got a new laptop with Win7, I've the offline file problem. While looking for a solution, I found your JAC4 firmware threads. My main question is: Will an upgrade to JAC4 wipe the current content of my HDD's?
  9. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    No. The upgrading process doesn't change any of your files, and the configuration of your NAS will remain the same, too.

    Also, if you decide that you don't like my firmware after all, you can use the web GUI to flash the original firmware back.

  10. aajmj

    aajmj Serious Server Member

    I lost communication (bad cable) with my Nas200 when upgrading firmware from stock to Jac4. Now stuck. Power light is flashing green/orange ethernet and drive lights normal. Is there any way to take it out of "upgrade" and load Jac4 or any firmware for that matter? Hasn't been powered off and I can get to the web gui. Not afraid of a little modding if needed.
  11. ninny

    ninny Serious Server Member

    Hi jac, yerstday i download your firmware NAS200_V34R79jac4 and so i uploaded my NAS200 using gui interface. The upload process ran fine and nas200 reboot correctly and after a resoneable time i had again gui interface. But is a problem :) ! My nas 200 is unchanged in every feature, also the password of admin user is unchanged. Nothing about ssh in gui interface and if i use winscp to test ssh on nas200 i have the following message:

    connecting to host .....
    authenticating .....
    Using username "admin".
    Authenticating whit pre-enterd password
    Access denied.
    Access denied.
    Access denied.
    Access denied.

    I tried to re-upload the NAS200_V34R79jac4.bin but nothing again is changed
    On upload section i get the following:

    Current Firmware Version: V3.4R79

    I am looking forward for a your replay and to use your firmware
    Thank you for your time
  12. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    You won't notice from the web GUI that JAC4 has been installed: I didn't make any changes to the web pages.

    You can't log in to SSH (including WinSCP) as Admin, or as any other ID that you create or modify from the web GUI. You have to log in as root.

  13. ninny

    ninny Serious Server Member

    wauh now i log-in my nas with winscp using username root password root :)

    thank you !!!
  14. agent orange

    agent orange Serious Server Member

    Jac, first off thank you for continuing to answer questions about such a legacy piece of hardware!

    I just installed two fresh 1.5TB drives in RAID1, then updated the firmware to Jac4, then moved 160GB of pictures onto the new storage. All seemed to go well. After the file transfer was shown as complete (16 hours later...) I was still able to connect to the NAS webpage and it showed that the array was in the process of rebuilding/mirroring, and the disk 1 and disk 2 lights were flashing steadily. I shut my computer down for the night and left the NAS200 running.

    Now that the Disk 1 and Disk 2 lights are steady I can no longer connect to the NAS. I have restarted the NAS, tried a different cable, tried waiting, tried discovering the NAS through the OEM setup utility, nothing seems to work. When I plug in the ethernet cable, the port shows activity however my router does not show any sharedstorage in the DHCP client table, so it's not picking up an IP somehow?

    Any thoughts?

    Edit: *facepalm* nevermind... switched the port at the *router* end and somehow that woke the NAS up and it's running fine... weird behaviour, but hey it's working!
  15. mvesco

    mvesco Reformed Router Member

    Hi Jac,
    A power system failure in my office building shut down my NAS with data stored plus the entire network. Once up, the DHCP had a new lease and changed the address of each computer (including the NAS). After retrieving the location of the NAS, finally could access the welcome screen with the browser. However, I cannot access the data stored inside whether as a user or as an administrator. I cannot map it either from My Computer. I tried the admin/admin combination but does not work. I can only enter as a Guest, but it is of little use since the Guest account does not have any access priviledges.

    Any thoughts? I am considering resetting but am afraid I will lose the data stored.
  16. Les Walsh

    Les Walsh Network Newbie Member

    I am wondering if there has been a reply or update to this question?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice