NAS200 lost communication during firmware upgrade stock to JAC4

Discussion in 'Cisco/Linksys Network Storage Devices' started by aajmj, Aug 12, 2012.

  1. aajmj

    aajmj Serious Server Member

    Lost communication to Nas200 about 30 seconds into upgrade from stock V3.4R79 to JAC4.. (bad cable) Any hope? Lights look normal* (note below) on Nas power, ethernet, and drive. I plugged the cable back in when I noticed and it has been stuck in "upgrade" ever since.. ( about 12 hours now) I would like to try and save the Nas but not sure how to proceed. I have a spare and no data is involved since I was still setting up the system. Still attached and powered on. Warning says not to power off the Nas while upgrading but I am afraid that losing communications might be as bad.. I can still access the web gui from another computer. Using XP and or Ubuntu 12.04.
    The power light is flashing green and orange as it should be when flashing firmware.
  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    If you can still access the web interface from another computer, try doing the firmware upgrade from there.

    Make sure the firmware file has the correct size and (if you can) check if the md5 checksum is correct (check the Jac4 article to see what it should be).

    If you can't upgrade the firmware from another computer, try shutting down the NAS200 the normal way by pushing the Power button. Normally that should beep and then (after a few seconds) turn the NAS off. Then use the power button to turn it back on.

    If you can't turn the NAS off with the power button, you'll have to unplug the power and plug it back in. Then push the power button to turn the NAS on.

    When you turn the NAS on again, all the lights will initially turn on. Then after a second or two, most lights should go off again. That means the boot loader is working and has loaded the kernel. If the boot loader is working, it means it will be pretty easy to rescue the NAS and you may not even need any extra hardware.

    After a while (a few minutes?) the disk light(s) should go on, indicating that your disks are detected. A bit later, the NAS should beep indicating that it's online and ready. Then you can try the normal firmware update procedure again.

    If the green lights stay on after you restart it, it means that something has seriously gone wrong. It is ALWAYS possible to unbrick the NAS200 (even if the ROM got wiped clean by accident) but you may need a bit of hardware. If it ends up getting this bad, I'll be happy to help you.

    Meanwhile, you can copy the data from your hard disks by connecting the hard disk to a PC with a SATA to USB cable and using SystemRescueCD.

  3. aajmj

    aajmj Serious Server Member

    I could see the nas200 from another computer, access the web gui but showing hung in upgrade.. I couldn't get it to shut down normally or long press so I pulled the power cable waited a bit and plugged it back in..Pressed power.. All lights came on at first then most went out.. waited .. lights went normal and steady as if nothing is wrong.. ( I got a little excited ) . But ...after checking the MD5 sum with your Jac4 post, which was fine, I tried to enter the web Gui again and it hung on "connecting" in the browser(s). Tried Firefox Explorer and Chrome. I can see the Nas in my routers "attached devices" page.. Tried resetting but no beeps after more than a minute.. tried shutting it down using the power button but that didn't work. I haven't lost anything on the drive as I was still experimenting with how I want to set it up.. Thanks Al
  4. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    If you do a hard shutdown like that, it may take a while to come up again because the file system check takes a long time, especially with large disks. Did you wait to connect to the web interface until after the power-up double-beep? Normally there is one beep right at power-up, then two more beeps after a few minutes, when it's ready.

  5. aajmj

    aajmj Serious Server Member

    I actually left the room while it was booting. I saw all lights on and then change to only power and ethernet. Then I left for some reason or another and when I came back an hour or so later the drive light was also on solid... I am at work now but will try again when I get there.. it is a 2TB drive so if it runs a scan it will take quite a while...I tried the web this morning after about 9 or 10 hours. Oh yeah, after the initial power cycle and gui failure I tried resetting it but no response from the reset button after more than a minute of pressing. Then tried the power button to see if it would cycle.. no luck. ....................Home now......Ok I unplugged it again and powered back up. I heard the beeps (single and double) and lights look good. I can see the Nas through the routers gui but can't get to the Nas through the web .. it won't reset or power down using the buttons. fan is running. I can't think of anything else that might be useful.
  6. aajmj

    aajmj Serious Server Member

    Now only the ethernet light is on ( after the 2nd power cycle ) .. I tried powering down again (3rd cycle). The Buttons not working. When I plugged it back in and turned it on it ran through the start up routine with all three beeps and settled into power, ethernet, and drive green and solid... After some unknown period of time (but less than an hour and a half) the power and drive turned off.. That is twice ...after the original cycle lasted about 20 hours. If this is too much information I'm sorry .. just not sure if it is important or not. Thanks Al
  7. aajmj

    aajmj Serious Server Member

    I don't understand what happened but I was able to power down normally.. Started up and waited overnight.. I logged in this morning and was able to get to the web gui..and Administrative pages.. No longer stuck in firmware upgrade so I tried again. Finished the upgrade and saw a message saying something like " will reboot in 30 seconds ". I pressed ok and waited for the beeps. ( I couldn't see the NAS200 ) After a minute of not hearing them I went to investigate. Everything is normal.. ? I mean that is great but Did it fix itself? or was it a timing issue because of the big drive? I was actually looking forward to working this problem out because (if you haven't figured it out yet) I haven't a clue and would love to learn by hands on experience. ... Anyway thanks for your help and patience. By the way I read through some of your posts and am amazed at how knowledgable you and your fellow gurus are.. Maybe some of it will soak in... Thanks Al
  8. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The NAS should not power down by itself so I'm thinking you may have some other hardware problem, or your fan is not keeping your hard disk cool and it's shutting itself down. This is a common problem with the NAS200: the air flow in the case is wildly inadequate for hard disks that produce any amount of heat. I have a Western Digital Green drive (1TB) in there which is supposed to produce less heat than other drives, and it really does. But even with my fan replaced by a 50 (or was it 60) mm fan, it still gets almost too hot to touch. Heat wears the disk like nothing else (in my experience) so I avoid turning the NAS on at all nowadays, unless I need something from it.

    Anyway if you installed my firmware, it will take (quite) a few minutes before it boots the first time because it has to generate the encryption keys for dropbear (ssh) and that takes a few minutes extra. It only has to do this once.

    With all the quota checking and everything else that happens on startup, and with my hard disk getting pretty full, my NAS200 takes a good long time to boot up, I think it's something between 10 and 20 minutes until I hear the double beep now. So be patient.

    Either way, don't trust your data to this NAS (alone): it sounds like you shouldn't expect anything from its stability right now, so make backups. And no, a RAID mirror is not a backup.

    Sorry I don't frequent this forum very often anymore... I still support my firmware as much as I can, but I don't develop it anymore; I've moved on to different things (see and since the forum software was updated a while ago, I don't get emails anymore when someone posts a message here. :-(

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice