NAS200 Media Server Problem

Discussion in 'Cisco/Linksys Network Storage Devices' started by EgyptianPrince, Jun 12, 2009.

  1. EgyptianPrince

    EgyptianPrince Addicted to LI Member

    Hello, All:

    I just bought, and RMAed, LinkSys NAS200. The problem that I am having is with the Media Server... is the static IP, so under Windows XP, when I double click the Nas200_Media_Server, the web browser loads up and I get a big red screen with the error message:::

    Access is restricted to MediaServer configuration!

    However, under, it seems that the NAS is correctly reading Media Files...

    But it's not streaming it at all... under, it seems to be listing the files correctly (with download links), but is being disabled....

    I tried installing the modded firmware, but same problem.. I can't login via Telnet to disable the password, let alone the existing Twonky Media Server still failed under the new patched firmware....

    LinkSys Tech support is useless... they said it's not their problem!!!

    Any help is much appreciated.
  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    If you RMA'd it, that means you're returning it. So why all the questions?

    The Twonky server announces itself via UPnP and broadcasts its own configuration page. However in the standard Linksys firmware the configuration pages are not present, you have to configure Twonky via the usual Linksys web interface. If you want to update Twonky with a more recent version you will have to install my Jac2b firmware and follow the instructions. That will still not give you access to the configuration pages because by default the Twonky server doesn't allow anyone to access the config pages except on the same system as where the server is running. You will have to create a small script in the right location that starts the Twonky server with some extra options that allows your entire network to see the config pages. See the link above for more information (and yes I know it's kinda buried in there, you will have to do some reading and some hacking).

    When it's enabled and configured correctly, it will stream perfectly fine if you are using a media player that's compatible (I know, that's the same as saying if we would have some eggs we could have some ham and eggs if we had some ham:wink:). The problem is that recently some media players such as the Playstation 3 have gotten some firmware updates that make it incompatible with the Twonky server on the NAS200. Twonky has released some updates too since Linksys firmware 75 came out, but the Linksys software doesn't allow you to update the Twonky server. Jac2b does.

    Telnet on Jac2b doesn't require logging in, you go straight to a Busybox prompt. If you are being asked for a user ID and password, clearly you are trying to connect to something other than the NAS200. If your Telnet client program asks for the password before it makes a connection, try a different Telnet client (like the one that's included with Windows: just type "telnet" from a command line).

    Obviously Linksys is not going to solve your problem. They will say if you have their firmware, it works as it's intended. They can't help that media players update their firmwares and break compatibility with Twonky. If you tell them you're running alternative firmware, you should be happy they don't hang up on you right away: they can't be expected to support something they didn't make.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice