Nas200 problems with password and reset!

Discussion in 'Cisco/Linksys Network Storage Devices' started by Xiztnzz, Jan 25, 2011.

  1. Xiztnzz

    Xiztnzz Networkin' Nut Member

    Hey guys. I have a problem with my NAS200 wich i have been having since i first bought it about 2+ years ago. I cant access the nas through the setup or the web-based page. I can access everything from my computer through the network but cant make any changes at all... It started when i had formatted the 2nd harddrive really. Never changed any password at all on it. And also, i cant use it as FTP-Server wich i really need now.

    What i really wanna do is a total nuke of every setting there is in that box because im tired of searching the internet for hours and hours without any results that can help me.

    I have tried 2 sec reset, 10 sec, 30 sec and 1 min reset. No difference at all. I also removed the disks before i tried the resets.

    Been searching for anyone with the same difficulties but cant seem to find anything that matches my specific problem.

    I have tried different routers, computers (both mac and win) and also wired and wireless but im just about to break down and throw it at the neighbours.

    Right now i have Netgear WNR2000 v2 router, disk one is a seagate 500gb and 2nd is a 250 maxtor. Internet speed is 100/100 (dont know if it matters, but to avoid later questions and discussions about slow internet later on)

    Can someone please help me with this extremely annoying problem. The faster the better since i need it to work really soon since im gonna use it as an FTP while im down under and uploading photos. I´d love to get some help either by responds here or mail or even through skype =)

    Big thanks for a nice forum and good tips overall.

  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Turn the NAS off using the power button (it beeps and after a few seconds the lights go out).

    Then turn it back on again, it will beep once, then after a few minutes it will beep again, twice.

    If this doesn't fix the problem, you can reset all settings to the default by holding the reset button. It will beep once after 5 seconds and again after (I think) 30 seconds. If you hold it down until you hear the second beep, it will reset all settings to the default.

    I have to say I don't do this often so I'm not 100% sure what the default settings are but I think the NAS gets an IP address via DHCP by default. If you don't know how to find out what its address is, you can use the program from the setup CD to find it and reconfigure it. The default user id / password is admin/admin (or was it admin / blank?).

    Hope this helps!

  3. Xiztnzz

    Xiztnzz Networkin' Nut Member

    thanks for the reply, but i have tried to reboot it a few times. Reset 2 sec for renew of ip and such, 10 sec was to reset the passwords and so on.
    But still not working, tried through the program that´s on the cd and im coming up to the step where i need to enter password for admin-login and it´s not working at all. not admin as pass nor blank.

    I have looked through the entire manual for an answer of how to reset everything back to factory settings but cant find anything... Soon i´ll have to throw it at something hard and buy a new one since i really need it for my trip... damnit, i chose this NAS for it´s "easy to use".

    Everything have a way to reset it to factory settings apart from this device it seems...

  4. tajudd

    tajudd Networkin' Nut Member

    I've noticed that in order to affect a configuration of this NAS200, disks have to be installed. The firmware allows the same settings (by use of the config partition) if disks are missing, but no edits can be done if the disks are missing.

    Even to telnet into redboot needs a disk installed, seems it's somehow dependant on that.

    To this extent, it may be required to get a single spare SATA disk (which may have it's data overwritten), pop it into the top bay and try to do your defaultings.

  5. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Yes you have to have disks installed for it to work, most of the configuration (including the user accounts and shared directories) is stored on a partition that's hidden from file sharing. What's stored in flash memory is things like the network configuration, the disk configuration (RAID vs separate disks etc) host name, time zone etc.

    I have no idea why you can reach it through the configuration utility but not through the web interface. Have you tried using a different web browser i.e. Internet Explorer instead of Firefox?

    I seem to remember a problem with the installer program on the CD where it asks you to change the password and then it won't let you log in with the new password, or something. It's too long ago that I used it, so I don't remember details. Either way, pushing the reset button with a pen or paperclip and holding it for a few seconds until it beeps will reset the admin password to the default which I think is "admin".

    Note that the reset button only resets the configuration, it doesn't restart the NAS! To actually restart it, you have to power it off. The right way to power it off is with the power button. When you power it on again, you have to wait for the double-beep which takes a few minutes. Before the double-beep, you may be able to connect to it but not all of the functionality is running.

    The disks don't need to be installed for a telnet to RedBoot to work: Redboot doesn't use the disks and I don't think it even knows about them (I'm pretty sure you can't boot from disk through Redboot). If you want to make a telnet connection to Redboot, you have to connect to its special preset IP address within the 5 seconds that it waits before it starts Linux. See this page for more information. DON'T USE THE "FLASH" COMMAND FROM A REDBOOT COMMAND PROMPT! YOU WILL BRICK YOUR NAS!

    Telnetting to Redboot is probably not going to help you much anyway: As soon as you tell it to boot Linux, your telnet session disappears. If you're brave enough and you have electronics experience (or you know someone who does), you can install a serial port so you can use it as console for Linux. This was an invaluable help when I was working on my firmware. I use a 3.3V voltage converter that I built myself (based on MAX3232) but you can get 3.3V to USB converters at places like Make sure the pinout of the connector matches the pinout on this page (the NSLU2 and NAS200 serial port pinouts are identical). If your serial cable already gets its supply from a USB port you only need to connect RXD, TXD and GND; in other words don't connect the 3.3V pin unless you don't have any other power source. Connection speed is 38400bps, 8bits, no parity, no flow control.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice