NAS200 Scandisk problems - V34R75 issue?

Discussion in 'Cisco/Linksys Network Storage Devices' started by 5circles, Jul 23, 2008.

  1. 5circles

    5circles Network Guru Member

    I thought I was through the painful restore of all my NAS200 data, but I've run into a problem with Scandisk. I had earlier mirrored all the data to another location on my LAN, and then reformatted. I've been juggling firmware but ended up with the V34R75 firmware. Ran a Scandisk on the empty disk which went very quickly.

    Then I put the data back on. Then tried running Scandisk. Through several tries it either failed - message in the log and email with no additional information or locked up (with both power and disk lights on or both off). I tried disconnecting the shares from the connected computers - it doesn't make sense to me that this would be necessary given the message when starting Scandisk that connections will be terminated, but some of the messages in the forum imply that it is necessary - and got the same problem. THen I disconnected the Ethernet after starting the Scandisk. Same problem.

    Then I 'upgraded' the firmware to the 34R62Jac version and restarted. I was expecting to have problems with a Scan being forced during power up, but this wasn't the case. I guess the firmware upgrade performed a clean reboot.

    Then I restarted the Scandisk. Unfortunately, it froze again.

    I returned the firmware to the V34R75 and it has frozen again. I'm going to leave it a lot longer this time to see if it recovers.

    I'm about done with NAS200. I'm ready to move the disk to a computer and throw the hardware out the window. But is there anything else I can do - short of never doing a Scandisk?

    What use is a Scandisk failed message unless there is some reason why or a way to fix it?

  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I think those lights normally blink while it's running the scandisk, right? The blinking is done in software through a kernel module; the fact that they stop blinking can only mean that the software has crashed. Of course you won't see exactly what goes on unless you have the serial port connected. You may have some kind of hardware problem, or maybe your disks are getting too hot and aren't answering to the software the way they're supposed to.

    I had some crashes over the past weekend that I couldn't explain. When I took the harddisks out, they were so hot that I couldn't hold them in my hands! I had to juggle it from one hand to the other while I put it into the freezer. I opened my NAS200 and did some Dremeling and drilling to put a 60x60x10mm fan in there to keep the disks cool. That made a major difference! The disks are still warm but not nearly as hot as before. All day yesterday, I've been consolidating all my files to one harddisk so I can reformat the other one, and I didn't have a single crash.

    See this thread for more info.


    The image is a picture taken of the center part of my unit, as seen from the bottom (with the bottom part of the unit taken off of course). I removed the original fan for maximum air flow. The power cable of the fan runs between the center part and the top part so it doesn't get in the way. I haven't inspected the motherboard to verify if it's capable of driving a large fan through the fan header and I didn't want to risk it, so I connected my fan to the harddisk power output on the motherboard via the molex splitter that came with the fan. That means it's always on for now but from the looks of the messages on my console, the motherboard would have kept it switched on all the time anyway.

    If you want to open your NAS200 (which will void the warranty!), check out this link (found via

    If your NAS200 is still under warranty, I would tell Linksys about the problem and try to get it replaced or repaired. If it's not under warranty anymore or you just don't want to bothered, or you simply want to verify if the problem is heat-related, you can try adding a fan (clearly the tiny fan that's in there now is underdimensioned). If you don't have a Dremel or you don't want to deal with drilling a couple hundred tiny holes in your case, you can try mounting the fan on the back of the case.

    Good luck!

  3. 5circles

    5circles Network Guru Member

    I was very concerned about the heat when I took one drive out to put into an external enclosure when this problem started. I also wondered if the drive in the enclosure would be OK (no fan, very small), but the enclosure doesn't seem to get all that hot. I suppose all the electronics in the NAS200 makes the difference.

    I'm sure that the lights are under software control (perhaps not the ethernet light), but I'm not totally sure that the lights staying in one particular state indicates that the kernel has frozen. I've seen situations where the lights stay on for longer than usual, and then off for longer than usual, and then resume the normal pattern. I'm surmising that the lights are flipped during some parts of the scandisk process and that maybe when there is a problem it takes longer than usual to get through the routine.

    Why would a serial connection be more likely to talk to the device than Telnet? And if so how can I add one? Hopefully I'll find a reference in a forum search.

    I still like the idea of a separate dedicated box, but I'm putting a lot more effort into this than getting disk space on a Ubuntu box.

  4. 5circles

    5circles Network Guru Member

    I discovered that the drive was pretty cool, so I don't think heat was the issue. I wondered if the firmware was messed up so that the Scandisk wasn't being seen as drive activity, so changed the options to keep the fan on permanently. Then I moved the drive to the lower bay and left the back panel off the top one. Then reloaded the Jac firmware, and checked that I still had Telnet access.

    Started a Scandisk. After no more than 30 minutes it had frozen. Lack of telnet access seems to confirm that the firmware is stuck. And the drive is cool.

    It is probably time to give up on this.
  5. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    All lights are connected to GPIO pins on the CPU, including the ethernet light. The Linksys engineers made some modifications to turn lights on and off from the kernel e.g. while the drives or the network are being accessed.

    The program to switch lights on and off from a script (and to sound the speaker and make lights blink) is closed-source. It connects to a kernel module that's loaded at startup time which is also closed-source.

    When the lights stay on or off longer than usual, it means the box is very busy and is probably swapping. But because the blinking program is separate, the lights don't simply stop blinking when something goes wrong in the disk scanner program. Even if it's just the disk scanner that stops working, it wouldn't stop any other programs such as the one that's doing the lights.

    The NAS200 (like many other embedded devices) uses the serial port as console. When the kernel crashes, that's the only place where you will see it because any network connections will be disconnected.

    To make a serial port, you will need a Maxim MAX3232 chip and a few passive components. You can order all these online at places like, they will probably cost you less than $20 including shipping. The pinout for the serial port of the NAS200 is the same as on many other Linksys devices; see this page for more information and schematics. The serial port is close to the center of the NAS200 motherboard and you'll have to solder your own header to it. You can use the 3.3V pin on the header to supply the power for the MAX3232.

    DO NOT attempt to connect an RS-232 port of a PC straight to the 4 pin port, this will not work and you will probably destroy the hardware. The NAS200 works at 3.3V and RS-232 works at up to -12V to +12V.

  6. mstombs

    mstombs Network Guru Member

    The cheapest way to get a serial console cable is to cut the end off an appropriate mobile phone cable. Here's a couple of usb based ones /USB%20console%20cable%20for%20a%20Linksys%20router.pdf

    My last dku-5 cost approx 4 USD from HongKong via ebay!

    I have tried and failed to make a serial port one this way - so also have a MAX3232CPE based one.

    Both are configured as 3 wire only, the serial port one has a 3.3V regulator to take power from the PC serial port.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice