NAS200 v3.4R71 Beta Firmware

Discussion in 'Cisco/Linksys Network Storage Devices' started by Toxic, Jan 10, 2008.

  1. Toxic

    Toxic Administrator Staff Member

    Linksys Tech Support should now have this Beta firmware available.

    Changes are listed below:


    1. Fix the long indexing time issue when media server scans certain video file format

    2. Fix the slow write performance by enabling non-jounaled file system -- drive reformatting is required

    3. Updated Media Server

    4. Detect and display the invalid characters entered by user in WebUI

    5. Hard Disk Configuration can be changed without reformatting the drives. URL: http://<NAS200_IP-Address>/Administration/mode.cgi

    6. Force to perform DDNS update when user click “Update Now” button.

    7. Fix the issue that WebUI cannot be accessed until system boot up scan disk completes.

    8. Fix that the configuration file cannot be restored if the file name includes space.

    9. WebUI, “Cancel” button will be disabled while performing “Reset to Default”.

    10. WebUI, Add a test button for e-mail alert testing.

    11. Fix the issue that the drive size can not be recognized correctly when hard drive size over 500GB under JBOD/LVM configuration.

    12. Enhanced to prevent strange share folder name.

    13. Fix WebUI problem for share permission assignment when there are more than 7 users.

    14. Fix the IP address validation rule so that "" will not be accepted. V3.4R62 (First Release)

    The NAS200_V34R67 beta firmware addressed the following issue.

    When you create more than 7 users on the NAS, only the first 7 users (excluding admin and guest) have configurable access rights under Shared Folders.

    Read Only and Read/Write access are grayed out for the 8th and succeeding users. But if the 8th user (and succeeding users) was created with a personal folder (creating of a personal folder is an option every time you create a user), this user will have a Read/Write access on its personal folder, but will be completely denied from accessing other personal/private folders.

    This is because the Read Only and Read/Write options will be grayed out. Unless the 8th and succeeding users will be moved on the first 7 User List, you will not be able to manipulate its access rights

    Please contact Linksys Tech Support for the V3.4R71 firmware for the NAS200.
  2. jeffsani

    jeffsani Guest

    So is there anywhere other than Linksys TS to obtain this beta version?
  3. Toxic

    Toxic Administrator Staff Member

    not that I know of or I would have stated that fact.
  4. RHTizzy

    RHTizzy LI Guru Member

    Actually I just adapted the Linksys download URL for the 34R62 firmware to "34R71" and it seems to have worked

  5. Toxic

    Toxic Administrator Staff Member

    sorry that link only pulls down the 62 version for me. opened the zip file up and it was NAS200_3462.bin :)

    if anyone needs the firmware contact Linksys Tech Support.
  6. DragonsLore

    DragonsLore LI Guru Member

    Contacted Linksys yesturday, then a short while later, they contacted me via phone and asked me a few questions. After a short while, they said they would be sending me the new firmware.

    Unfortunately, I never received it from them. :(

    Instead, I managed to get it from a friend and I installed it last night.

    So far, I have noticed a couple of improvements in perormance with this firmware.

    - 1) Tranferring files "seems to be" quicker

    - 2) With Media Server enabled and scanning, I can still access the device where as before, it could not be accessed during a scan.
  7. heinz-willi

    heinz-willi Guest

    Hello DragonsLore,

    can you send me a email with the Beta Firmware?

  8. darcytucker

    darcytucker LI Guru Member

    could I get a copy also

    I contacted linksys yesterday, but they still have not sent me the files. if anyone could post them somewhere that would be great.
  9. Please tell me where the new firmware can be fount.
    V3.4R71 Nas200

  10. Toxic

    Toxic Administrator Staff Member

    if you contact linksys Technical Support they should be able to send it to you.
  11. RHTizzy

    RHTizzy LI Guru Member

    quite correct, sorry about that :tongue:

    do we need to register as beta testers before TS send the firmware because just an email produces the following response:
    "Thank you for contacting Linksys Technical Support. Linksys has discontinued the e-mail support channel for Technical Support Inquiries."
  12. Toxic

    Toxic Administrator Staff Member

    I would not know, contact TS via the live chat feature, or phone them, thats what I would do.
  13. darcytucker

    darcytucker LI Guru Member

    nas200 Beta Firmware

    Well, I contacted tech support on Friday morning. They said they would send it withing 48 hours. That never happened!
    I logged into the live chat again on Sunday morning. They told me they would send it within 24 hours. Once again that never happened.
    Has anyone actually recieved these files from liksys support?
  14. darcytucker

    darcytucker LI Guru Member

    nas200 Beta Firmware

    Does anyone know how to donwload files from a newsgroup? I am told there is a copy of the beta firmware posted in alt.binaries.atest
    The title is: NAS200 v3.4R71 Beta

    If anyone has access to this newsgroup, please send me a copy to

    Thank you.
  15. DragonsLore

    DragonsLore LI Guru Member

    If you need access to a news server, you can try the NNTP server provided by your ISP.

    Should your ISP News Server not carry this news group, then there is an alternative. provides a one month Free trial. They have both a Web Interface and nntp access.
  16. RHTizzy

    RHTizzy LI Guru Member

    Actually the free trial has been discontinued. Easynews now provide a service which allows you to apply for a refund, which imho is too much of a risk seeing as creditcard info is required..

    I too have yet to receive the promised files from linksys. I've also contacted the dutch linksys office in the hope they can help but their 24h window is also almost expired without result.

    In a final effort I 've also registered as a betatester and requested the firmware through them. Who knows, it might just prove to be the catalyst. I'll keep you informed if all goes well.
  17. RHTizzy

    RHTizzy LI Guru Member

    Used the US chat option and received a live link for download:thumbups:, will install soon. Cheers, Rick
  18. leeden

    leeden Guest

    I'm using the beta firmware but it doesn't solve my problem with divx files streamed to my PS3. They still come up as unsupported formats. What version of the media server is included? The Twonky forums say the newest version fixed this problem.
  19. RHTizzy

    RHTizzy LI Guru Member

    still extremely poor performance so returned it to the shop and am now looking closely at the D-link DNS-323 and the QNAP TS-201.
  20. darcytucker

    darcytucker LI Guru Member

    I have installed the Beta firmware, No performance increase, there are a few new options that should have been included in the original release (Test Email for example).

    Before installing the beta firmware, I had no problem streaming a 1.4GB Divx file to my xbox360. Now when I do this, the video pauses for a few seconds about once every 10-15 minutes. Almost like it needs to buffer more data?

    I really like the media server aspect of this device and because of this, I think I will try putting the original firmware back on this device.
  21. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Incidentally, if you're interested in extracting the root file system from the .bin file to see what's in there, try the following:

    dd if=NAS200_V34R71.bin of=romdisk71 bs=65536 skip=28 count=96
    mkdir /mnt/71
    mount -o loop,ro -t squashfs ./romdisk71 /mnt/71
    The included Twonky version appears to be 4.4 beta 4.

    The non-journaled filesystem is ext2 and it apparently delivers about a 50% speed increase from 4MB/s to 6MB/s. I measured this by using Windows XP to restore a 100GB backup to the NAS. I also measured that 6MB is about the fastest speed that can be reached with the hardware (measured using firmware 3.4R61 with Telnetd mod by running a dd command in telnet to copy /dev/sda1 to /dev/null)

  22. xlr8

    xlr8 LI Guru Member

    I attempted the online chat to get the beta firmware and was told it would be sent to me within 24 hours... nope. So I went back onto the chat and had better luck. Here is a transcript of the session which you may find helpful:

    Chat Transcript - 03/03/2008 1:23 PM
    Hi, my name is Nurodin (24931). How may I help you?
    Jon: Hi Nurodin. I chatted with Gloria yesterday about my NAS200 having very slow write speeds. She stated that she would send a beta firmware V3.4R71 that would help with the problem. This was at 12 noon yesterday and she said I should expect the file via e-mail within 24 hours. It has not yet arrived.
    Nurodin (24931): I see.
    Nurodin (24931): Let me check and process this again.
    Nurodin (24931): Okay?
    Jon: ok.
    Nurodin (24931): Please give me 5 minutes here while I check your record.
    Jon: OK - thank you very much.
    Nurodin (24931): Thank you and I'll be right back.
    Nurodin (24931): I'm back.
    Jon: ok
    Nurodin (24931): I see that the request was being made and processed.
    Nurodin (24931): Already.
    Nurodin (24931): Jon, try to download the firmware on this site:
    Jon: trying now
    Nurodin (24931): Okay.
    Jon: downloading now
    Nurodin (24931): Okay.
    Jon: downloaded - that seems to have worked
    Jon: Wish they had mentioned that yesterday. :)
    Jon: Thanks for your help!
    Nurodin (24931): You're welcome.
    Nurodin (24931): Wait.
    Jon: ok
    Nurodin (24931): Would that be all for now?
    Jon: Yes that is.
    Nurodin (24931): Again, this has been Nurodin (ID 24931) and please don't forget to log-out. Have a great day and take care! Please don't forget also to visit our site ( and our Ask Linksys help line). After this session there will be an automated case number sent to your e-mail for this session.

    Nurodin (24931): Goodbye for now!
    Jon: Thanks again.
    Nurodin (24931): You're welcome.
    Jon: disconnected
    Nurodin (24931): disconnected
  23. NightmareonWax

    NightmareonWax LI Guru Member


    where can i enable the option "non-journaled file system"? I have updated my NAS to VV3.4R71 but i did not find the option ...
  24. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    When you format a disk, the firmware will show you the option of using journaled vs. non-journaled filesystem.

  25. NightmareonWax

    NightmareonWax LI Guru Member


  26. Int15

    Int15 Network Guru Member


    Anybody knows when the v3.4R71 will be released officially?

  27. huseyinb

    huseyinb Guest

    up up up up
  28. DragonsLore

    DragonsLore LI Guru Member

    Better yet.....

    Does anyone know what the most current Beta Version IS ?
  29. srainess

    srainess LI Guru Member

    Is there any other caveat besides recovering data, if not using the journaled file system ? (ie: Disc space gain, etc.. )
  30. srainess

    srainess LI Guru Member

    Interesting.. Just put in a 500GB Seagate drive... Journaled gives me about
    465GB of usable space, while Un-Journaled gives me about 453GB. I would have thought that the Journaled version would have required more space initially, or does it use more space as the disc fills up ? Is there an appreciable speed difference ?
  31. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The only explanation I can give (which I admit is speculation) is that the XFS (journaled) file system is more efficient than ext2 (non-journaled) filesystem.

    There is definitely a speed difference: I measured write speeds of about 4MB/s on XFS and 6MB/sec on ext2.

  32. srainess

    srainess LI Guru Member

    So the big question then, is it worth the tradeoff on data corruption/recovery vs speed.
  33. srainess

    srainess LI Guru Member

    New question, and since this is the only release of firmware I'm working with, I'm not sure if it is functionality related, or firmware.

    Trying to map to a share within Vista. I can check XP, but I dont think thats it.
    I can not map if the share is marked read only for that user. I did a
    'net view \\nasdevice', and it only shows the shares that this user has 'read/write' access to. If the user has 'read' access, I do not see the share. If I change it to 'read/write' it shows up, and I can map.

    Is this just a v3.4R71 issue ? Figured would ask here before calling support.

  34. donhuaso

    donhuaso Network Guru Member

    NAS200 R71 Disk Mode Change

    I upgrade from R62 to R71 because I wanted to change the disk mode from JBOD to SEPARATED Disks by using the now availalabe option http://<NAS200_IP-Address>/Administration/mode.cgi of R71.

    Remove the internall disk (Have only one 500GB)
    Upgraded to R71
    Use the new option
    Installed the disk on slot 1
    All of these step with the proper shutdows etc etc...

    After the last re-boot I was hoping to see my disk content but that is not the case. It show the disk available but unformated. I can't see my data or users.

    Where did I when wrong?

    Any help will be apreciated
  35. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I work with my own firmware (based on R62), not with R71. However it's unlikely that it will ever be possible to switch from JBOD to Separated without loss of data.

    The reason is that with JBOD, the OS pretends that two partitions are one continuous area of disk space. Then it stores a file system in the combined space. If one of the harddisks is removed, the file system is automatically going to be corrupt because part of it is gone.

    By the way, the difference between JBOD and RAID 0 (stripe) mode is that in JBOD mode, the disks are mapped as two contiguous spaces, whereas in stripe mode the disks are divided into many small parts which are interleaved. Theoretically, a striped set of disks would give better performance but I doubt whether it makes a difference on the NAS200 because all the RAID processing is done in software...

  36. donhuaso

    donhuaso Network Guru Member

    Thank you. I will stay with R71 and reformat the disk.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice