NAT question

Discussion in 'Tomato Firmware' started by Dryvlyne, Jul 23, 2008.

  1. Dryvlyne

    Dryvlyne Addicted to LI Member

    Hello - I'm currently running a MacBook Pro and have Windows XP running on it under VMWare Fusion. I'm trying to figure out how to get the streaming capabilities of my WinXP VM to work with my Xbox 360 (this was working before converting my Windows installation into a VM).

    My route is a Linksys WRT54G v2 with the latest Tomato firmware. My WinXP VM is running in Bridged networking mode and is thus treated as if it were a separate node on my home network. I'm using the router to dole out static IPs to my MacBook, WinXP VM and Xbox 360.

    When I use enable the media sharing feature in Windows Media Player 11 it detects my Xbox 360. However, my Xbox 360 cannot apparently see my WinXP VM as it says it does not detect any available Windows computers on the network.

    Now I've ensured that the WinXP firewall is configured correctly and that both it and the 360 are on the same subnet. The router is picking up the 360 as a UPnP device and I've even tried forwarding the appropriate Windows Media Connect ports directly to the WinXP VM IP.

    My theory is that this is some kind of NAT issue going on since my WinXP VM can see the 360, but the 360 cannot see the VM. I'm thinking that even though my WinXP VM is being treated, at least by the router, as a separate entity on the network that the 360 doesn't see it that way because traffic from the VM is going through my MacBook's wireless card.

    At any rate, sorry for the long post, but I felt it necessary to give as much background info as possible on the issue. I'm fairly confident this is just some kind of routing issue and it can be resolved. If anyone has any thoughts it would be greatly appreciated.

  2. dvaskelis

    dvaskelis Network Guru Member

    NAT (and therefore, port forwarding) only is used between WAN and LAN. You're not even routing packets when they're all on the same subnet on your LAN, much less routing them through NAT.

    I'd guess it's some kind of firewall issue in the guest XP. Maybe try disabling all network security in the guest VM and see if that helps. If that doesn't, maybe try disabling all network security in the host OS and see if that helps.
  3. ifican

    ifican Network Guru Member

    It could be nat because any VM software will nat by default. Make sure that your VM is truly bridged. What ip dhcp range is your router using and what ip is the XP VM receiving? To have your VM hit the xbox but the xbox not able to get to the VM its is probably a)firewall or b)nating on the VM. VM's can be very touchy as you are seeing when trying to map ports correctly in the inbound direction. So look over everything carefully as something most definetely is just a tab off.
  4. Dryvlyne

    Dryvlyne Addicted to LI Member

    So you guys are basically telling me that there's really no reason to expect that my router would be the potential problem here since it's all LAN traffic?

    I've double/triple checked and the VM is definitely running in bridged mode. In fact, my wife's WinXP laptop can see and access the VM through the Windows Workgroup.

    Maybe I'll try allowing ALL incoming connections on my Mac and turning off the software firewall completely in the VM. I'm fairly certain though that I've tried this before without any success. A friend of mine is going to let me borrow a hub tomorrow so if I still don't have any luck today then I'll give that a try just to rule out the router being the problem for sure.

  5. Dryvlyne

    Dryvlyne Addicted to LI Member

    One more quick question... I was just reading the Wikibooks entry on Tomato and wonder if I should try putting the VM in the DMZ?


    I know typically you would place a machine in the DMZ so that it is accessible by other machines from outside the LAN, but I did notice there is mention of enabling NAT loopback so that internal machines can also have unrestricted access to the machine placed in the DMZ. Or at least that's my understanding of it anyway :redface:
  6. ifican

    ifican Network Guru Member

    In a nutshell, that is correct, if all your host are on the same subnet then your router would not be doing anything with it. Your "router" is 2 parts, 1 part switch and 1 part router. All of your host on your lan only use the switch to communicate with one another. You can plug a hub in an all else being equal with no changes made, your xbox will still not see your machine. So what ip does you mac and xpVM have?
  7. Dryvlyne

    Dryvlyne Addicted to LI Member

    I see, thanks for the info.

    The Mac has an IP of and the VM has an IP of 192.168.201. The Xbox, if it matters, has an IP of
  8. ifican

    ifican Network Guru Member

    My last post did not take into account you question as they crossed. Depending on what router you use the dmz could but probably wont make a difference. The reasons are this, most soho router use the dmz port to forward traffic around the firewall so to speak. Really not what happens but is easier for most to understand that way. However there are some router that use an entirely different subnet for the dmz. It you router is a basic one then the dmz wont matter, however if it uses a different subnet you will have to allow the correct access control to let traffic in. In your specific case the dmz port should not have any effect on your current situation. I still think its relate to a configuration on your machine, do you have access to another machine to put on the network and test?
  9. Dryvlyne

    Dryvlyne Addicted to LI Member

    Yes, I have used my wife's WinXP machine and successfully streamed media to the Xbox.

    For the longest time I kept thinking it was a limitation of my WinXP being a VM, but the more I thought about it this should be a non-factor. This is especially the case now that I've got a Windows Workgroup setup and both my wife's machine and my VM can see and share files with one another. Indeed it seems there is some kind of networking problem that is preventing the Xbox from seeing my VM.

    When I get home tonight I'll try doing what I mentioned previously (allow all incoming traffic on the Mac and turn off the firewall inside the VM) to see if that makes any difference. I see no reason why I shouldn't eventually be able to get this working.

  10. ifican

    ifican Network Guru Member

    Agreed, this should eventually work. The VM should be a non issue, i did some searching around and have found other having your same problems and well as other that have no issue. Try the firewall route and let us know as i am really curious now.
  11. TexasFlood

    TexasFlood Network Guru Member

    I think ifican got it right.

    I'm assuming you meant the VM has an IP of

    So these IPs are all on the LAN subnet and there is really no routing or firewall in between them.

    As ifican stated, most soho router use the dmz as a special port forwarding case so only traffic coming from the WAN side to the LAN would be impacted. You can forward individual ports, defining a server as in the "dmz" is a quick and dirty way to forward all ports to it so it's basically exposed to the WAN side or typically the Internet. Obviously this is not the same as a "real" DMZ.

    So if I understand your posts correctly, the problem seems much more likely that your problem is in the VM routing and/or firewall.
  12. Dryvlyne

    Dryvlyne Addicted to LI Member

    Well I just got it working before my MacBook's battery died last night and I think it may be a software problem/issue.

    The first thing I did was to allow all incoming connections on the Mac and enable all sharing capabilities just for good measure. Next, I logged into the VM and disabled the software firewall and rebooted it + the Mac.

    Upon getting back into the VM I launched WMP11 and made sure the media sharing feature was enabled then I booted up the Xbox and it still could not the WinXP VM. Next I tried downloading/installing Microsoft's Zune software. It too was able to see the Xbox, but the Xbox still could not see the WinXP VM. Finally, I tried downloading/installing a media server application for Windows called TVersity ( and suddenly my Xbox was able to see the VM!

    My battery died a few minutes thereafter so I didn't get to do any further testing or try turning on the VM or Mac firewalls again, but it was at least working. I find it strange that WMP11 and the Zune software would not work. Perhaps Microsoft has some secret code embedded into their software that can tell when traffic is being routed through Mac hardware :biggrin:.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice