Need firmware 1.01.54 for my WAG354GV2 Annex B!

Discussion in 'Other Linksys Equipment' started by herrde, Feb 14, 2007.

  1. herrde

    herrde LI Guru Member

    Hi everybody,

    can anybody please provide a download link for firmware 1.01.54 for my WAG 354GV2 Annex B ?

    A couple of days ago I unfortunately upgraded to version 1.01.57, but my performance dropped by approx 30% since then. Now I really would like to go back to 1.01.54, but strangely enough I haven't been able to find a BIN file anywhere on the net!

    Please help!

    Thanks A LOT in advance,

  2. masterb

    masterb LI Guru Member

    it's your lucky day.....:biggrin:
    get it HERE

  3. herrde

    herrde LI Guru Member

    Thanx a lot!!! I'll try to flash it back immediately tomorrow!!!

    Thanx again!!!!

  4. herrde

    herrde LI Guru Member


    well, I just tried it and it worked like a charm! Everything's back to normal here, I have my full speed back (12 MBit via WLAN!!) and I am completely happy!


    All the best & many thanks again for your help!

  5. masterb

    masterb LI Guru Member

    you are the second person on a total of 2 :)biggrin: ) who says the 1.01.57 firmware sucks... what the hell has linksys done??

    anyway If you wanna help me test some new fw, tell me... I need a tester for v2. My site is in the signature...

  6. herrde

    herrde LI Guru Member

    As a matter of fact, flashing the 1.01.57 firmware on my Linksys did the following:

    • Internet downstream performance decrease by approx. 40%. I used to have 12 MBit via my WLAN, and after flashing to 1.01.57 it went down to about 7.5 MBit,
    • strange fluctuations in the nominal transmission rate between router and client. The rate changed between 54 MBit and 11 Mbit and back in seconds, going back and forth all the time,
    • strange behaviour regarding the reaction of the web interface upon configuration changes. After a couple of changes had been applied, the web interface became "sluggish", to say the least. This effect could only be reverted by restarting the router

    After I flashed back to 1.01.54 today (thanks to you, my friend!!), everything was fine again and none of the above problems existed any longer!

    BTW, I visited your page, but it seems to carry stuff for the WAG354G Annex A (version 1) only, and nothing for V2...

    All the best,

  7. masterb

    masterb LI Guru Member

    yes, it' because I can only test the firmware on my version, that is v1 AnnexA. If you like to test / need a firmware with telnet, ssh, dhcp reserved and a rw partition, and much (?) more, let me know...


  8. herrde

    herrde LI Guru Member

    Hmmm, DHCP reserved sounds good (missing that from my old router) - but what's the advantage of telnet and/or ssh access to a router...?

    Sorry if this is a dumb question.... :halo:


  9. Toxic

    Toxic Administrator Staff Member

    If any guys require the WAG354GV2-E1_v1.01.54 firmware PM me and i will email it to you. gimme the email address you want it to be sent too in the PM (not in this thread)
  10. iassael

    iassael LI Guru Member

    so what is wrong with 1.01.57?
    Why linksys made this?
  11. phil_cole

    phil_cole LI Guru Member

    Why did it take me so long to find this forum and thread?

    I updated the firmware on my WAG354G v2 to 1.01.57 last week and noticed that the wireless performance afterwards was pretty poor. I've downloaded the 1.01.54 version from the above link, but before I flash it, can anyone confirm that it is the right version for me? I've the UK version of the WAG354G v2... the 1.01.57 version from the Linksys site contains AnnexA in the filename, the one above had AnnexB...

    What'd happen if it were the wrong version?


  12. mstombs

    mstombs Network Guru Member

    For UK you need Annex A. Annex B is for countries like Germany which use ADSL over ISDN. I think the hardware is similar, just the software protocol driver is different.
  13. Toxic

    Toxic Administrator Staff Member

    just to make things clear I only have the AnnexB 1.01.54 Firmware.

    AnnexA = POTS (Plain Old Telephone Service)

    AnnexB = ISDN (Integrated Services Digital Network)
  14. HiSpeed

    HiSpeed Network Guru Member

    I have the AnnexA 1.01.54 Firmware available on my forum !

  15. phil_cole

    phil_cole LI Guru Member

    Hi HiSpeed. Thanks - found the firmware on your site and it has worked a treat. Wireless speeds back up to what they should be.

    Seems there must be a problem with the 1.01.57 firmware...

  16. phil_cole

    phil_cole LI Guru Member

    Before I found this site, I'd opened a support call with Linksys UK Support. They've logged that I'd noted a performance drop after installing the 1.01.57 firmware. The hope there being that if others experience problems they know a little more than nothing about it.

    So, if you have problems after upgrading a WAG354G v2 from 1.01.54 to 1.01.57, can I suggest you let Linksys Technical Support know...

  17. fresnel

    fresnel Guest

    WAG354G Annex B firmware

    Can I ask a stupid question?

    The firmware 1. 01. 54 is in German???? Is that true???

    My German isnt so hot!-hm

    Can anyone confirm this?

  18. toyo

    toyo Networkin' Nut Member


    Hi I want firmware 1.01.54 for Wag354G v2 annex b in english.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice