Need help restoring original Linksys firmware

Discussion in 'DD-WRT Firmware' started by 7endless, Feb 6, 2006.

  1. 7endless

    7endless Network Guru Member

    Yesterday I successfully installed the DD-WRT firmware V23 Std but decided today to go back to the original Linksys firmware.

    I followed the instructions in the Revival guide but when I run the Linksys Auto Upgrade Utility and get to the point where it should start the flash procedure it just says "Unable to get responses from the server". I can hit retry but the same thing keeps popping up.

    Since using the Auto upgrade utility doesn't seem to be working, what's the next best method to try?
  2. Guyfromhe

    Guyfromhe Network Guru Member

    you can use the TFTP method laid out in many of the debricking guides or you can try using the web interface to flash the official firmware on... Just curious why are you switching off DD-WRT it doesn't remove any of the linksys features..
  3. mmisnan

    mmisnan Network Guru Member

    I bricked my previous WRT54GS when trying to go from DD-WRT to HyperWRT .. reason .. I didn't follow fully the instruction to reset the router into factory standard.. How to unbrick it? I returned it to PCWorld and got a new one :) .. If you forgotten to do factory reset, my guess you already bricked your router .. if this is new, get a replacement from retailer where you got it.. otherwise, follow the de-bricking procedure, else, ask for RMA from Linksys and get a replacement from them.
  4. 7endless

    7endless Network Guru Member

    Found some other posts in a couple other forums where users got the same error using the Auto Upgrade utility while following the same revival steps in the guide.

    I did do the 30 second reset but it didn't make a difference. Boot Wait was also enabled but that didn't help. The tftp setup wizard app that was mentioned in the revival guide also didn't help.

    So I decided to re-download the .bin version of the latest Linksys firmware and applied it from within the administration page - waited 5 mins and then power cycled the router. Seems to have worked as I'm now back at 4.20.7.
  5. t4thfavor

    t4thfavor Network Guru Member

    dont go back noooooo
  6. Randyincv

    Randyincv Guest

    WRT54G v5 Bricked.

    I have a good CFE file that I created with the correct MAC Address, I apparently need nvram.bin and it's gone. I have a Jtag cable and I can talk to the Chip, I just need to know what files I need to have to put in before I can get it to TFTP. In setting my laptop to I can get a connection to the Router, but I haven't been able to Ping it. Must be a different I.P. is all I can think of. It's had an -erase:wholeflash run on it, the CFE.Bin is loaded back but TFTP can't get a response. Any hope? Please let me know.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice