Need help retrieving data from EXT3

Discussion in 'Cisco/Linksys Network Storage Devices' started by LordFlux, Oct 24, 2005.

  1. LordFlux

    LordFlux Network Guru Member

    I've been using my NSLU2 since early this year without any problems. Even the upgrade to R63 went without a hitch. I just encounted my first snag this morning and it's a pretty major one.

    Was playing some MP3s off of my NSLU2 using Windows Media Player and suddenly the MP3s stopped playing. Tried to access the drive through explorer and it said the mapped drive was no longer available. Tried to access the NSLU2 via web browser and it was not responding. Took a look at the NSLU2 itself and all of the LEDs were lit. Tried to restart the unit by holding down the power button and it would not restart. I unplugged the unit and the drive and then powered both back up.

    Looked at the status of the disk via the web browser and it said that no disk was installed. Tried rebooting several times but the connected hard drive was never seen. So I installed the EXT2/EXT3 IFS for Windows ( ) to gain access to my files that way. Connected the USB drive to my PC and three Linux partitions were available. I mapped a drive letter to the largest partition and tried to view my files through explorer and it says the drive is not formatted.

    So...... to sum things up, I think the file system on the drive is screwed. I'm not familiar with Linux... is there anything I can do to repair the file system and gain access to my files? Or any utility I can run that will give me insight on what is going on?

    I'd like to get my files off and then format and run a thorough scandisk.
  2. LordFlux

    LordFlux Network Guru Member

    Nevermind, guys -- the drive is now making an awful clicking noise. I think my drive is dying, but just to be sure, I'm going to remove it from the USB enclosure and put it in my PC.
  3. d__l

    d__l Network Guru Member

    Just out of curiousity, what is the drive model and size?

    I had the infamous clicking problem happen to me once with an IBM Deathstar 60 drive that was half of a Raid 0 array. I don't recommend doing this except as a last resort, but I was able to restore the drive's functionality by a firm bump on the side of the drive (the impact was transmitted through the computer case) with the heel of my fist while it was running/clicking. Maybe it was just good luck that it fixed itself after that.
  4. LordFlux

    LordFlux Network Guru Member

    It's a Maxtor DiamondMax 10 300GB hard drive. I bought it in February of this year, so it's still under warranty. When I get back home, I'll give it a swift kick and see what happens... at least it'll make me feel better. ^_^
  5. LordFlux

    LordFlux Network Guru Member


    Okay, I removed the drive from the USB enclosure and installed it into my PC. The drive seems to be running fine, which leads me to believe the USB enclosure or the enclosure's power supply is bad.

    Anyway, I'm still unable to use the EXT3 IFS to get my files. I ran the mountdiag utility located on the same page and this is what it says:

    The volume has an Ext2/Ext3 file system, but the Ext2 IFS 1.10 software did not mount it because there is at least one incompat feature flag set. The Ext2 IFS software does not implement:
    * needs_recovery *
    Here we have an Ext3 file system which has transactions left in its journal. A pure Ext2 driver must not access such a volume which is in that state (to prevent data loss!). You may solve it by mounting it on Linux (which has a kernel with Ext3 support). Be sure that you cleanly dismount it, before you shutdown Linux. After that the Ext2 IFS software should be able to access the volume.

    Alright... could someone tell me what I need to do from here? I like the idea of using a LiveCD to boot from Linux... but right now, I'm willing to reformat my PC so I can get this data off. Someone please help.
  6. LordFlux

    LordFlux Network Guru Member

    *UPDATE 2*

    Okay, I've got access to my files using the EXT2 IFS driver for Windows. I downloaded the Ubuntu LiveCD and ran it, then logged off and rebooted back into Windows XP.
  7. jameslee

    jameslee Guest

    Totally shutdown need


    I got the same issue today,finally I found the reason:

    Not hot unplug USB DISK from NSLU2,instead,push power button on NSLU2 and make it totally shutdown,this will make USB DISK
    EXT3 file system "completely" close. Then hook it up to a windows
    machine and start this cool EXT2IFS tools,it really works great!

    Hope you are lucky like me too :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice