Need Help With Bad Firmware Flash

Discussion in 'Tomato Firmware' started by hfwarner3, Jan 29, 2008.

  1. hfwarner3

    hfwarner3 LI Guru Member

    I have two WRT54G routers at the house - a version 1.1 and a version 4. The 1.1 is my main router plugging into my AT&T U-Verse RG. The 4 is a wireless bridge that uses the WiFi connection to put two PCs in the back of the house on the network.

    A few weeks ago I flashed with 1.1 with Tomato 13 (Had been DD-WRT) and have loved it. Performance has been a little better and QoS has worked great.

    Last night, I decided that I would go ahead and flash the version 4 with Tomato 15 so that I could setup WDS. I went into the DD-WRT Admin screen, pointed it to the Tomato firmware, and flashed just like I did with the ver 1.1. Everything appeared to go great until after the reboot. The lights on the front of the router come up just like they should, so I think the flash worked (Power flashes a few times for a couple of seconds, goes solid, a few seconds later WiFi light goes solid).

    The 1.1 router is setup as and the version 4 had been setup as I tried connecting to it on both and and can't get connected on either IP address. I port scanned everything in the subnet and did not see the router at all.

    I tried holding the reset button for 30 seconds, unplugging and replugging power while still holding reset for another 30 seconds thinking this would clear the settings, but I still could not login after doing this.

    Any suggestions on what to try next?

    Thank you in advance for your assistance!
  2. Mastec

    Mastec Network Guru Member

    Try reflashing via TFTP. Not the one from the Linksys website but the one in Windows. Below is the installer for the Buffalo routers modified for your Linksys. Just copy and paste it into a text editor and save it as, just for example fixit.bat and run it.

    This worked for me some time ago on my GL
  3. hfwarner3

    hfwarner3 LI Guru Member

    I gave it a try three times and it did not work.

    The router is booting up and appears to be running fine, but its IP address is not and I can't figure out WHAT it is. I have pinged every IP address from to without luck...
  4. mstombs

    mstombs Network Guru Member

    I suggest you try all the LAN ports, just in case they are incorrectly assigned to WAN/LAN.
  5. hfwarner3

    hfwarner3 LI Guru Member

    I am confused. Do you mean I should physically plug the cable into each of the ports? I am currently plugged into port 1.
  6. mstombs

    mstombs Network Guru Member

    Yes, there is a possibility port 1 thinks it is the WAN port, its assigned by nvram variables
  7. hfwarner3

    hfwarner3 LI Guru Member

    Thanks! I'll go give that a try.
  8. hfwarner3

    hfwarner3 LI Guru Member

    You, sir, rule. I plugged into the WAN port and there was the web interface at just waiting for me to login.
  9. szfong

    szfong Network Guru Member


    NEXT time, if there is one, when flashing between different 3rd party firmware, FIRST reset everything to defaults BEFORE flashing, then perform 30s hardware reset, then flash, wait a couple min. after the flash, and 30s reset once again. It'll save you ALOT of headache. I've corrupted my firmware more than once during crossflashing between firmwares.

    tftp or serial will usually bring it back to life, jtag not required.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice