Need help with Vista client :(

Discussion in 'Tomato Firmware' started by Dagger, Sep 12, 2010.

  1. Dagger

    Dagger Networkin' Nut Member

    I have TeddyBear's Tomato running on an Asus WL500GP with three XP clients, a wireless printer, and a blue-ray player all connected via wireless... however, my son's laptop which has Vista refuses to connect. It connects to an Asus RT-N13U running stock firmware just fine... but I can't figure out why it refuses to connect to Tomato.

    What what I can see, it doesn't get connected to the network at all... so it's not even trying to get an IP via DHCP.

    Has anyone else seen this problem with Vista and Tomato?

  2. myersw

    myersw Network Guru Member

    Before upgrading to Windows 7 I ran Vista Ultimate 32bit. Never had a issue with wireless connection using Tomato, DD-WRT or OEM firmware on my RT-N16. Sounds like something not configured correctly on the Vista client since other devices connect.
    One suggestion is to make sure you have the latest drivers installed for the wireless network card. Down level drivers can cause all kinds of odd behavior.
  3. Dagger

    Dagger Networkin' Nut Member

    Checked the settings and the driver version already. I have security on the router set to WPA-TKIP with a pre-shared key... pretty simple.
  4. Dagger

    Dagger Networkin' Nut Member

    Disabled all security on the WL-500GP and Vista still will not connect. Everything else I've tried connects fine. I turned on the old RT-N13U and Vista still connects to it fine... it's also set for WPA-PSK w/TKIP...

    I just don't get it...
  5. maurer

    maurer Network Guru Member

    delete the wireless network from vista to enter the password again or change the SSID of tomato network and try again.
  6. Toastman

    Toastman Super Moderator Staff Member Member

    I'm guessing that it's an Intel wireless chipset? I've seen an issue with them and Vista, but Windows 7 connects fine with the same card and the built-in drivers. My standard cure (bodge) is to give the laptop a fixed IP address so it doesn't need to obtain one with DHCP. Incidentally, his laptop will probably get a new lease of life with 7 if you upgrade it. Vista belongs in the history books.
  7. Dagger

    Dagger Networkin' Nut Member

    I loaded the router with the latest ASUS firmware and his computer would connect, get an IP via DHCP, but that was all... it would not ping the router or any other device on the network.

    The weird thing is that his laptop connects fine to the RT-N13U... it just doesn't like the radio chipset used in the WL-500gP for some reason.

    I think the real root of the problem is Vista... you're certainly right when you say Vista belongs in the history books...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice