Need Help with WRT54G V.6

Discussion in 'Networking Issues' started by riteshpandey, Apr 7, 2007.

  1. riteshpandey

    riteshpandey Guest

    I have a PRONET wireless router and Linksys WRT54G V.6. I connect to internet using PRONET wireless router. And I have a desktop which is connected using Ethernet Linksys Wireless Router. Is there anyway I can connect 2 routers wirelessly and connect my desktop to internet which does not have wireless card. Basically how can I create a bridge between the routers and save some bucks. Please help.
  2. Slimey

    Slimey Network Guru Member

    Set the wrt as a client bridge, you will have to use dd-wrt firmware.
  3. leftcoastdave

    leftcoastdave LI Guru Member

    I too would like to use my WRT54G V6 router as a wireless bridge. I have no clue what dd-wrt firmware is nor how to use it. Can someone provide step by step instructions on how to convert a V6 router into a wireless bridge for someone who is network illiterate?

    I have a WRT54G V5 as my primary router and I want to connect other devices to a V6 router and thence connect the two routers wirelessly. Said another way, I wish to connect a DirecTV HR20-700 DVR to the WRT54G V6 and use the V6 as a bridge to gain access to the internet for the DVR.

    I know you can do this with a ZyXEL P330 out of the box but I only have this WRT54G V6.

    Thanks in advance for any help on this.

  4. thepianobar

    thepianobar Network Guru Member

    Check out this page:
    specifically, the about and install sections

    the download is available here:

    I'm sure there is the same disclaimer somewhere on the dd-wrt pages, but putting 3rd-party firmware on your router is not officially supported and you carry the risk of bricking your router.

    Since you have a WRT54G v6 start here and verify it really is a v6 router: Versions 5 and 6 are somewhat more difficult to successfully install dd-wrt and carry a greater risk of bricking your router.
  5. leftcoastdave

    leftcoastdave LI Guru Member

    Another Question --

    I have verfied that I have a version 6 WRT54G and I have downloaded all of the prerequisite tools to begin the firmware upgrade.

    I then disconnected my laptop from my primary WRT54G router (by disabling the wireless adapter) and then hardwire connected to the laptop the target WRT54G upon which I wish to upgrade the firmware.

    When I attempted to access the Admin screens on the router at, I keep getting a message that I must be connected to the internet in order to access the internal menu of the router.

    Must I now connect this router to the DSL modem and access the internet or is there some way to modify the router without being online?


  6. thepianobar

    thepianobar Network Guru Member

    There is no requirement to have an Internet connection that I am aware of. Have you tried resetting the device back to factory defaults first? and verify you are connected to one of the LAN ports.

    I would find a walkthrough from the links above from someone who has successfully installed dd-wrt on a WRT54G v6 and follow it to the letter.

    You might also want to try the forums at for help as well since the members there have much more experience with installing dd-wrt
  7. leftcoastdave

    leftcoastdave LI Guru Member

    I don't wish to prolong this discussion unnecessarily, because I have thrown in the towel on flashing the WRT54G V6 and have ordered another bridge ready ZyXEL router, but I do want to share my failed experience with flashing the WRT54G V6 in case it might help others.

    Let me say first that the information here at DBSTalk and at is outstanding. The problem is probably my own ineptitude that caused the failure with the upgrade.

    Here is what I did or tried to do.

    I followed the links that gave specific information about the various tools and downloads to collect on my laptop. Once I had these in place, I fired up my XP laptop and disabled the wireless connection to my primary router (also a WRT54G) in order to avoid any conflict when I attempted to access

    I then connected and powered up the target WRT54G V6 router and launched the IE browser. Initially I got a message saying I could not access the desired URL because I had no internet connection. I re-enabled the wireless adapter, powered up the target router, then disabled the wireless internet connection and at that point I successfully was able to access the admin screens on the target WRT54G.

    I followed the instructions to upgrade the firmware located here ( and got to the point where I successfully located the xxx.bin file on my laptop and it appeared the router accepted the upgraded firmware.

    I then followed the visuals on the screen that instructed me to fill in the desired MAC address and to save the wkilermac.bin file which I also did successfully.

    Next the instructions said to: "....... Then we need to point our web browser back to the WRT54G at and we will get a new screen it will look something like this: ((followed by an image of a screen dialogue box that said in large bold type)) "" MANAGEMENT MODE FIRMWARE UPGRADE"".

    I was never able to access this screen on the router even after several resets. I tried to repeat the entire upgrade sequence but after having hit the create button as instructed above, I was never presented with a Mgt Mode Firmware Upgrade screen, so I gave up in frustration and quit at this point.

    I am not sure what I was doing wrong, but it is pretty clear that with my limited knowledge of how routers work that at this point I was out of my depth. I concluded I should locate a bridge ready router and save myself additional pain.

    I am curious to know where I went astray, but not so curious that I want to try again.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice