Need quick help configuring packages. Looking 2 days!!!

Discussion in 'DD-WRT Firmware' started by 100KV, Jul 13, 2005.

  1. 100KV

    100KV Guest

    Hello, Thanks in advance for any help for this newbie.... I've been using DOS, OS/2, and Windows(and Cisco IOS) for the last 20 years, but only first tried Linux two days ago on a Linksys!!! :D

    I'm currently working with DD-WRT firmware, as this seemed to be the most powerful flavor for those not familiar with Linux, but I believe that my question would apply to any flavor of Linux based Linksys firmware.

    What I am trying to do is configure a Linksys router as a wireless PPPoE client, using 128-bit MPPE encryption..... I already have the wireless link working well, and the PPPoE connection is working just fine, even assigning the proper IP address to the Linksys from my Radius server. The problem I have, of course, is setting the PPPoE access concentrator(intentionally not mentioning the mfr. It works just fine with any client, hw or sw, that supports PPPoE and MPPE) to require encryption for the PPP link. The access concentrator is giving the standard error that any client causes when the client doesn't support encryption(or I have disabled encryption on it for testing), "Encryption Negotiation Failed". Once encryption is reenabled on the client in these cases, the access concentrator will negotiate the connection just fine.

    I tried to install the kron-ppp-mppe-mppc package(it told me that it installed properly) in RAM just to test with, but I could not get any different results when trying the PPPoE connection, the Linksys just would not encrypt. I would have assumed that the PPPoE client would need to be told to use the newly installed encryption package, but I could find no information on this anywhere. I did find a reference to a pptp_encrypt parameter, but I found no equivalent for PPPoE. How do I enable, configure, or properly install this package, and would I need other packages, also?

    I also thought that I might invoke or execute(term?) the new package to set some parameters, but being a newbie I cannot find out how to navigate to the RAM location that I installed it in to find it. I tried to install to the flash(maybe to the sbin directory where some other stuff is), but got a read-only error, even after properly changing the jffs parameter in nvram to allow for this, and commiting and rebooting....

    I have spent 10 hours each for two days trying to sort this out, but I fear at my rate this will take a month... :( Any help is greatly appreciated, and I will return the favor helping others(knowing less than me) on this forum in the future....

    Many thanks!


    PS.. I have become somewhat familiar with the shell, as I have done some of my configurations there... I've got navigation down fairly well, but am having some problems with some of the standard things that all of the forum posts and FAQs assume someone should already know, such as how to edit a configuration file, and how they relate to the module that they belong to, for example. I have read many generic Linux FAQs, but they all seem to have a slightly different story about the way things are than they appear to be when I am actually trying to use the shell in DD-WRT. I plan on learning how to do all of this and more with any Linux flavor over the next month, but right now I need to just get this one thing working....
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice