NetBIOS over VPN with RV042 & BEFSX41

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Bryanba, Aug 23, 2006.

  1. Bryanba

    Bryanba LI Guru Member

    I've got the RV042 setup at the office and several Gateway-Gateway tunnels established from BEFSX41's at remote locations. The tunnels connect fine (I'm using the email and FQDN method).

    I am unable to browse the office network from home or connect to any computer using NetBIOS names. I can't ping netbios names either. I am able to connect using IP address and ping, no problem. I have enabled NetBIOS broadcasts in the VPN advanced sections of both routers. This worked when it was BEFSX41 --->BEFVP41 but no longer works with the new BEFSX41 ---> RV042 VPN's.

    Disconnecting the gateway-gateway tunnel and disabling it, then connecting using PPTP connects fine also but same problem - no NetBIOS.

    RV042 firmware
    BEFSX firmware 1.52.9

    Anyone able to use NetBIOS over VPN with these devices? Any ideas what to check next?

    Obviously I'd like to figure this out before the phone lights up with those "I can't connect" calls... :eek:

  2. d__l

    d__l Network Guru Member

    I didn't even try NetBIOS testing while I was working with an RV082-SX41 tunnel, so I can't say if that works or not. In an RV082-Sentinel tunnel that I would be using most of the time, it isn't even available. Because NetBIOS introduces some additional traffic in an already reduced throughput tunnel (due to upload limitations and encryption overhead), I've decided to only use lmhosts and hosts files whenever I use the VPN tunnels.

    Can you use lmhosts and host files in your tunnels? NetBIOS is often problematic with some router combinations:
  3. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    Do try to stick with hosts files..or better yet...if you have a domain controller at the central office running DNS...use it. netbios really clogs the traffic of the tunnels.
  4. Bryanba

    Bryanba LI Guru Member

    It would be easier to implement static IP's and just reference those and forgo the time consuming adminstration of hosts and lmhosts files.. lmhosts and hosts solutions will work but they're manual and a headache to admin..

  5. decker12

    decker12 LI Guru Member

    I'm about to post my own problems with this matter. HOSTS files don't seem to make a difference. I can put Server1 as in my hosts file, I can ping Server1 and see it resolve, but when I try to connect to \\server1 it never works. Connecting to \\ works, though.
  6. Bryanba

    Bryanba LI Guru Member

    Just a followup..

    RV042 to RV042 tunnel, NetBIOS works.

    Problem now is that the RV042 is dropping the tunnel periodically and won't reconnect until you manually hit the "Connect" button..

  7. Guyfromhe

    Guyfromhe Network Guru Member

    I was just upgrading works BEFSX41's firmware and I was looking at the change log, the latest firmware had this in it:

    10. Fixed netbios not passed through VPN tunnel.

    in version 1.52.10. If your running a prior ver that could be why it's doing that.

    What i've noticed is the tunnel will drop on it's own, it will re-connect as soon as traffic to the VPN is requested...
    I havn't found anyway to turn this off, try leaving a ping to the vpn running and see if that stops it.
  8. Bryanba

    Bryanba LI Guru Member

    Hey you had me excited for a minute .... until I checked the release notes for 1.52.10 .. The NetBios fix was actually for 1.52.9 ..

    1.52.10 fixes only the following things.. #2 being most interesting...

    1.52.10 May 10, 2006

    1. Fixed some online games issue.
    2. Fixed for stability
    3. Fixed UPnP forwarding issue.

  9. Guyfromhe

    Guyfromhe Network Guru Member

    Too bad, I guess I must have mis-red
  10. d__l

    d__l Network Guru Member

    On the SX41, the latest firmware isn't the greatest. Over the years through the different firmware versions, Linksys has played "whack-a-mole" with the bugs. They will eliminate one bug in a new firmware and old ones will re-occur.

    Firmwares 1.45.7 and 1.51.00 are known to have functional NetBIOS over a SX41-SX41 VPN tunnels. I've used 1.45.7 with two SX41s and NetBIOS worked perfectly (albeit slowly as is typical of NetBIOS) and the tunnels would restore themselves promptly.

    Either firmware is as stable or more so than 1.52.1. Get them here:,11329487 Firmware 1.45.7 is an unreleased version that most people who know about it and have experimented with various firmwares will gravitate to because it is so good.

    Edit: It is probably not your firmware that is the NetBIOS problem (unless it is something specific between the SX41 and RV042) because the NetBios works for SX41 to SX41 tunnels:,15331164
  11. pablito

    pablito Network Guru Member

    I don't pretend to be a netbios expert as I have no need for noisy protocols over VPNs but I have a few tunnels at various places that have no problems with Win Networking. Instead of relying on Netbios broadcasts I'll use WINS, Samba servers, or LMHOSTS to get the job done. Someone mentioned HOSTS files which takes care of the resolution for pings etc but for Win networking you need to use LMHOSTS. The format is the same (as I remember) and the file is in the same location. Note that these files have no extension (.txt etc).

    AFAIK if you resolve the destination (LMHOSTS etc) you are running over TCP/IP and don't require Netbios which in fact is best to not run over the link.
  12. Guyfromhe

    Guyfromhe Network Guru Member

    I found another thing in my poking around the befsx41, theres a allow netbios broadcasts option and a keepalive option under advanced at the bottom, those may help.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice