Netgear WNDR3400 v1 - (beta)Tomato support

Discussion in 'Tomato Firmware' started by shibby20, Sep 13, 2012.

  1. flatipac

    flatipac Network Newbie Member

    Mangix thanks.. that's what I figured.

    I was able to build both wndr64 and wndr64-nousb from arrmo's branch and flash Tomato from DD-WRT, but my WNDR3400v2 erases its settings after some condition I'm trying to put my finger on.. might be related to the 5GHz band settings which seems to go away randomly. Either the 3400v2 support is really flakey or my router has some issues. I'm going to keep troubleshooting to figure out which one.
  2. amitg0123

    amitg0123 Serious Server Member

    I am playing with arrmo's WNDR3400v2 work to add support for WNDR3400v3 which is almost identical to v2 (possibly some minor differences, at least the power led gpio seems inversed and may be BCM43236 rev3 chip).

    So far it's working good except on problem as @flatipac mentioned. The settings are erased last night, though I am testing it since last couple of days. So I can say, erase doesn't happen always but random.

    I'll publish my changes as patchsets once I figure out some GPIO related problems.


    UPDATES: router keeps erasing nvram randomly, happened twice in last 5 days.
    Last edited: Jul 10, 2014
  3. Tomas

    Tomas Network Newbie Member

    Hi! I would like to ask people around this forum for some help configuring Netgear Wndr3400v1 as a wireless Ethernet Bridge. I followed several guides around the net on how to set it up. So far, all I can do with the Wndr3400v1 is to get it to connect to the main AP and it shows that it is connecting to the correct channel and SSID and signal strength is acceptable (Overview tab). However, workstations and clients connected (wired) connected to this wireless bridge CANNOT access the internet and CANNOT ping or connect to other wireless devices on my home LAN. This is very puzzling. I also entered all the information necessary for gateway, DNS.
    Is there any other feature that must be enabled? Does the firewall need to be turned off? Is there any setting in NAT that must be turned of or changed? Does the Tomato firmware in wireless bridge mode forward DHCP requests from clients connected to it to the appropriate DHCP server? Are there any bugs known and workarounds? Any help would be appreciated. I think this router is very close to connecting properly. I must be missing something or some feature that must be turned on that I am not aware off.
    I would include screenshots, but I can't figure out how to insert the pictures for this posting.


    Last edited: Aug 21, 2014
  4. Benji778

    Benji778 New Member Member

    Hi, in the beginning of this blog I read that I have to do the following below to have the Tomato firmware installed for the WNDR3400v1. This was however for the beta version. Since then Shibby released another version in 2014. Do I still have to execute steps 4 and 5? This is my first time doing this, just want to make sure.

    How to flash tomato:
    1) restore default settings
    2) flash using tomato image via GUI
    3) after flash leave router for 5-7 minutes until ping will return
    4) log into Tomato and first of all erase nvram!!
    5) after erase 2nd radio will disapear. Dont panic :) Just make reboot one more time
    6) log into tomato and Have fun


  5. Superhai

    Superhai Serious Server Member

    If it is from a previous tomato there should not be a reason for such extensive procedure, only if you have stock.

    Sent from my iPhone using Tapatalk
  6. Benji778

    Benji778 New Member Member

    Can it hurt if I execute steps 4 and 5 even with the most recent release?
  7. Superhai

    Superhai Serious Server Member

    It is inconvenient but sure you can do it.

    Sent from my iPhone using Tapatalk
  8. Lambo029

    Lambo029 Serious Server Member

    Right now running:-

    tomato-Netgear-3400v1-K26USB-1.28.RT-101.chk (1.28.0000 MIPSR2-101 K26 USB)

    But I want to upgrd to full rom.

    Try this many and all of them bricked my router


    This one is too big to flash

    before TomatoUSB I was running DD-WRT then moved to OFW and then TomatoUSB did 30-30-30

    All this DD-WRT running fine:- That I tested today was board haha


    But I want TomatoUSB FULL because I like the GUI and few other things
  9. arrmo

    arrmo LI Guru Member

  10. Lambo029

    Lambo029 Serious Server Member

    Thank you I have downloaded that one I will try it soon as I go... but can you tell me where did you got this from? so I can see if they have newer one and test them out too...nice .chk format so I can just restore from OFW.
  11. arrmo

    arrmo LI Guru Member


    This is my build - built in the last week or so.
    brianli likes this.
  12. Lambo029

    Lambo029 Serious Server Member

    wow awesome buddy... nice to know I'm using new build and dev is running it at same time
  13. brianli

    brianli New Member Member

    Can I flash it directly from the OFW and flash it back through the GUI? Thanks in advance.
    Last edited: Jan 22, 2016
  14. brianli

    brianli New Member Member

    Thank you so much for your hard work. I had downloaded and flashed it from OFW without any problem.
    Here are the features I have tested:
    Did a 30-30-30 reset and reboot, the 5GHz radio is gone. After 2nd reboot, it works again w/o any problem.
    wifi button at the back is working but not the LED (WPS) button at top. In fact I prefer the big blue button is off just like right now, since it is too bright.
    PPTP client works perfectly. USB support for NTFS hard drive also work.
    The CPU load is not showing anything.

    Thanks again for your great work.
  15. marooned

    marooned New Member Member

    Is there any VPN build for WNDR3400V1? I'm currently using the VPN build for V3 on it. Everything except the big blue button works. I'd like the capability of turning the Wifi off/on as needed.
  16. brianli

    brianli New Member Member

    The build
    for the WNDR3400v1 already has PPTP client and server but not the OpenVPN. The back wifi button can turn WIFI on/off as needed.

    Thanks again from arrmo's work.
    Last edited: Feb 8, 2016
  17. jenom

    jenom LI Guru Member

    Installed ARRMO's "tomato-WNDR3400-K26USB-NVRAM64K-1.28.0094MIPSR2-RMo-Std.chk" to a WNDR3400V1 from previous TOmato WeB GUI
    After the second reboot 5 Ghz radio showed up, and all seems like working fine!

    Would like to add "entware" or "optware" on an USB stick, need "extras.tar.gz" file
    Shibby has these "extras" available, however they are version specific.
    Can somebody tell me which Shibby's version is compatible with ARRMO's 1.28.0094 ?
  18. jenom

    jenom LI Guru Member

    meanwhile found this on ARRMO's 1.28.0094

    build date 2015-OCT-22

    Also found some non-working menu items:

    --Status-CPU Load - No Data to Display
    --Status-Wireless Noise - No Data to Display

    Any suggestion how to get them to work ?
  19. joe1387

    joe1387 New Member Member

    Lemme get this right. Are you saying that you are using WNDR3400v3 Tomato VPN firmware on a v1? Please confirm. I wanna use an OpenVPN build too.
  20. smithmal

    smithmal New Member Member

    Confused about flashing instructions....
    OP wrote: "flash using tomato image via GUI"

    but then wrote in Support:
    "upgrade router via GUI will brick router!!"

    How specifically should I flash the firmware and which image is the latest and greatest.

    I initially flashed my router using the Netgear GUI. Waited about 10 minutes, but could never access the router @

    I have another WNDR3400 v1 and want to make sure I'm flashing properly. Any help would be appreciated.

  21. arrmo

    arrmo LI Guru Member

    I admit - not sure. I update all the time from the GUI, but I'm using my builds. Would be good to have Shibby comment, as I believe you're using his builds.
  22. jenom

    jenom LI Guru Member

    I think the idea here to purposely brick the router with:
    "flash using tomato image via GUI" & "upgrade router via GUI will brick router!!"
    than in a bricked router a firmware will not load (because it is corrupted) ,
    Then you can use a serial interface to do serial recovery to transfer back factory firmware.
    Read first post, first sentence:

    BE WARNED! This is highly beta tomato version. This image may brick your router. Make sure you have serial cable to debrick router!!

    Last edited: Jun 27, 2016
  23. smithmal

    smithmal New Member Member

    Seems to me that many individuals on this thread have flashed this experimental firmware without any issues. My question is, did they do so going through Netgear GUI or some other GUI? I really dislike the Netgear GUI and my other routers in my house are on Tomato....
  24. jenom

    jenom LI Guru Member

    yes, this is how to do it from Netgear's webpage, Do NOT skip any steps :

    1) restore default settings
    2) flash using tomato image via GUI
    3) after flash leave router for 6-7 minutes until ping will return
    4) log into Tomato and first of all erase nvram!!
    5) after erase 2nd radio will disappear. Make reboot one more time
    6) log into tomato

    Search for this file in Shibby's repo, it worked for me: Tomato-Netgear-3400v1-K26USB-1.28.RT-101.chk
  25. smithmal

    smithmal New Member Member

    Thanks for the reply. Just wondering if I can resurrect my 1st WNDR3400. Flashed firmware and waited 10 minutes. Tried to ping and got nothing. Rebooted and all lights are functional, but can't gain access to the GUI. What are my options?
  26. jenom

    jenom LI Guru Member

  27. joe1387

    joe1387 New Member Member

    A bit late to the discussion.

    However, there is a difference between "flash using tomato image via GUI" and "upgrade router via GUI will brick router!!". I believe he meant that you should flash Tomato from the Netgear firmware's GUI. However, once Tomato is on the router you shouldn't upgrade from Tomato's GUI because it will brick the router.

    English is a strange language. Furthermore, from reading shibby's writings, I don't think English is his mother-tongue.
  28. smithmal

    smithmal New Member Member


    Thanks for the reply. That makes sense. I'll make sure I keep Netgear's OFW handy in case I want to update the router's firmware in the future.

    I've solved my issues. Turns out after flashing TomatoUSB using the Netgear GUI, I needed to do a 30-30-30 reboot procedure using the reset pin to be able to access the router once again using Once resetting the router, I need to reboot (not reset) the router once more so the 5Ghz antenna shows up in the GUI.

    I was able to flash both of my WNDR3400 v1 routers successfully using arrmo's firmware (firmware link noted on post #109 of this thread). Thanks to everyone's feedback. Nice to see that a thread that is 4 years old can be revived and have great community engagement so quickly on this board.

    etyrnal likes this.
  29. Tirnaz

    Tirnaz New Member Member

    -bringing back from the dead- So i have this router. used it for various purposes for years. Started looking into custom firmware specifically for VPN and found you fine folks. A lot of great information here. Installed Arrmo's work and works great. Has there been any updates specifically for VPN that will work on this router? Fairly certain I have a v1.
  30. arrmo

    arrmo LI Guru Member

  31. ceevee

    ceevee Network Guru Member

    arrmo, please post your latest build for WNDR3400 v1. I currently have 1.28.0094 MIPSR2-RMo K26 USB Std. It's running great, but would like to run the latest so far.
  32. pomidor1

    pomidor1 Networkin' Nut Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice