Network connections dropping and Realtek RTL8201cp

Discussion in 'Cisco/Linksys Network Storage Devices' started by JamesH, Aug 16, 2005.

  1. JamesH

    JamesH Guest

    I have had the NSLU2 for almost a year now and it worked fine with an occasional hiccup. Now it started dropping the network connection all of a sudden. When I try pinging it I get replies for a while (say... 15s) and then the connection will go down and after a minute it will come back and then it will go down again and so on...

    I opened the case and checked how hot the chips get and the only chip that I felt got really hot was the network chip. The Realtek RTL8201cp chip's temperature correlated to the ping packet behavior. I don't have a laser thermometer but from what I can feel with my finger the connections drops when the RTL8201cp chip heats up. I would estimate it heats up to about 50 deg C and then the connection drops... after it cools down again the connection gets restored and I can feel it heat up under my finger under those ping packets.

    In this thread mrfixit5 reduced the CPU clock from 33 MHz to 30 MHz and that seemed to have helped with his connection problem. But I have a feeling that (at least in my case) the CPU is not overheating and that it is running. Since the NSLU2 always normally responds to the power button press and properly shuts down the NSLU2 using the kernel... the CPU cannot be stuck.

    So if I am right... the problem should not be in the CPU but somewhere else. Maybe the Realtek chip... I do not have the proper equipment to prove this but if somebody else could check out the Realtek chip on a misbehaving NSLU2 that is dropping the connection... I would love to see a proper temperature measurement or signal analysis on the pins...

    I will try to run a test by telneting to NSLU2 and running a script that adds a line with a timestamp to a file on the HDD every second. If the CPU really does halt there should be a gap in the timestamps. But the interesting thing is that the connection does come back. Also the switch and the NSLU2 report the connection to be up just the packets (according to the LEDs) are not sent out of the hub to the NSLU2.

    The thing that bothers me most is that the CPU is actually running at half the clock speed it is rated for. See here... And instead of reducing clock speeds we should be increasing them. Maybe Linksys is using components of questionable quality and is counting on us not to return the units under the warranty.

    Any thoughts?
  2. mrfixit5

    mrfixit5 Network Guru Member

    If you refer back to my post, I refered to one unit as my more problematic one. After reducing the CPU to 30mhz, I had the ethernet light go out when it was first powered up. I turned it off and on once or twice and the ethernet light never went out again. I did not mention this because all my data corruption problems were gone after the speed mod and am fairly sure the 30mhz mod did not cause this problem.

    Reading several ethernet chips data sheets, I found that the crystal must be within 50 parts per million to comply with the ethernet 100m standard. I checked the frequency at work and it was something like 2.3khz high. If my math is good, at 25Mhz, the error should be no more than 1.25khz.

    I replaced the crystal with one from a spare ethernet card and the error was .75khz. Tried powering the unit up while cold twice, and it seemed to be OK, but have not tested it enough to be sure. Also, this nslu2 had several parts removed and reinstalled, including this crystal, so I cannot be 100% sure that it was out of spec from the factory, but it is possible.

    This is one thing you could try if you are good at soldering, but note that your problem is a bit different from mine. My unit only gave problems for a few minuites at power up, while yours is going up and down continuously. Could even be a bad solder connection somewhere on the board. If you twist the board slightly, can you make it come and go?

    Also, when I spoke of thermal problems, my CPU was not really overheating, it just started corrupting data when it was warm.
    After I modified the CPU speed, you could put the unit in its case and cover it with something and make it get warmer than normal and it would still work without corrupting data. Maybe it would have worked before modification if I would have left it in the freezer and just run cables to it (I never tried that.) If you ever try something like this, remember you could get condensation on the board (not good).

    One other note. On the nslu2-linux site, they tell you how to increase the CPU core speed and this was the first modification I did, even before the CPU 30mhz clock speed. It corrupted data before and after the core speed mod, so I left it at the higher speed. With the higher core speed and lower 30mhz clock speed, I am sure it is running faster than stock, and I get no data corruption. Have verified a 3.5gig acronis image several times without problems.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice