new adsl router setup causing major issues for me

Discussion in 'Tomato Firmware' started by luke-san, Feb 27, 2007.

  1. luke-san

    luke-san LI Guru Member

    Ok, I'm not very happy what my ISP did today because I requested a phoneline using there services.

    Ok previous logical setup:

    A linksys adsl modem router that I set to bridge mode so everything was transparent to the 'Tomato machine' on which I used the WOL, DDNS, QoS for my voip etc functions on a daily basis.
    The most important part is that I must be able to control or access the router remotely.

    Now comes the part that freaks me out.

    My ISP installed a Fritzbox fon which is an adsl router with an ATA for voip.
    But , and that is a big but, I had to sign an agreement that I could not go into the config page of the device, which is protected btw by a non universal pw.

    So basically I cannot access my router from outside.

    The Fritzbox gives a DHCP address in the range of 192.168.178.x/24

    Any solutions that you guys can think of?
  2. Roimeister

    Roimeister LI Guru Member

    have your tomato clone your fritz mac address and put the tomato as the dsl interface and add routes to the fritz
  3. luke-san

    luke-san LI Guru Member

    Not as simple as that because the wan input of the fritz is adsl and the fritz is needed for there voip, so that is a no go.
  4. RTSAnime

    RTSAnime Network Guru Member

    EDIT: oops didn't see that you needed remote control. If you are not allowed to modify the config of the fritz then there is nothing you can do. Complain to your ISP that you need to modify port forwarding.
  5. luke-san

    luke-san LI Guru Member

    wow, I found something very weird that might explain things

    If I do a dyndns it should resolve to my WAN-ip address and it doesn't.
    It points to which is the IP that my WRT got from the fritz DHCP on its wan-side.
    That might explain things, but I don't know my actuall IP address so I can't do any further testing.
    But this is certainly 1 thing that is causing me not to be able to access my server.

    small update : I managed to get my wan ip but I'm ofcourse unable to connect to the router which obviously confirms that this is a nat 'problem'
  6. luke-san

    luke-san LI Guru Member

    Update : I think I have discovered a bug in Tomato

    My ISP forwarded all the ports in the fritzbox so I can access Tomato, BUT...

    The dyndns still shows, in my case , which is the ip it gets from the fritzbox.
    Rebooting etc ... still the same.

    So I tried dd-wrt and with the same dyndns credentials and it works as it should meaning it shows the wan ip

    I already emailed Jon about this, but any takers on this with a workaround?
  7. azeari

    azeari LI Guru Member

    its not a bug.

    the box does not necessarily need to NAT your tomato even though its handling the connections. Its possible it simply forwarded the wan side ip to the tomato for handling, in which case you should be able to access all ports from the wrt
  8. luke-san

    luke-san LI Guru Member


    This the answer from Jon, but it is not really usefull for me since my ip tends to change every couple of days.


    DD-WRT uses a different program.

    The only work-around to this is to use a custom URL, omit the IP address, and let DynDNS decide the IP address on its own. You can use the following format:

    The downside is if the wan address changes, it's likely that the router will not get its address changed so you will not get an updated DDNS.

    - Jon
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice