NEW De-Bricking Solution - Turning off Wireless Adapter!

Discussion in 'Cisco/Linksys Wireless Routers' started by malfeasance, Jul 24, 2005.

  1. malfeasance

    malfeasance Network Guru Member

    This looks new to me, so I'm posting it - my recent experience.

    Problem: WRT54GS v.2 with DD-WRT v22 prefinal 5. Flashed to HyperWRT 2.0. Everything fine until: attempted to change the WAN from DHCP to Static. Craaaash! No workee no more! Seemed ded. I try everything short of popping the top and shorting pins - it's the only one I haven't opened and I wanted it to stay virgin, for some reason. However, I can get a DHCP address on my wired connection if I try to.

    Uh oh, but wait: I can get some pings in from time-to-time, and an occasional web management page up, right after booting or at different times whilst holding the reset button down and holding my mouth just right, etc.... Doesn't last, though. Yes, tftp is the last option before popping the top but I don't have any confidence in it working at this time. Hmmm.... I got an idea!

    If I can get some web management pages maybe I can try to turn off the wireless adapter! I thought it was worth a try and it worked. I was speculating that a WDS setup might have transferred to the HyperWRT firmware even though I selected defaults on the DD-WRT pre5. HyperWRT doesn't support it through the web interface. Maybe this was bogus, but the strategy worked.

    We are trying to turn off the wireless adapter, and we have to do it in the very few seconds the router can allow us in. Also, we'll have to erase nvram.


    -Router set to defaults through resetting for 30 seconds and turned off. If you want to use another version of resetting reported: no network cables plugged in and whilst holding down the reset button, plug in, hold for 30 seconds, let sit for 2 minutes, then unplug.

    -I set my my NIC to 10baseT half-duplex and a static IP with gateway as Maybe not necessary, the NIC mode change. Plug into router.

    -Type default IP for router into address bar of preferred browser plus Wireless Basic Management screen asp, like this: but don't push enter yet. It has to be just like that or it won't go to that page. (With this new Posting interface, I didn't know how to turn off automatically converting URL's to live URL's, so there is an underscore, like this: Wireless_Basic.)

    -Plug router in and, if you are using XP, watch the connection icon in system tray and when it's connected, hit enter. It should be about 3 or 4 seconds. If your using another operating system, you could set up a ping to run and when it reports contact, go! If you get in, you will be presented with the login screen, so be ready to type in the password of admin You may have to do this more than once to get in.

    -If your lucky, the Wireless Basic Management page will be presented to you. However, you may have entered the password but communication ceased before the page could load, so unplug, wait a few seconds, highlight the URL in the browser and then plug in again and be ready to hit enter. You may have to do this more than once.

    -If and when you get the page, choose Wireless Network Mode>Disable, (it will be set to Mixed by default) but don't push the 'Save Settings' button yet.

    -Unplug router, wait for connection again, then push 'Save Settings.' As usual, may have to repeat. Depending on what browser your using and how it's set (to cache pages or not) notice that if it ain't goin' through, stop it or you'll have to reconnect to the Wireless Basic page again.

    I think you get the idea. You'll have to erase nvram to get it back on it's feet normally, which can be a problem.

    I was able to get the Web interface to work normally after success. However, putting it back into wireless mode crapped it out again. Repeated process, and flashed official firmware. Setting of Disable for wireless mode transferred, so I could interact with the router via HTTP normally. However, enabling a wireless mode knocked it down. So, I wanted to try to erase nvram but couldn't with official firmware. So, put HyperWRT back on (after getting it going again via above method.) But, after telnetting in and attempting a 'nvram erase' the operating system reported back "no nvram applet found." I guess I could have used a wl nvram command, but I didn't know one and I didn't experiment. The 'mtd' command I've seen for 'mtd nvram erase' must only be available on DD-WRT v22 pre5 because none of the other operating systems I have running know what to do with it.

    I got it running with wireless disabled again, put Alchemy final 1.0 on, telnetted in and executed a 'nvram erase' and, voila! Totally back in business (after about 3 or 4 days.)
  2. Mediamon

    Mediamon Network Guru Member

    Hey Mal-

    Congratulations on finding and documenting a new method of debricking.

    To tell you the truth I got a little lost. Hoping you might be able to reduce the above solution into a simple step-by-step, including only the necessary steps that provide positive results (and not including the actions that did not work). Thanks.

  3. jagboy

    jagboy Network Guru Member

    the command is "mtd erase nvram".
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice