New E3000 - WAN connection troubleshooting?

Discussion in 'Tomato Firmware' started by rubik, Feb 10, 2012.

  1. rubik

    rubik Networkin' Nut Member

    Hey All-

    Just bought a new E3000 router and flashed it with 'tomato-E3000USB-NVRAM60K-1.28.7495.1MIPSR2-Toastman-RT-VPN' and everything seems to work well... except that I can't get it to connect to my ISP to get an IP address.

    Unfortunately, flashing it with the Toastman's tomato build was the first thing I did -- it never crossed my mind to try to hook it up to my Verizon FIOS box using the Linksys firmware that it came with.

    I'm not really sure how to troubleshoot this issue at this point. Should I flash back the Linksys firmware and see if that works? Any precautions with flashing it on top of a tomato build?

    The WAN port does seem to work because if I chain the E3000 to the old WRT54G (running tomato-ND-1.28.8525_RAF-VPN) and set it up for and then hook up my PC to the E3000, the tomato UI shows the WAN port connected and I can access the Internet on my PC, etc.

    MAC Address *edited*
    Connection Type DHCP
    IP Address
    Subnet Mask
    MTU 1500

    Status Connected
    Connection Uptime 0 days, 00:03:23
    Remaining Lease Time 0 days, 23:56:37

    Also, I can obviously get a WAN IP on the WRT54G so there doesn't seem to be anything wrong with the ISP link. I tried spoofing the WAN MAC address to that of the WRT54G router (just in case the ISP is checking for it) and it didn't help.

    Any suggestions on what to try, please?

    Thanks much in advance.
  2. ntest7

    ntest7 Network Guru Member

    On the Advanced->DHCP/DNS page you can try fiddling with the "reduce packet size" setting at the bottom of the page.

    I don't know about FIOS, but cablemodems can often be cured by turning everything (modem and router) off for 10 minutes and then starting back up. (I assume there is some sort of FIOS adapter you can turn off)
  3. rubik

    rubik Networkin' Nut Member

    Thanks for the reply.

    Yes, there is a FIOS "box" which basically converts the coaxial connection to ethernet, into which I plug in the router.

    I will try powering that off for a bit longer to see if it helps. I've power cycled it already but only left it unplugged for ~30 seconds.
  4. rubik

    rubik Networkin' Nut Member

    After flashing back to stock Linksys firmware and verifying I still couldn't get an IP address from the ISP, I called them and they had to remotely reset something on my box/account and sure enough, it then worked.

    I'm back on the same Toastman build as above and everything is working well now. Whew!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice