New Firmware 2.3 R63

Discussion in 'Cisco/Linksys Network Storage Devices' started by Javert, Aug 6, 2005.

  1. Javert

    Javert Network Guru Member

    I downloaded and upgraded my unit to this version o Linksys' firmware. The first thing that I noticed is an option to activate FTP. I activated this feature, setup the router to allow FTP traffic to the NSLU2 only, and then tested it. I worked out good.

    I am concerned about security though. I can't find any info regarding Linksys' newly added FTP and if there are any "back doors". For now I only open the port when I know I'll be away and I'll need access to files. However, I don't feel comfortable leaving it open when going out of town on business etc...

    Does anyone have any info on this? Has anyone tried "hacking" in? Until I know a bit more regarding what type of FTP "service" Linksys added etc., I'll keep the port closed for good. Sort of defeats the purpose of FTP though.

    Thanks in advance...
  2. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    Interesting..... So where did you get the firmware? I was trolling around on the official Linksys FTP site and didn't find it there. What else does it fix? Care to share ;-)

  3. techmanblues

    techmanblues Network Guru Member

    Well, there is a contradiction on the Linksys site. It does offer a new firmware of 2.3 Release 63 for download, but the txt file that would explain what is in this R63 update is meant for R29! So what is going on here?!

    I am not going to download and install "R63" unless I know what new features and fixes are included with R63.


    I went on chat with tech support at Linksys and this is the transcript from that chat

    Hyacinth M(15715): Hi, my name is Hyacinth M(15715). How may I help you?

    You: Hello. I need for you to resolve a contradiction on a firmware update that is found on the Linksys website. It's for the NAS NSLU2 device

    Hyacinth M(15715): One moment please, while I verify that information.

    You: according to the product support page, the latest firmware is 2.3 Release63, but the info txt file says it's R29. So before I install this R63 update, I want to know what is included in this update of R63

    Hyacinth M(15715): Okay. Give me time to get those information please.

    Hyacinth M(15715): The download site will let you download the R63. The release notes was just not included. But here it is anyway.

    Hyacinth M(15715): Fixes and enhancements:

    * Now supports FAT16/32 and NTFS. No need to reformat the hard drive
    to EXT3 to be able to recognize by the NSLU2

    * Disk 1 and Disk 2 was replaced with USB Port 1 and USB Port 2 on the
    Web UI

    * Supports multiple partition per hard drive

    * Also resolves the problem with displaying the free space on Disk 2
    with firmware version 2.3 r29 and 2.3 r31

    Note: NTFS will only work on USB port 1

    Hyacinth M(15715): For general networking concerns, you may go to

    Is there anything else I can help you with?

    You: So this is the info on R63? If so, is there another Relase between R29 and R63?

    Hyacinth M(15715): No. I'm not really sure why they named the new release like that. Just in case you would ask.

    You: So you have no info on R31? R31 was mentioned on the info for R63

    Hyacinth M(15715): No. You may e-mail us for a request for that information instead.

    You: ok, what email?

    Hyacinth M(15715): You may also email us at

    You: ok, thank you


    Well, there you have it folks. the big news is now the NSLU2 can take NTFS drives! Hoohoo! I will download and install R63 to see what other goodies does post R29 firmware offers.


    Oh crap! After the update to R63, it worked until I tried to reformat my ext3 drive to NTFS. Now, I cannot get to the webgui for the device. I can ping it, but I cannot get the gui on IE. Any sugestions?

    Looks like I have a bricked NSLU2 at the moment.
  4. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    Wow, that's a lot of very useful information. Thanks!

    Also on a thankful note, I didn't read your post until after I had installed the new firmware myself. I likely would have tried to format the 1st hard drive as NTFS too. Hope you get that resolved.

    I did notice that my 2nd hard drive doesn't show as 0% free space anymore...that was a major pain with the 2.3R29 and previous firmware. Other than that it was clear sailing before and even clearer (for me) sailing now.

    Shows the value of this board doesn't it? If you unbrick your NSLU2, please let us know how you did it.

  5. techmanblues

    techmanblues Network Guru Member

    Anyone here knows how to use the tftp command to flash the firmware in the NSLU2 in DOS?

    The man file of tftp is confusing to me.

    The firmware file is r29.bin because I want to flash it back to the previous working version. My machine where the bin file resides has a NetBIOS name of p24 and an IP of The NSLU2 has the default staic IP of and a NetBIOS name of Slug. The weird thing is no matter how many times and how long I press the reset button, the wizard running from the CD that comes with the NSLU2 always detects the NSLU2 at But the kicker is I previously renamed the SNLU2 from its default NetBIOS name of whatever to "Slug", but after many attempted resets, the wizard still sees it as "Slug" instead of its default out-of-the-factory name. It is as if the reset only changes everying except the NetBIOS name. Therefore, it seems to me that the resetting is not completely clear out all settings.

    If the tftp command does not work, it's back to the store it goes. I bought this less than 30 days ago.

    Incidentally, when it was working right after upgrading to R63, there was an FTP option in the firmware of R63. This means you can now upload files into the NSLU2 locally and I assume from the Internet as well. This is such a cool feature. Too bad my NSLU2 got bricked before I had a chance to try it out.
  6. techmanblues

    techmanblues Network Guru Member


    It's a miracle! The fact that the "slug" name that I gave the NSLU2 was never removed after several resets made me wonder what other old settings were still retained in addition to the name. Then it hit me, the damn port number. In the old setting of R29, I told the device to listen to port 81 instead of the default port 80. So when I put in in IE, there it was: the GUI screen! So then I went in and began to click on the buton to reset to the manufacturer default setting and everything is the where it should be (I think).

    There is one thing that I need you guys to confirm for me for the R63 firmware. If the USB1 Disk is formatted NTFS, I cannot change the default password of admin to anything else?! Is this true? Basically, with NTFS, I cannot create any new users or new groups? This is awfully weird NOT to be a bug.

    When I reformat the NTFS drive back to EXT3 using the NSLU2 as the formatter, I can change the password to admin user and create new users and groups like it was in R29. This has got to be a bug in the R63 firmware. Please confirm. Also please confirm that I cannot use the NSLU2 to format the USB1 Disk NTFS. In other words, I have to pre-format the drive NTFS, then connect it to the USB1 port on the NSLU2?

    Ever since I bought this NSLU2, there has been one problem after another. I am seriously regreting buying this infernal device. Any of you know if Linksys' other higher end NAS devices have the same buggy history? You know, the ones that have the hard drives already included inside the enclosures?
  7. thekey

    thekey Network Guru Member

    New firmware still sh@!#t

    Just downloaded and installed the new 2.3r63 firmware.
    Tried one copy operation (one directory with some big files (20 Mb))
    " lost connection" messages pop up within one minute.

    I give up. I want to return this absolutely useless piece of junk.
  8. Javert

    Javert Network Guru Member

    Just to update the group on my experience thus far since updating the firmware.

    Drive 2 now shows the correct size.

    Transfering files up to 4 gigs (image of DVD version of Mandrake) tranfered without any problems.

    The group and share options "seem" a bit easier to use (although it's been months since I last used it).

    FTP is working great (I still have security concerns).

    I plan on testing Linksys' claims that FAT32 and NTFS formats are now supported. I just haven't had the time. Plus, it'd be a pain to set the shares up and transfer everything over.

    While the NSLU2 isn't the fastest NAS i've used, it has done well considering the price. I had just about given up hope that Linksys would publish new firmware.
  9. Oisi

    Oisi Network Guru Member

    I just reflashed back to R29, perfect now!
    Had same issue - losing connection after a few mins.
  10. Javert

    Javert Network Guru Member

    Just to update the group on my experience thus far since updating the firmware.

    Drive 2 now shows the correct size.

    Transfering files up to 4 gigs (image of DVD version of Mandrake) tranfered without any problems.

    The group and share options "seem" a bit easier to use (although it's been months since I last used it).

    FTP is working great (I still have security concerns).

    I plan on testing Linksys' claims that FAT32 and NTFS formats are now supported. I just haven't had the time. Plus, it'd be a pain to set the shares up and transfer everything over.

    While the NSLU2 isn't the fastest NAS i've used, it has done well considering the price. I had just about given up hope that Linksys would publish new firmware.
  11. LordFlux

    LordFlux Network Guru Member

    Been running great...

    Updated to R63 yesterday and things have been running great. I don't use all of the features of the NSLU2... just use it as a backup for device drivers, ROMs, MP3s, etc.

    Haven't done much testing, but the transfer rate seems to have improved a little. Anyone else notice a performance boost?
  12. mgamrac

    mgamrac Network Guru Member

    I have a one question – can I enable telnet or SSH in new 2.3r63 firmware? Now I have a Unslung 5.5 Beta firmware (based on 2.3r29) and I can enable telnet.

    The telnet mode I have using only in a local network. Then I can login via telnet, running “wget†command, logout from NSLU2 and turn the computer power off.

    Mariusz - Poland
  13. techmanblues

    techmanblues Network Guru Member

    Ok, the NSLU2 of mine has been serving out files via ftp for a few days now w/o problems. Can any security experts here tell me how secured are the files being served? For my NSLU2, there are several "private" accounts that require log in names and passwords, but are the accounts secured?

    I read somewhere that FTP was invented in the old days when security was not an imporatnt issue. So has the original insecured nature of this protocol been "solved" by newer versions of the protocol? I think HTTP version 1.1 was a security upgrade to HTTP, but has FTP gotten the same treament, and to be more precise, is this newer more secured protocol being used by the NSLU2?

    I really like FTP. It makes transfers of files a snap, but I am concerned about the stuff being accessed by unauthorized users.
  14. Slackmaster

    Slackmaster Network Guru Member

    After upgrading to the new firmware my "slug" became almost unusable. It took 15 seconds to open any shares, another 15 seconds to open a folder, another 15 seconds to open a file, etc, etc. I contacted Linksys support about this and was told they would look into it. I had to downgrade back to release 29.

    I know it seems to be a common Linksys practice nowdays to release buggy firmware, but I was wondering if anyone else has had this problem.

    Also, the last time I checked the Linksys website STILL has the wrong firmware version info. Would it really be that much trouble to update the website with the correct information?
  15. techmanblues

    techmanblues Network Guru Member

    I am convinced that R63 is not ready for primetime. The fact that they do not have the release info accompanied with R63 shows that it is. Sometimes my R63 firmware NSLU2 does not recognize a HD attached to USB1. I had to downgrade to R29 then re-upgrade to r63 before it recognizes the drive. Another weirdness is the R63 mistakens my 5GB HD atached to USB2 as a Flash drive ("Flash"). And it does not recognize this 5GB drive attached to USB1 at all (Ext3 or FAT32 or NTFS)!
    I hope that the people at can release a more stable firmware based on the R63 release. Actually, I am not sure they can fix R63 because as I understand it, the unslung firmware does not modify the stock Linksys firmware, but appends to it. Therefore, if R63 remains buggy, unslug will not do any good. Those who are adventurous can use Openslung which completely replaces the stock Linksys firmware. Use this with extreme caution though because you may not be able to flash back to the stock firmware.

    At this point, Unslung is based on R29. The reason I am not using Unslung because I am not a Linux person. I am used to have all the features built into the firmware directly. To really use Unslung, you have to install these "packages. " Right now, I have no clue how to do that. The site for Unslung is designed with the experienced Linux users in mind and therefore is useless to newbies like myself.

    The NSLU2 is filled with so much potential. Unfortunately, it seems Linksys is not taking this product seriously. Afterall, its cashcows are the WRT54G so I can't blame linksys for not having enough manpower to work on the NSLU2.

    Come to think of it, since this is version 1 of the hardware, could all these problems be attributed to the hardware of the NSLU2?
  16. Slackmaster

    Slackmaster Network Guru Member

    There is an interesting article on the NSLU2 Linux site ( about how to de-underclock the NSLU2. Apparently the processor is set to run at half speed (133mhz compared to 233mhz), and there doesn't appear to be any obvious reason for this. If you remove one resistor from the board the processor runs at the standard speed.
  17. yopnono

    yopnono Network Guru Member

    Yes you can revert back to the standard Firmware of linksys

    Just download the flash utility from sercomm
    If you are using windows LINK: SerComm

    If using linux use upslug
  18. janericster

    janericster Network Guru Member

    The R63 firmware is definitely not ready for prime time. Just wasted all afternoon with it (including a 25 minute hold on tech support phone call)...had to revert back to the R29 version.

    The NSL kept timing out and disconnecting (requiring the power plug to be pulled and then restarted) in order to get back online.

    I'm very disappointed in Linksys for their lack of QA on their firmware.
  19. rwhitby

    rwhitby Network Guru Member

    Linksys stock firmware considers anything less than 10Gb to be a flash disk. It's hard-coded into their kernel. Unslung reduces this limit to 1Gb.

    You can *always* flash back to stock firmware from *any* nslu2-linux firmware. Always.

    -- Rod
  20. techmanblues

    techmanblues Network Guru Member

    No wonder it does not recognize my 5GB drive on USB1. USB1 is meant for only a harddrive. This case, any over 10GB.
  21. Pendragn

    Pendragn Guest

    Re: New firmware still sh@!#t

    This the first thread I've ever read here, so forgive me if I'm covering information that's been covered before.

    I had the same problem with my NSLU2. It would drop off the network periodically. For me (and many others) it was a problem with uPNP. I disabled uPNP on my NSLU2 and on my DLink router and my NSLU2 has been solid as a rock ever since. This was with two different firmwares.

    Good luck,
  22. LordFlux

    LordFlux Network Guru Member

    Just wanted to say that my experience with R63 is still going great. This past Friday, I followed the 'OverClockTheSlug' instructions so that the IXP420 runs at 266MHz. Didn't see much of a gain, but the directory listings seem to appear quicker.

    I ran the DiskBench utility ( ) to see what kind of bandwith I was getting. Tested it on a Doom3 PAK file (336MB) and got 5.47mbit/sec (read speed). Got 1.78mbit/sec write speed. Not sure how accurate the utility is, but the NSLU2 definately seems quicker since the firmware update and IXP420 modification.

    As I said before, I only use the NSLU2 for backup... I do not use any of the advanced features. I'm running a MASSCOOL FU310 3.5" external enclosure ( ) and a Maxtor DiamondMax 10 6L300R0 300GB hard drive ( ).
  23. janericster

    janericster Network Guru Member

    My experience has been a nightmare. So far I have lost over 8 hours of work time trying to get these damn things to work properly. I've also lost two 250GB USB drives (worthless if I need to connect them back to my PC directly with that Linux formatting that the NSL puts on them).

    I've tried putting just one drive on Disk 2 connection...I've tried disabling the uPNP, even tried 3 different firmware versions.

    Nothing works!!! The NSL keeps disconnecting during large file transfers or even a simple backup procedure.

    I've spent over an hour on the tech support phone line...another hour on their live chat...still no answers.

    I've tried using Knoppix to reformat the drives, but it won't even recognize them.

    About all I can do is keep disconnecting the plug to the NSL and use it for a few minutes at a time during transfers.

    Eagerly waiting to hear back from Linksys (open ticket number with their tech support) but I'm not holding my breath.

    If I could at least restore the 2 USB drives back to FAT32, I could take the NSL back to the store and call it quits.



    I was FINALLY able to get Knoppix to work on another PC and used the fdisk command to reformat my USB drives!!! I'm so relieved....and so eager to take the NSL back to Best Buy tomorrow.

  24. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    rwhitby, does unslung support NTFS, FAT32 similar to the new Linksys firmware or is there work for future addition? I'm currently running V2.3R25-uNSLUng-standard-2.12-beta and have been debating upgrading it straight to unslung 5.5.
  25. uffez

    uffez Network Guru Member

    Where can I find the R63 firmware

    The download link here seems not to work - is there somewhere else I can download the new firmware?
  26. techmanblues

    techmanblues Network Guru Member

    Unslung 5.5 does not support NTFS/FAT drives because it is based on the R29 Linksys stock firmware. Remember that unslung does NOT replace the stock firmware, just appends to it. If you want a complete replacement of the stock firmware, try OpenSlung. But do this only if you are a Linux geek.
  27. yopnono

    yopnono Network Guru Member

  28. Ollyholmes

    Ollyholmes Network Guru Member

    Link to R63 not working!

    The file was working fine and now all I'm getting is a 511k file!! Has anyone got the real firmware that they can send me? I'm trying Live Tech Support but they aren't being too helpful - the guy is denying it exits!

    Ritchie F(13960): We have an updated firmware 2.3 Release 29 from I need to confirm this 2.3 release 63. I think this is an incorrect firmware.

    I only bought one as it has ntfs support now!
  29. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    Re: Link to R63 not working!

    I have posted it on my own ftp site. It will be there for only a day (until midnight GMT-5 19 August 05)
    user = nslu2
    password = nslu2.firmware.version2.release63

  30. Ollyholmes

    Ollyholmes Network Guru Member

    Eric is the man!!

    Thanks - I'm downloading as we speak (but being dragged off to bed so I'll have to try it in the morning!!)

    This forum rules!
  31. B-Art

    B-Art Network Guru Member

    Re: Link to R63 not working!

    Thanx guyes.

    It works like a charm! I plugged in my FAT32 HD (120Gb) Faster than ever. It recogniced my HD in seconds. previously I Used MU-5000FS form Ovislink[web:40bba7480a][/web:40bba7480a]. I wanted to use FAT32 being able to connect to any PC with Windows. But my MU-5000FS was slow.... :( realy slow..... :cheerup: Perhaps the new one is better but now I can stick to the NSLU :drinking:
    A great other tool I found a link at ovislink:
    Works great if you want to format bigger than the 32GB M$Limit.
    Or more direct:
    Eric would please leave it there for others to download?
    It worked for me :thumbup:
  32. yopnono

    yopnono Network Guru Member

  33. B-Art

    B-Art Network Guru Member

  34. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    Re: Link to R63 not working!

    I'll leave it up for an extra day or two. I just don't like opening my network up to the Internet anymore than I have to!

  35. you da man!!!!

    Hey Eric

    Thanks a lot for that - just downloaded! Not wanting to make a big deal about it, but stuff like that certainly restores my faith in humanity!!!

    thanks again....
  36. Kelxin

    Kelxin Network Guru Member

  37. Kelxin

    Kelxin Network Guru Member

    You know....

    Even after flashing the firmware, getting the NTFS drive up and running on it, I'm pushing maybe 30 mbits a second off of it on a Gigabit network, if I'm lucky. When dealing with 30 GB + files this thing is way to slow. I ended up taking it back and looking for yet another solution. Back to the 700 mhz file server, atleast they're still good for something... ;)

    - Kelxin
  38. techmanblues

    techmanblues Network Guru Member

    Linksys finally posted the documentation of firmware 2.3R63. What is puzzling is the following:

    V2.3R63 (7/06/2005)
    1. FAT32/NTFS support on Port 2 and FAT32/EXT3 support on port 1

    Does this mean USB1 cannot read NTFS drives? Can anyone here verify this after install the latest R63 firmware? Is there a R63 version B now? This is getting confusing.
  39. d__l

    d__l Network Guru Member

    In their haste to get out the release notes, Linksys must have messed up. That has to be wrong because we would expect that Port 2 also does EXT3 on a Port 1 to Port 2 back up and this EXT3 capability isn't shown for Port 2.
  40. techmanblues

    techmanblues Network Guru Member

    Sometimes I wonder how seriously Linksys puts thoughts into the NSLU2. Anyone here uses Linksys' other NAS devices? Are they as buggy and poorly documented as the NSLU2?
  41. techmanblues

    techmanblues Network Guru Member

    v2.3R63 second version?

    I downloaded and installed the "latest" version of the firmware for the NSLU2 today, the supposedly R63 version. To my surprise, this particular download fixes some minor bugs found in a R63 firmware that I download a few weeks ago from Linksys. This could mean that Linksys has released several versions of the the R63 firmware without telling us.

    Weird, but the moral of the story is, if your NSLU2 has problems even with the latest firmware that you downloaded from Linksys a few weeks ago, re-download the this "latest" firmware and give it another shot.
  42. Rufus

    Rufus Network Guru Member

    What were the minor bugs techmanblues? My R63 is currently good except for the users page.
  43. d__l

    d__l Network Guru Member

    I see no differences between the older R63 version without the release notes and this new R63 version with the release notes. The date and time stamps are identical for the two bin files, the sizes are the same, and a binary file comparison of the two says there is no difference.

    Perhaps your second flashing fixed some register settings that the first flashing didn't correct. I'd hate to think that we would have to reset the NSLU2 to factory defaults before and after a flashing like we have to do with the SX41.

    Maybe a reflash of R63 is a good idea for anyone having minor problems with the NSLU2 on R63 in case there is a problem with the first flashing.
  44. techmanblues

    techmanblues Network Guru Member

    The bugs are really minor. For example, I could not remove the user accounts and their associated shares and groups in one stroke. The check boxes that allow me to do so were all grayed out. i had to delete the shares and groups manually.

    Also it seeems a bit faster now when it comes to data transfer in and out of the NSLU2.
  45. khisanthax

    khisanthax Network Guru Member

    I tried to go to Management/telnet.cgi to gain access to telnet but it didn't work. I'm going to attempt to install unslung but not sure if the apparent lack of telnet would be a problem once I install unslung. Does anyone know?
  46. scvogel

    scvogel Network Guru Member

    R63 Not ready for Prime-time

    I must agree with whoever said that R63 was not ready. I just spent way too much time trying to fix the dreaded disk Read-only error.

    Linksys tech support recommended all the usual stuff - reset the unit, unplug the drive, try switching the drive to the other port. All to no avail. The drive still appeared to be read-only.

    Then they recommended an upgrade to the lastest firmware - 2.3R63. After the upgrade, the drive was still readonly but now it was so slow that it was unusable. Mapping the drive from Win-XP took 75 seconds. Really. Opening a simple file took minutes.

    I did try accessing the shares via ftp (in a browser window) and that was really fast. One nice feature that worked in R63, but using the drives as network shares was absolutely useless.

    So after giving up on that, I downloaded R25 and downgraded my firmware. Voila - Read only problem is gone and the drive access speeds are back to normal.

    What I learned from this exercise is to check this forum first, since most of the reliable info that I got was from here and not from Linksys tech support.

    I noticed that someone else had a real problem with slowness after upgrading to R63. I hope downgrading to R25 will help you too.
  47. d__l

    d__l Network Guru Member

    Did you try a scandisk to fix the Read-only problem?
  48. scvogel

    scvogel Network Guru Member

    Scan disk

    Scan disk did not fix the read-only problem.

    Tech support seemed to think that holding reset for 30 seconds with the power off would fix it.

    When that didn't work, they said that holding reset for 2 minutes with the power off, then power up while holding reset for 1 minute, then power down for 2 minutes, then power it up... would fix it.

    It didn't.

    I half-expected to be asked to stand on my head.....
  49. MattK

    MattK Guest

    Hi, just thought I'd relay my experience with this device/firmware. (Which is minimal).

    I bought the device in order to get a very specific USB Hard Drive on to my network. It is a Freecom Media Player. At first, things looked good - I plugged it all in, formatted the Media Player, and transferred a few MP3s and AVIs. Fired up the player, and it wouldn't recognise the Hard Drive. Shame really, thought I. A bit of reading told me that the Media Player requires FAT32 or NTFS format. Of course, after the recent formatting, it was neither.

    To make a short story even shorter, I formatted it back to NTFS, put the latest firmware on the NSLU2, and all was good straight away. Thank goodness. The only issue I can see now is that the browser reports the disk has 0% free. If that's the only bug, I can handle that.

  50. Pimptastic

    Pimptastic Network Guru Member

    Where can i get old versions of the firmware so i can downgrade!?

  51. PedrosPad

    PedrosPad Network Guru Member

  52. alannyc

    alannyc Guest

    Hello I just got the nslu2. I am already having issues. This is my situation:
    1-Tried to upgrade the device to r63 and got an error saying"Not enough space"
    2-Attached a blank seagate drive to usb 2 and formated with the firware that came with it.
    3-Upgraded the firmware to errors
    4-I mapped a drive and found out that I could not delete files I created on the drive from windows xp sp2...strange.
    5-I called Linksys and we went through alot of things.
    6-we tried to reformat the drive, but it would say it was doing it, but it would stop very quickly.
    7-I deleted the particians by attaching it to my Windows XP PC
    8-reconnected the drive to nslu2 (reboot etc.)
    9-reformated the drive using the nslu2
    10-still I could not delete files.
    11-Just as a lark I reconnected the drive to usb 1 and low and behold i was able to delete the files I created
    12-I then decided to connect the NTFS drive I have to the free port as the firmware notes said it would work...well it recognized the drive, but said I needed to reformat the drive
    13-I switched the devices and the nslu2 recognizes the NTFS drive, but says format it and does not recognize the ext3 formated drive.

    This is a wacky device...did they test it. I asked linksys to send me a new device.
  53. PedrosPad

    PedrosPad Network Guru Member

    Apparently not as thoroughly as the mere 'users' in these threads.
  54. Pimptastic

    Pimptastic Network Guru Member

    Just for everyones information

    I recently converted my drive to Ext3 and now all my problems have gone using the latest firware.

    transfer speeds have tripled too.

    Now happy :cheer:
  55. yaking

    yaking LI Guru Member

    NSLU2 and R63

    I must confess that I have had terrible luck with many Linksys products. And their customer support is very misguided. Eventually, my studio required a completely professional approach to networking and it was amazing how quicking everything worked. That said, there was a real need for clients to download their projects in progress without learning an FTP program. Hence the purchase of the NSLU2. After my third unit, and hours of technical support, I realized that LEAVING THE FIRMWARE ALONE makes a happy device! Also, when upgrading, be sure to disconnect the hard drive, connect directly to a computer, and reset the unit after complete (even though that never worked). I still use a computer running Bullet Proof FTP for uploads but I must say, when you leave the NSLU2 alone, it works REALLY well. Just my two cents and personal experience with Linksys products. Your mileage may vary.
  56. yaking

    yaking LI Guru Member

    NSLU2 and R63 addition from tech support

    ...Be sure to disconnect the hard drive, connect directly to a computer, and reset the unit after complete (even though that never worked) +

    try lowering the port speed on the computer that is initiating the upgrade and do a hard reset.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice