NEW firmware based on 1.01.58 GPL code for WAG354G V2

Discussion in 'Other Linksys Equipment' started by Carciofone, May 17, 2007.

  1. Carciofone

    Carciofone LI Guru Member

    Hi to all!
    New firmware for WAG354G V2 based on 1.01.58 GPL code in two versions:
    1.01.58_004 with original DSP 6.2 driver and
    1.01.58_005 with DSP 7.2
    Wireless fixed with 1.01.54 driver and other futures:
    telnet support available
    1.2.1 Busybox with other line commands
    rewritable partition of 128 KByte on Eprom for personalized scripts.

    Infos on the Neptune354 Project:
  2. bill888

    bill888 LI Guru Member

    Hi, I was testing your modded 1.01.58_005.

    I notice the log does not work. It is always empty.

    Although the logging never worked properly, the official FW usually displays the start up date & time and a few pages of events following a reboot.

    The line attenuation and may be other ADSL line parameters is also incorrectly reported with DSP 7.2. It is usually around 49dB on my line, but this firmware is reporting 122dB.

    I am now testing your modded 1.01.58_004 with DSP6.2
  3. marksutherland

    marksutherland LI Guru Member

    Hi, I'm having a bit of trouble installing the new firmware. I tried installing the 1.01.11 "official" firmware off of the linksys website, and it seemed to like the Annex A firmware better (i.e. the upgrade failed whne I tried the Annex B firmware), so I assume I have an Annex A router. Anyway, the .11 firmware installs, but the router is still unreliable. I've tried installing pretty much all of the .57 and .58 versions you have listed on esnips, but they pretty much all result in me seeing the "Upgrade is failed" page. Anybody have any ideas as to what I'm doing wrong? Thanks for your help.

    Mark Sutherland
  4. Advis

    Advis Network Guru Member

    The 1.01.11 firmware is for the V1 version of the router. The 1.01.57 and .58 versions are for the V2 models. As the hardware is different in both V1 and V2 versions that's bound to be why your having problems.
  5. marksutherland

    marksutherland LI Guru Member

    yup, that would explain it :) Thanks!
  6. Carciofone

    Carciofone LI Guru Member

    Hi bill888. Thanks for your interest in this project.
    What you say with regard to the logging is right. It depends on the new busybox 1.2.1 that doesn't have some type of logging.
    If you need the logging and if the new instructions of busybox 1.2.1 do not serve you, I compile a firmware with the old 0.6 or 0.9 busybox for telnet made by Linksys that have the log function.
    DSP 7.2 is specific for ADSL2+
    There are 2 new versions of firmware (DSP 6.2 and 7.2) …_006 and _007 that would have to resolve the issue of the freeze of the DNS with the browser.
  7. bill888

    bill888 LI Guru Member

    Tnx for the reply.

    I'm currently into the 4th day of testing of this firmware and so far I am happy with it. I may try your new '006' release later.

    WAG354GV2 EU ANNEX A 1.01.58_004 DSP

    fyi, I previously tested the following release for 12 days without turning router off:

    1.01.57 EU WAG354GV2 by C@rciofone wireless OK.bin.tar (no busybox)

    Only problem I observed was at night, the router would often resync once after every 1 or 2 days. when noise margin probably deteriorates. My ADSL line is not very good. speeds vary from 4400-6200kbps. I've witnessed similar problems with a Speedtouch 585v6 fwiw.


    WAG354G UK v2
    802.11b only
  8. Carciofone

    Carciofone LI Guru Member

  9. diz2k

    diz2k Guest

    Neptune WAG354GV2_006 1_01_58 at last fixed wifi for me. Thanks a lot.

    Some problems:
    1. No matter what I do, I can't generate private key for sshd (partition is formatted and mounted I guess and daemon is off at the time of generation). Always tells me that "The values you entered are invalid. Please try again".
    2. Administration -> Utility tab is only visible when Administration -> Management is active.
    3. There is a bunch of layout problems in web interface. Can I contribute to fix this things? If you could put these files somewhere, I can do some modifications.
    4. Also there is one feature that I’m missing since I bought this router.
      I would like to wake up (WOL) my computer from Internet. For that to work, I should forward WOL packet to broadcast address (x.x.x.255). In interface (Applications
      & Gaming -> Single Port Forwarding), I can’t set *.255. I can only use 0-254.
      Would it be possible to modify firmware to accept *.255 in address field? Another question is if this would work but this is something I can test.
  10. Carciofone

    Carciofone LI Guru Member

    The SSH generation key is fixed in WAG354GV2_008 1_01_58 kernel firmware (
    Other problems with the layout interface come from original project Neptune354.
    If you want the sources of the firmware please contact me with a PM or in the forum :
  11. Kroekel

    Kroekel Networkin' Nut Member

    Hello, I´m from Germany and try to configure my WAG354G V2 Annex B with the 1.01.58 Kernel.
    My Problem is, that since I made an downgrade from the Version 1.01.57 to 1.01.54 my WLAN doesn´t work and the DHCP Server in this Router doesn´t work too.
    Now I made an Update to 1.01.58 an these 2 Features doesn´t work.
    Any Ideas to solve this Incident?


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice