New firmware for WRT54G/GL released.

Discussion in 'Linksys Official Firmware' started by Trademark, Feb 3, 2007.

  1. Trademark

    Trademark Network Guru Member

    Thought some of you might want to know.

    WRT54G(v1-4) 4.21.1
    WRT54GL(v1-1.1) 4.30.9

    Firmware Date: 11/01/2006
    Release Date: 01/30/2007

    Version Info:
    - Resolves issue with L2TP connection
    - Resolves issue with Linux kernel vulnerability
    - Resolves issue with UPnP
    - Resolves issue with Access Restriction
  2. sNNooPY

    sNNooPY LI Guru Member

    Hm...why don't I see that update on
    I've got firmware v4.30.7.
    Is this 4.30.9. just for US?
  3. Trademark

    Trademark Network Guru Member

    Ya, it's only for US right now AFAIK.

    Also wondering if the GS will see an similar update?
    Just have to wait and see.
  4. super_coo

    super_coo Guest


    Hi guys I'm confused about the current versions for the Linksys WRT54G v3.0... do I use 4.30.5 that's on the Canadian site? Or the 4.21.1 that's on the US site? The Canadian version is a higher number but the 4.21.1 has a newer date I believe. Which version is better?
  5. Trademark

    Trademark Network Guru Member

    Use 4.21.1 as it is the most up to date and coded for the G.

    4.30.5 is actually based on the GL code, but they changed it this release.

    For some reason, Linksys decided to release the same firmware for the G and GL hardware on the last update. Mistake? Who knows.

    I would also suggest looking at all different flavors of firmwares that are listed on this website, that is of course unless the stock firmware fits your needs. Some very talented people have made a great selection to choose from. Enjoy.
  6. Acquirer

    Acquirer Network Guru Member

    Upgrade to 4.21.1 causes broken config page on WRT54G v2.2

    Just flashed to 4.21.1 with successful flash message. However, now when I go into the web ui, it is completed corrupted, don't see options for any tabs, etc. I've tried viewing with IE7, Firefox and Opera with same results.

    Now, I've tried to reflashing and get an unsuccessful message. Tried reflash via TFTP and that doesn't work either (says it can't receive response from server).

    So, now I'm sitting here with no way to config the router.
  7. Trademark

    Trademark Network Guru Member

    Ouch, that blows. Curious, did you do the upgrade wired or wireless?
    You could try the pin-short technique. Might work.
  8. dilman

    dilman Guest

    i have asked the linksys support by email about 4.21.1 and 4.30.9, and it's what the techsup replied.


    Dear Valued Linksys® Customer,

    Good day!

    Thank you for contacting Linksys® Technical Support.

    Actually, it is just the same. You can upgrade the firmware of the router using the ordinary G or the GL. You can do the firmware upgrade using the GL if you still want to use the GL mode of the router but it still the same.

    Thank you for the time and patience.

    For frequently asked questions, you may visit our knowledgebase at

  9. Acquirer

    Acquirer Network Guru Member

    I actually ended up doing the pin-short method on pins15-16 late last night. I was able to get the router to accept a very early version of the firmware (2.02) so I am at least up and running. However, I can't get it to flash to any later versions for some reason.

    Any suggestions would be appreciated.
  10. Trademark

    Trademark Network Guru Member

    Nice that the pin-short method worked for you.

    It almost sounds like the firmware upgrades are being held back because they think the router doesn't have enough flash ram? This is pure speculation, and just off the top of my head, but I remember reading about it.

    Have you tried any 3rd party firmwares? Maybe try DD-WRT Mini Generic at first, since it is a smaller file, than flash to official firmware (if the first step works). It might work. Good Luck.
  11. Acquirer

    Acquirer Network Guru Member

    After much work

    I finally was able to get a micro build of DD-WRT on the router but it still doesn't allow any standard builds of ANY firmware. I checked the status page for the DD build I'm using and it shows something that may indicate a problem....

    Total Available13.8 MB / 16.0 MB
    Free2.6 MB / 13.8 MB
    Used11.2 MB / 13.8 MB
    Buffers1.6 MB / 11.2 MB
    Cached4.8 MB / 11.2 MB
    Active3.5 MB / 11.2 MB
    Inactive2.9 MB / 11.2 MB

    I may be reading this incorrectly, but does it show that my router is currently using most of the available installed memory, and if correct isn't that unusual?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice