new firmware for WRTP54G 1.00.43

Discussion in 'Cisco/Linksys Wireless Routers' started by Mufasa, Aug 21, 2005.

  1. Mufasa

    Mufasa Network Guru Member

    Well looks like my WRTP54G got upgraded to a new firmware last night. Anyone know what they changed in this version? Its causing me issues, but I do have unusual circumstances currently...

    1. Normally I use the router with my comcast cable internet giving a direct connect from the cable modem to the internet port on the router...

    2. Last Thursday comcast accidently disconnected my cable service and I have been forced to share a friends wirelessly accessable DSL to my entire network. To do this, I'm pretty much natting nat.

    3. By using the "static ip" feature of the router giving it a new internal IP on my network and giving it its new default gateway and DNS, I was able to use my vonage service in the NATted NAT scenario--even on incoming calls. :)

    4. The firmwmare upgrade resulted in no dial tone. When I went to connect to the router I couldn't. I could only connect after resetting the router and loosing the current configuration.

    5. Applying the same configuration back (assuming on the first screen that I don't change the router's IP and provide new static info at the same time) and I'm able to use diags to ping internet hosts by name again. BUT... I still don't get any service and if I power cycle with these settings, I can no longer reach the router again.

    Oh and all of this just so happens to have occured at the same time I was billed for the first time ever. Got my billing e-mail notificaiton and tried to make a phone call to check my cell phone voice mail (cell reception is non existant at home) and found no dial tone, etc...

    Any ideas anybody? I'm thinking they broke the nat traversal and I'm just stuck without service until my comcast is fixed on Tuesday. Arrrrgh.

  2. anazoal

    anazoal Network Guru Member

    I checked my WRTP54G and it's been upgraded to 1.00.43.

    ...Not much I can see different except that now it shows all the info when listing the clients table.
  3. Mufasa

    Mufasa Network Guru Member

    Well I think I might have just realized why my configuration no longer works. It relied on bridging between the lan and internet interfaces. I'd set the default gateway on the internet interface and it would use it on the LAN. They actually fixed it in .43 and it broke how I was using it.

    I've tried my best, but thus far it doesn't look like I can cheat the lan interface into having an internet default gateway due to its data checking on the advanced static routes page. Anyone know what IPs at Vonage's side are? I at least proved to myself I could make a specific external IP address route to the correct local gateway and be ICMP reachable from the router. I just don't know Vonage's IP/ip mask.
  4. Mufasa

    Mufasa Network Guru Member

    Well took a little restructuring of my local network but after I took my WGA54G that was using through my linux box and put it directly onto my WRTP54G and configuring for the other network statically in my WRTP54G I now have phone service again on the .43 firmware. I usually like to have this backup connection via the linux boxes routing but due to the configuration limitions in the WRTP54G firmware, this'll do for now. Sure wish it was nicer about default gateways within the local interface.

    Really odd bug that occured though... For some reason I couldn't get it to take my default gateway setting while configuring statically at all. Everytime I saved the setting it saved it as It wasn't until I set automatic configuration via DHCP, saved, power cycled and tried static (all settings at once) again that it took my default gateway. It didn't have any issues with any of the other static settings the whole time.
  5. blog

    blog Network Guru Member

    Anybody know if this version supports WDS? I had to totally restructure my network when I put a wrtp54g in place of my wrt54g
  6. ydef

    ydef Network Guru Member

    does anyone know where to download this latest firmware?
  7. Mufasa

    Mufasa Network Guru Member

    You should be able to have it pushed to your equipment if you contact Vonage support.

    Also if anybody was interested, DynDNS support was broken in .37 (my old version) and it works now in .43 It use to be flaky with the return messages and kept updating my host with an IP that was neither my lan or wan IP. Now it works as intended.
  8. ydef

    ydef Network Guru Member

    I'm not interested in having it pushed to my equipment.

    Obviously it would serve everyone interest's much more if i had the image to dissect so i can do a diff of the images and create a .43 patch for .00.37 , so that it includes the necessary patches fixes as well as passwords that we are aware of that will allow access to the router.
  9. Mufasa

    Mufasa Network Guru Member

    Oh I'm so sorry. I should have payed attention to who was posting. You're from that cool reverse engineering post. :)

    Based on the TFTP method, I guess the big mystery is the new filename. If nobody's figured it out by the weekend, I'll be glad to setup some in the middle ethereal capturing, downgrade my firmware (looks like the old password to the firmware page still works in .43) and call Vonage to have them push it to me. Then it should just be a matter reading the capture for the TFTP URL.

    Sure wish I had the TFTP URL to that mystery .xml extension file though. Not sure how much better I'd be at turning it into an xml doc (assuming it is an encrypted/encoded xml doc) but if it can be figured out, future updating manually will be a lot nicer.
  10. ydef

    ydef Network Guru Member

  11. Mufasa

    Mufasa Network Guru Member

    Well I'm under the assumption their deployment mechanism has not changed. For instance, on my windows box if I download (so that I have a TFTP client) and then run:

    tftp -i GET wrt-11.1.0-r016-1.00.37-r050624.img

    I am able to download the previous .37 firmware direct from Vonage right on my Windows box. So I figure if we just get the new filename for .43 we'll be in good shape to download it.

    Also read a few posts indicating that the initial .37 was sent from tech support (tier 2) to a user so that they could do the manual upgrade. I've never called support before so I can't vouch for it.
  12. anazoal

    anazoal Network Guru Member

  13. Mufasa

    Mufasa Network Guru Member

    Thank you! As suspected, this also works to get the .43 firmware:

    tftp -i GET wrt-11.1.0-r021-1.00.43-r050816.img

    All we did need was the file name.

    That HTTP link is pretty interesting too... Must be a web service of some sort based on the output without a "parameter"

    400 Missing path

    Resin-3.0.8 (built Tue, 08 Jun 2004 02:25:40 PDT)
  14. _JC_

    _JC_ Network Guru Member

    1.00.45 just flashed on mine

    Just saw my connectivity drop and start back up... looked at my router, and we are up to 1.00.45 now..... *70 still doesn't work :(
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice