New laptop won't connect to router

Discussion in 'Tomato Firmware' started by wbs333, Feb 17, 2010.

  1. wbs333

    wbs333 Addicted to LI Member


    I have a new Gateway EC1456u with an Intel WiFi Link 1000 BGN adapter that won't connect to my WRT54GL with Tomato v. 1.22

    In Tomato, at Status/Device List, I can see the Gateway's MAC address connecting, but Tomato does not give it a Lease. It shows it as Interface eth1, as it shows when my wife's netbook is connecting. But the log does not show DHCPREQUEST and DHCPACK lines for what is happening.

    Can you provide any suggestions? See below for the troubleshooting I've done. This is a 64 bit OS, Does that make any difference?

    I've rebooted the Modem, Router, and all the machines involved at the same time, reconnecting in the proper order.

    I normally use the Wireless Filter, and I entered the adapters MAC address. I'm currently trying with the Wireless Filter disabled, but it still doesn't work.

    I have a large enough IP address range allowed to cover my devices.

    I can connect to a different, unsecured network, so I know the adapter works.

    I can connect to the router through the Ethernet card.

    I have a Toshiba netbook, also with Windows 7 (but 32 bit), connecting to the router just fine, so I know the router works. My Wireless Network Properties are set up exactly the same on the two machines.

    I don't want to take the machine back, so any help will be gratefully appreciated!
  2. Toastman

    Toastman Super Moderator Staff Member Member

  3. wbs333

    wbs333 Addicted to LI Member

    Tomato is version 1.22, not sure what is meant by "wireless driver in it."

    Intel WiFi Link 1000 BGN driver is, which appears to be the latest from both Gateway and Intel, if I'm not missing something.

    I discovered that I can connect to my router if all security is turned off. I'm reasonably certain my security settings match, but I still can't connect with them on.

    Also, I note in Device List, in the Quality column, it is showing 99 with 2 darkened bars of 5; and down below it says Noise Floor: -99dBm. Are these connected, and/or significant?

    Thanks for your interest.
  4. Toastman

    Toastman Super Moderator Staff Member Member

    The wireless driver used in Tomato is the one I mean. If it doesn't mention "ND" in the version number, I expect that is the problem. Try the one I suggested, and report back! There is a very good chance that it'll fix things.

    Good luck.
  5. wbs333

    wbs333 Addicted to LI Member

    Seems like an awful lot of variables reported in that thread. And what is the likelihood doing this will screw up one or more of the other devices connecting?
  6. myersw

    myersw Network Guru Member

    Vectek's version works great. Use the ND version and I bet your issues are gone. --bill
  7. wbs333

    wbs333 Addicted to LI Member

    Once the ND version is installed, do I need to do anything else, such as this:
    Telnet to the router, log in and enter the following lines:

    nvram set wl_reg_mode=off
    nvram set wl0_reg_mode=off*
    nvram commit

    or is that all included in the newer versions? Thanks!
  8. wbs333

    wbs333 Addicted to LI Member

    OK, I flashed the Tomato RAF 8515.2 ND version, and it does work!!, but ...

    my early subjective feeling is that the connection (downloads and even page loads) is noticeably slower than my desktop and even my wife's netbook. Is that likely, and is there anything I can do about it?

    Thanks much for getting me this far!!
  9. Toastman

    Toastman Super Moderator Staff Member Member

    I doubt it, because the concensus of opinion is that 8515.2 is quite probably the fastest and most reliable implementation of Tomato RAF so far, which is why I recommended it. Also, it has the reg_mode setting already in ADVANCED / WIRELESS so you do not need any scripts.

    Of course, there might be a different reason!
  10. wbs333

    wbs333 Addicted to LI Member

    Any suggestions on how to test to see if the connection is really objectively slower on my new laptop than on my wifes?
  11. wbs333

    wbs333 Addicted to LI Member

    FWIW, tried theSG Vista TCP/IP Patch from Checking before trying produced:
    ** The above autotuninglevel setting is the result of Windows Scaling heuristics overriding any local/policy configuration on at least one profile.

    So the system may have changed something in trying to connect before I flashed the ND version. Applying the patch did nothing, but going back to Default seemed to help.

    Still not what I think it should be, but may be tolerable. Thanks again.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice