New Linksys Firmware 4.30.5 Available for WRT54G v1-4

Discussion in 'Linksys Official Firmware' started by Trademark, May 28, 2006.

  1. Trademark

    Trademark Network Guru Member

    I was just on and to my surprise they have released new firmware 4.30.5 for the WRT54G v1-4. I have included the info listed below which also mentions firmware 4.30.2 fixes.

    Release Date: 05/25/2006

    Firmware 4.30.5
    - Resolves UPnP vulnerability reported by SANE

    Firmware 4.30.2
    - Resolves issue with filter name
    - Resolves issue where service name for PPPoE cannot be added
    - Resolves issue with detecting UHP modems
    - Resolves issue where DynDNS Custom and Static accounts cannot be used
    - Resolves issue with WEP passphrase not recognizing spaces

  2. Nomad327

    Nomad327 LI Guru Member

    This is bad juju for me so far...after the "upgrade" it renamed the model to is a WRT54GV3...linksys has no explanation...doh!
  3. Ron2006

    Ron2006 LI Guru Member

    I noticed that too so I looked at the Firmware for the WRT54GL and it seems to have the same features. I kinda looks like Linksys is writing the same firmware for both of these devices.

    I was using this firmware but just upgraded to HyperWRT Thibor 15c last night. It rocks! The only thing I didn't like about it is the fact that it says it's now a Linksys Broadband Wireless G with Speedbooster when it's only a wrt54g v1.1, but hey, that's no big deal.
  4. Nomad327

    Nomad327 LI Guru Member

    I am on the verge of jumping to HyperWRT Thibor 15c
  5. Ron2006

    Ron2006 LI Guru Member

    I was using the Linksys Firmware 4.30.5 and was not having any problems. I started reading up on Thibor's Firmware and was impressed with what it can do. Even though I was not having any problems I upgraded to Thibor's and I'm loving it. This is my first time using a 3rd party firmware and I don't regret it. The beauty is that if you're not completely satisfied with it you can go back to the Linksys Firmware.
  6. Nomad327

    Nomad327 LI Guru Member

    Very nice!
  7. rocketknight73

    rocketknight73 LI Guru Member

    Yeah I upgraded to this new FW this morning ang guess what? Now my I can't connect to internet. WTF? I followed standard procedures I'm just not sure what went wrong. Any ideas? I was running "ddwrtpsp4d" which worked except I would have to reboot router every few days which got old.
  8. IrishMike

    IrishMike Guest

    Mine's "this" much above being a brick.

    In an effort to have a local copy of the firmware for my brand new (and unused wrt54gl.v4 that I just got, I did the download from the Linksys website. Gee, I clicked on 4.30.2 and I got 4.30.5! Okay, they must have fixed something.

    As the return key completed it's journey to the bottom of its travel my brain screamed CHIT!!!!

    I knew I'd made a stupid mistake. Up, the firmware upgrade (*COUGH*) broke the unit. It now is close to unusable, the setup tabs #1,3&4 have disappeared and the DDNS is more than slightly confused.

    I called the help line. (I think that hurt more than the firmware upgrade to begin with). I don't mind the outsourcing to provide 24x7 support as long as the droids do more than read a damn script!. I got "Oh yes, we'll take care of that." said to me way too many times.

    I finally got someone in Cisco to send me the x.2 firmware but it still hasn't solved the problem. It behaves the same as the x.5 but the x.2 includes the upnp (or whatever the acronym is) fix so it's not the original.

    I'm gonna try some of the other ones available to see what becomes of the brick now.
  9. trexxx

    trexxx Guest

    I noticed the same thing renamed the router to WRT54GL, which originally is a WRT54G v4. So from now on, when downloading new firmware, which product should we look under WRT54GL v1.0 or WRT54G v1.0-4.0? Will it even matter?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice