New Official firmware 2.00.17 for the WRT300N v2

Discussion in 'Linksys Official Firmware' started by Stimpy, Nov 16, 2006.

  1. Stimpy

    Stimpy Network Guru Member

    Hi Guys, just wanted to let you know that the new firmware many of us have been waiting for has just been released over at Linksys UK...

    WRT300N v2 (silver casing)

    Classification: Firmware Release History

    Release Date: 11-15-2006

    Firmware Version: 2.00.17 (ETSI)

    - Fixes usability issues
    - Overall performances improvement (speed and range), it is
    recommended to upgrade your Linksys draft N clients to the
    latest driver also available on this web site
    Tip : Linksys recommends using WPA2-AES security setup to
    combine best performance and security

    - To upgrade the router from firmware version 2.00.8, it requires
    two steps as follows:
    step 1) Upgrade the router using the bin file called: wrt300n.bin
    step 2) Upgrade the router using the bin file called : wrt300n-2.00.17.bin

    - To upgrade the router from firmware version 2.00.13 and after, only one
    step is required, upgrade the router using the file called
    wrt300n-2.00.17.bin in the zip file.

    I will be installing this new firmware on my WRT300N as soon as I get home from work, about 8 hours time. I will tell you all how it goes.

    One thing I have noticed, is that the information in the release notes is slightly wrong. It's the part about the filename for the new firmware, the notes call it wrt300n-2.00.17.bin, but the file that is inside the zip is actually called New_wrt300n.bin, so use this file and all will be ok for you.

    Please post your comments about this firmware, lets hope this one is a good one!


    I have installed this new firmware, without any problems. I have found no new functions in the menus, and have noticed that the router is slightly more responsive. My ping test to the router's IP has improved. It now has a TTL of 64, instead of 255, and the responce time says less than 1ms, which is also better, as the older firware always stated 1-2ms. I had been having problems with a wireless uPnP media player (random but frequent disconnections), and will test this in the next day or so.

    My family have told me that they have not suffered lock-ups or wireless disconnections since the upgrade.
  2. Toxic

    Toxic Administrator Staff Member

  3. Stimpy

    Stimpy Network Guru Member

    Thanks for that Toxic! I should have done that. DOH! lol
  4. MarcoFranceschini

    MarcoFranceschini LI Guru Member

    My first post here...

    Greetings from Italy...
    I follow the above flashing procedure and now the router it's bricked (sigh, sigh).
    Could anyone explain to me a recovery procedure (if it exist) ?
    Thanks in advance.


    Marco Franceschini.
  5. Stimpy

    Stimpy Network Guru Member

    Hi Marco. I'm sorry to hear that you have had problems. What happend exactly? I updated mine this morning, and it was easy. I just used the instructions here.

    The only thing that I can think of, is what version firmware did you have on your WRT300N BEFORE you updated? I was using the beta 2.00.14 version, and just updated using the file New_wrt300n.bin, anything using firmware v2.00.08 needs to be reset by using the file WRT300N.bin first, then you would user the file New_wrt300n.bin to complete the update process.

    If you are running a firewall like Zone Alarm, sometimes ZA gets funny about an IP address change, and will result in windows not re-connecting with the router, resulting in no internet/network connection, despite Windows reporting that it is connected. The best way around this, is restarting your pc.

    Also, if you configured your WRT300N to a different default IP address, then the firmware update might have reset to the default IP address.

    Oh, and I know this could be a stupid question, but you do have the silver (v2) version, don't you?
  6. Toxic

    Toxic Administrator Staff Member

    Marco did you update over a wired or wireless connection?
  7. Intratech

    Intratech LI Guru Member

    upgraded from V 2.00.14 to 2.00.17 without any problems. Will test new firmware for improvements.
  8. MarcoFranceschini

    MarcoFranceschini LI Guru Member

    Thank you for replies...

    1) i have a "silver" case (V2) Linksys WRT300N version

    2) i have updated from 2.00.14 beta version over wired connection with New_wrt300n.bin file.

    When i try to reset the router (i.e reset button pushed while applying at same time the power line), the power led start to blink green<->ambra endless.
    What should i do to debrick my router ?
    Thanks in advance again.

    Marco Franceschini.
  9. Stimpy

    Stimpy Network Guru Member

    Hi Marco.

    Mine did that, and the way i stopped it was to pull the power, and then wait 30 seconds, then simply plug the power back in, without pressing the reset button. It booted up, and i set it up with no problems after that.
  10. raczkri

    raczkri Guest

    router dead here too

    Hi All,

    I also tried to upgrade my firmware on my WRT300Nv2 from 2.00.13 to 2.00.17, but i ended up with a dead router.

    The flashing process reached 100% as it should, but after that nothing happened. I waited 10 minutes periodically trying to 'repair connection' from windows, but the PC did not receive IP address. I pulled the power plug, tried to reset, but nothing helped.

    I made the firmware upgrade from a wired connection, but i forgot to disconnect all wireless clients before the upgrade. Maybe this is where I scewed up...:(

    Can I restore some kind of factory firmware somehow, or my only option is to ship back the router to linksys to repair?

    please help if you can,
    thank you
  11. humba

    humba Network Guru Member

    I noted two things:
    Linksys never got the HTTPs working, and now apparently instead of trying to fix it, they simply removed HTTPs access. Great way of solving problems...

    And as far as QoS goes, it's still useless unless you have a symmetrical line, as all you can configure is the downlink bandwidth.. we'd either need to be able to set the uplink bandwith, or both. Linksys even confirmed (after I had opened 3 separate cases as they kept ignoring this issue) that they can't handle assymetric links, but they've been told so almost half a year ago, and what did they do? Nothing.
    My 3.5 year old WRT54G V1 can do what the latest generation model cannot :( (and that actually goes for both https and qos)
  12. tantrix

    tantrix LI Guru Member

    First of all.. Hi! I'm new here. Bought a WRT300Nv2 (silver casing) a couple of months ago. With version 2.00.08 firmware it didn't get an IP from my ISP's DHCP so for some time I used the static IP function, worked fine. This month my ISP switched to dynamic IP's so I decided to update the firmware. I updated to version 2.00.17 without problems (using the 2 bin files as described in the info). However, last night I couldn't access the router through the web interface anymore. Pulling the power plug for a couple of seconds was the only option, which resolved the problem. Today this happened again when I noticed my notebook wireless couldn't get an IP address from the router. The wired computer was still working but the router couldn't be accessed. I just downgraded to v2.00.13 again and now the wireless LED is off (known problem) but also not working (can't see SSID in Windows networklist). I'm thinking of upgrading to v2.00.14 (beta?) and see what happens... If anyone has another option please share, all help is welcome!
  13. Toxic

    Toxic Administrator Staff Member

    did you reset the router to factory defaults after upgrading?
  14. tantrix

    tantrix LI Guru Member

    No I didn't. Could try that indeed. But is it necessary? I upgraded 2.00.13 to 2.00.14 and wireless is working again. I haven't noticed the problem described yet, but I will do some more testing later. Maybe upgrade to 2.00.17 first and reset to factory defaults as you suggest. Thanks and I'll keep you posted. But first time to get some sleep :)
  15. JmJ17

    JmJ17 Network Guru Member

    I've got exactly the same problem. Any idea?
  16. hrikken

    hrikken Guest

    Well, I tried to upgrade to 2.00.13 and ended up with a non-wireless AP. I had to upgrade to the beta 2.00.14 to get it up and running again. I don't trust the 2.00.17 release and don't trust Linksys as well.
    Anybody any experience with 2.00.17 (other than mentioned above)?
  17. basvd76

    basvd76 Guest

    Dead as well...


    I also upgraded my router without succes. I however did it wireless and also forgot to disconnect any wireless connected hosts. Is there a solution to revive the box?

    I might add to this that I can't get to the box by browser anymore, but strangely two hosts wirelessly connected which did not receive DHCP answers back and therefore got APIPA addresses, were able to see each other (iTunes library for example).

    So the box still does something, but is inaccessable for management and does not hand out IP's through DHCP.

    I've tried to reset without result, it still broadcasts my old SSID and is inaccessible from browser.

    Who can help or knows how to reset or login the router?
  18. arcencio

    arcencio Guest

    I have the same problem after trying updating the firmware of the wrt300N v.2... I've tested all the other soluntions I've found around the threads to ressurrect my silver router, to no use at all... please help...
  19. JmJ17

    JmJ17 Network Guru Member

    Through it to the trash and buy a Microtik or something similar. This was what I did...
  20. Aratar

    Aratar LI Guru Member

    Anyone knows the latest build for the WRT350Nv2?

    I hear there's 2.00.17(05), not sure if that's latest or if there's even a new .xx version
  21. whiteshark

    whiteshark Networkin' Nut Member

    missing 2.00.17 firmware

    Hello who!

    I'm stuck with a poor performing WRT300N v.2 router with bad bad wireless performance with my Toshiba Satellite L555D-103- The laptop is not compatible with the Linksys router and the router will not accept the latest 2.00.21-firmware. Somebody says that I must upgrade to 2.00-17 before I go for the latest. The problem is that it's impossible to get the old 2.00.17-firmware.

    Is there anybody ot there who is in possession of this old firmware and wants to help me out, it would be very much appreciated.

    Hopeful is hoping for a miracle.

    Have a nice day folks

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice