NEW Official firmware for the WRT300N v2!!!

Discussion in 'Linksys Official Firmware' started by Stimpy, Sep 8, 2007.

  1. Stimpy

    Stimpy Network Guru Member

    NEW Official firmware for the WRT300N v2! *Updated*

    After making us wait for nearly a year, Linksys has finally decided to grace us customers with a new firmware for our "flagship" WRT300N v2's!

    Here's the copy and paste of the info file...

    Linksys, A division of Cisco Systems, Inc.

    Product: WRT300N v2 (silver casing)

    Classification: Firmware Release History

    Release Date: 09-04-2007

    Firmware Version: 2.00.20 (ETSI)
    - Updated wireless driver
    - Improved WEP/WPA-TKIP performance
    - added security checking for setup wizard
    - Support for USA& Canada daylight Saving time change
    - Fixed PPTP/PPPOE/L2TP and BPA Username/Password special characters support
    - Fixed PPtP/PPPoE connection bug

    - To upgrade the router from firmware version 2.00.13 and later, only one
    step is required, upgrade the router using the file called
    wrt300n-2.00.20.bin in the zip file.

    - To upgrade the router from firmware version 2.00.8, it requires
    two steps as follows:
    step 1) Upgrade the router using the bin file called: wrt300n.bin
    step 2) Upgrade the router using the bin file called : wrt300n-2.00.20.bin

    Tip : Linksys recommends using WPA2-AES security setup to
    combine best performance and security

    Anybody notice the part where it says Updated Wireless Driver? Does that mean Draft 2.0 support or not? Seems a strange ommission from Linksys...

    Right, I'm off to do some updating, I will return if all goes well, and IF I can remember how to update this thing!

    *** UPDATE ***
    Well, nothing much to report, only one option seems to be different, and thats support for the Setup Wizard, one other thing is evident though, and thats the speed of the router seems quite a bit faster, or at least more responsive than before. Not sure about the Draft 2.0 support either, as the default channel setting is Wide (40MHz), and not 20MHz like it's supposed to be, but this is not conclusive of Draft 2.0 support. There are no new or changed settings in the Wireless control panel, so I really cant say much... I just feel kind of dissapointed that this is what a year of firmware development brings to the table.

    *** UPDATE 2 ***
    Oh well, it's nice to see Linksys up to their usual standard... This firmware breaks compatibility with the Xbox 360... Nice work testing your firmware Linksys...

    Any chance of a fix? Probably not...

    *** Update 3 ***
    I have been in contact with Linksys, and we have found together that the Xbox problem started in 2.00.18, and is carried over into the 2.00.20 firmware. So if you connect wirelessly with your Xbox 360 to this router, make sure your not using any firmware later than 2.00.17. I have the firmwares if anyone has already upgraded to the latest and wishes to downgrade.

    Lets hope Linksys dont take another year to fix this.
  2. Stimpy

    Stimpy Network Guru Member

    It would be nice if others reported their findings with this firmware? And maybe the site admin could actually report on the frontpage that this firmware is out?
  3. jbrbv

    jbrbv Network Guru Member

    And update the firmware tracker...
    This version seems to be better than 2.00.17 or 18.
    For these versions many special settings were advised. Are they still needed or are the default settings OK?
  4. renatoso

    renatoso LI Guru Member

    WRT350N v2 - intel 4965AGN

    Is possibile to link the linksys with the intel 4965AGN at 802.11n?

    The link is loked at 54g for the incompatibility from the two product.

    Linksys is draft 1.0 and intel is draft 2.0!?

    There is a new firmware to resolve this ?
  5. Stimpy

    Stimpy Network Guru Member

    I definatly find the .20 firmware faster, and had no problems using it with my N clients, or my G ones on the default settings, other than the Xbox360 not being able to connect to it.

    Just remember, this firmware (.20) is several months old, so I hope they are working on a new one that fixes the Xbox problems, and brings us Draft 2.0.
  6. Stimpy

    Stimpy Network Guru Member

    Thats strange, as the WRT300N v2 is based on the Atheros radio, and these are regarded as some of the best networking chipsets around. And I hear that Atheros chipsets usually work very well with Intel's latest... I would say give the .20 firmware a go, after all, they did update the wireless Drivers, and they have not done that in a very long time for this product. I really hope that Draft 2.0 is not far away!

    BTW, try setting the Wide channel setting from 40MHz (default) to 20MHz, this is a must for Draft 2.0 compatibility.
  7. renatoso

    renatoso LI Guru Member

    WRT350N v2 and intel 4965AGN

    The linksys and the intel wireless is not compatible!?

    Only 54g is possibile with all settings.

    Anyone can suggest a solution?

  8. renatoso

    renatoso LI Guru Member

    WRT350N v2 and WRT300N v2

    this two linksys product have the same firmware?

    I can try the WRT300N v2 2.00.20 on WRT350N v2 ?
  9. la82

    la82 LI Guru Member

    My WRT300 crashes at least once a day after I updated it from 2.00.17. I have to unplug it to get it working again. I reset it to factory defaults, but it did not help any :( Can I revert back 2.00.17 again (where can I get it) ?
  10. franklj

    franklj LI Guru Member


    My WRT300Nv2 dies at least 4 times a day now. The wireless network can still be seen, but you cannot associate with it. If connected and another device connects, the router hangs.

    Its running firmware 2.00.20 and still no improvement. Even if connected, DNSLOOKUP fails for no reason intermittently.

    I'm using TKIP encryption because I'm running a WET54GV2 attached to my Xbox and unfortunately I cannot seem to make it support WPA2 AES which linksys recommends. Does the WET54 support WPA2 AES at all (fairly new to this ... )

    I guess I could switch all security off and rely on MAC filtering, but I'm not convinced that is the way forward. Is there any miraculous firmware upgrade I could perform on either unit to solve my problem ?
  11. Stimpy

    Stimpy Network Guru Member

    WPA2 is not supported by the Microsoft Wireless 360 Adaptor, the option is there, but greyed out. It would be better to use WPA with AES, as this is as secure as it gets, and WPA v1.0 still has not been hacked buy any amature driving past! TKIP may be what is causing some of your trouble.

    MAC Filtering is not really needed with WPA, just remember to turn off your SSID, and that will be strong enough.

    This is what I do with my WRT300N, and have only the odd problem with connecting.
  12. Stimpy

    Stimpy Network Guru Member

    This is in the release notes for the latest drivers for your card... "The Intel(R) Wireless WiFi Link 4965AGN adapter can only achieve transfer rates greater than 54 Mbps on 802.11n connections when using AES security, or no security."

    To enable AES for Personal Security, select WPA-Personal (AES-CCMP) or WPA2-Personal (AES-CCMP) in the Security Settings pulldown menu. To enable AES for Enterprise Security, select AES-CCMP in the Data Encryption pulldown menu.

    This card is currently Draft 1.0 only.

    If this is not the problem, then only Linksys will be able to fix this.

    I'm hoping that Draft 2.0 will be coming soon to our router.
  13. Ukeâ„¢

    Ukeâ„¢ Guest

    I've had no end of trouble since updating to this firmware. Network discovery breaks after under an hour from it being turned on and if I attempt to repair the connection on any of my wireless clients it cuts off the internet and gives a 'Could not find a certificate to log you on to the network' message. This happens with both WPA-PSK TKIP and AES.
  14. KeysDaMan

    KeysDaMan Guest

    If someone has a copy of 2.00.17 can you please pm me. The current firmware has basically killed the wireless network at my flat. I seriously have to wonder if they test this stuff at all before they release it.
  15. Taomyn

    Taomyn Network Guru Member

    I hit the same issue with my Xbox 360, really wished I'd seen this thread first.

    Luckily I chatted on Linksys' chat support with a nice chap called Charles that a) confirmed .20 was the latest b) gave me a link to the .17 firmware. The link was username/password protected so I don't feel happy giving that out (though I suspect it probably expires), so how can I upload it to here so it can be used by those in need?

    He did say to try a full reset of the router to see if that fixes it, but after spending 5 minutes with the reset button pressed and pulling the power and putting it back etc, the router still had my original settings and made no difference. Perhaps someone else is willing to give it a go?

    So far, reverting back to .17 hasn't shown up any new problems.
  16. Toxic

    Toxic Administrator Staff Member

    i'll put up the WRT300N v2 (EU) v2.00.17 firmware up shortly, check the downloads section in a moment. but it is available from Linksys Tech Support.
  17. Taomyn

    Taomyn Network Guru Member

    Why is v2.00.17 beta? I'm sure I had a release version before - this one's been nothing but trouble compared to before I had v2.00.20 :-(
  18. la82

    la82 LI Guru Member

    Same with mine. When I had the .17 fw, my router was always fine. Then when I flashed it with the .20, it started to chrash on a daily basis. Tried the .17 beta, but it only got worse so I'm sticking with the .20. Buying a new router very soon and throwing this piece of sh*t in the garbage! :angry:
  19. azaonline

    azaonline Guest

    howdy guys,

    i have 3 of these based in a school, upgrading to 2.00.20 was the worst thing i could have done and reli regretting it now.. it seems to be everyday they need rebooting, just to clear the limited or no connectivity error. seeing as we are going to be adding 17 laptops to the network wirelessly reli need to get it sorted out? dose anyone know where i can get the .17 firmware from.

    im doing some searching on the net to see if i can get it from a forum or somthing, becoming desprate now :(

    if i find anything ill let ya know

  20. Taomyn

    Taomyn Network Guru Member

    Looked above!?!??!??!
  21. dirtybobby

    dirtybobby LI Guru Member

    i can only find the beta .17 in the downloads section.. is there a final release version anywhere?

  22. Toxic

    Toxic Administrator Staff Member

    if you read the initial post, the link is in there.
  23. dirtybobby

    dirtybobby LI Guru Member

    the only link i can see in the OP is this one, which is the official linksys site and will only allow me to download .20 ..

    i'm after the final release of version .17, as per the other posters in this thread..

  24. X3lectric

    X3lectric LI Guru Member

    Read this topic

    I have 2.00.20 (04) on mine and have further previous versions 2.00.20 (02) both are superceeding the firmware posted both on Linksys and this topic....

    Also why theres a needfor two topics for same subject I dont know... This one is newer therefore should IMO be merged with older and obviously original topic.
  25. Taomyn

    Taomyn Network Guru Member

    So if it's a later version than that posted by Linksys, this begs the questions a) does it fix the the issues mentioned here and b) if it does fix the issues, how do we get a copy?
  26. X3lectric

    X3lectric LI Guru Member

    Im not sure if it fixes your issues, but Im sure it did not fix mine, however getting it is a question of going on linksys chat for your relevant country and asking for it...

    The support person will hand you user name Linksys and password beta(whatever4numbers) and youll get it...

    If they say no then just ask and Ill send you a copy.
  27. Stimpy

    Stimpy Network Guru Member

    This situation with this router has made me conclude that sadly after 5 years of only Linksys networking equipment, I will switch to another hardware company, probably D-Link and it's DIR-855, when it is released.

    There is no reason why Linksys chose to abandon this "flagship" router so quickly, it was never really supported from the beginning. And from what Linksys are telling me, then the WRT300N v2 is no longer a supported product.
  28. X3lectric

    X3lectric LI Guru Member

    If the WRT300N v2 is no longer supported it wouldnt surprise me since its never really been draft 2.0 compliant unlike it's V1 according to WIFI alliance information page

    I cannot get it to connect to a Intel 4965AGN at anything greater than 54mbps even if I finally got the router recognised as a 802.11N broadcast device with the introduction of Vista SP1 beta to the equation. This also means the same with XP sp2 or sp3 using whatever newer drivers and router firmware except in XP I never got the router recognized as a N draft device....

    I do think its a massive failure indeed. However it operates just fine with linksys own adapters but not many laptops (or any) ship with Linksys hardware in them or with them to my knowledge that in any case would resolve the many shortcommings of this router.

    I agree that D-link are better and have got it right this time around I for one want a router that works with 3rd party products however Linksys wanna go around that I dunno but I know I will get a free upgrade...

    So heres my 2c WRT300N v2 is a no go area if your thinking about getting one... Nice lights though, looks good as a dust gatherer.
  29. kjaasebo

    kjaasebo Guest

    WRT300N vs XBox 360

    Just ran into the XBox 360 incompatibility with version 2.00.20 and want to downgrade to 2.00.17.

    See that Stimpy might provide it,

    please advise
  30. Stimpy

    Stimpy Network Guru Member

    Can the Admin of this forum please consider letting me give them the firmware downgrade patch for this router, so that I don't have to keep uploading it all over the place.

    This patch needs a home, and the Download section here would do very nicely.
  31. Taomyn

    Taomyn Network Guru Member

    Well so long Linksys - that piece of ****e has been condemned to silicon-hell and replaced by a D-Link DIR-635 a properly 802.11n (draft) compliant device.

    Everything I use on a daily basis connects up faster with better speeds, the Belink N1 PCI adapter in my new HTPC now gets 143mb/min for backup to my sever instead of the 13mb/min I could achieve via the Linksys. I heartily recommend the DIR-635 as a replacement to the WRT300N - I even think its web-based interface is better and it gives me far more advanced options for troubleshooting.

    Ever since Cisco bought them their kit had simply gone downhill - perhaps it's a deliberate ploy by Cisco as they were worried that Linksys were producing better equipment than theres and buying them out allowed them to put an end to that.
  32. pantaluna

    pantaluna LI Guru Member


    I wanted to let you all know that my WRT300N crashes too a few times a day after upgrading it from v2.00.17. I always have to reset the box in order to get it going again. Am going to downgrade to asap. to .17 :(
  33. Taomyn

    Taomyn Network Guru Member

    Don't expect the download of .17 to be any better, at least it wasn't for me and made mine more unstable. It's not a release version but a beta!
  34. pantaluna

    pantaluna LI Guru Member

    The router works flawlessly again after downgrading to .17 :)
  35. Kovenant

    Kovenant Guest

    Could someone provide me with .17 FW version? Would be very grateful
  36. mackps2

    mackps2 Guest

    Hello there,

    Could someone please hook me up with 2.00.17 firmware? Many, many thanks in advance.
  37. X3lectric

    X3lectric LI Guru Member

    Firmware removed by author of post.

    If anyone wants it please ask at linksys chat (India).

    Ask Florina or Angela anyone else are a bit too dim...
  38. sheu_ron

    sheu_ron LI Guru Member

    I need the firmware version.

    It isn't in the download section.
    I have seen ALL links in this post but all of them takes you to the

    Can anybody help me please?
  39. sheu_ron

    sheu_ron LI Guru Member

    Nobody has a copy of the firmware??????????


    There is no way to download it or find it in google, altavista or

    THIS is the only site where somebody can help me.

    I have gone to the Linksys web support page, but there is no chat site, only a stupid an a ************ automatitzed system of booooooring questions that i have done once and twice.

    Do I have to take this crap router to the windows???

  40. Taomyn

    Taomyn Network Guru Member

  41. sheu_ron

    sheu_ron LI Guru Member

    They are for the Linksys WRT300N v2 (gray case)?

    Where did you found the 21 version if the latest in linksys homepage is v.20?
  42. Taomyn

    Taomyn Network Guru Member

    The clue is in the thread title ;-)
  43. sheu_ron

    sheu_ron LI Guru Member

    They don't work.
  44. Taomyn

    Taomyn Network Guru Member

    Strange as the V17 was the one I used last time, went back to v20 when I got the new D-Link as it was better for me than v17 (which is beta btw), then the v21 that was posted before after I renamed it to ".bin" from ".img".

    Are you sure they are downloading correctly? I just tested them from a different computer and they look fine to me.
  45. tonyk79

    tonyk79 Guest

    The v21 worked ok for me, going to go back to v17 and get the xbox working again.
  46. InSanex

    InSanex LI Guru Member

    gigasize times out every time :-(

    Could someone plz use rapidshare (that i would even ever dare to ask)

    nevermind, google was my friend and provided me with a username and a password :)
  47. tantrix

    tantrix LI Guru Member

    actually.. gigasize says the file is no longer available :(
    can anyone post them somewhere else?
    thanks in advance!
  48. bhoch

    bhoch Guest

    I need the .17 firmware for WRT300N v2.0 as well. Can someone please PM me or direct me to a download location?

    Thanks in advance
  49. josephcorso7

    josephcorso7 Guest

    mahboub26 likes this.
  50. tantrix

    tantrix LI Guru Member

    Thanks for your post, but there's no 2.00.21 firmware on that page..
  51. nikoqwerty

    nikoqwerty Guest


    thnx for the link
  52. sheu_ron

    sheu_ron LI Guru Member

  53. DrJones1982

    DrJones1982 Guest

    I've also got a WRT300N V2.0. It seems that firmware 2.00.21 fixes the draft-n issue with Intel's 4965AGN-Chip.
    Actually I had a chat with the linksys-support, where they told me they don't have got a 2.00.21-Firmware... Can anyone tell me where to get it?
  54. hugovsky

    hugovsky Guest

    I had a problem too... After the flash, my macbook kept droping the connections to the router. Back to 2.0.17. If anyone needs it, I can send it.

    Or you can get it here: WRT300N v.2/
  55. 3dfx

    3dfx Networkin' Nut Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice