New Release: V23 beta 01.11.2005 Bug Reports Here!

Discussion in 'DD-WRT Firmware' started by Honki, Nov 1, 2005.

  1. Honki

    Honki Network Guru Member

    client bridge mode reworked (wpa in bridge mode verified, wpa2 still not)
    ethernet driver changed
    wl500g-deluxe is now fully working with all features. (reboot problem solved too)
    ifconfig enhanced (for supporting multiple ip's per interface)

    @Brainslayer: how does "ifconfig enhanced (for supporting multiple ip's per interface)" with NVRAM variables work?
  2. BrainSlayer

    BrainSlayer Network Guru Member

    not with nvram, but with commandline
  3. Honki

    Honki Network Guru Member

    tell me about the solution, please...

    i have conflikt with NVRAM solution like this:

    nvram set vlan0ports="1 2 3 5*"
    nvram set vlan1ports="0 5"
    nvram set vlan2ports="4 5"
    nvram set vlan2hwname=et0
    nvram set rc_startup="ifconfig vlan2 212.202.x.1 netmask"
    nvram set rc_firewall="
    iptables -I INPUT -i vlan2 -d 212.202.x.1/29 -j ACCEPT
    iptables -t nat -I PREROUTING -i vlan2 -d -j DROP
    iptables -t nat -I PREROUTING -i br0 -d 212.202.x.1/29 -j DROP
    iptables -I FORWARD -i vlan2 -o ppp0 -j ACCEPT
    iptables -t nat -I PREROUTING -i ppp0 -d 212.202.x.1 -j DNAT --to-destination
    iptables -I FORWARD -d 212.202.x.1 -j ACCEPT
    iptables -t nat -I PREROUTING -i ppp0 -d 212.202.x.2 -j DNAT --to-destination 212.202.x.2
    iptables -t nat -I POSTROUTING -s 212.202.x.2 -j SNAT --to-source 212.202.x.2
    iptables -I FORWARD -d 212.202.x.2 -j ACCEPT
    iptables -t nat -I PREROUTING -i ppp0 -d 212.202.x.3 -j DNAT --to-destination 212.202.x.3
    iptables -t nat -I POSTROUTING -s 212.202.x.3 -j SNAT --to-source 212.202.x.3
    iptables -I FORWARD -d 212.202.x.3 -j ACCEPT
    iptables -t nat -I PREROUTING -i ppp0 -d 212.202.x.4 -j DNAT --to-destination 212.202.x.4
    iptables -t nat -I POSTROUTING -s 212.202.x.4 -j SNAT --to-source 212.202.x.4
    iptables -I FORWARD -d 212.202.x.4 -j ACCEPT
    iptables -t nat -I PREROUTING -i ppp0 -d 212.202.x.5 -j DNAT --to-destination 212.202.x.5
    iptables -t nat -I POSTROUTING -s 212.202.x.5 -j SNAT --to-source 212.202.x.5
    iptables -I FORWARD -d 212.202.x.5 -j ACCEPT
    iptables -t nat -I PREROUTING -i ppp0 -d 212.202.x.6 -j DNAT --to-destination 212.202.x.6
    iptables -t nat -I POSTROUTING -s 212.202.x.6 -j SNAT --to-source 212.202.x.6
    iptables -I FORWARD -d 212.202.x.6 -j ACCEPT
    nvram commit
  4. -jcb-

    -jcb- Network Guru Member


    always on work !

    So, with this version it seem that client ROUTER mode don't work. I try WPA2 pre-shared key mixed first (perhaps a good news) but as the others version, it don't work. I go to use WPA pre-shared key as I always do but it don't work to :sadbye: I have don't try the others methods.

    (I make a hard reset, I had installed every beta ;-) )

    2x GS1.1 (afterburner ON, frame burst ON, 42 mw as I always do)

    JCB (I continue to search)
  5. BrainSlayer

    BrainSlayer Network Guru Member

    i just tryed wpa2 which worked
  6. -jcb-

    -jcb- Network Guru Member

    I stop to search, I reinstalled the 27.10 version on the client router GS and all work fine (wpa pre-shared key).

    I use the 01.11 on the AP without probem.

  7. 4Access

    4Access Network Guru Member

    There should be no conflict. BrainSlayer just added more functionality to the ifconfig command. Your configuration will still work.
  8. itsmeohmy

    itsmeohmy Network Guru Member

    Were can i downlod this masterpiece?
  9. BrainSlayer

    BrainSlayer Network Guru Member

  10. itsmeohmy

    itsmeohmy Network Guru Member

    I cant beleve i didnt see it :eek: !

    edit: now i can see there is a version with "voip"... is that someting i should get?
  11. BrainSlayer

    BrainSlayer Network Guru Member

    3 distributions per version

    mini - minimal base firmware
    std - contains all features
    voip - all features + sipath for sip voice over ip routing

    voip should only be used on gs units for stable using, also if it works too on g models
  12. dellsweig

    dellsweig Network Guru Member


    1) Logging still fails when config save
    2) access list url or keyword restrictions do not work
    3) httpd crashes on config save

    It is great to see DD-WRT branching out to other platforms but please dont forget to address these nagging issues on the WRT
  13. BrainSlayer

    BrainSlayer Network Guru Member

    so everyone can save but you. maybe i should release a video while i'm pressing the save button
  14. itsmeohmy

    itsmeohmy Network Guru Member

    Sounds like fun, but what is it? I dont understand, is it like skype or something for those special voip-phones or what?
  15. dellsweig

    dellsweig Network Guru Member

    Do you want nvram dumps, screen shots, what do you need??

    WRT54G V3.1


    1) flash in V23 std 11/01
    2) hard reset (30 seconds)
    3) enter configuration manually - enable logging (just wireless settings, http only)
    4) verify logging is working
    5) save config - web gui times out. (telnet in - httpd not in ps -ef)
    6) reboot router
    7) web gui is back, logging has stopped.

    Tell me what you need to see
  16. -jcb-

    -jcb- Network Guru Member

    I think that BrainSlayer use IE and you Firefox, I make a test and I also crash GUI with Firefox (with Adblock & noscript plugins desactived but ?). I make the test with IE and I bachup without problem. I't perhaps the same problem that the post 'always "upgrade wrong" '?

    I think also that there is sometime a temporary file error with IE when you use 2 routers and change the IP by another, sometime I must clear it. When I install my AP, all is OK, then I change the IP, flash my client (witch is now at the same link that the IP) and after I can't validate the first config page with is not the same on AP & Client (PPPOE & DHCP).

    And sorry for my english :-/

  17. dellsweig

    dellsweig Network Guru Member


    Thank you. I am using Firefox. I did not know there were browser issues here.

    Next problem:

    1) flash V23 11/0 std on WRT54G V3.1
    2) hard reset
    3) define single access list - define IP of this PC - allow internet 24x7 - no other restrictions
    4) open URL from browser - - no problem
    5) add keyword restricition linksysinfo
    6) open URL from browser - - no problem
    7) add url restriction -
    8) open url from browser - - no problem

    Apparently URL or keyword access list blocks do not work
  18. hotrat

    hotrat Network Guru Member

    Thank you BrainSlayer! GS v1.1 dd-wrt 1.11.05
  19. Kane91z

    Kane91z Network Guru Member

    glad i saw this was having save issues with firefox as well...
  20. jagboy

    jagboy Network Guru Member

    did you guys that have the httpd crash when you save the config did you do it from another computer. my gut tells me it is a nvram that is currputed. try to send your nvram dump to brainslyer. or dellsweig could you send it to me. my email is .
  21. disclog

    disclog Network Guru Member

    Since there is an issue with Firefox. What is the IE equivalent browser in Linux?
  22. Sjowhan

    Sjowhan Network Guru Member

    I have just upgraded my wrt (v2.2) -was flashed with 4.20.8- to dd-wrt beta2 27.10 or 01.11 (router says 27.10, but changelog says 01.11?). It looks so great! Thanks Brainslayer :clap:

    (upnp is working perfect for me, bittorrentclient got the external ip itself)
  23. 4Access

    4Access Network Guru Member

    1. I too can confirm that client bridge mode is now working with WPA! Thanks BrainSlayer! (Tested WPA TKIP on a WRT54G v4)

    2. I can also confirm doing a config backup crashes httpd. But here's a little more info: I've discovered that httpd doesn't actually crash until you try and load another page from the WRT. In other words:

    - Open telnet & check ps to confirm that httpd is running
    - Using FireFox backup the config but DON'T LEAVE THE BACKUP PAGE!!!
    - Check ps again and notice httpd is still running
    - Now go back to FireFox and open another page such as Status (it may or may not load)
    - Check ps again and notice that httpd has crashed! :(

    As -jcb- discovered (nice one BTW!) this only affects FireFox. But wait! It actually gets more interesting...

    - Using IE backup the config
    - After you have saved the config check a few more pages in the WRT just to make sure httpd is still working
    - Now close IE
    - Wait a little while if you want
    - Open FireFox and log into the WRT
    - Notice that httpd crashes!??!!?

    So in summary: For some reason when the configuration is backed up (regardless of what browser is used) the next time FireFox requests a web page from the WRT it crashes httpd.

    BTW I noticed BrainSlayer added a cron job that runs every couple of minutes to make sure httpd is running, so it's possible depending on your timing that after you crash httpd it may restart automatically almost immediately.

    3.Speaking of FireFox problems, when in Client Bridge mode the WRT-radauth page looks like this:


    Overall things are definitely improving, keep up the great work!
  24. LAGMonkey

    LAGMonkey Network Guru Member

    When setting the internal router clock (via the setup page) to "(GMT) England" the router can not pick up the current time. This problem persists no matter is daylight savings is checked or not.
    A small problem but one none the less i suppose.

    Excilent Firmware so far tho Brain :thumb:

    EDIT:: router is WRT54g v2.2
  25. 4Access

    4Access Network Guru Member

    I'm not having any trouble with Client (routed) mode here. I'm actually posting this using a WRT54G v4 in Client (routed) mode with WPA TKIP enabled. (I haven't tested WPA AES or WPA2)
  26. dellsweig

    dellsweig Network Guru Member

    I will create dump (nvram) when I get home from work and post.

    I am sure nvram is getting corrupt as logging no longer works after the config save.

    Anyone else able to re-create the url and keyword access list issue I am seeing - they dont appear to work. I have not tested any of the port or L7 filters yet but I assume they do not work either
  27. 4Access

    4Access Network Guru Member

    I just duplicated your instructions exactly but everything worked correctly here. (I couldn't load The only difference that I see is that I am using a WRT54G v4 and I was actually in Client (routed) mode when testing. (Although that shouldn't matter.) Here's how my rule looked:

  28. dellsweig

    dellsweig Network Guru Member

    I just verified again - using AP mode. Just a plain Internet gateway router on V3.1 hardware, std build 11/1

    Define access list to cover single IP address (mine)
    add keyword restriciton - no effect
    add url restricition - no effect

    One question, the physical PC I am testing from is connection through the AP via a WDS repeater node. Might that have some effect?
  29. zyclone

    zyclone Network Guru Member

    dellsweig :
    - the blocking url and keyword fonction works fine for me. I've just tried it on linksysinfo , no way to reach the page if I block it
    you probably missed something in the config

    thanks a lot -jcb- ,
    for telling and showing us , to use iExplorer when using the backup/restore fonction.
    strange problem which happens also with 'opera', that's not a problem poping only with firefox !

    DDWRT is a great firmaware, I haven't encountered any problem with this latest version, since I am using IExplorer to manage the router,
    I really like the new css themes , very good.
  30. -jcb-

    -jcb- Network Guru Member

    Thanks, perhaps I make a error but I don't think, since I test V23, I now make installation of my 2 gs 1.1 in less than 10mn :)

    I will test again with the next release (we make beta for this ;-) ).

  31. itsmeohmy

    itsmeohmy Network Guru Member

    The flash is done. But i have some major problems.

    1. When i press i button that saves anything (in the web interface) i will get disconnected and i cant connect agin. Well, sometimes i can but only if i restart the network card. But it worked when i was connected with a wired connection.

    2. After, lets say, 5 to 40 minutes i lose my internet connection. Just gone. I can still access the routers web interface. The only solution seems to be a restart of the router... since nothing else i tried works.

    Hope we can solve this because if i dont count these things the firmware seems nice :thumb: .
  32. Cyberian75

    Cyberian75 Network Guru Member

    "Current Time" on the Status page appears to be broken which means Schedule Reboot will fail.
  33. itsmeohmy

    itsmeohmy Network Guru Member

    Its works here. Current Time that is.
  34. Cyberian75

    Cyberian75 Network Guru Member

    It is now. I had to re-configure everything manually.
  35. itsmeohmy

    itsmeohmy Network Guru Member

    Found someting else, all help text looks like crap. I dont think it did before.
  36. Sjowhan

    Sjowhan Network Guru Member

    it's not a major problem to me, but that was something i saw too.

    After making some configuration changes (for example add a port to the port forwarding), when clicking on 'save', the internet disconnects. It comes up after that again btw.

    I remembered that the original firmware of linksys haven't this problem, i could make a lot of configchanges and no disconnect..
  37. Sjowhan

    Sjowhan Network Guru Member

    For example on the 'managementtab'. Help isn't showed, when clicking on more, it's a page full of text with no breaks in it.
  38. itsmeohmy

    itsmeohmy Network Guru Member

    I flashed dd-wrt.v22-final-r2 insted and now it works fine :) .
  39. 4Access

    4Access Network Guru Member

    It's been like that for quite a while. (I think v23 has always been like that.) At least throwing some paragraphs in there before v23 goes final would be a good idea.
  40. jagboy

    jagboy Network Guru Member


    if you think that the help look like crap then write the help text your self and send it to brainslyer.
  41. BrainSlayer

    BrainSlayer Network Guru Member

    good idea. but i think i can take one or two days to fullfill this job alone
  42. 4Access

    4Access Network Guru Member


    When the router is in Client Bridge mode could you rehide the "Wireless Setup" section on the Setup > Basic Settings page like the last version did?


    Those options aren't needed in Client Bridge mode and it confuses beginners.
  43. itsmeohmy

    itsmeohmy Network Guru Member

    I am also too crappy for that.
  44. robmack

    robmack Network Guru Member

    ntpd is not operational

    There is no ntpd process running even though I've configured ntp in the web GUI. Is ntp broken? What behaviour should I expect if I configure ntp (normally there should be an ntpd process and I can query/control the process with ntpdc)?

    BTW running 01.11.05 std on a WRT54GS v2
  45. Cyberian75

    Cyberian75 Network Guru Member

    Try reset everything and re-configure manually. Worked for me at least.
  46. Maugus

    Maugus Network Guru Member

  47. dellsweig

    dellsweig Network Guru Member

  48. Maugus

    Maugus Network Guru Member

  49. robmack

    robmack Network Guru Member

    ntp not working.

    Michael, Are you saying ntp is working for you? Each time I upgrade the firmware in my router, I follow the procedure published on the Wiki. I have never tried the "hold reset button for 30 sec" trick nor the "erase nvram" trick. As for manual reconfig, I do that every time I upgrade. Are you performing the above two "tricks" and having success?

    - Robert.
  50. romsworld

    romsworld Network Guru Member

    Bug with 1.11 and 3.11

    - http crash after reboot
    - Dyndns don t update ip
    - Ppt server didnot work

    with previous version, it s ok, so...

    WRT54GS v2
  51. Cyberian75

    Cyberian75 Network Guru Member

    Re: ntp not working.

    Not now. It's not working for me, either, since 11/01 release.

    EDIT: It is working now. Try turning it off and then back on.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice