New Release: V23 beta 06.12.2005 Bug Reports Here!

Discussion in 'DD-WRT Firmware' started by Sjowhan, Dec 6, 2005.

  1. Sjowhan

    Sjowhan Network Guru Member

    0000282 Remote Router Access : https check box disabled
    0000356 03/12 build: DHCP Clients table shows empty
    0000289 Wireless Clients -> Radio Signal RSSI -> Status not resetting when no signal
    0000337 2/12/05 moto mini version upgrade does not work
    0000098 JOIN does not work when SSID contains a <space>
    0000340 LAN port 4 and WAN port mixed up on 02.12.2005 std release
    0000372 Static IP: no WINS field for DHCP server
    0000353 DNSMasq doesn't work as DHCP Server
    0000359 Masqed MACs in DHCP Client Table
    0000351 Management.asp page - Java Script Errors
    0000369 Unmask MACs in DHCPTable.asp
  2. dellsweig

    dellsweig Network Guru Member

    Access restricition,s L7 filters, logging issues from the following bugtrak issues are still broken

  3. Sjowhan

    Sjowhan Network Guru Member

    With wan, signal is constantly decreasing/increasing. I'm within 1 meter far from my AP (wrt54g v2.2), so the distance isn't a problem.
  4. Silas

    Silas Network Guru Member

    Problems with torrent programs (azureus, bitcommet), neither of them can connect to any it doesn't download or upload.

    Program opens port wiht Upnp.
  5. in8skillz

    in8skillz Network Guru Member


    I've had this problem with 12/02 at roughly 3 meters away and default 28mw TX.

    I'll try 12/6 in a bit and see if I can confirm it.
  6. vincentfox

    vincentfox Network Guru Member

    Okay, I'm hoping someone else can confirm this as I have just done the same thing to 2 different routers and ended up at the same place.

    Firmware 2005-12-06

    WRT54G CDFA and WRT54GS CGN6

    1. Flashed with mini, factory reset
    2. Flashed with std, all seems okay
    3. Factory reset, all still looks okay all tabs
    4. Go along configuring numerous settings.
    5. Get done, think "oh time to backup settings file!".
    6. Notice the "Firmware Upgrade" and "Backup" tabs stay white and are no longer clickable.
    7. :eek:
    8. Reboot, refresh browsers, try IE, same problem.
    9. Reset to factory defaults, those 2 tabs are accessible again

    Repeat same steps with other router, end up at same place.
  7. Chryx

    Chryx Network Guru Member

    WRT54GS v1.1, 06/12/05 mini-generic, hardware reset before and after flashing, router manually reconfigured.

    connections to remote servers are not stable, still.

    eg, ichat and adium roll on and offline every few minutes for no apparent reason, file transfers conk out after a few (variable) megs, sometimes 3MB goes though, sometimes 15.. but they do conk out.

    Surely I'm not the only person having this issue?

    Rolling back to a build from a month ago doesn't show this behaviour... Nor does the linksys firmware, but I'd kinda like to keep using DD-WRT if I could actually get it to work :D

    If there are any settings you guys need to know about to diagnose this, please let me know, I'll help in any way I can.
  8. in8skillz

    in8skillz Network Guru Member

    Ok, seems my signal up/down is still around and has large swings from 44-67 on netstumbler. I will state I'm in an apartment with a high concentration of wireless networks, but none are on my channel.

    The good news is that it is atleast not dipping down to 10 which makes it a lot more usable.

    I wish I could confirm your situation, but I usually use an Mac iBook for upgrading my WRTs. I can say for the last 5 firmware or so, that when using Safari to upgrade, the whole gui is screwy but navigatable with practice.
  9. daenigma

    daenigma Network Guru Member

    I dont know why but I still do not get the list to show static address... I have tried using both DHCPd for static addresses and DNSMasq. I also want to add that getting an address from the dhcp server is a bit slow since the Dec 02 build.

    Using a WRT54GS v3 DD-WRT v23 beta 2 mini build December 6th 2005
  10. rljo

    rljo Network Guru Member


    I had exactly the same problem with previous builds, haven't tried it yet with the 06/12 build. if I tried to set use https and unchecked use http, for web access on the administration page. Thereafter the backup and firmware update tabs would go white, and stay that way regardlesss of whether I re-enabled http and unchecked the use https. Only a reset to factory defaults would bring it back. Someone on the forums said this was a known limitation (http for web access must be left checked.)

  11. Tomchu

    Tomchu Network Guru Member

    Unfortunately, bug 332 is still around. :-(

    Otherwise, excellent work on the latest build!
  12. Magus255

    Magus255 Network Guru Member

    not really a bug, but it would be nice to have a wan uptime. currently the uptime seems to be for the router which is good but doesn't really tell you anything about your internet connection.
  13. Tomchu

    Tomchu Network Guru Member

    Uptime measures uptime of the kernel -- it's a command, and every single *nix has it.

    It's sort of measuring different stuff. :-/
  14. Sjowhan

    Sjowhan Network Guru Member

    Well, can you?
    There are still problems with staying online, router just loses in times the connection to the internet, but it doesn't reboot:
    Time: 14:53:12 up 17:25, load average: 0.00, 0.00, 0.00
  15. vincentfox

    vincentfox Network Guru Member

    I believe I only added https, and left http alone. I will test again.

    I suppose I should check and see if anyone filed a bug report, have to figure out how to do that.....
  16. Lazybones

    Lazybones Network Guru Member

    The restore backup and firmware ugrade features do not seem to work reliably in HTTPS mode.. I alwasy revert back to HTTP only mode before performing those functions.
  17. vincentfox

    vincentfox Network Guru Member

    If you think about this problem a bit, you will see that in some ways "is the internet working?" is not just a simple 3 lines of code. Do you have PPPoE, static IP, or what? There are several ways you could be connected to the internet, and you'd want different tests for different situations. For example what if you wrote a program to ping the gateway every 10 seconds. Okay it works fine but once in a while drops a single packet. Was the internet "down" such that we should raise red flags and set the counter to zero? What if your gateway is not pingable due to firewall rules that toss out ICMP?

    If you have some suggestions for how all situations should be handled fire away. False positives and missed negatives are non-trivial problems for IP networks. The common ISP networks are designed such that for consumer-level hardware, there is little or no link-status information you can access on a second-by-second basis.

    Aside from which this is not a "bug" per se. You misunderstood what uptime meant. Now you are asking for a new feature. That might be a good thing for v24 but the rest of us would just like to see v23final for Christmas.

    You could use the KeepAlive function to schedule reboots every hour or something if you wanted, that would be one way to workaround your ISP issues. You should address the real issues though of why your ISP is dropping you.
  18. Sjowhan

    Sjowhan Network Guru Member

    I'm on several IRCservers, IF there's a connectionloss for some minutes, IRC disconnects. Also MSN disconnects at the same time, and i can't use the internet futher. It IS a bug, i can't stay online on ircservers for more than 24 hours :thumbdown: . And it is a problem of the dd-wrt firmware, because i didn't have problems at all with my original linksys firmware.
    I'll get an IP from my ISP (with DHCP)
    Reboots (scheduled or not) doesn't solve the problem, because the routeruptime is correct. And NO, i don't ask for a new feature for v23. It's just that annoying bug that i've SINCE i'm using dd-wrt on my linksys WRT54G v2.2 router!

    The only thing i can suggest is going back to the linksys-firmware, but that's the last thing i want to do.
  19. vincentfox

    vincentfox Network Guru Member

    My point was, uptime works as it should.

    What is it you DO want exactly? It certainly sounded like you wanted something that would tell you how long internet has been up.

    Now it sounds like you want to know why you can't stay connected. That is a valid question. Well maybe a lot more details in your bug report would show why this is the case. Most people have problems with PPPoE. If you are not using that and using just plain DHCP on WAN, is it possible that this "offline" state is coming up right at time for DHCP renewal on the WAN port? See information like that would be useful. Just saying every day it quits is not putting much light on the problem.
  20. vincentfox

    vincentfox Network Guru Member

    THANKS! that was it, I usually switch to https after enabling, hadn't thought to switch back to http. When I do those tabs work fine. Weird. I can see why maybe doing a firmware upgrade over https would be a problem, but backup?

    Anyhow, now that I know I can work around it.
  21. Sjowhan

    Sjowhan Network Guru Member

    No, just give a bugreport that the router looses the WANconnection on different times.
    If i can log the DHCP'client' on the WANside of the router, perhaps i can give more information what's going on, and what happends/causes that the router looses the internet connection..
  22. vincentfox

    vincentfox Network Guru Member

    Have you enabled syslog? There would likely be entries in there with useful information.
  23. bigjohns

    bigjohns Network Guru Member

    clients not showing in DHCP client table when using DNSMASQ for DHCP.... Is this a known bug?
  24. dellsweig

    dellsweig Network Guru Member

    I have seen them appear when the client renews.

    The static lease works correctly.
  25. bigjohns

    bigjohns Network Guru Member

    ok... do you configure static addresses and dhcp range in the dnsmasq configuration on the administration page, or do you do it on the services page under dhcpd? And what is dhcpc?

  26. dellsweig

    dellsweig Network Guru Member

    Personally, I have dnsmasq enabled on the admin page and the static leases defined on the services tab.

    I am not completly clear on the effect of checking the dnsmasq button on the setup tab. When I check this - I see what you describe - lease info not showing up in status screens until lease is renewed by client.

    I have not seen any reason to leave this checked.
  27. Lazybones

    Lazybones Network Guru Member

    Creating backups is not a problem, just restoring them.. Both firmware updates and restoring backups reset variables. HTTPS depends on some sort of key being passed between the router and your browser. When everything resets I assume this key is lost sort of screwing up your browser session and possibly interfering with the reset it self..

    Might be best if these two features forced http mode and warned the user.
  28. bigjohns

    bigjohns Network Guru Member

    Now, if I understand this correctly, not checking that box on the setup page leaves DHCPD running as well as DNSMASQ - which both consume memory and to a degree duplicate eachother's function...

    That's why I'm really trying to make sure that I do this right - I want to free up as much memory as possible to make the router run efficiently.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice