New Release: V23 beta 14.12.2005 Bug Reports Here!

Discussion in 'DD-WRT Firmware' started by bytes2000, Dec 14, 2005.

  1. bytes2000

    bytes2000 Network Guru Member

    This release needs a full reset of all nvram settings to get everything in the right place

    - ASUS WL500G-Deluxe support fixed
    0000442 DNS problems with 12.12.05
    0000450 12/12 build: Calling ntpclient manually sets time to UTC
    0000446 UDP Timeout option broken
    0000129 L7 protocol for half-life 2:DM applied ? (where are additional l7 filters ?)
  2. dellsweig

    dellsweig Network Guru Member

    Well - I just flashed in 12/14 over a 12/12 client bridge. After power cycle, I cannot log on (telnet or http) to the device. I just did a hard reset - lets see if I can get in now

    This is going to be a real pain if we have to hard reset every box to get this build up

    After a hard reset - LED's look normal - cant ping, telnet or http into device
  3. bytes2000

    bytes2000 Network Guru Member

    My WRT54GS v1.0 wasnt bricked but Im still experiencing the same DNS problems with pppoe

    WRT54GS v1.0
    14/Dec/05 VOIP
  4. dellsweig

    dellsweig Network Guru Member

    One attempted upgrade (from WRT54GV2 Mini 12/12 to WRT54G Mini 12/14)

    I have a brick

    LED's look normal. Netstumber shows the default wireless network 'linksys'. Client cannot connect (static or dhcp).

    I try to use Linksys firmware restore tool - cannot contact router

  5. flexy

    flexy Network Guru Member

    did you try the pin-shortcut method ?

    I remember i once bricked my wrt54g and had a hard time even with pin-shortcuts and stuff...took me half-an hour trying and pushing the reset button....but after some time it magically came to life again.....just keep trying.
  6. dellsweig

    dellsweig Network Guru Member

    This one is NOT coming back. It was a WRT54G V2

    I tried the revival stuff - not happening

    I am on-line with Linksys now - they are going to RMA a 2 year old unit!!
  7. dellsweig

    dellsweig Network Guru Member

    Has ANYONE had a sucessful upgrade of this build??
  8. Tomchu

    Tomchu Network Guru Member

    I just upgraded both my WRT54G v4 and WRT54GS v4, and they're both working fine, though I had to enable DHCP through DNSMasq in order to get DHCP addresses (dhcpd worked the first time, then it wouldn't give out any leases).

    I did a 30-second-reset, and the WRT54GS did not come back up (power kept blinking). I unplugged the power and then plugged it back in, and had a clean-slate DD-WRT. I followed that with an upgrade from the web interface with the "Firmware defaults" option selected.

    The second router I didn't even bother with the 30-second reset, I just used the web interface and used "Firmware defaults" again.
  9. dellsweig

    dellsweig Network Guru Member

    Well - as I posted my WRT54G V2 would not come back up.

    I flashed in the 12/14 and did a hard reset. The router came back up. I went in and changed the IP, turned off DHCP. I hit save and that was the last it talked to me

    It may have been old age but none of the tricks worked. I do not know if the 12/14 build had anything to do with it - its time may have just been up.

    I will wait and see if anyone else has troubles before I upgrade my 2.2 and 3.1 54G's

    BTW: Linksys had no problem giving me an RMA for a 2 year old, MANY times flashed, case opened and pins shorted WRT54G

    I hope they dont send me a V5 :)
  10. gaster

    gaster Network Guru Member

    I had nearly a brick, but I got it back. My router is a Motorola WR850G V2. I had this problem before with other builds so I had experience with it.

    1. Motorola's default IP is no matter what you set it to. This is even after a erase nvram. It always boots with that for at least a few seconds. Since the router acts dead you need to change your computer's IP to Use for a Linksys. Actually, the 6 could be 2 or any small number you like.

    2. Get an old firmware, rename it to binary.bin and put in in the root folder of your C: drive. Yes, this is for Windows people only.

    3. Open a dos type window and get to the c: prompt

    4. Paste this in there: tftp -i put binary.bin
    Change that to for Linksys

    5. Unplug the router and then plug it back in

    6. Pretend the ethernet cable is in port 1. Watch for the port 1 light to go on. When it does hit Enter on the keyboard.

    7. Be patient. Even if the router had appeared dead, boot wait was on and the tftp should work. It did for me. Let it do it's thing for a few minutes before changing the IP of the computer back.
    And even if you do you might not initially be able to get to the router. For the Motorola, I've had trouble with DHCP, so I had to change the IP on the computer from to just to access the web page.

    Lots of work, but you can get them back to life.
  11. gaster

    gaster Network Guru Member

    BTW: Linksys had no problem giving me an RMA for a 2 year old, MANY times flashed, case opened and pins shorted WRT54G

    that might just be because they haven't seen it yet
    good luck though
  12. TexasFlood

    TexasFlood Network Guru Member

    Man, weird, this is exactly what happened to me, I could have written that post, right down to the choice of IP. Well. Except that I use the Linksys TFTP Utility. I'm not sure how to do a hard reset on the WR850G, couldn't seem to get it to work.
  13. Cyberian75

    Cyberian75 Network Guru Member

    My upgrade went just fine.
  14. djmallon

    djmallon Network Guru Member

    I upgraded fine, though I had to unplug/replug power to get a response, and then do it again when i issued 'mtd erase nvram; reboot' after upgrading. Everything's running awesome right now.
  15. daenigma

    daenigma Network Guru Member

    Upgraded fine here... WRT54GSv3 DD-WRT v23 beta 2 I went from the December 12th mini build to the December 14th mini build.
  16. Spontex

    Spontex Network Guru Member

    Has anyone had a sucessfully flash of the mini_geniric build on a SE505v2??
  17. LAGMonkey

    LAGMonkey Network Guru Member

    first flash resulted in no responce untill hard button reset. Then when changing the routers IP resulted in no responce untill hard reset. Flashed again and had to hard reset after "erase nvram" command but afte that its all working fine and dandy.
  18. devil-strike

    devil-strike Network Guru Member

    Upgrade also fine with a v2.2. (std version)
  19. dirtyclyde

    dirtyclyde Network Guru Member

    14-12-05 upgrade is a bummer! "mtd erase nvram" ha

    Just upgraded from 12-12-05 to 14-12-05 (std) WRT54GSv2.1 (two) after mult resets , mult power downs, hangs , bricks etc..... the WRTs final settled down. The time use to come up correctly after a minute or so, but now time is not set on the wrt54gs. I can force a time by "ntpclient" or use the ip address. 12-12-05 was OK with updating the time and date auto. This is not too stable of a load! would advise people to stay away, stay with 12-12-05.

    "mtd erase nvram;reboot" hangs you have to power off

    Well my time maybe because of my DSL (log file off the westell)

    THU DEC 15 11:28:34 2005 Error getting time from SNTP server

    ran a DGN on my DSL, will wait and see!

    Still no time. 12-12-05 is screwed on the time also!

    went back to the old (std) Dec-11-05 (11-12-05) load, it's a broke dick dog, but like it better then the 12-12 or 14-12 load!

    Time & Date works, wds works, I have DHCP turned off, let the Westell DSL assg my IPs. WRT54GS does update the Date & Time.
  20. Fman99

    Fman99 Network Guru Member

    This version sounds like a russian roulette game... more bricks than a schoolhouse. I'll stick to 3-12-05 thanks.
  21. Linksysinformer

    Linksysinformer Network Guru Member

    tftp was indeed successful for me, command prompt shows "binary transfer successful of 2,xxx,xxx bytes"

    but now my WRT54G v3.1 is just flashing its power led non-stop, even after reset, or unplugging and plugging in of power cable. I can't get an IP, and manually setting an IP doesn't help at all!

    What's happening? Any hope for me?
  22. Linksysinformer

    Linksysinformer Network Guru Member

  23. ericjwill

    ericjwill Network Guru Member

    blinking power led

    changed from hyperwrt to dd-wrt (am now running std build) on 1.1 hardware and have constant blinking power light. all other leds behave normally and router functions A-OK. thoughts?
  24. pmagsino

    pmagsino Guest

    Any resolutions to those that have bricked their router using this firmware? I have the same problem. I've tried all the previous recommendations to no avail.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice