New Release: V23 beta 17.10.2005 Bug Reports Here!

Discussion in 'DD-WRT Firmware' started by sufrano63, Oct 17, 2005.

  1. sufrano63

    sufrano63 Network Guru Member

    As recommended by BrainSlayer, I upgraded to the mini first and it works with a few exceptions

    1 - worked great if I'm connected wired
    2 - doesn't recognize the router if I'm wireless

    Thanks to BrainSlayer for great FW :cheer:

    Hardware - WRT54Gv3 running beta2 10/14/05 FW
  2. Toxic

    Toxic Administrator Staff Member

    catched 2 long term memory leakes in httpd daemon
    possibly crashbug fixed in uclibc (can also cause the strange upnp crashes)
    uclibc pipe function optimized (possibly you get enhanced speed now)
    building bug with std version fixed (wrt54g binary only), sorry about this
  3. Cyberian75

    Cyberian75 Network Guru Member

    FYI, UPnP still crashes with Azureus...
  4. Cyberian75

    Cyberian75 Network Guru Member


    "Wireless Network Mode" seems to be broken or its variable changed.
  5. Maugus

    Maugus Network Guru Member

    Old Problems, Old Sugestions

    When using large access restrictions, iptables goes blank after reboot.

    DNSMasq as DHCP dont support static DHCP ( GUI )

    DHCP clients tables goes empty when using dnsmasq as DHCP

    In port range forward if i use a ip like, when i save, last number disapear like :, i have to complete and save again after that work ok (old problem, since v22)

    Please increase the number of MACs AND IPS in access restrictions/edit list of pcs.

    Please update KAID to lastest version and include PSP support.

    Is possible to create a default/standart page to nocat ?

    In firmware upgrade, what is the difference between firmware defaults and factory defaults ? If there s a difference why dont u put an option that restore to firmware defaults in GUI ?
  6. dellsweig

    dellsweig Network Guru Member

    Upgraded my WRT54G V3 to 10/17 Beta 2 Std build

    The upgrade was from the 10/12 V23 build

    All settings were retained and the router is working correctly
    As in almost all other V23 build, logging stopped working.

    It would be nice to do an upgrade WITHOUT loosing all settings

    I guess I will have to reset and start over - again.....


    Reset to factory defaults, put back in all settings logging ok now

    1) JFFS shows partition 100% full
    2) config save crashes httpd
    2A) after config save, logging no longer works

    Brainslayer: A working config backup/restore would help ALOT. It would allow upgrades of firmware with a full reset followed by a simple config restore.
  7. bytes2000

    bytes2000 Network Guru Member

    Port range forward

    another port range forward problem (usability?)

    BUG 1)
    Filled the 1st row with the data (application, start, end, protocol, ip and check in enabled) then I clicked on ADD

    I got another row, but the data from the 1st row was deleted!!

    workaround: add as many rows as you need, fill the data then save. If not you will loose your settings.
    Tested with IE 6

    BUG2) UPDATE> another bug
    Clicked another link then clicked again PORT range forward
    and the application filed now was an IP, the same ip from the ip field.

    UPDATE3: Forgot my HW version: WRT54GS v1.0 (17.10.05 build)
  8. Cyberian75

    Cyberian75 Network Guru Member

    I do this quite often with no apparent problems. I don't use logging, though.
  9. MBChris

    MBChris Network Guru Member

    Problem with Client Routed Mode:

    AP WRT1:


    DHCP enabled



    DHCP enabled

    Routing Mode: RIP2/both Interfaces


    When i connect to the LAN-Port of the Client WRT, i should get an DHCP-IP out of the Range 10.1.5.X (as verified with V22R2)

    But strange i get an DHCP-IP from the MAIN AP (AP WRT1) e.g.

    And ... of course on the wireless Page i choose CLIENT not Client Bridge.

    Update of both WRTs was from V22R2 to V23 17/10 standard wrt54g.bin

    Could someone second this ???
  10. npero

    npero Network Guru Member

    Yes I confirm set client mode eth1 wireless interface is bridged with LAN,( like client bridge mode) if you change some setting and click save setting then client mode work this is problem with frist boot.
    I solve this problem with startup script works on WRT54g v2.0 eth1 is wireless interface.

    nvram set rc_startup="brctl delif br0 eth1"
    nvram commit

    with this in client mode remove eth1 wireless interface from bridge and wrt routed between wireless and LAN interface.

    Brainslayer thanks for FW
  11. dellsweig

    dellsweig Network Guru Member

    Try this:

    Test 1:

    Take your working configuration and turn on logging - syslog is not needed, just internal logging. Then perform a config backup and see if logging is still functioning

    Test 2:

    Take the saved config - where you had logging enabled. Restore your router with that config. Does logging work?? - I bet it wont. I wonder what else doesnt work.

    Compare your IPtables (iptables --list) before and after your backup and before and after your restore. You may be suprised
  12. MBChris

    MBChris Network Guru Member

    Thx npero, ill try this in the evening. Its a good workaround and if it works it is not anymore a showstopper :)

    Of course ... thx to Brainslayer too :)
  13. npero

    npero Network Guru Member

    client routed mode missplaced bridge fixed

    :thumbup: try tomorrow.

    Brainslayer in client mode PPTP client and PPTP client Use DHCP interface work on wan port is posible to change in client mode work on wireless port eth1 like PPPOE.

    Thanks Brainslayer. :thumb:
  14. Cyberian75

    Cyberian75 Network Guru Member

    Is the wireless working???
  15. MBChris

    MBChris Network Guru Member

    Ok, i tried this version but, sorry Brainslayer, doesnt work also with 18/10.

    Tried your solution (npero) and it works but not reliable because the following:

    i changed the rc_startup to "brctl delif br0 eth1", reboot the WRT.

    and the ping does not work :(

    I recognized the following thing. If the wired PC is still connected to the wrt, the PC gets his DHCP-Address within the bootsequence of WRT, possible before the rc_startup changed the Bridge. therefore the arp-cache has an invalid mac-entry for the WRT (bridge).
    when i delete the arp-cache on the PC manually, or do a DHCP-renew after complete booting of the WRT all went well.

    See code:
    C:\Documents and Settings\ITADMIN054>arp -a

    Interface: --- 0xb0003
    Internet Address Physical Address Type 00-13-10-2f-f3-ae dynamic

    C:\Documents and Settings\ITADMIN054>arp -d *

    C:\Documents and Settings\ITADMIN054>tracert

    Routenverfolgung zu über maximal 30 Abschnitte

    1 1 ms 1 ms 1 ms
    2 3 ms 2 ms 2 ms
    3 4 ms 3 ms 4 ms
    4 6 ms 5 ms 6 ms

    Ablaufverfolgung beendet.

    C:\Documents and Settings\ITADMIN054>arp -a

    Interface: --- 0xb0003
    Internet Address Physical Address Type 00-13-10-2f-f3-ad dynamic

    C:\Documents and Settings\ITADMIN054>

    So there are 2 different MACs for one Interface/IP i think there is something wrong
  16. Jeffrccar

    Jeffrccar Network Guru Member

    When on the Administration page the status page is not there.
  17. MBChris

    MBChris Network Guru Member

    @nepro, @all

    with the, for me so called GREEN EDITION ov V23 19/10, the "misplaced bridge" BUG is gone :clap: Thank you Brainslayer !!! Now for me its more than a beta !

  18. craig_oz_land

    craig_oz_land Network Guru Member

    1) Web management interface is only accesible once with wireless connection. After one connection cannot connect anymore.

    2) Constant rebooting of WRT54Gv2

    3) WNIC = D-Link DWL-G520
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice