New Release: V23 beta 24.11.2005 Bug Reports Here!

Discussion in 'DD-WRT Firmware' started by Sjowhan, Nov 24, 2005.

  1. Sjowhan

    Sjowhan Network Guru Member

    0000276 openvpn version 2.02 wich is used in the vpn version contains security bugs
    0000269 cgi method show_modules() doesn't (jffs|mmc)/etc/config for files
    0000265 snmpd binary missing from V.23b VPN 2005/11/23 build
    0000272 Status page incorrectly reports DHCP is enabled in Client Bridge mode
    0000273 udhcpc starts new instance of openvpn on every wan lease renewal
    0000275 Cant change Static DNS in Setup/Basic Setup
  2. Lazybones

    Lazybones Network Guru Member

    Are there errors in the title of this thread? It doesn't make sence

    Is this a V24 beta build for 23.11.2005 or maybe
    Is this a v23 Beta build for 24.11.2005 ?
  3. Toxic

    Toxic Administrator Staff Member

    I've changed the topic title to read correctly.. it is v23b released and NOT v24
  4. hhsn2001

    hhsn2001 Network Guru Member

    IP input field missing !

    8O I was in the wrong thread, sorry! must have been :drinking: :drinking:
  5. mattpwill

    mattpwill Network Guru Member

    I've only tried mini versions of WRT54G and GS.

    With the WRT54GS version the Basic Setup page won't save. The WRT54G version is fine.

    Edit - It was my PC at fault, not the firmware! oops!

    I just want to say - great job with the firmwares! They're functional, fast and reliable
  6. DaRkBoZ

    DaRkBoZ Network Guru Member

    DHCP Static adress is still broken :cry:

    since v23b1 it's broken i hope it'll be fixed :/ i must use the old v22 :(
    it's a crucial feature since i set a lot of NAT on my network if the ip adress change each time...
  7. Sjowhan

    Sjowhan Network Guru Member

    Dunno what you're doing wrong, but @ the 21.11 version, Static DHCP works for me..

    @Toxic, Oopz, sorry!
  8. -jcb-

    -jcb- Network Guru Member


    not a bug but...

    My ADSL line is KO at home but all my computers use static DHCP and I think the DHCP server wait the line because it don't give IP. So I must change all network config. A solution to make dhcp work with DHCP and if problem without ADSL quickly ? It wait only the DNS ?

  9. Sjowhan

    Sjowhan Network Guru Member

    You mean, because there isn't an external DNS available, the DHCP server on the router doesn't give out IP's?
  10. Sjowhan

    Sjowhan Network Guru Member

    After 4h spending on the internet, without using a bittorrent client, the connection resets:
    Firmware: DD-WRT v23 (11/24/05)
    Uptime: 19:46:23 up 4:02, load average: 0.01, 0.01, 0.00

    I got a disconnect on IRC, MSN etc.

    Is it a bug, is it my DSLline?
  11. Cyberian75

    Cyberian75 Network Guru Member

    Even with constant heavy traffic, there were disconnects for me overnight.

  12. Sjowhan

    Sjowhan Network Guru Member

    So this means, there IS a disconnect-bug in v23b2. However, it's kinda weird not all users do have problems with this (annoying, for me and users on IRC) bug..
  13. DaRkBoZ

    DaRkBoZ Network Guru Member

    Sjowhan > i'll try the 21/11 then... thx :thumbup:

    i dunno what could be wrong since i enter the parameters like it's asked on the GUI.
  14. Cyberian75

    Cyberian75 Network Guru Member

    Oops, I meant to say there were no disconnects.
  15. hotrat

    hotrat Network Guru Member

    Must be getting close to Release Candiate/Final time huh!?
  16. Couledouce

    Couledouce Network Guru Member

    Installed Mini on WRT54G with WDS and WEP.
    No problems :cheer:
  17. murdock1234

    murdock1234 Network Guru Member

    my dhcp clients are losing their ip address with the 24.11 release.
  18. 4Access

    4Access Network Guru Member

    Are they able to lease an address at all? What happens if you type the following two commands on the computers that you're having trouble with:

    ipconfig /release
    ipconfig /renew

    Which DHCP server are you using? (Did you check the box to use DNSMasq for DHCP - if not then give that a shot and see if it helps.)
  19. Sjowhan

    Sjowhan Network Guru Member

    It isn't needed to check the box to use DNSMasq. It works without here..
  20. 4Access

    4Access Network Guru Member

    Do you mean that DNSMasq is providing DHCP even if you don't check the box, or that you don't need to use DNSMasq because you're not have the problem murdock described?
  21. dellsweig

    dellsweig Network Guru Member


    I think it is time for some help from the master!!

    We have a section to enable or disable dnsmasq on the admin page
    We also have a checkbox on the setup page for dnsmasq

    What is the difference?? What do the two setups tell us??

  22. Cyberian75

    Cyberian75 Network Guru Member

    The first is for DNS and the second is for DHCP.
  23. -jcb-

    -jcb- Network Guru Member

    Yes, it's this.

  24. dellsweig

    dellsweig Network Guru Member

    SNMP missing from the 11/24 Standard build. I did not look in any of the other builds as standard contains the tools I use.

    Still waiting for an explaination of why I would want to check the dnsmasq box under DHCP setup
  25. tievolu

    tievolu Network Guru Member

    My understanding is that Dnsmasq is useful as an alternative to the rather unstable DHCP daemon.
  26. redpanther

    redpanther Network Guru Member

    Static ip bug?

    Trying to set statc ip in this format xx:xx:xx:xx:xx:xx then click save it fails and i get error message not valid mac.

    If I enter it in this format xx xx xx xx xx xx then click save the static ip's set ok.

    Just an fyi.

    PS...been away for a while and I love the new look over the original v.23! Keep up the good work! :thumb:
  27. rljo

    rljo Network Guru Member

    Can someone confirm this before I report it on the bugtracker? On the administration tab, select the https option under web access, and unselect the http option, save, then reboot. Don't forget now to access the interface with . In the last view versions, firmware update and backup tabs become unavailable. Re-selecting the http option and rebooting will not bring the tabs back. Only a reset to factory settings will work. This has been driving me nuts on the last few versions, and finally narrowed it down today.
  28. zyclone

    zyclone Network Guru Member

    as far as I remember , brainslayer has removed the backup/restore utility from being accessible, when using the secure http administration.
    so it's normal that you can't access those fonctions with https://...
    he explained, why, in some older post.
  29. bytes2000

    bytes2000 Network Guru Member

    23 Nov build reboots!
    WRT54GS v1.0

    I was browsing the internet with a desktop and suddenly the LAN icon in my xp told me "the Cable is disconnected"... huh the cable was connected

    Then I checked a LAPTOP near me: it was disconnected from the wifi network and trying to reconnect

    After that: I checked the router uptime.... it just rebooted and no internet ip yet

    Firmware: DD-WRT v23 (11/23/05)
    Uptime: 00:00:19 up 0 min, load average: 0.49, 0.11, 0.03
    WAN IP:

    UPDATE: I did a manual reboot thru telnet -> reboot > enter
    weird, now uptime is:
    Uptime: 23:17:45 up 7 min, load average: 0.30, 0.31, 0.15

    WRT54GS v1.0
    23 Nov build (VOIP)
  30. Sjowhan

    Sjowhan Network Guru Member

    My router keeps disconnecting from the internet. It's since i'm using the dd-wrt firmware, and it's still not solved.

    However; the router doesn't reboot, it just loses the connection (uptime almost 3 days)
  31. zyclone

    zyclone Network Guru Member

    dhcp static Leases don't work for me

    like redpanther, I receive an error message : not valid mac address, while entering it in 00:00:00:00:00 format.

    if I enter it in : 00 00 00 00 00 format , I don't receive the error message , but the leases aren't working at all,
    it don't show up in the Lan status windows, and it don't set the right ip, when a computer comes on the network.
  32. idigital

    idigital Guest

    My router drops out when anyone tries to use anything like Limewire. Turning on QoS has no effect, either.

    WRT54Gv2 DD-WRTv23 (11/24/05)
  33. lore

    lore Network Guru Member

    Try setting your IP Filter settings in Administration to 4096 ports/90 seconds/90 seconds. That should take care of it.

    Make sure it's not your desktop firewall software going bonkers, too.. I thought it was the router acting up but it turned out to be my desktop.
  34. Cyberian75

    Cyberian75 Network Guru Member

    I can confirm this.
  35. Sjowhan

    Sjowhan Network Guru Member

    Another bug; the wlan is (sometimes) ultimate slow (max downloadspeed is than 20kB/s in stead of 760kB/s), with the past versions, i didn't have problems with using VNCviewer and surfing through the internet, but with the 24.11 version, i have.
  36. Tomchu

    Tomchu Network Guru Member

    I have three bugs to report, and one semi-confirmation of a previous bug report.

    Firstly, the main Setup page is messed up when viewed in Safari (version 2.0.2, OS X 10.4.3). The very same page in Firefox 1.5 on OS X 10.4.3 looks fine. All other pages look fine in either browser. Ignore the hostname in the screenshots below. :-P

    The second bug is related to remote admin port configurations. When I enable remote admin on port X, remote admin becomes available on both port X and port 80. Port 80 should not accept connections from the WAN interface unless I specifically say remote admin should run on 80. Overall not a big issue, but I know that some people's ISPs get their panties all up in a knot if they find anything running on common ports.

    The third bug is very ambiguous, and I'm not even sure if it is a bug. I have version 23 beta 2 24.11.2005 of DD-WRT running on two routers. One is a WRT54G v4, and the other is a WRT54GS v4. The WRT54G acts as the gateway for my Internet connection, has one client hooked up directly to an Ethernet port, and is also linked to the WRT54GS through wired Ethernet. It sometimes has 1-2 clients on the wireless side of things. The WRT54GS has all of the DNS/DHCP/etc. options disabled, has its IP changed to, and acts as a second AP + switch for some more clients upstairs. This all works wonderfully, and I'm happy -- the router downstairs handles all Internet + DHCP + DNS + management stuff, and the router upstairs is just an "extension" of the wired/wireless reach of the first.

    Both routers underwent a full 30-reset-button procedure, followed by a "factory defaults" reload in the stock Linksys firmware. They were then flashed to the mini generic version of the DD-WRT firmware we are discussing. I then proceeded to configure both routers to my liking.

    The "problem" I've noticed is a bit of an anal one, but given the close nature of the hardware, procedures they underwent, and software they are running, I can't help but notice the following:

    SexBox (WRT54G)
    ~ # ps
      PID  Uid     VmSize Stat Command
        1 root        704 S   /sbin/init noinitrd 
        2 root            SW  [keventd]
        3 root            RWN [ksoftirqd_CPU0]
        4 root            SW  [kswapd]
        5 root            SW  [bdflush]
        6 root            SW  [kupdated]
       11 root            SW  [mtdblockd]
      106 root        828 S   httpd 
     2001 root        320 S   resetbutton 
     2031 root        296 S   tftpd -s /tmp -c -l 
     2065 root        316 S   /sbin/wland 
     2110 root        352 S   dropbear -r /tmp/root/.ssh/ssh_host_rsa_key -d /tmp/r
     2231 root        364 S   dnsmasq --conf-file /tmp/dnsmasq.conf 
     2246 root        188 S   igmprt -f -i vlan1 
     2288 root        396 S   process_monitor 
     2329 root        264 S   udhcpc -i vlan1 -p /var/run/ -s /tmp/udhcpc
     2800 root        540 S   dropbear -r /tmp/root/.ssh/ssh_host_rsa_key -d /tmp/r
     2801 root        432 S   -sh 
     2804 root        320 R   ps 
    CaptainOwnage (WRT54GS)
    ~ # ps
      PID  Uid     VmSize Stat Command
        1 root        680 S   /sbin/init noinitrd 
        2 root            SW  [keventd]
        3 root            RWN [ksoftirqd_CPU0]
        4 root            SW  [kswapd]
        5 root            SW  [bdflush]
        6 root            SW  [kupdated]
       11 root            SW  [mtdblockd]
      109 root        696 S   httpd 
     1714 root        320 S   resetbutton 
     1747 root        296 S   tftpd -s /tmp -c -l 
     1761 root        316 S   /sbin/wland 
     1801 root        352 S   dropbear -r /tmp/root/.ssh/ssh_host_rsa_key -d /tmp/r
     1864 root        396 S   process_monitor 
     1951 root            Z   []
     1965 root            Z   [wdswatchdog.sta]
     1970 root            Z   [wrt-radauth.sta]
     2115 root        548 S   dropbear -r /tmp/root/.ssh/ssh_host_rsa_key -d /tmp/r
     2116 root        432 S   -sh 
     2121 root        320 R   ps 
    In case anyone is confused ... what's with the zombie processes? I haven't found a way to get rid of them (short of killing init, the parent), but why are they lingering around in the first place? WRT-RADAuth and WDS are not enabled on either router, so why the discrepancy?

    This is after a cold reboot, by the way.

    My last point is a semi-confirmation of the static DHCP issue that two others have mentioned here. I say "semi" because static DHCP works for some hosts, and doesn't work for others. It works for both of my wireless clients, and some of my wired clients, but it doesn't work for two of my other wired clients -- they are merely assigned IPs out of my non-static DHCP range. No amount of tinkering with the adapter settings or firmware settings seems to fix it. I've entered the MAC addresses in the XX:XX:XX:XX:XX format. This format appears to work, the interface does not complain, and the settings are retained. And yes, I've checked and re-checked and checked again that the MAC addresses match.

    To summarize, these are all non-critical issues, but it would be nice if they were fixed. It may seem like I'm nagging, but in reality, I just want to see DD-WRT become the better than it already is. :-D

    I seriously love this firmware. Ever since installing it this morning, I've been fiddling with the ins and outs of it, and I'm liking what I see. I tried Sveasoft's Alchemy final before this, as well as HyperWRT, but nothing comes close to this. It seems to be super stable, fast (my wireless performance is better with this than any other firmware, even the latest stock Linksys), and the interface is totally kick-ass.

    Good job guys! Keep up the great work. ;-)
  37. Andreasx

    Andreasx Guest

    after Flashing "24.11.05-dd-wrt.v23.mini_generic" wds stopped working.
    I have two "WRT54GS v1.1" using exactly the same firmware.

    bevore I used "18.10.05-dd-wrt.v23.mini_generic" wds with wpa-psk.

    When I look under "Status - Wireless - Survey" I have a Signal (Rssi -80 ; noise -99)

    Sorry for bad english
  38. 4Access

    4Access Network Guru Member

    I'll try to find time to confirm this tomorrow. It must be a simple iptables misconfiguration.

    Do these zombie processes ever go away? I've noticed zombies on occasion but they usually only last a short time while the router is initilizing. Once or twice they seemed to stick around for an unknown reason but a reboot killed them for good. (Sorry about the pun, couldn't help it. :grin: ) BTW there was a random comment mentioning similar behavior in bug 215 which was opened for an unrelated reason.
  39. Chryx

    Chryx Network Guru Member

    Okay, this needs looking at, downloads 'STICK', and have been doing on builds since (roughly) Brainslayer changed the config file format.

    just did a hard reset / flash / hard reset / reconfigure manually type dealie with a WRT54GS v1.1, with 24-11-05 std

    go to fileshack, or anywhere really, to download something, it gets a couple of megs in and then just STOPS

    although 24-11-05 doesn't seem to drop the connection entirely, just that one transfer.

  40. Tomchu

    Tomchu Network Guru Member

    Nope. :-( It ran all night long, and the zombie processes were still here this morning. I did a reboot of the router, and now I've got one more lingering around:

    ~ # ps
      PID  Uid     VmSize Stat Command
        1 root        644 S   /sbin/init noinitrd 
        2 root            SW  [keventd]
        3 root            SWN [ksoftirqd_CPU0]
        4 root            SW  [kswapd]
        5 root            SW  [bdflush]
        6 root            SW  [kupdated]
       11 root            SW  [mtdblockd]
       73 root        320 S   resetbutton 
      107 root        296 S   tftpd -s /tmp -c -l 
      110 root        440 S   httpd 
      122 root        316 S   /sbin/wland 
      162 root        352 S   dropbear -r /tmp/root/.ssh/ssh_host_rsa_key -d /tmp/r
      225 root        368 S   process_monitor 
      305 root            Z   []
      313 root            Z   [smtp-redirect.s]
      320 root            Z   [wdswatchdog.sta]
      329 root            Z   [wrt-radauth.sta]
      364 root        548 S   dropbear -r /tmp/root/.ssh/ssh_host_rsa_key -d /tmp/r
      365 root        432 S   -sh 
      366 root        320 R   ps
    I can give you a dump of my NVRAM if that would help at all.
  41. henrych

    henrych Guest

    He's right

    I was using my WRT54G V2.2 with the build from 24/11/05 and I has similar problems.

    Downloads do seem to stop after about 3megs or so. As Chryx has posted it doesn't drop the connection but it won't carry on the download. I ended up having to directly connect with my modem to download an earlier version.

    Thee also seems to be problems with IM programs. I use iChat and although it doesn't drop the connection to AIM's host, but it does hang for a while before you get any messages come though.
  42. gaster

    gaster Network Guru Member

    I don't have any download problem with my Motorola WR850G running the latest 24-11-05 mini version.
    I tried downloading the SUSE 10 DVD iso file. I didn't let it complete, but it ran for a few minutes with no problem.
    With QoS I can even watch a streaming music video at the same time with no stutters on the video.
    No QoS = major stutters so it seems QoS is working too.
  43. Sjowhan

    Sjowhan Network Guru Member

    Got many disconnects, with WLan and Wanside of the router with the 24.11 version
    It just reboots within every hour..
  44. Tomchu

    Tomchu Network Guru Member

    I'm happy to report that the zombie processes which I reported earlier as happening on one of my routers no longer show up. They are there after a boot, but they seem to go away after a while.


    Oh well. I guess that "bug" can be ignored. :)
  45. tommurphy73

    tommurphy73 Network Guru Member

    When I try to connect to an SSID which has a two part name i.e. "Linksys home" using the join button on the site survey page it will not join. If I change the name to "Home" it works perfectly.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice