New Release: V23 beta2 14.10.2005 Bug Reports Here!

Discussion in 'DD-WRT Firmware' started by cyrano, Oct 14, 2005.

  1. cyrano

    cyrano Network Guru Member

    Hi !

    Just found a new release, and it seems v23 is no longer beta1, but has advanced to beta2 !!

    zlib support added for dropbear
  2. onenut

    onenut Network Guru Member

    install it and let us know how it goes
  3. dellsweig

    dellsweig Network Guru Member

    Flashed 2 routers with this

    First one - WRT54G V2 - no problem

    Second one - WRT54G V2.2 Bricked

    Reset - can not restore . After reset - cannot ping - default address, tftp cannot locate server

    Can someone send me the link to the de-bricking guide

    I am really ticked off by this - I have been upgrading to many Beta releases along the way - I have always been able to restore back to Link defaults..

    How does one open the Linksys case and which pins to short for hard reset??
  4. dirtyclyde

    dirtyclyde Network Guru Member

    3 WRT54GS v2.1 & v1.1 updated OK
    2 WRT54G v4.0 are in the shitter! did recover them on stock firmware took a while.

    All five were on 121005 STD, did a Gui update on all 5, all said the Update OK, but the two WRT54G v4 did not recover, they looked OK, but no telnet or http, scan the ports , no open ports.
  5. jagboy

    jagboy Network Guru Member

  6. Toxic

    Toxic Administrator Staff Member

  7. jagboy

    jagboy Network Guru Member

  8. dellsweig

    dellsweig Network Guru Member

  9. jagboy

    jagboy Network Guru Member

    good to hear!!
  10. -jcb-

    -jcb- Network Guru Member


    -Alway same problem for me, WPA2-PSK don't work on client router mode (start if I change to WPA-PSK) (WRT54GS 1.1)
    Anybody can confirm ?

    -httpd don't start (sometime) after a reboot

  11. sufrano63

    sufrano63 Network Guru Member

    upgraded to beta2 successful, but lost connection to WAN. Revert back to beta1 10/11/05 FW

    Also after the beta2 upgrade. Power button (Cisco System button) would not come back on automatically. I had to press it to get the orange light back on.

    BTW, I'm using wrt54gv4 same as BrainSlayer... :thumbup:
  12. zoyd

    zoyd Network Guru Member

    only generic version will install on my WRT54GSV4

    on backup config an error is reported to stdout:
    rm: unable to remove '/tmp/nvram': directory not empty

    the nvrambck.tgz file is saved but this somehow kills httpd

    http -S is started with ssh even though it is disabled
  13. hotrat

    hotrat Network Guru Member

    CONFIRMED client mode is still not working here with WPA
    GS v1.1

  14. -jcb-

    -jcb- Network Guru Member

    Thanks, so it's seem it's not me ;-)

  15. vinz

    vinz Network Guru Member

    Same as dellsweig, bricked my WRT54G V2.2.

    No ping, no tftp after hard reset :sad:
  16. hotrat

    hotrat Network Guru Member

    yah but doesn't even work with WPA here let alone WPA2!!
    WEP works but who wants to use that :/
  17. vinz

    vinz Network Guru Member

    Ok, my wrt54g is back to life after shorting pin 16. My wrt54g become bricked after upgrading from "121005-2.dd-wrt.v23.std_beta1" to "dd-wrt.v23.std_beta2" :( Back to "121005-2.dd-wrt.v23.std_beta1" for the moment.
  18. dellsweig

    dellsweig Network Guru Member

    Brainslayer NEEDS to take the beta2 build DOWN off the website

    Nayone thinking about using this should wait till we hear why so many are having problems with this build.

    BTW: Mine toasted using the standard build on a V2.2 box
  19. djmallon

    djmallon Network Guru Member

    my wrt54g v3 was bricked using the standard wrt54g flash. fyi.
  20. exnetgear

    exnetgear Network Guru Member

    v.23b2 mini 14-10-05 flashed fine on my WRT54G v.3.0
    It has been running for about a day without any problems. WPA works fine for me in client mode. I ALWAYS make sure I erase nvram, flash back to factory fw using Linksys EXE, do a 30 sec reset, cycle power, flash DD-WRT fw using tftp, do a 30 sec reset, and then cycle power. I have to enter all of my settings again, but not a big price to pay for no-cost, expanded functionality fw.

    Thanks again BrainSlayer!

  21. -jcb-

    -jcb- Network Guru Member


    I don't know if it is a bug, I now use local DNS on my AP, it's work fine, but on the client (router mode) I MUST also use local DNS, if not the dreambox connected to the client router can't resolve names (!?)


    PS : for me WPA-PSK work, it's WPA2-PSK witch don't work.
  22. unikum

    unikum Network Guru Member

    No probelms with wrt54GS v1.0

    I always go back to a original Linksys firmware first, do a factory reset, flash DD-WRT, do a factory reset again.
  23. bigbaraboy

    bigbaraboy Network Guru Member

    v.2.2 bricked and I can not install previous version of DD-wrt after debricking and installing last firmware from linksys.
    Ačč the time upgrade fails ( but luckaly i can work with orginall firmware)
  24. vinz

    vinz Network Guru Member

    After I bricked mine yesterday, I had many problem to reinstall DD-WRT. I had success installing first stock firmware 4.20.6, then "dd-wrt.v22.prefinal5" and finally "121005-2.dd-wrt.v23.std_beta1". After every flash, I did a 30 sec reset to be sure.
  25. bigbaraboy

    bigbaraboy Network Guru Member

    Same here,now I have ddwrt 0410.v.23 working and now I will wai for next release.
    It was my first debrick and I do not want to repeate this.
  26. dellsweig

    dellsweig Network Guru Member

    More info on the Beta 2 failure:

    My WRT54G V2.2 has not had anything except 3.x Linksys, hyperwrt and DD-WRT on it. The flash was from V23 10/12 to beta 2 10/14 (std).

    The upgrade went normal. The router re-booted, lights sequenced, power light stopped flashing, LAN and WAN light came on but no contact from router. Netstumber showed no radio, ping on LAN had no response.

    Held reset button to 60 seconds, not difference. Not bricked in the classic sense as the power light was NOT flashing but the router was dead. I could not TFTP or Linksys reset as the router would not respond to (default)

    It is almost like the factory defaults were changed so it did not default back to - maybe some other default addr.

    Router was configured as a WDS node with Internet disabled (not sure if this has anything to do with problem).

    This is basically the same failure mode as MANY are seeing - leds are on and look normal but WRT is dead
  27. hotrat

    hotrat Network Guru Member

    NO problems flashing v23 14.10 mini on GS v1.1
  28. 4char

    4char Network Guru Member

    No Problem flash v23b2 (14/10 std) on to GS v3.0
  29. dellsweig

    dellsweig Network Guru Member

    I think all the folks having problems were with the std version on WRT54G V2.2 and greater

    Personally, I have beta2 runnng on a WRT54G V2 but it failed on my 2.2
  30. vinz

    vinz Network Guru Member

    This is exactly what happened to me.
    I forget to mention that I always use std version on my wrt54g v2.2. Ok Dellsweig, you resume very well the situtation. Has somebody an idea of what happened?
  31. Tartanpion

    Tartanpion Network Guru Member


    Just flashed my wrt54gs with from 14 oct 2005. I noticed that pppoe with connect on demand still doesn't work correctly:

    I have to reboot the router one time after power on to make the rp ppoe works. And for the basic ppoe won't work at all. Both ppoe deamons work in 'keep alive' mode.

    Hope this will help for bug resolution.

    This firmware is really a great job ! :thumb:

  32. vincentfox

    vincentfox Network Guru Member

    antenna selection?

    It looks to me that antenna selection is "reversed" for the G build as compared to what we have all gotten used to.

    On GS it looks like "left" is as seen from rear.

    On G it looks like "left" is as seen from front. I have a v3.1 and v4.0.

    Can anyone else confirm this?
  33. vincentfox

    vincentfox Network Guru Member


    When I enter a WDS MAC in the GUI and go check with nvram show it comes out like this:

    wl0_wds= 00:xx:xx:xx:xx

    I think there should not be a blank space there?

    I manually set with
    nvram set wl0_wds="00:xx:xx:xx:xx:xx"
    nvram commit
  34. vincentfox

    vincentfox Network Guru Member

    WPA key truncation

    If I enter a 63-character WPA-PSK key, when I go back to that page it only shows a few characters of it.

    Doing an nvram show gives the correct key.

    Problem comes if someone mistakenly hits apply on the screen and now it saves the truncated key.
  35. vincentfox

    vincentfox Network Guru Member

    site survey sometimes give a full listing, sometimes it stops after 1st or 2nd unit.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice