New Release: V23 beta2 27.10.2005 Bug Reports Here!

Discussion in 'DD-WRT Firmware' started by cyrano, Oct 27, 2005.

  1. cyrano

    cyrano Network Guru Member


    Siemens SE505 support finished. works and fully tested (mini,std,voip)
    (see hwsupport.txt for additional notes)
    added linksys wds/wpa fixes
  2. Honki

    Honki Network Guru Member

  3. BrainSlayer

    BrainSlayer Network Guru Member

    mmh i dont see any critical things in it, but will take a look in it tomorrow
  4. sufrano63

    sufrano63 Network Guru Member

    no problem the control panel and cyan color :thumbup:
  5. 4Access

    4Access Network Guru Member

    BrainSlayer - Please click here

  6. simax

    simax Network Guru Member

    Does that mean that Client Bridge Mode (using WPA) is fixed??? I'll try this one today. With previous releases this month, I wasn't able to keep it running for more than an hour (if at all).

    Good ;)
  7. simax

    simax Network Guru Member

    DD-WRT is down :(

    Can't download new betas :(
  8. DynaMight

    DynaMight Network Guru Member

    All webpages crawl (even the router page) after Bittorrent has been running for 6-10hours, I've tried two Bittorrent clients, Closing down Bittorrent doesnt speed it up either, only a reboot of the router (then only for a few hours). Happened on 24-10 but not on v22 and v23 beta 1

    It doesnt seem to effect the Bittorrent speeds either, Just the web browsing.

    Any ideas?

    I love the look of Beta 2 and would like to keep it.

    It's a WRT54G 3.1 router btw, Happens on machines connected by LAN and Wireless.
  9. hotrat

    hotrat Network Guru Member

    Client Bridge mode NOT working when using WPA on a GS v1.1
  10. JawS

    JawS Network Guru Member

  11. habskilla

    habskilla Network Guru Member

    Increase your available ports to 4096
    Enable QOS and put in 85% of your max upload speed and 100% of your download speed.

    give that a try
  12. knight14th

    knight14th Network Guru Member

    If you put 85% as maximum speed this will slow down your internet speed to 85%. Also while transfering "normal" packages. Keep this in mind.
  13. robmack

    robmack Network Guru Member

    Upgrade and Backup tabs disabled

    Just upgraded a WRT54GSv2 box. Is it a bug or by design that the Firmware Upgrade and Backup tabs under Administration are disabled? Seems I'm going to have problems upgrading in the future if I can't enable them.
  14. jon9314

    jon9314 Network Guru Member

    i have a wrt54g 2.0 and am having the same thing happen it also slows pop3 and smtp
  15. DynaMight

    DynaMight Network Guru Member

    Well, I downgraded to beta1 12/10 and it did it on that too, So this told me it must be a funky setting, I'm usually lazy and dont do a factory reset when upgrading. So I reloaded 27/10 but choose to reset to firmware defaults and I havent had a problem since!
  16. hotrat

    hotrat Network Guru Member

    u relise that by being lazy u are probably gonna brick your router at some point, this being beta firmware and all.. u deffinately shouldn't be complaining about things not working if u can't take the time to upgrage it properly.
  17. 4Access

    4Access Network Guru Member

    Re: Upgrade and Backup tabs disabled

    They are available via HTTP. They were disabled on purpose when using HTTPS starting with the 10.10.2005 build due to some kind of problem with those features over a HTTPS connection. (Although I'm not sure what the problem was or if disabling them is a temporary fix until the issue can be resolved... I hope so. Any input BrainSlayer?)
  18. robmack

    robmack Network Guru Member

    Disabled tabs

    Thanks for the answer.

    Maybe a more intuitive option would be to remove the tabs under HTTPS or replace the pages with instructions like "Available under HTTP access only".
  19. HansGruber

    HansGruber Network Guru Member

    I'm using DNSmasq for my DHCP server, which all seems fine, however when the lease expires my connection drops. For example as it's renews the lease I will lose connection from an IRC server and it has to reconnect. I never had this problem using the regular DHCP server (although it used to crash regularly).

    Is there a way fixing this, or just a drawback of using dnsmasq for DHCP?
  20. lore

    lore Network Guru Member

    Another thing that might be dnsmasq/DHCP related:

    I have a port forward set for my ReplayTV (port 54321). This allows it to get shows from Poopli. When I rebooted my router, the router did not know that the ReplayTV already had a lease. Therefore, it would not let the port forward happen even though it was set up correctly. I had to have the ReplayTV request the static IP via DHCP one more time before the port forwarding would work.

    As soon as the ReplayTV renewed the IP lease, the port forwarding worked immediately and Poopli users were able to contact my unit.

    Any thoughts on this?
  21. knight14th

    knight14th Network Guru Member

    Hm, maybe you try to setup some static leases. I've no connection drops with static leases.
  22. lore

    lore Network Guru Member

    The replaytv is on a static lease - that's the only way I can set up a port forward.
  23. 4Access

    4Access Network Guru Member

    Hmm that's strange. Unless something was changed with the recent iptables tweaks port forwarding rules should always be in effect regardless of whether there is a PC using the IP address the port forwarding is configured for... (For example what about port forwarding rules that point to computers with Static IP addresses that DHCP knows nothing about??)
  24. lore

    lore Network Guru Member

    What's what I would think too - yet it wouldn't work after a reboot until I renewed the lease on the replay. I'm hoping it's just a fluke, but who knows.
  25. 4Access

    4Access Network Guru Member


    Friday I picked up a new WRT54G v4 for testing purposes and yesterday spent over an hour trying to get Client Bridge Mode working with WPA.... but never succeeded. :(

    Today I downloaded Tofu's v7 firmware and in less than 10 minutes had WET mode working with WPA. (Which is equivalent to Client Bridge Mode.)

    Did you say you've been able to get client bridge mode working on your test systems? If so, do you have any tips? (I reset to defaults by holding reset button for 30 sec more than once during my tests.) Maybe you could take a look at Tofu/Thibor code if there are known problems you're dealing with...?

    Thanks for all your hard work.
  26. barthezz

    barthezz Guest

    i have big trouble with wlan here... wlan only works if wep ist activated... when wpa ist on the clients cant find the router... wpa2 is not testet... but even if encrytion is completly off (no wep or wpa or etc) then the wlan is off too... seems that there is something broken

    P.S. My router is an WRT54GS v2.1
  27. hotrat

    hotrat Network Guru Member

    i deffinately can confirm this on my GS v1.1's aswell running Thibor hyperwrt biuld in WET mode (client bridge) WPA works everytime, am running V23beta2 27.10 on my GS thats an AP
  28. robmack

    robmack Network Guru Member

    ntpd not operational

    Have configured ntp but it's not operational either on a reboot nor if I try and get it to run manually. Can't see that the HTTP configureation system creates an ntpd.conf file anywhere with my ntp server IP. Manually creating a /tmp/ntpd.conf and trying to get ntpd to work (ntpd -c /tmp/ntpd.conf) also fails.

    When this works, will the router be able to deliver time to downstream ntp clients?
  29. 4Access

    4Access Network Guru Member

    I believe ntp settings are only saved as nvram variables. After configuring try the following command to confirm:

    nvram show | grep ntp
  30. jdelange22

    jdelange22 Network Guru Member

    Reset to Firmware Defaults after firmware upgrade still results into an infinite reset-loop. I'm using a WRT-54G V2.1 and the mini-version of 10-27. I have set all defaults and erased NVRAM before upgrading the firmware but the router still hangs. I have to unplug power after the upgrade to get the router back to functioning. Please fix this one...
  31. robmack

    robmack Network Guru Member

    ntp config in nvram

    True enough...ntp settings are stored in nvram and they are correct for my router. However, there is no ntpd server running nor any apparent cron job to kick off the ntpclient. So how is time synchronization done (is it done at all)?

    - Robert
  32. robmack

    robmack Network Guru Member

    udhcpd crashes once per day

    I've been having this problem for some time and has dogged me through all the v23beta releases since upgrading after running v22stable for some time.

    udhcpd starts on a system reboot but crashes about 24 hours later. I can restart manually but have to assign a manual address on the wireless card to get into the machine to perform the repair.

    Is this crashing a residue of my upgrade procedure? For example, I have not done a hard reset on the machine between firmware upgrades, as others have done. Or an "nvram erase".

    Thanks for any insights.

    - Robert
  33. itsmeohmy

    itsmeohmy Network Guru Member

    The flash is done. But i have some major problems.

    1. When i press i button that saves anything (in the web interface) i will get disconnected and i cant connect agin. Well, sometimes i can but only if i restart the network card. But it worked when i was connected with a wired connection.

    2. After, lets say, 5 to 40 minutes i lose my internet connection. Just gone. I can still access the routers web interface. The only solution seems to be a restart of the router... since nothing else i tried works.

    Hope we can solve this because if i dont count these things the firmware seems nice :thumb: .

    Edit: Wrong topic :eek: ..... i flashed 1.11.2005.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice