New V4 -Tofu9-Bricked- Tofu10 - Save Broken

Discussion in 'HyperWRT Firmware' started by pulliam, Nov 30, 2005.

  1. pulliam

    pulliam Network Guru Member

    Ok -
    The subject says it all in as few words as possible, and here it is in more detail.

    I bought a V4 Tonight (11/29) and the reciept is still warm from CompUSA.

    I upgraded to Tofu9

    Couldn't get WDS-AP to work properly with my network. Came to the forum to see that Tofu 10 had been released since I last checked the boards. I saw that Tofu10 had a Site Survey and other goodies.

    I downloaded Tofu10, and promptly bricked the router during the upgrade. (How you might ask - by having an errant 'repair' connection command in windows that switched me to my alternate config during the update - Silly me)

    I got the Fast Power blink. Tried the Linksys TFTP upgrade Firmware exe. It said succeded (Twice) but the fast blink never went away (at least not during my patience time-out).

    I powercycled and confirmed that the router was live with ping at and proceeded to try and se the windowsXP TFTP command to put Tofu 10 on the box.

    Issued commands..... waited... waited...rebooted to lights of death. (Fast power blink and all 4 port lights on)

    Disassembled router
    Shorted pins 15/16 - No Joy

    Earthed pin 16 to the Antenna. - Success!!!!

    Flashed with linksys TFTP (Left the room so I wouldn't be impatient)

    Upgraded to Tofu 10 Successfully. (again I walked away from the router)

    Now here I am - Brand New Router, that has been thoroughly violated, with a brand new distribution on it. (Remember, this router has never been used usccessfully though my wireless card did see it in a site survey)

    My firewall wireless router is running a Rupan release from July or so, and now I want to setup my new Tofu10 Router as part of a WDS cloud, with AP functionality for my test bench in the garage.

    Problem Statement (Finally):
    The Tofu10 Router Inconsistently, but repeatably forgets things.
    I can't get an SSID to stay put. I can't get the wireless security to stay remembered. It does remember the channel choice I input however. It also cannot find a network when in WDS-AP mode or Client mode in network scan.

    Question: Did I 'Break' something when i was clearing the flash that now it isn't holding al lthe variables in nvram correctly?

    Second Question: Is this an appropriate network setup?

    Internet>Modem>Rupan>Wireless> Tofu10)> (LAN Tofu10)>Wired Client

    Or should I be doing something different?

    Thanks for the time to read this an any advice in advance.

  2. sded

    sded Network Guru Member

    Did you try erasing the nvram and resetting the parameters?

    Go to the "run" line on T10 (or use telnet if you prefer) and enter "erase nvram; reboot". Don't use a saved configuration, but reenter all the stuff by hand.
  3. pharma

    pharma Network Guru Member

    You might want to see this thread regarding flashing a V4 router:

    Rereading your post, would agree with Sded's post and issue the erase nvram; reboot command. After that, set parameters manually instead of using a saved configuration.

  4. pulliam

    pulliam Network Guru Member

    Next Idea?

    I had been entering the settings by hand all along, but the nvram erase sounded like a good idea.

    So I executed 'nvram erase' followed by 'reboot'

    I then logged into the tofu10 router.

    Clicked Wireless Basic. Changed it to WDS-AP. Changed SSID. Changed Channel. Saved.

    Clicked Wireless Secutrity. Changed to WEP. Changed keytype to 128. Entered Key. Saved

    Clicked back to Wireless Basic. SSID had been changed back to Linksys.

    Changed SSID.

    Clicked Save.

    Switched to Admin, and rebooted.

    Logged into router - clicked Wireless settings - SSID was back to 'linksys' Clicked wireless security, encryption was set back to disabled.

    This was all hand loading and abosultly no other items were changed during this testing.

    I also duplicated this behavior with Type set to just AP.

    Also - Thanks for the link - Looks like the Site Survey may be partially broken.

    SO..... Suggestions as to what I should try next?

    Thanks again
  5. sded

    sded Network Guru Member

    Are you using IE as your browser? Some others have trouble with the router JavaScript. Firefox seems to work well. Suggest the nvram; erase followed by a reflash of tofu10. If it still doesn't work (and you don't have a strong firewall or something stopping communication) may be a router problem?
  6. danielhaden

    danielhaden Network Guru Member

    Oh, yes! That's an easy one! Since you have a V4 router, you can load Thibor's GS firmware, get speedbooster, get a longer range, and have everything work. I'm using 111509. See the sticky on the forums if you want to try different versions (download links provided).

    EDIT: I have seen the problem you described in that Internet Explorer did not refresh the page and merely served you an old page. Could this be the trouble? Erase IE's cache to find out.
  7. pharma

    pharma Network Guru Member


    That does not solve his problem, and there is no reason for people with V4 router's to use Thibor's GS firmware. I tried Thibor's GS version on my V4 router and saw no significant difference, so switched back. I'm currently using Tofu10 on a V4 without any problems, so obviously the problem he is having something else.


    Still sounds like you have problems with nvram variables not being cleared. There was a sticky in this forum about clearing nvram, but do not see it.
  8. pulliam

    pulliam Network Guru Member


    These problems happened using Firefox (And IE 6 once), from a laptop plugged directly into the router. As for the GS firmware, I'll pass.

    I'll think upon clearing the nvram and reflashing tofu9 or tofu 10.

    I'm still wondering on my original question though.

    Has anyone seen behavior like this, that was attributable to mucking up the router during the unbricking process?

  9. pharma

    pharma Network Guru Member

    I was just going to mention try the HyperWRT forum. You will find some posts in the Basic and Advanced Help forums regarding getting WDS to work with the firmware.

    In particular the following might help:

    Just one comment on using TFTP ... after it states it was successful leave it alone. The router ping should be replaced with "Request timed out" but should eventually return to your router ping once it reboots itself. That is when you know the firmware has been successfully upgraded. Looks like below ...

    Reply from bytes=32 time=207ms TTL=128
    Reply from bytes=32 time<1ms TTL=128
    Reply from bytes=32 time<1ms TTL=128
    Reply from bytes=32 time=9ms TTL=128
    Reply from bytes=32 time<1ms TTL=128
    Reply from bytes=32 time<1ms TTL=128
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Reply from bytes=32 time=2ms TTL=64
    Reply from bytes=32 time<1ms TTL=64
    Reply from bytes=32 time<1ms TTL=64
    Reply from bytes=32 time<1ms TTL=64

    Hope this helps,
  10. pulliam

    pulliam Network Guru Member

    I'm sorry to sound abrupt, but my problem isn't with getting WDS to work. My problem is getting variables to store themselves in nvram. (The 'Save broken' part of the thread title, and the 'Did I break something' part of my primary question)
    As for the tftp suggestions, there are really not relevant. As described above, I obviously learned my lesson on impatience.

    Further testing

    From the web interface I issued the "clear nvram, restore factory defaults' command.

    From the command line interface I issued the following commands...

    nvram show | grep ssid
    with a response that wl_ssid and wl0_ssid both =linksys

    I then entered
    nvram set wl0_ssid=test
    nvram set wl_ssid=test
    nvram show | grep ssid

    The first two commands apeared successful.
    The third command was successful in that I got a response..... that both wl_ssid and wl0_ssid =linksys

    It can't get any simpler than that.... This router appears to not be capable of changing those nvram variables.

    Suggestions? (Could this in any way be firmware=tofu10 related? Could this in any way be related to my unbricking methods? could this be indicitive of a bad router that I should return for a refund and get a new box?)


  11. virgil

    virgil Network Guru Member

    I suggest you try to reflash it back to the LinkSys official firmware and check if NVRAM is OK...
  12. pharma

    pharma Network Guru Member

    Virgil has a good idea ... if that doesn't work return the router. It won't be the first time someone bought a "dud".

    Good luck!
  13. pulliam

    pulliam Network Guru Member

    Tested with 4.20.7 direct from linksys. Router would not remember a changed ssid or a WEP selection.

    SSID change tested in both firefox and IE with a close and restart of each browser after saving changes.

    So it's official I guess. It's broken (but strangely working in most ways.)

    So now the moral dillema. Did I break it (and hence returning it for a new one is wrong) or was it broken when I got it.

    Has anyone seen behavior like this previously, and if so, what was the state of the router (New from box, flashed, flashed third party, or resurrected brick)?

  14. sded

    sded Network Guru Member

    Check with the ethics manager at Linksys

    who came out with the v5 without informing the public that it was a new and untested firmware suite. But all you did was use the flash capability provided by Linksys, even flashed it back to OEM, and it still doesn't work. You fixed the nvram and rom back to factory; should work as specified unless the hardware has a problem. You shouldn't be able to break hardware by flashing firmware unless there is an inherent defect. And Linksys can refurb and resell it. If you still have an ethical dilemma, let us know, and we can bid on it. :)
  15. pulliam

    pulliam Network Guru Member

    Please read my original post again. I did muck around with shorting the flash in two different methods in addition to reflashing to OEM firmware.

    I also just noticed that there was a warranty void sticker on the case so I'm assuming I can't take it back anyhow now.

    You want to buy a partially functional router?

    Have broken WRT's sold on ebay for more than $5?
  16. pharma

    pharma Network Guru Member

    Since you have to keep it, I'd probably keep trying debricking techniques ... something might give and you might end up with a router that "remembers"! :thumb:

    Not sure it you tried loading DD-WRT mini generic first ... but might be worth a try, then load what you eventually want to use.

  17. gaster

    gaster Network Guru Member

    I agree with the dd-wrt comment. Even if the flash chip and part of the nvram area is messed up it's remotely possible that dd-wrt will use another part of the ram and leave the bad area alone, meaning a working router
    I know it's a long shot, but you might as well try.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice