New Victek releases

Discussion in 'Tomato Firmware' started by mpegmaster, Jul 2, 2009.

  1. Deception``

    Deception`` Networkin' Nut Member


    I recently upgraded to an N16 from a WRT54GL (with HyperWRT) that I used for over 6 years. Currently I am running Victeck's most recent firmware after first trying TomatoUSB.

    I've been running this router for over a month now, and for the most part I am pleasantly surprised. However, I noticed that speeds bounce up and down while downloading torrents on Transmission. To the best of my knowledge, this did not happen at all on my 54GL. I have toyed around with many of my advanced settings; my download speeds are fine while downloading through Chrome / Firefox; my speeds are good through Speakeasy Speedtest.

    I don't know if the speed dips (might be 600K for 5 secs...dip to 150K....back up to 650K) are common on this router, of if I should try another blend of firmware. For reference, the same thing happened on the TomatoUSB mod.

    Please advise.


  2. rubik

    rubik Networkin' Nut Member


    I recently installed this firmware on a WRT54G (V2, so only 4MB flash) and most things work well but I do have a few issues that I'm hoping someone can assist with.

    The firmware that I installed is "tomato-K26-1.28.9006MIPSR1_RAF-VPN-NOCAT" (I want to set up the router as a VPN server for me to remote into when not at home, etc.) Is this flash OK for my router or should I grab the K24/ND one? I'll have to check whether there is a VPN version of it, I forget...

    First off, there's nothing I can do to make the router remember the timezone that I set through the Basic->Time options (GMT-8, North America NTP servers). I make sure to save it and it takes effect almost immediately but every time the router reboots, it loses the timezone and it defaults to "Dec 31 1969" or whatever. Is there a way to make this "stick"? Here are nvram settings:

    root@tomater:/tmp/home/root# nvram show |grep ntp
    root@tomater:/tmp/home/root# nvram show |grep tz
    I'm also working on setting up the openvpn server but having a little trouble there... I can get it to work if I type all the commands manually but not through the GUI. The 'tun' kernel module doesn't seem to auto-load? If I type these commands (or save them under Scripts->Init, I can get it to load:

    /sbin/modprobe /lib/modules/
    /usr/sbin/openvpn --mktun --dev tun21
    brctl addif br0 tun21
    ifconfig tun21 promisc up
    However, I still see log messages about 'tun21' not being up (but it is, 'ifconfig' shows it up).

    Am I missing something in regards to the VPN GUI settings? I'm entering all my info including certificates/keys, but I can't seem to start the server through there at all (router mostly freezes on a 'Start' click and I have to reboot).

    Thanks for any help in advance!
  3. roadkill

    roadkill Super Moderator Staff Member Member

    Rubik - I suggest you try with a firmware image with only VPN (tomato-K26-1.28.9006MIPSR1_RAF-VPN) to try and isolate the issue
    don't forget to erase nvram after upgrade and I advise configuring the router manually afterwards rather than restoring a saved configuration file.
  4. rubik

    rubik Networkin' Nut Member

  5. roadkill

    roadkill Super Moderator Staff Member Member

    this one has usb support you don't need it on wrt54gl...
  6. rubik

    rubik Networkin' Nut Member

  7. roadkill

    roadkill Super Moderator Staff Member Member

    kernel 2.4 has some advantages when it comes to the WRT54GL
    but I hope Victek will updates the repository soon :)
  8. eahm

    eahm LI Guru Member

    Victek, just asking as many others: will 5Ghz ever be available for the E4200? I like the router and I love tomato, I don't personally use 5Ghz but I have to test it for work. If there are no plans to bring it to that router I'll have to go back to my next favorite router, the E3000.

  9. Beaker1024

    Beaker1024 Networkin' Nut Member

    I have been using a Linksys WRT54GS v2.1 for about 6yrs and I can't give it up because it's rock solid (never ever locks up / needs rebooting). Years ago I start using the Tomato firmware and was comfortable with it (what version / didn't have so many types, etc...). Can someone please give me a hand with getting used to the offspring firmwares since original tomato has gone dormit? My main concern is to get the most speed out of the router while keep the same or more security. I do have the wireless on but it's not used for any of my primary internet devices (all PCs/Bluray/etc are CAT5e hardwired). I currently have 6Mb DSL service if that matters for settings/version but I only clock in at 5.2Mbps (650kps) using Tomato 1.28 although there is a slight chance of switching to faster cable modem. I do use video Skype and will be using video streaming more in the future.

    From what I can figure out the TomatoRAF firmware is what I need (with speed-boost and many more add-ins to the original Tomato). Thank you for your assistance and I'm sorry for the newbie question (what version). Oh and would it be possible to see a performance boost by flashing a newer firmware (than Tomato 1.28) or is it getting close to the point of picking out a new router?
  10. ntest7

    ntest7 Network Guru Member


    Your WRT54GSv2.1 should be good for *at least* 20M+ wired throughput with stock tomato 1.28, so the 5.2 you're measuring on your DSL is probably accurate.

    If you want to try the Victek's RAF (which is great, BTW), start with the K2.4.20 MIPSR1 1.28.121006. Victek claims 80M throughput for that version, but the best I've been able to get is high 40's (on 100M business class fiber service). Still, not too bad.

    It seems to me that the K2.6 versions run a little slower on the WRT54G* compared to the K2.4 versions, but the newer features are only found with the newer 2.6 kernel.

    Anyway, feel free to fiddle around with any of the Victek releases marked for MIPSR1 WRT54GL routers. They should all work, and give you different feature sets to experiment with.
  11. Toastman

    Toastman Super Moderator Staff Member Member

    The OP has a 6Mbps service but actually gets 5.2Mbps from the ISP. That is unlikely to change whatever version of Tomato he runs. It's pretty typical of ISP's I'm afraid.
  12. danielhaden

    danielhaden Network Guru Member

    I just loaded the Tomato by Victek 121006 onto a Linksys WRT54G v3 and have to report 24 megabit despite WPA + TKIP in use. Its steady with no wireless drop. Its running frame burst and 84mw. I haven't tested the bidirectional throughput; however, the unidirectional throughput is the highest that I've ever tested for this hardware (while security is in use). The testing was done over several hours and there was no wireless dropout. The lagtime is at or less than 1ms. I haven't tested any use of the WAN port or advanced routing features, and that's because I'm using this hardware along with a MER DSL (cannot bridge) modem that must do its own routing.
  13. neothemachine

    neothemachine Networkin' Nut Member

    I noticed something really strange... Before I continue, it's RAF1.28.9006 MIPSR1_RAF K26 Std-NOCAT, a WRT54G v2.0 and I did a full nvram clean up. I have no idea if it was like that before but probably not.

    The thing is I have two PCs connected with wires to the router and from PC1 I can see network packets from PC2 going out to the Internet, not the other direction. It's not multicast, just regular TCP/UDP packets. And this is possible from both PCs. So from PC2 I can see outgoing packets from PC1. I should note that this is not possible when using a wireless connection.

    Any idea on this?

    Edit: Just flashed 1.28.121006, it's happening there too.
    Edit2: I flashed latest OpenWRT (10.03.1-rc5/brcm-2.4), although it's slow as hell it doesn't happen there.
  14. danielhaden

    danielhaden Network Guru Member

    It seems to be your loopback settings. Either that or the inbuilt switch is acting as a simple hub.

    You have a couple of options:
    Use only 1 Lan port and plug everything else into one of those handy Asus switches, or
    Have something else do the routing, or
    Install a firmware that has a broken loopback, or
    Do manual configuration using linux compatible script, and/or
    Change your loopback settings.

    Well, at least one of those options should clear up the problem. It would be interesting to know which you choose.
  15. neothemachine

    neothemachine Networkin' Nut Member

    Hm, I changed the NAT loopback setting from All to Forwarded Only and to Disabled but no difference at all. I don't think it's a hardware problem because it works with OpenWRT, or are you saying OpenWRT has a broken loopback to fix a specific problem for WRT54G's? By the way, how does a broken loopback look like?
  16. danielhaden

    danielhaden Network Guru Member

    Dnsmasq. . . floorboarded
    The Dnsmasq feature operates independently of most other features.
    This is a great technology!
    Here's what I did to it (The custom settings):

    The "cache-size" at maximum may be excessive, because it will certainly use a lot of ram. However, the default 150 is too small.
    So, its probably okay to go for max if you've got a GS; however, you might want to choose a more moderate setting for G and GL. I've tried 5192 on that hardware and initial testing has had good (nearly identical) results. I'm still not sure if the cache should be that big. Use your own judgment.

    The "domain-needed" is an ineffective typo protection option.
    The "stop-dns-rebind" is a protection against DNS spoofing (ingress)
    The "bogus-priv" is a protection against lan PC misbehavior (egress)

    Steve Gibson's DNS Benchmark test showed the Victek router had extremely high performance even when requests went to OpenDNS, a popular spoofing protection service. Although OpenDNS is only half as fast as Speakeasy DFW, the DnsmasQ cache successfully "covered up" the speed difference, since any DNS option is going to be speed cached, and since my cache is now so very large.

    Results: Better protection for clients of the network (family members who just click on everything). Large quarter second delay for un-cached lookups (normal for OpenDNS). Fiercely fast speed for up to 10,000 cached lookups (max setting of Dnsmasq may or may not be appropriate). CPU load went lower, not higher. Highest speed was achieved with two, not three, DNS server entries.
  17. danielhaden

    danielhaden Network Guru Member

    Its not a hardware related problem, but I suggested utilizing a switch as a test to find out if the problem is MAC level or IP level.

    A broken loopback? It looks just like any new edition of DD-WRT.
    SVN15760 and higher. . .
    Save the following commands to the Firewall Script on the Administration->Commands page to fix loopback.
    insmod ipt_mark
    insmod xt_mark
    iptables -t mangle -A PREROUTING -i ! `get_wanface` -d `nvram get wan_ipaddr` -j MARK --set-mark 0xd001
    iptables -t nat -A POSTROUTING -m mark --mark 0xd001 -j MASQUERADE

    The script that I just posted, will add loopback, back into DD-WRT (according to their tech support documents).
    The EKO builds are available in VINT to support older Linksys hardware (without incessant wireless drop).
    Then the question becomes: Does DD-WRT, with the loopback repaired, then reproduce the problem?
  18. neothemachine

    neothemachine Networkin' Nut Member

    Ok I flashed SVN17084, and did a test before and after saving the commands & rebooting. No difference at all, the traffic is still duplicated. Don't know if it helps, but here's iptables:
    root@DD-WRT:~# iptables -L -t nat -v
    Chain PREROUTING (policy ACCEPT 440 packets, 46874 bytes)
    pkts bytes target    prot opt in    out    source              destination
        0    0 DNAT      icmp --  any    any    anywhere   to:
      187 21774 TRIGGER    0    --  any    any    anywhere   TRIGGER type:dnat match:0 relate:0
    Chain POSTROUTING (policy ACCEPT 2 packets, 399 bytes)
    pkts bytes target    prot opt in    out    source              destination
      144  8449 SNAT      0    --  any    vlan1  anywhere            anywhere            to:83.221.70.xx
        0    0 RETURN    0    --  any    br0    anywhere            anywhere            PKTTYPE = broadcast
        0    0 MASQUERADE  0    --  any    any    anywhere            anywhere            MARK match 0xd001
    Chain OUTPUT (policy ACCEPT 38 packets, 2723 bytes)
    pkts bytes target    prot opt in    out    source              destination
    Edit: I flashed dd-wrt.v24-17084_VINT_std-nokaid_nohotspot_nostor.bin
  19. danielhaden

    danielhaden Network Guru Member

    Okay, howabout HyperWRT version Thibor 15C (ancestor of Tomato)? Almost all of the behavior on that is "by design"
  20. danielhaden

    danielhaden Network Guru Member


    Well, that seemed to work a lot better on routers that were very very busy, since it gave the router less work to do than the higher figures I tried earlier.
  21. eahm

    eahm LI Guru Member

    I tested Toastman build today and I noticed a WiFi decrease on my wife's laptop so I ran few test:
    E4200 + 100 feet + 1 wall + 1 wood door

    -Tomato RAF
    Open WiFi (2.4Ghz 20Mhz): 23-25Mbps
    WPA2 Personal AES WiFi (2.4Ghz 20Mhz): 23-25Mbps

    -Original Firmware
    Open WiFi (2.4Ghz 20Mhz): 12-13Mbps
    WPA2 Personal AES WiFi (2.4Ghz 20Mhz): 12-13Mbps

    -Toastman build
    Open WiFi (2.4Ghz 20Mhz): 5-7Mbps
    WPA2 Personal AES WiFi (2.4Ghz 20Mhz): 5-7Mbps

    Still using RAF. Thanks Victek, great mod.
  22. danielhaden

    danielhaden Network Guru Member

    A laptop with the Atheros wifi chip, can generally run the windows task manager to 3000,000 byes aka 24 megabit or slightly higher. However, the Realtek and Ralink, generally top out at about 2750,000 bytes, aka 22 megabit. Likewise, wireless drop issues can come from the client. I've upgraded my MSI Wind U100 to a replacement Atheros card for Acer's little 9" netbook. Wow, the quality improvement was amazing, especially the absence of wireless drop.

    I did test Victek's tomato at 25 megabit with open and with WPA2.

    Power output range for max throughput is between 72mw to 96mw, with the center point being 84mw. My throughput did decrease a bit when testing 126mw.
  23. eahm

    eahm LI Guru Member

    Apologize, I wasn't precise in my description. The test are internet test, performed with
    I did not test the WLAN but the internet speed that my wife's laptop was reaching at 100 feet from the router.
    My internet connection is 27/6.

    And yes, I got your message but I performed too many test with the same firmware, these numbers are the average of each series of test.
  24. danielhaden

    danielhaden Network Guru Member

    With the combined load of both routing and wifi, plus the distance at 100 ft indoors, I'd have to say that you've got very, very fine performance.
    Your throughput is amazing.
    At this point, any improvement comes from decreasing lag.
    Given the distance of 100 ft indoors, its possible, although somewhat unlikely, to get that throughput up to 24 megabit (download) if you install a more significant antenna so that the router can "hear" the laptop a bit better, and thus decreased lag.

    Also on the topic of decreasing lag:
    Those are currently the settings that I'm using for dnsmasq, using 2, not 3 servers--it was far faster with just 2
    see also:
    Gibson Research DNS benchmark.
    You can discover which 2 of the OpenDNS (phishing protection) is fastest for your area, and as the protection is great but the service isn't fast, they do benefit from the inbuilt Tomato Dnsmasq cache.

    I'm still experimenting to find the optional cache size.
    We know its somewhere between 150 to 10000 because those are the minimum and maximum, or in other words, two different ways to go slower than optimal. I believe that 10000 caused my router to be overly busy, but my internet connection is pitiful, so I couldn't tell for sure.

    Since your internet is so very fast, I think that you'd have great luck in determining if a figure higher or lower than 2048 is appropriate for DNS cache size.

    I also use Adblock Plus and Ghostery and disabling "3rd party cookies" to turn Firefox into an "internet washing machine" plus setting its disk cache to zero (also disabled browser.cache.disk), and switching on pipelining. The amount of junk that's cut out is amazing and the ram-only caching really can go faster, especially with the 4 simultaneous connections (the default for pipelining, if you turn it on). Since Ghostery takes a bit of tweaking for performance and to keep its protection up to full strength, I also add "Beef TACO" and "Better Privacy" to help it out.
    In effect, you don't really have to wait on both the hard drive and advertisements (especially not both at once). :) No need waiting on overburdened advertisement servers. Preventing marketeers from making your computer so busy, can decrease lag.
  25. eahm

    eahm LI Guru Member

    My Boxee Box is at 32 feet from the router, I only use 2.4Ghz WiFi and I can stream 1080p Blu-rays without problems. That's the main expectation I want for now at home.

    I use the Google Public DNS as static DNS (,, namebench and DNSBench tell me that Cox is the fastest DNS server from here. OpenDNS only for my customers. I also use this script as "anti ads", nothing else.
  26. mikeownage

    mikeownage Networkin' Nut Member

    Victek, Will you ever increase the functionality of the captive portal. In it's current state using it's just for publicity which has it's applications but if you could add in the ability to require logins and maybe even only have it apply to the wireless interface that would be a great security feature on top WPA2.
    eahm likes this.
  27. Toastman

    Toastman Super Moderator Staff Member Member

    eahm, your comment on the RAF firmware v. Toastman was interesting. I downloaded RAF 1.28.9006MIPSR2_RAF-VPN-NOCAT.trx and compared the wireless to my build 1.28.7481. Tested on two routers, RT-N16 and E3000 at two power settings - 17 and 60.

    My findings were that the wireless signal strength was exactly the same whichever firmware was in use. That is what I expected I would find, since both use exactly the same wireless driver

    I didn't try to do a proper test of throughput, I just streamed 1080p video to my [G] laptop for a while and noticed nothing unusual. I just downloaded the same movie from my server and reached top speed of 17Mbps and the average about 16Mbps (stats from server).

    Both firmwares tested from the same laptop with WLAN on intenet connection, using were the same on my "16mbps" ADSL connection, at around 15.8 mbps - which is normal.

    Why you got only 5-7 mbps on your wireless connection I cannot understand.

    I can't test on an E4200, but I would be very surprised to find it was any different on that router, though stranger things have happened :)

    I also tested the txpower setting again, and the maximum output was reached at a setting of 60, as usual.

    What Toastman MIPSR2 version did you try? Here, they are all exactly the same.


    With the latest laptops/netbooks now becoming popular as people bin their old ones, I am also finding new disconnection problems. They are invariably due to the power saving functions on their wireless being enabled by default. When they are disabled, things are usually OK. There was one netbook this week that had no settings that you could change, so I tried it with a USB adapter and that cured it also.
  28. eahm

    eahm LI Guru Member

    I used this one tomato-E4200USB-NVRAM60K-1.28.7481MIPSR2-Toastman- RT-VPN-NOCAT.bin, I really enjoy your mods and I will keep testing.
    The laptop and the WiFi drivers are fine.
  29. myersw

    myersw Network Guru Member

    Question about e4200 dual band support. When I was on Victek's site I see the following description. This seems to indicate that Victek does support dual band since it clearly states no on the E2000. Anyone know for sure. I guess I could load on my E4200 and try but wondering for someone has any insite? --bill

    Linksys E4200 R2 Yes/Si No All/Todas(simultaneous dual-band support)
    Linksys E3000 R2 Yes/Si No All/Todas(simultaneous dual-band support)
    Linksys E2000 R2 Yes/Si No All/Todas(no simultaneous dual-band support)
  30. eahm

    eahm LI Guru Member

    myersw, the E2000 has dual band support, just not simultaneous. You can choose to stick with 2.4Ghz or 5Ghz.
    The other problem with the description on victek's website is that these features are from Cisco and not from his firmware. The E4200 has simultaneous dual band support with the original firmware but it doesn't even have 5Ghz yet with Tomato RAF.
  31. danielhaden

    danielhaden Network Guru Member

    With Rosewill RNX-GX4 (NetCore NW618) running Victek Tomato RAF 1.28.8515 ND
    The diversity chip cannot be controlled. Settings are randomized for A or B and don't survive a reboot.

    The Rosewill (newegg) uses Broadcom BCM5354KFBG 240MHz
    Similar hardware includes: Buffalo WHR-G125, Asus WL-520gu, D-Link DIR-320
    Is this diversity chip errata common to all or just to the Rosewill/Netcore circuit board?
    Is it possible to run 1.28.121006 on this hardware or not? I couldn't find the answer to that.
  32. danielhaden

    danielhaden Network Guru Member

    That router shows Corerev = 13 and Broadcom 5/0x048e/1/0x35/0x750
    So, what versions of Victek and Toastman will it run?
    There are a few irascible wifi issues and so I'd like to try a few different versions without bricking the router.
  33. myersw

    myersw Network Guru Member

    eahm, thanks for the clarifcation. I have to admit I didn't think what I was seeing was correct but was hoping. I used Victek's mods on my Asus RT-N16 and loved it. However I had to move on to a different router and chose the e4200. I was hoping that he was now supporting 5Ghz as well. I currently do not "need" 5Ghz but would be nice. I may load it anyway as I do like the additional visibility I get with the Tomato mods.
    When I was looking at one of the Tomato WiKi's they were saying that Toastman has a 5Ghz beta but I do not see any reference to this in any forums. So I am guessing that is not correct either. ;-(
  34. eahm

    eahm LI Guru Member

    meyers, I had the RT-N16 and the E3000 and now I have an E4200 as well. I actually changed the wikipedia page of toastman build to "beta" because I've tested his latest build and it wasn't supporting the 5Ghz so I thought that the the one I haven't tested yet (MULTISSID beta was the one with the 5Ghz support.
    I don't use 5Ghz but I'd like to test it as well, I'll wait for a victek release with that driver.
  35. myersw

    myersw Network Guru Member

    eahm, thanks for the additional info. I want the additional function of Tomato as far as visibility, things like bandwidth usage, wireless connection info, etc Also like being able to telnet to the router to look at things. The e4200 went to lunch the other day and only thing I could do was reboot as telnet is not available as you know. May give Victek's latest a try or possibly Toastman's multissid. Not sure that means dual band or not though.
  36. Toastman

    Toastman Super Moderator Staff Member Member

    I don't actually know who is updating the wikipedia pages, but there is 5GHz support in RAF, Toastman mod, Shibby mod, Teaman mods (and other common mods based on TomatoUSB too) but just not for the E4200. There is at the moment no working driver in Tomato for 5GHz on the E4200. If the new driver were merged into Tomato, it would also have to support all of the older stuff too - and that would have to be tested. It will be a lot of work. As far as I know, nobody is working on it. Teddy Bear was the guy who did this best, and he's no longer around. If anyone else is actually working on the problem, perhaps they will post here and tell everybody?
  37. eahm

    eahm LI Guru Member

    Toastman, I did add the Captive Portal and the 5Ghz columns. I completely forgot that TomatoUSB and other mods are completely compatible with 5Ghz bands, I was concentrating on the E4200. My bad, correcting right now, I only touch TomatoUSB, RAF and Toastman because I don't test other mods.
  38. danielhaden

    danielhaden Network Guru Member

    Hi Toastman! Is there a solution to get the diversity chip and other wireless errata under control on this hardware:
    Rosewill RNX-GX4 / NetCore NW618 using Broadcom BCM5354KFBG 240MHz similar to Buffalo WHR-G125, Asus WL-520gu, D-Link DIR-320
    And, which Tomato firmwares work for these?
    Only ND?
    K2.4? K2.6?
    Not 1.28.121006? Of course, it would make sense in a Murphey's Law sort of way if it won't run the firmware that I'd really like to use. However, the most important part is getting the wireless antenna diversity errata under control. The problem blocks dish and yagi use, since every power up uses a random port, and it freaks out if you put on 1 antenna or any 2 antennas that are bigger than the common China +6 which are a bit modest.
    I'm just guessing that it requires ND K2.4 MIPSR1.
    Sure, there was plenty of searches and research but I didn't learn much since it all conflicts.
    What all Tomatos can I use on this?

    Edit: Or, if firmware control is impossible, do just I need a tiny soldering iron and a 3.3pF porcelain capacitor?
  39. Toastman

    Toastman Super Moderator Staff Member Member

    Sorry, I have no idea about that. One would assume that the wireless driver really ought to work with it if the hardware is so similar. K2.4 would be my choice but I don't see any reason why it won't run K2.6. Just remember that K2.6 versions are rather larger and slower on the older routers, generally speaking people aren't very happy with their performance, I personally find them rather flakey and unpredictable.

    As far as diversity goes, I think you'll have to live with what is there already, if it doesn't work then try your hardware mods :)
  40. danielhaden

    danielhaden Network Guru Member

    Can you tell me if 1.28.121006 is inappropriate for the Rosewill RNX-GX4?
    I think that is is the case, and thus have not tried it.

    But, its the firmware that makes old routers really really run, so I do like it on my G and GS.

    I'm still just aching for confirmation on if the Rosewill (Corerev =13) absolutely requires "ND" and really some details on what firmware I should be running with it. Guesses are good, as long as they're better than mine. :)

    You're correct on the hardware mods; however, the circuit board antenna output is very much unlike my Linksys's clear cut "Y" out of the little black chip. Rosewill also has stronger filters: And, it has a power reducing voltage divider mistake that appears on Linksys boards, except that Linksys omits those load resistors at the antenna hookups. Anyway, that thing has me bluffed. Can't find the spot to mod it. If it were a Linksys, I'd have relocated the coax to instead of the diversity chip and be done in just five minutes. But, this Rosewill is a mess! No wonder the firmware doesn't control antenna selection reliably.
  41. myersw

    myersw Network Guru Member

    Toastman, thanks for the info and all your hard work especially around QOS and Victek to. To bad they used a different wireless support in the e4200 requiring a different driver. I cannot imagine how you folks take the Linksys code and do your magic. I think I read where Teddy Bear had a serious family problem. Has anyone communicated with him to see how he is doing?
  42. Victek

    Victek Network Guru Member

    To achieve E4200 5Ghz you need to update some other modules, I received some information from Broadcom, working on it.
  43. myersw

    myersw Network Guru Member

    Victek, that is great news. Hopefully you and the rest of the developers will be able to use the info to get 5Ghz working on the e4200. Fingers crossed.
    I like the router but would love it if it had one of your Victek mods. They worked great on my RT-N16.
  44. myersw

    myersw Network Guru Member

    victek, just an update. Just loaded your latest (9006) on the e4200. Looks good so far. Don't "need" the 5Ghz at this time and really was missing the visibility that Tomato gives. Hopefully by the time that I need the 5Ghz support of the e4200 we will have it.
  45. rubik

    rubik Networkin' Nut Member

    Hey All-

    I'm having a rather strange issue with Victek's Tomato RAF Firmware v1.28.8525 _RAF ND VPN on a WRT54G V2.

    I thought for the longest time that my ISP (Verizon) is blocking incoming port 80 connections so I was trying to run a web server on a different port when I found out that the ISP is actually not blocking port 80.

    I have tested this by enabling the router web access on port 80 and accessing it directly from an external connection. Sure enough, the router user/password box came up and I was able to access it.

    However, I cannot seem to be able to forward port 80 to another internal IP through the router port forwarding screen. It completely ignores the forwarding rules and I get connection-timed-out messages from an external connection (with the router web admin disabled).

    If I go back and enable the router web admin via http on port 80, I get the router menus again.

    Any idea why the router refuses to forward port 80 to anything but itself?
  46. myersw

    myersw Network Guru Member

    Rubik, just a fyi. WEB browser traffic is port 80 so ISP really cannot block it and have happy customers. :)
  47. rubik

    rubik Networkin' Nut Member

    Thanks but here in the US (not sure whether you live in a different country), it is quite common for residential ISPs to block incoming port 80 (and 25 and a few others) so that residential customers don't run web servers, mail servers, etc.

    It's even in their terms of service that you agree not to run any kind of server on their network, etc.

    They usually want you to pay for a "business" account (higher speeds and much higher monthly fee) in order to open up those ports.

    Most residential customers don't care because only a very small percentage of us would ever know how/want/need to run servers. ;)
  48. Victek

    Victek Network Guru Member

    Rubik, did you opened the new port in your dsl-router? because your have a dsl device prior to your router, not? or it's simply a modem?. Then try to DMZ the WAN IP of the router in your dsl-router to avoid double NAT.
  49. rubik

    rubik Networkin' Nut Member

    Hey Victek. Thanks for your help.

    I am not using any modem or router in front of the WRT54G because I have FIOS (fiber) connection so I am connecting the WRT54G directly via Cat-5 cable. The WRT54G acquires an IP address from the ISP directly via DHCP; there is nothing in between.

    I did try DMZ to the 192.168.1.x IP of the computer that has Apache running on it but that didn't seem to work.

    I temporarily turned on the logging for rejected traffic and monitored the log but nothing showed up.

    The iptables looked correct as far as I can tell...

    I am at work right now with no way of accessing the home PC but one thing I will try is plugging in the Cat-5 cable directly into my PC (bypassing the WRT54G) and then seeing whether port 80 is accessible externally (it should be).
  50. Edrikk

    Edrikk Network Guru Member

  51. ntest7

    ntest7 Network Guru Member

    Change the Administration - Admin Access - HTTP Port to something other than 80.
    In other words, the router's own web browser is interfering with the forwarding, so move it to a different port.
  52. danielhaden

    danielhaden Network Guru Member

    I'm not having any issues with forwarding port 80 on 1.28.121006 on WRT54G-v2 hardware.
  53. rubik

    rubik Networkin' Nut Member

    Thanks all for the help! It turns out there wasn't anything wrong with the router or the port forwarding.

    It's embarrassing but the problem seemed to actually be that work (where I was doing most of the testing from) is somehow blocking access to my home IP (port 80 for sure but not all ports), so I was never able to reach it and I'm still not able to.

    However, I tried a different connection as well as have my brother test from a 3rd location and port 80 is properly routed through to my internal IP where Apache is running so all is well.

    Thanks again for the help.
  54. MaX PL

    MaX PL Networkin' Nut Member

    for all American users, what is your Transmit Power set at?
  55. myersw

    myersw Network Guru Member

    My Transmit power is 100mw, which is the default for me. Located in SE Michigan, USA. Reaches all over my 1800 square foot home with wet plaster walls. Router is located in basement near ceiling. I use wireless for a desktop, laptop, Nook Color running CM7 Android, and 2 Samsung Fascinates. Have one hardwired desktop as well.
  56. MaX PL

    MaX PL Networkin' Nut Member

    100mw is your default?

    mine is set at 42 by default and although i get great coverage and my full down/up speeds, i often drop signal bars where as i'd never have that problem with other firmware. no changes in the environment here either.
  57. danielhaden

    danielhaden Network Guru Member

    Most generally, this hardware is set at 84mw because that's the maximum prior to hindering throughput and/or causing lag. Its unlikely that a wifi client, such as a laptop, is going to output more "reply" power than 84mw anyway, so higher power at the router is usually pointless.

    Samples with "irritated radio" caused by worn out diversity chip on a real, well used, Linksys or execrable circuit layout of some clones, is set approximately 62mw~63mw in order to avoid wifi drop from either too little or too much.

    Use at wireless B long range settings goes from 126mw and up, and also usually involves setting (or soldering) only 1 antenna jack in use. Such examples are usually employed by the owners of large properties, thereby the FCC maximum isn't exceeded at the border of the property. This class of high power use is called "Premisis wifi" indicating the need to cover a large, privately owned, area. Its the same as FM radio broadcasts at drive in theaters. Applicable client devices for the USA include Alfa AWUS036H and Rokland accessories. Much of their client (your PC) hardware uses adaptable output, automatically adjusting as necessary.

    Backhaul use involves directional antennas with the polarity turned sideways, and so much effort involved to avoid interference. Section 15.23 of the FCC code allows high power use IF there is much effort to avoid interfering with other wifi users and ONLY if the equipment is homebrew, such as the recycled primestar projects. In this example, we still don't turn the transmitter up far enough to clip itself. 62~84 for wireless "G" and 126~150 for wireless "B" still applies. The lower your expected throughput, the higher you may turn up the power without clipping the transmitter (some technicalities omitted, but that's basically how the concept works).

    Since we don't usually clip the transmitter causing lag, and since any higher power use that doesn't clip, is with directional antennas, then the FCC really has no worries whatsoever about Linksys hardware (it can't do brute force). Wireless TV and baby monitors are far worse.
  58. danielhaden

    danielhaden Network Guru Member

    Since "ND" drivers don't strictly equate your setting into milliwatts, you'll need to experiment while observing Windows Task Manager's description of Bytes Per Second. Choose whatever power output makes the highest Bytes Per Second, and your choice will also happen to equate to highest stability with least lag.

    Unfortunately, some newer hardware does require the "ND" drivers and thus you do have some additional fine tuning tasks to perform. Generally either 63 or 84 should solve the problem if your firmware offers a "mw" setting.

    Here it is: ND also limits by country code, so don't set it on Japan! Country code always overrides your power setting. The unseemly default of Japan, seems to be a flaw. You can change this setting easily. No need to change firmware.

    Really old vintage Linksys hardware prefers standard drivers, such as what may be in Victek's that runs so brilliantly on my old linksys. Since that particular firmware is finer than any of its peers, I continue to wish to have a full compatibility list for it.
    Unfortunately, that information is absent.
  59. myersw

    myersw Network Guru Member

    Probably should have stated this is an e4200 and 100 is what is shown in the transmit power setting. Have not done any tweaking to the wireless other then setting security. --bill
  60. danielhaden

    danielhaden Network Guru Member

    It seems that the firmware defaults for "ND" need fixed. Japan and WMM are terrible defaults.
    Need to set power to 84mw for maximum speed on wireless "G" (higher is slower, lower is slower)
    Need to turn off WMM's selective slowdown of wifi
    Need to set country code so that it doesn't limit power output (don't default to Japan)
  61. Beaker1024

    Beaker1024 Networkin' Nut Member

    Ok I had asked earlier about firmware beyond Tomato's 1.28 standard (which I currently do have installed) and got wonderful replies. Thank you!

    At that time I was still with DSL 6Mbps down/1.5 up so I stayed with 1.28 standard just out of laziness on having to redo all my parameters.

    Now I have Comcast HSI 20/5 (and man the upload is so much better!).

    My question is: Is it worth the time of redoing all the parameters CIFS, Wifi passwords,etc.... to go from the standard Tomato 1.28 to the suggested Victek's Does this version of Firmward have the "speed boost adjustments" that I saw from a different redo of Tomato (and on the Wikipedia Tomato entry)?

    Any guesses on what I'd gain feature wise and speed wise? I run Gigabyte LAN hardwired that's my primary concern Wifi is only for secondary access devices that I"m not as concerned about for speed/reliability.

    PS - I have a: Linksys WRT54GS v2.1

    Strangely I clocked my Comcast HSI at 25 Mbps at 12:10am (likely no neighbor usage) and the next day at 7:00pm I have 5-6Mbps download (almost same as DSL was, hopefully only due to neighbor traffic). I can't really complain as the Upload is insanely faster and it still "feels" faster than DSL did.
  62. MrKnister87

    MrKnister87 Networkin' Nut Member

    Are there some new infos about the 5Ghz support on the E4200
  63. Toastman

    Toastman Super Moderator Staff Member Member

  64. TerminatorHTK

    TerminatorHTK LI Guru Member

    I'm currently running the latest version of Teddy Bear's Tomato ND USB mod kernel 2.6 with OpenVPN support. However, it's starting to look like this variant may no longer have any support, so I'm considering moving to the Victek variant. Can anyone tell me (or point me in the right direction) for a comparison of the 2 mods? Any pros or cons of each?

  65. asturnauta

    asturnauta Addicted to LI Member


    I have an E4200, and I wold like to use tomato raf mod, but i have a question.

    Will be implemented virtual wlan in the future or it will not be implemented never?.

    I have two Nintendo DS, and it is compatible only with wep secure, and i am not to downgrade my wpa2 secure.
    I wanto to have my prinipal wifi with WPA2, and a virtual wifi without ssid broadcast and wep.

    Victek, Has you thinked to implement this feature?

  66. Beaker1024

    Beaker1024 Networkin' Nut Member

    Toastman - Thanks the for the link to your settings saving steps.

    Can anyone make a quick statement on real world high level bullet point, no technical unix/networking details with normal household usage advantages of the suggested Victek's to the standard Tomato 1.28? [I read through this webpage: and I have a hard time following what is really gained / different sorry.]
  67. Azka2010

    Azka2010 Networkin' Nut Member

    I'm new to this forum. nice to meet you all.
    And special thanks for victek for building this awesome firmware ...
    Currently i'm using Tomato Firmware RAF1.28.121006.

    Today, i need to change routing mode from gateway to router mode. After done some works, both network are able to communicate.
    The problem now is, access restriction has no effect. Even when i set to block all internet access. PC behind linksys still able to open a webpage.

    So, The question is ... is there a way to have at least access restriction working in router mode ?
    how about the qos ?

    Thank you,
  68. cofetym

    cofetym Networkin' Nut Member

    Been lurking for sometime and decided to join. Recently migrated from Tomato 1.27 and just recently installed Victek's RAF1.28121006. ( Wrt54gs/Wrt54g ).
    I noticed that Interference Mitigation is missing from this build !

    Thanks for all the hard work you put into these builds. I'd like to send in a donation. Who does the donation go to ?
  69. fubdap

    fubdap LI Guru Member

    I am running RAF 1.28.9006 on RT-N16. I am saving my bandwidth data on a usb stick on the router. Everything works fine. However, if I reboot my router for some reason, the usb stick does not auto mount. The logs will show that the router is trying to mount the usb stick, but it will not mount. In the USB support menu, I checked auto mount. The only way I can get the usb stick to mount is to pull it out and then put it back in. Does anyone know if there is a script I can put somewhere to mount the usb stick after a reboot? Thanks
  70. csm746

    csm746 Network Guru Member

    I believe there is a button on Victek's Tomato RAF....
  71. csm746

    csm746 Network Guru Member
  72. myersw

    myersw Network Guru Member

    Log into the router and go to the about page. There is a place there to donate. --bill
  73. kabar

    kabar LI Guru Member

    seems like Toastman finally made it using new Teddys drivers - e4200 runs with 5ghz, as they say on tomatousb. Im gonna give it a try, I hate the original firmware. Still - cant wait for the beloved Victek mod with working 5ghz. But I guess its a matter of time now :) fingers crossed.
  74. fubdap

    fubdap LI Guru Member

    I also like the IP traffic monitoring. Wondering when that will migrate to Victek build.
  75. cofetym

    cofetym Networkin' Nut Member

    Never did get a response to Interference Mitigation on the Victek build ! Maybe it was causing problems with connectivity ?
  76. cofetym

    cofetym Networkin' Nut Member

    One of my routers went down so I'm only using my wrt54g/Victek build for the router. Under the Wireless Survey my router is not showing up. Did I do something wrong ? Any help greatly appreciated!
  77. kabar

    kabar LI Guru Member

    maybe someone will be interested - theres new firmware for e4200 on cisco site - v1.0.0.3

    - Added supports of Native IPv6 over PPPoE Internet connection when only keep
    alive option is selected.
    - Added supports of Native IPv6 on guest network if there are more than two
    available IPv6 subnets
    - Added supports of Native IPv6 on Parental Control
    - Added supports of 3TB Hard drive with NTFS and HFS+ format
    - Improved firmware upgrade stability
    - Improved IPv6 WAN performance
    - Fixed media server unstable issue
    - Fixed Cisco LED flashing issue
    - Fixed some minor bugs
    - DLNA certified
    - IPv6 Gold logo certified
    - UPnP certified
  78. eahm

    eahm LI Guru Member

  79. fubdap

    fubdap LI Guru Member

    Hi Victek - Are you doing ok. We've not heard from you since your last post on Sept 1, 2011.
    4char likes this.
  80. DeiF

    DeiF Networkin' Nut Member

    He wrote an entry in his personal blog on Sept 18.
    Maybe he's on vacation (I hope so).

    I'm trying to contact him by email since Sept 1, to report a bug in Tomato RAF 9006.
    If anyone is interested, in httpd/misc.c, line 485, where it's written:
    web_printf("%s['%s','%s/%d','%s','%s',%u]", n ? "," : "", dev, s_dest, s_gateway, s_mask, metric);
    it should be:
    web_printf("%s['%s','%s','%s','%s',%u]", n ? "," : "", dev, s_dest, s_gateway, s_mask, metric);
    That's it, remove the extra parameter "/%d".
    This bug causes some garbage numbers to appear in Advanced->Routing->Current Routing Table, and maybe related to another bug: you can't add more than 1 route using the GUI (the browser is prompted to download the page instead).

    Also Captive Portal not working, uPnP, etc... at least for me with the E4200 (which is not a surprise, since Victek didn't have this router to test it, AFAIK).
    It could be totally my fault, however.:oops: (maybe I missconfigured something)

    Victek, we miss you.;)
  81. Victek

    Victek Network Guru Member

    I'm fine, thank you, working in some other features to build in 1.28.9007, now in beta test, and available from next weekend.
  82. fubdap

    fubdap LI Guru Member

    Victek - glad to hear you are doing fine. Looking forward to trying the 9007 build. Some of the features you are working on, any chance one of them is the IPTraffic Monitor?
  83. myersw

    myersw Network Guru Member

    Victek, glad you are still working on Tomato. Still think your's is the best, but I currently have a E4200. Are you going to be working on the latest stuff from Teddy Bear and Toastman to give us your dual band e4200 support? Hope so as yours, in my opinion, is always the best for my use.
    Am currently running the latest from Toastman with dual band support. Looks good.
  84. DeiF

    DeiF Networkin' Nut Member

    I'm happy to hear from you Victek. ;)
    Really. You're the man.

    You're always working for us when you really don't have to, and your work is always excellent.
  85. djroby19

    djroby19 Networkin' Nut Member

    When hitting your new stable build with support for E-4200 5Ghz?
  86. Victek

    Victek Network Guru Member

  87. meazz1

    meazz1 LI Guru Member

    I have tried this (tomato-K26USB-1.28.9007MIPSR2_RAF-VPN-NOCAT(RT-N16_8MB_FLASH)) build in Asus RT-N16 and experienced wifi drops, some times I had to reboot the router so my laptops could see the AP.
    I did a full NVRAM wipe.
    Is this not the correct build for this router? Should I use 1.28.9006 build that is for RT-N16?
  88. Victek

    Victek Network Guru Member

    Well... Set a fixed wireless channel as first step. 9007 is still a Beta release.
  89. mikechml

    mikechml Networkin' Nut Member

    Which builds have support for DSCP matching in the QoS classification? I've been trying out 9006 builds on my WRT54GS (v1.1) but they're quite unstable - the router keeps rebooting every 5-20 minutes. The K24 builds i've tried have been stable but have no DSCP. :(
  90. djroby19

    djroby19 Networkin' Nut Member

    Thanks Victek and a pleasure to meet you ... thanks for the work you are doing for us ..
    I think you found the bug that the cpu was set to 133Mhz alone I found out when I was using the wifi off the night-time and the next day he was with the wifi and 133Mhz crashhappens after 3 4 hours. .. I hope I have explained myself well with my English school, I am Italian ......
  91. Victek

    Victek Network Guru Member

    No, CPU clock is 480MHz, no problem, I'll release in two-three days since I'm checking memory swap with USB transfer and the posibility to choice the SSID showing Nocat Splash welcome screen.

    Thank you for the comment about CPU frequency, till now it works fine.
  92. fubdap

    fubdap LI Guru Member

    Any chance IPTraffic Monitor will be part of the next release? Thanks.

  93. djroby19

    djroby19 Networkin' Nut Member

    Where can I download your beta? 1.28.9007 build in E-4200
  94. meazz1

    meazz1 LI Guru Member

  95. DeiF

    DeiF Networkin' Nut Member

  96. eahm

    eahm LI Guru Member

    djroby19, wait for the stable...
  97. djroby19

    djroby19 Networkin' Nut Member

    ok ;)

    DAVIZINHO Addicted to LI Member

    works, VERY fine the 5ghz in E4200. Fantastic job victek, you are the best!!!
  99. djroby19

    djroby19 Networkin' Nut Member

    Which version you have installed?
  100. Victek

    Victek Network Guru Member

    He received a "near" end release from me.. I'm doing always the same sending the RTM one-two days before public. Thanks Davizinho ;)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice