New Victek releases

Discussion in 'Tomato Firmware' started by mpegmaster, Jul 2, 2009.

  1. Toastman

    Toastman Super Moderator Staff Member Member

    phreshanova, can I ask what wireless card you are using to access the router?
  2. noodles2k

    noodles2k Addicted to LI Member

    I've found a bug with WDS. I've got two WRT54GLs running 1.25.8515 (A & B). A is on all the time, and B is turned on for an hour or two a day, as a neighbour uses it to access our wifi.
    Half the time, it works fine with B connecting to A. The other half, the wds interface connects between A & B but A doesn't forward packets. Resetting the br0 on A resolves the problem, but I only know how to do this from the webgui. Is their a cli command I can use with a script to fix the issue?

    I was planning on using something like this on 30min intervals -

    if(brctl showmacs br0 | grep MACOFB0000 && !(ping of B)))
    then service wireless restart
  3. Victek

    Victek Network Guru Member

    Sounds strange the 50% probability that success or not for the WDS, I think it's more related with radio interferences or channel neighbour. If it's a bug should be 100% fail. I don't use WDS but I'll try before releasing next update. Thanks for the advice.
  4. dingmel

    dingmel LI Guru Member

    i tried the command teddybear provided to mod the IMQ number both thru ssh, and through the scripts tab. doesn't seem to be working. perhaps i'm not doing something right?

    could someone shed some light as to how i'm supposed to go about adding a few more IMQ numbers to the realtime bandwidth monitor as Victek's 1.23 mod had.

  5. teddy_bear

    teddy_bear Network Guru Member

    It DOES work in 2.4 kernel, and the command syntax is exactly as I posted above:
    insmod imq numdevs=N or modprobe imq numdevs=N

    BUT - it doesn't work in vanilla Tomato, because it strips out parameters from all compiled modules. In my usb mod, and I believe in Victek' RAF mod as well - the parameters are not stripped out from the IMQ module, hence the numdevs param works.

    As for the correct place to load the module, it depends on the exact implementation in Victek mod. If IMQ module is automatically loaded by this mod, maybe there's a setting somewhere in the GUI to specify the number of devices? If not, maybe Vic can chime in about where to call "insmod|modprobe" to override the default behavior...
  6. Victek

    Victek Network Guru Member

    The IMQ behavior was set to the stock values, so, from console command it works in both version, I tested now in 1.25.8515.2 ND.
  7. jsmiddleton4

    jsmiddleton4 Network Guru Member

    WDS fine here

    No problems with wds here. Did have an issue with packet loss on my wan port side with a Linksys 54GL and replaced it with one of my Buffalo HP54's. No problems since. The Linksys may be going bad.

    But WDS has been solid and I've used it for some time as my entertainment center is connected via the web by WDS. Its blu-ray, Wii and web enabled receiver do just fine. Listening to web radio station as I type.
  8. teddy_bear

    teddy_bear Network Guru Member

    Geez... I wonder how people make their conclusions ;)....
    "2" is the hardcoded default value, which can be overriden by the parameter specified when loading the module. No recompilation needed.
  9. noodles2k

    noodles2k Addicted to LI Member

    oops sorry, i'm a noob :redface:! although there does seem to be a bug,
    # insmod imq.o numdevs=4
    insmod: symbol for parameter numdevs not found
    Looks like a problem with busybox?
  10. gingernut

    gingernut LI Guru Member

    What security settings are you using?
  11. noodles2k

    noodles2k Addicted to LI Member

    using WPA AES with 2hr key renewal, it's very stable.
  12. gingernut

    gingernut LI Guru Member

    I use the same security on my WDS setup and sometimes experienced the same problems.

    Have you tried just to test if with no security or with WEP you get the same results?

    For me the non ND version gives me a more reliable WDS link, but maybe it's just my setup.
  13. TwixKing

    TwixKing Addicted to LI Member

    Hey all,

    I'm using the v1.25.8515 .2RAF ND firmware, works great! Since I am sharing my 100mbit internet connection with +- 15 people I made some acces restrictions (Blocking on keywords, layer7 etc.) I also found the script generator to limit the up- and download speed of those people (I make no restrictions for myself offcourse :p)

    I still have one question; is it possible (by script?) to show the (total/current) down/upload (speeds) by mac/ip adres? This would help identifying the people who still are able to pass my anti-p2p systems!

    Is it also possible to display a message when a page is blocked (by keywords), now the page is just blank. Using a wrt54GL 1.1 btw :)
  14. jsmiddleton4

    jsmiddleton4 Network Guru Member

    "using WPA AES with 2hr key renewal"

    I do not use any setting for the renewal key. Mine is static in that regard and I have no problems with WPA AES. So maybe the renewal key stuff is the problem?
  15. TexasFlood

    TexasFlood Network Guru Member

    So what's your "Group Key Renewal" (Under "Basic: Network") setting? Mine is 7200 seconds which should be two hours as well, think the default is 3600 seconds or one hour.
  16. Planiwa

    Planiwa Network Guru Member

    A Connection Storm -- A small Suggestion for Victek

    Thank you for posting data about a Connection Storm.
    Connection Storms are without doubt the most serious hazards that affect Tomato users. All connection-tracking routers are affected to some extent, but Tomato is particularly vulnerable because:

    1. The popular good old WRT54G[L] is seriously lacking in hardware resources.
    2. The old 2.4 Linux kernel lacks proper NF/Conntrack tools.
    3. The fine Tomato GUI attracts users who are typically not aware of the problem.
    4. The tools that might be helpful, such as NF/Conntrack and QOS connection counting are flawed -- the former fails to count to most rapidly surging (UDP) connections, and the latter fails to classify the most numerous DNS lookups, as well as connections that originate externally or appear to originate or terminate with the Router.
    5. The problem may be aggravated by the DNS multiplication, as in the case of Steam, etc., which can try to establish thousands of connections in a few seconds.
    6. Shell configuration problems hamper monitoring scripts.
    7. Most of what has been posted on the Net about counting connections is seriously flawed.

    The attached logs show a net surge of up to 90 connections per second. That amounts to 6,300 connections in just one minute!

    One single measure that could greatly assist in managing connection storms would be to include a tiny measure:

    Maintain the connection count in a /proc pseudofile:


    That would make it possible to write scripts that can monitor and prevent connection storms at a tiny fraction of the current cost. (Currently, a script must actually count all the connections in order to obtain that count! To do so, every 5 seconds, puts a very heavy load on the router, especially during a connection storm. But to check only once per minute will be too late, since most storms are over in 20-40s, and remain undetected.)

    I suspect that the vast majority of "disconnections" are actually router crashes caused by connection storms.


  17. Toastman

    Toastman Super Moderator Staff Member Member

    Yesterday I used the tracking scripts written by Planiwa to monitor this building's main router. While it didn't crash at any time, it came pretty close. About every half an hour someone in the complex was causing a connection storm. This one would open about 1200 DNS connections in a couple of minutes. Once alerted, I came to watch the QOS graphs in person and try to find out where it came from. I had a very similar log to gogubeb's. However, I could not see who or what was responsible before it ceased. Today it is not happening.

    I believe Planiwa is most probably quite right when he says that connection storms are perhaps the cause of much of our remaining problems.
  18. Victek

    Victek Network Guru Member

    Planiwa, thanks for the thoughts, but then, the scenario will affect to any connected router to Internet independent if Linksys, Tomato or any firmware.
    I think that the comfortable pool allowed in Tomato (up to 8192 connection) helps to mitigate this situation. New routers in the market did not extend the ip_conntrack space unless the RAM has been upgraded up to 32-64MB, then, the hardware, kernel, or GUI as you said are not in relation with the problem. it's an event that might happen and will overflow any connection.

    I have another approach and thought about this event; it's related with the ACK capacity of the upload channel in your Internet connection and the UDP packets. As you know we don't have 'real' DSL connection and almost ISP's provides you ADSL service with an upload ratio 1:10, the upload channel is almost of time dedicated to ACK the packets received to confirm the DSLAM successful-unsuccessful reception of the data stream. So, when the upload channel is busy or overflow with the usage of intensive P2P upload the bandwidth is restricted and almost of connection with peer remains open without acknowledge, this situation saturates the ip-conntrack pool and can provoke situations as we know already.

    This situation is nicely observed and can be provoked sooner if we establish P2P negotiation via wireless. (Toastman) Due to the instability of the link and consequently lack of connection the number of open connection raises considerable and consequently this case is more evident.

    In the case of UDP packets, this situation is much more critic and we have to cut it by hard with aggressive settings disconnecting these connection.

    So, a comfortable pool for incoming connected IP is not enough and a rational bandwidth management has to be planned if we are dealing with multiple peer application. And it's something not related with hardware, pool, kernel or GUI ... is related to QoS and upload bandwidth in your Internet service.

  19. noodles2k

    noodles2k Addicted to LI Member

    thats fairly easy to do with the wrt54gl. Also what about using sd/mmc as swap? (admittedly rather slow!)
  20. Trademark

    Trademark Network Guru Member

  21. GhaladReam

    GhaladReam Network Guru Member

    You're assuming Vic's next release will be based on 1.26 beta (or final). Can you confirm this Vic?
  22. mstombs

    mstombs Network Guru Member

    Tomato firmwares do not have tftp enabled - so no issue, but as the dnsmasq upgrade is in beta 1.26 it will come to a router near you soon!
  23. Trademark

    Trademark Network Guru Member

    Ya, I'm aware of that, but I sometimes leave it running for easy access, and since I'm a paranoid security freak, it would put my mind at ease. Thanks all.
  24. Victek

    Victek Network Guru Member

    GhaladReam, I'm looking sources diff in 1.26 beta... nothing special / new except digit change, but YES I'll do..
  25. QSxx

    QSxx Network Guru Member

    Vic, quick question...

    Can pfifo mode somehow be used on QoS basic settings on 1.25.8025 .2 - i don't see option for it on web gui.

  26. noodles2k

    noodles2k Addicted to LI Member

    think it's "qdisk scheduler"
  27. belliash

    belliash Addicted to LI Member

    Is it possible to have multiple MACs sharing indentical IP address?
    I use static DHCP and i would like my laptop to have identical IP all the time, whenever i connect through LAN or WiFi.
  28. Victek

    Victek Network Guru Member

    No, including 1.26 beta release can't do it as I tested.
  29. mstombs

    mstombs Network Guru Member

  30. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    I was referring to my patch (I haven't tried 1.26 or looked at the code changes in it yet) when I saying it worked. I sent him that patch months ago, and he responded that he'd look into including it, but I don't know how much of it he ended up using directly.

    I guess I'll add the 1.26beta code to git so I can see what's changed.

    EDIT: What Jon did is quite a bit different than what I did on the static DNS web GUI page, so I can't comment on it working. However, if you can manage to enter the two MACs in the table (I haven't tried it), it should work as I described.
  31. QSxx

    QSxx Network Guru Member


    straying away from discussion, I've got another question for Vic:

    What's the difference between 1.25.8025.2 and 1.25.8515.2 ND?

    I found this so far:

    - ND tag - for the new drivers on 8515
    - some options missing in Advanced/Wireless (due to older drivers of 8025?)
    - no option for pfifo on QoS/Basic page
    - UPnP NAT-PNP advanced options missing

    Anyone found something else? I'm assuming that Vic just forgot to adapt the source due to lack of time... or is there some other reason behind it?

    I found this out quite recently ... my good old WRT54GL 1.1 died because of to too much poking (hardware wise) so I'm back to WRT54G 2 and I can't really run ND on it...

  32. GhaladReam

    GhaladReam Network Guru Member

    What's the wl0_corerev of he WRT54G v2? Reason I ask, is I'm running ND on a WRT54GSv2 flawlessly, and it has corerev=7.
  33. QSxx

    QSxx Network Guru Member


    so yeah, i should be able to run ND without trouble too...

    I did follow the rule that ND is for corerev 9 and above - but well... I'll try ND then, report back here on how it's going...
  34. davistw

    davistw Network Guru Member

    Is Victek's site down?
  35. GhaladReam

    GhaladReam Network Guru Member

    The general rule is don't use ND on anything less than corerev=7, yes, but it will in fact work fine on this revision. On Vic's site (which does seem to be down at the moment) it does say this information as well. I think the reason most recommend at least a corerev of 9 is because 7 won't actually produce any benefits even though it works perfectly.
  36. mau108

    mau108 Addicted to LI Member

    I have a v2 wrt54g running the ND version, no issues at all. I think the wireless performance is better then regular one.
  37. phuklok1

    phuklok1 Network Guru Member

    I have tried the ND driver on a V2 (core rev 7) (I am doing WDS between a 54g-TM and the V2) and I couldn't get WDS to work. It worked initially, but after a hard boot it would not link up. I reverted back to non-ND and it works fine. So perhaps it only works fine as an AP?
  38. Victek

    Victek Network Guru Member

    What's the core_rev for the wireless chipset?
  39. gingernut

    gingernut LI Guru Member

    I can confirm that the ND drivers don't work to well in WDS. As mentioned sometimes the WDS link dies or won't relink after a reboot.
    With the standard drivers I don't get these problems.

    I have tested this on a GL (core_rev 9) and on two different Buffalo HPs (core_rev 9) with no success.
  40. QSxx

    QSxx Network Guru Member

    Well, my WRT54G V2 now runs ND. Stable and fast (QoS does take leeeeetle bit longer to kick in compared to what i had on GL).

    However i can confirm WDS issues. Didn't work between WRT54G V2 and WRT54GL V1.1...
  41. Badders44

    Badders44 LI Guru Member

    It's working fine here. Solid as a rock:thumbup:
  42. GhaladReam

    GhaladReam Network Guru Member

    Hmm, I'll have to test WDS at some point for its preformance when using ND.. I've never actually used it so I wouldn't have noticed this.
  43. RonWessels

    RonWessels Network Guru Member

    Excellent - other people are also noticing WDS problems with the new drivers.

    When I was pounding away on it, I discovered that the WPA/WPA2 security settings that worked for the old drivers didn't work for the new drivers. And even when I got it working, when one end of the connection reboots, you have to reboot the other end as well to re-establish the connection.
  44. mpegmaster

    mpegmaster Addicted to LI Member

    It's working fine here also... :thumbup:

    Solid as a rock!!!

    I using a WRT54G-TM as a AP with [4] four Wireless Bridges on WRT54G V2 routers.

    I only using... WEP not WPA or WPA2 - Yea I know it's not the best security!!!

    I have had the Wireless Bridges get their power bump off via house keeping chores, etc...

    I also modified them all via the power input with 4700mfd 35VDC Capacitors across the power connector. This prevents brown outs spikes and dips. A poor persons cheap UPS.:)

    Simple to do and not expensive either!!!

    This above network is running on Tomato Firmware v1.25.8515.2 RAF ND for all devices!!!

    Network clients/machines are...
    4-6 wired computers
    4 wireless bridges with printers, scanners and fax machines
    1-6 Laptops on wireless

    This network environment is in a 3 story house.

    The AP is the only router with... 16dbi antennas!

    ...Keeps the noise floor ratio @ 99dBm very clean!
    ...Keeps the RSSI & Quality levels good also!
    ...All [5] devices running @ 84mw on Channel 11 due too heavy usage on Channel's 1 & 6 in the neighborhood.


  45. Victek

    Victek Network Guru Member

    It's known the WPA/WPA2 issues... If I roll back to 4.150.10.x the problem will be overcome, but the performance obtained with the latest wireless driver it's a hit in AP mode with better compatiblilty,,, I know, and we have to decide, good performance an compatibility or average performance and stability?
  46. QSxx

    QSxx Network Guru Member

    i'm allways for good performance :)

    Another question... What's going on with imq devices in latest Tomato releases?

    I've got this script in Firewalls section:

    modprobe imq
    modprobe ipt_IMQ
    ip link set imq1 up name 1-Djuro
    iptables -t mangle -A PREROUTING -s 192.168.1.XX -j IMQ --todev 1
    iptables -t mangle -A POSTROUTING -d 192.168.1.XX -j IMQ --todev 1
    ip link set imq2 up name 2-DjJ
    iptables -t mangle -A PREROUTING -s 192.168.1.XX -j IMQ --todev 2
    iptables -t mangle -A POSTROUTING -d 192.168.1.XX -j IMQ --todev 2
    ip link set imq3 up name 3-D-Will
    iptables -t mangle -A PREROUTING -s 192.168.1.XX -j IMQ --todev 3
    iptables -t mangle -A POSTROUTING -d 192.168.1.XX -j IMQ --todev 3
    What happens when i reboot is loss of internet access on wireless clients and rstats appliaction (BW monitoring) shows only imq0 and imq1

    I have Toastman's set of rules for QoS - i'm not using IP/MAC BW limiter and no ARP Binding...

    What am i doing wrong?
  47. QSxx

    QSxx Network Guru Member

  48. Solid-State

    Solid-State Network Guru Member

    I have a WRT54GL with non ND version of polarcloud tomato. I need to know what version I should flash? ND or not? Also what is the difference?
  49. Victek

    Victek Network Guru Member

  50. ~nephelim~

    ~nephelim~ LI Guru Member

    router user.warn kernel: HTB: quantum of class 10010 is small. Consider r2q change.


    I have two QOS limit rules with the same settings

    DLRate 500kbps    DLCeil 1000kbps    ULRate 50kbps    ULRate 100kbps    Normal    50    10/s

    I get two "quantum of class 100nn is small. Consider r2q change." warnings when I enable IP/MAC BW Limiter.

    Are those rules inappropriate?
  51. Victek

    Victek Network Guru Member

    Yes, it's already fixed in the HTB rules. When the smallest rate (one example) : 16kbit = 2 kilobyt / r2q (=10) = 200. And this is < 1500. So you will get warnings.
    The same will happend for the biggest rate : 100mbit = 12.5 mbyte / r2q = 1.2 Mbyte > 60.000. So you get warnings.
    If you have only these two machines under the rules, try to quote the overall bandwidth as the sum of rates for each individual machine.
  52. ~nephelim~

    ~nephelim~ LI Guru Member

    I have only those two machines configured for  IP/MAC limiter though there are others on the LAN.

    I  tried to set IP/MAC limiter download to 2000 upload to 200 (just below Enable QoS Limit)

    or change the two rules settings to:
    DLRate 500kbps DLCeil 7000kbps ULRate 50kbps ULCeil 450kbps Normal 50 10/s

    with the  Download Bandwidth to 7000 and Upload to 450 I was using before.

    I also tried to disable Qos but in all cases I get those warning on reboot.

    edit: changing the ulrate to 80 worked.  

    though it would be still less than 1500. is there a way to confirm the r2q used on my router?
  53. Toastman

    Toastman Super Moderator Staff Member Member

  54. ~nephelim~

    ~nephelim~ LI Guru Member

    Thanks for the link.

    I ran the tc commands mentioned in that topic part and got the same scenario described by phykris 

    IP/MAC BW Limiter ULrate 80kbps

    tc -d qdisc output summary

    dev br0 r2q 10 
    dev ppp0 r2q 10
    dev imq0 r2q 10

    EDIT: the following is inaccurate as tc -d qdisc output  do not list the quantums of IP/MAC BW Limiter rules  and different commands are needed 

    br0 quantum 1514b  
    imq0 quantum 1500b 

    EDIT: the following is inaccurate as tc -d qdisc output  do not list the quantums of IP/MAC BW Limiter rules  and different commands are needed 

    Indeed with IP/MAC BW Limiter ULrate 50kbps after reboot I get quantum of class <classid> is small warnings but the tc -d qdisc output is unchanged and quantum values as above.

    Since r2q value is fixed to 10 both 80 and 50 ULrates should trigger the same warning nevertheless the quantum is set to those seemingly appropriate values.

    Guess it could worth mentioning that while in QoS Basic Settings I have Qdisc Scheduler set to pfifo the IP/MAC BW Limiter rules got a qdisc sfq.
  55. ~nephelim~

    ~nephelim~ LI Guru Member

    Quantum, rates and r2q informations

    Despite available info point out a min of 1500 and a max of 60000  (Thu, 20 Oct 2005 07:32:58 -0700) the limits actually changed though a r2q = 10 default value is still used. 


    1. quantum values are derived from corresponding rates using r2q 
    2. quantum values are constrained

    r2q influence what rates could be actually used in  IP/MAC BW Limiter rules 

    With some additional tests it looks the quantum of a class is derived from ULrate corresponding to imq0 (or DLrate corresponding to br0) of rules.

    NOTE:  DLCeil or ULCeil of IP/MAC BW Limiter rules(class) do not seemingly affect quantum values

    Quantum = 1000 * number of rate kbits  / ( 8* r2q)

    eg: r2q= 10; 80kbit/s ;   1000 * 80 / ( 8 * 10 ) =    80000 / 80    =   1000

    With the current r2q defaults (upload/imq0 r2q = 10 and download/br0 r2q = 10)

    • Setting ULrate to 80kbit will provide a corresponding upload quantum of 1000
    • Setting DLrate to 16000kbit will provide a corresponding download quantum of 200000 

    To get the current quantum of  IP/MAC BW Limiter rules:

    tc -d class show dev imq0  
    tc -d class show dev br0 
    In current implementations the quantum can be as low as 1000 and as high as 200000 (1000 < quantum < 200000 )

    • The quantum of class <classid> is small      warning   is actually generated when quantum is less than 1000
    • The quantum of class <classid> is big       warning is actually generated when quantum is greater than 200000
    With a r2q 10 (default value):

    80kbit/s < rate < 16000kbit/s (80 ----> quantum = 1000; 16000 ----> quantum = 200000), then:

    • If rate is less than 80 the quantum is small warning is provided.
    • If rate is greater than 16000 quantum is big warning is provided

    Download Bandwidth or Upload Upload Bandwidth (just below Enable QoS Limit) have the same constraints as rate

    With the r2q = 10 (default value)  the Bandwidth field input (either upload or download) cannot be less than 80 or greater than 16000 

    With a r2q = 10 (default value)  the quantum will be less than MTU/1500 if a rate below 120kbit/s is specified and greater than 60 000 if a rate above 4800kbit/s is provided.

    NOTE: I have no clue if a quantum < than 1500 or > 60000 (old quantum constraints) will affect performance in current HTB versions.

    Allowed rates change according to r2q:

    New limit : (1000 < quantum < 200000 )

    • With a r2q 10: 80kbit/s < rate < 16000kbit/s
    • With a r2q 9: 72kbit/s < rate < 14400kbit/s
    • With a r2q 8: 64kbit/s < rate < 12800kbit/s
    • With a r2q 7: 56kbit/s < rate < 11200kbit/s
    • With a r2q 6: 48kbit/s < rate < 9600kbit/s
    • With a r2q 5: 40kbit/s < rate < 8000kbit/s
    • With a r2q 4: 32kbit/s < rate < 6400kbit/s
    • With a r2q 3: 24kbit/s < rate < 4800kbit/s
    • With a r2q 2: 16kbit/s < rate < 3200kbit/s
    • With a r2q 1: 8kbit/s < rate < 1600kbit/s   
    Old performance related limit : (1500 < quantum < 60000 )

    • With a r2q 10:120kbit/s < rate < 4800kbit/s
    • With a r2q 9: 108kbit/s < rate < 4320kbit/s
    • With a r2q 8: 96kbit/s < rate < 3840kbit/s
    • With a r2q 7: 84kbit/s < rate < 3360kbit/s
    • With a r2q 6: 72kbit/s < rate < 2880kbit/s
    • With a r2q 5: 60kbit/s < rate < 2400kbit/s
    • With a r2q 4: 48kbit/s < rate < 1920kbit/s
    • With a r2q 3: 36kbit/s < rate < 1440kbit/s
    • With a r2q 2: 24kbit/s < rate < 960kbit/s
    • With a r2q 1: 12kbit/s < rate < 480kbit/s   

  56. ~nephelim~

    ~nephelim~ LI Guru Member

    REQ: Qos limit webif fronted upgrade

    It looks it would be possible to change the r2q

    Will it be feasible a webif upgrade that allow to set different r2q for upload and download mentioning the effective range (related to old quantum limits) and the allowed range (related to new quantum limits)?

    This would help dsl setups with a 1:10 ratio between upload and download.
  57. -=Renegade=-

    -=Renegade=- Addicted to LI Member

    Is it still test version or final & stable? Could not find any info and there is no more test section at victeks site.

    Thanks in advance
  58. GhaladReam

    GhaladReam Network Guru Member

    The current 1.25.8515.2 & 1.25.8025.2 are stable, at least they are for me. I have over 60 days of uptime, and I've never had a single hiccup.
  59. Victek

    Victek Network Guru Member

    Yes, I think are running well, nevertheless I'm working in a new 1.26 release (I don't know If I have to keep the standard Tomato version number as a reference versus latest changes in code....). In any case, yes, I work for a 1.26 release.
  60. kabar

    kabar LI Guru Member

    youre doing everything ok. its the number of IMQ youre using. in the latest software youre only allowed to use 2 IMQs. if u use more, thats it, router crashes. ive read that it should be available to change by n sth like "number of imq=XX" before the rest of the code, but ive tried it and didnt work. im using 2 imqs at the time and works. still, would like to use more, but its was not so necessary for me to try find out more about how to do it :) cheers

    edit: btw, im not very glad of how this imq thing works. i used 8 imq in previous raf release, and some imq showed real values, some not, sometimes is was showing activity of PC which was not even connected. same here, with 2 imqs. shows weird things. unuseful. generally speaking, i dont believe this thing and it makes me nervous when i try to understand int :)
  61. QSxx

    QSxx Network Guru Member

    Same thing happens here, hope to see it properly implemented soon...
  62. jdub8

    jdub8 LI Guru Member

    Hang on, I thought victek already allows you to up the limit from 2 (default in tomato) to 16 or 32. You just have to change the value right?

    That being said I haven't really gotten IMQ's to work right either and was waiting for the new version to try again.
  63. Victek

    Victek Network Guru Member

    Yes, there is no limitation on it since release 1.23, it was unlocked.
  64. Wolfeen

    Wolfeen Addicted to LI Member

    Are you sure? Look this ND version.

    [wolfeen@wolf~]$ ssh root@
    Tomato v1.25.8515 .2
    BusyBox v1.14.2 (2009-07-24 04:22:50 CEST) built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    # lsmod
    cifs                  190960   1
    tomato_ct               1136   0 (unused)
    wl                    895560   0 (unused)
    et                     21656   0 (unused)
    ip_nat_ftp              3712   0 (unused)
    ip_conntrack_ftp        4936   1
    ip_nat_rtsp             6656   0 (unused)
    ip_conntrack_rtsp       6344   1
    ip_nat_h323             2904   0 (unused)
    ip_conntrack_h323       2888   1
    ip_nat_pptp             2668   0 (unused)
    ip_conntrack_pptp       3452   1
    ip_nat_proto_gre        1888   0 (unused)
    ip_conntrack_proto_gre    2792   0 [ip_nat_pptp ip_conntrack_pptp]
    # modprobe imq numdevs=3
    modprobe: symbol for parameter numdevs not found
    # insmod imq numdevs=3
    insmod: symbol for parameter numdevs not found
    # insmod imq
    # lsmod
    imq                     2480   0 (unused)
    cifs                  190960   1
    tomato_ct               1136   0 (unused)
    wl                    895560   0 (unused)
    et                     21656   0 (unused)
    ip_nat_ftp              3712   0 (unused)
    ip_conntrack_ftp        4936   1
    ip_nat_rtsp             6656   0 (unused)
    ip_conntrack_rtsp       6344   1
    ip_nat_h323             2904   0 (unused)
    ip_conntrack_h323       2888   1
    ip_nat_pptp             2668   0 (unused)
    ip_conntrack_pptp       3452   1
    ip_nat_proto_gre        1888   0 (unused)
    ip_conntrack_proto_gre    2792   0 [ip_nat_pptp ip_conntrack_pptp]
  65. Victek

    Victek Network Guru Member

    Yes, I'm sure
  66. Wolfeen

    Wolfeen Addicted to LI Member

    So, what is wrong in my?
    # modprobe imq numdevs=3
    modprobe: symbol for parameter numdevs not found
    It is v1.25.8515 .2 ND.
  67. Azuse

    Azuse LI Guru Member

    Before i brick my router could someone clarify the version I should use? The instructions arn't clear. It's a wrt54gl v 1.1, corerev 9, currently running Tomato_1_25.7z, so does that mean i should use the 1.25.8515.2 or ND & if there's a choice which (and why)?
  68. Victek

    Victek Network Guru Member

    You can use any of both version, but ND version it's recommended in order to extend wireless performance (you must decompress the 7z package to obtain the file to be uploaded). More information in my site or in many post in this forum with comment about it.
  69. jdub8

    jdub8 LI Guru Member

    Need v1.26 plz

  70. QSxx

    QSxx Network Guru Member

    Any idea whatsoever about his Vic?
  71. Azuse

    Azuse LI Guru Member

    Took 15min with google but I worked that out :) Seems to be making better use of the ram too, even with the dns cache at 4096 :)
  72. GhaladReam

    GhaladReam Network Guru Member

    Not to rush what is already perfect (currently 85 days uptime on 1.25.8515.2!), but I was wondering about this as well. Do we have an ETA & what will be added/changed?

    Thanks Vic!
  73. Victek

    Victek Network Guru Member

    Next week if everything runs smoothly as up today (in reality is running since two weeks ago but I've been testing and testing many times to be sure). Changelog will be many lines ... and interesting to be read.

    Thanks to all!
  74. xuperman

    xuperman Addicted to LI Member

    Hi I got few questions I'm running v1.25.1720 in my WRT54GL router.
    Now, i downloaded the Tomato_RAF_1.25.8025.2 file.
    Can I simply upgrade it from the configuration page?
    Is that any steps i need to pay attention on?
  75. Victek

    Victek Network Guru Member

    xuperman, yes, you can, but in order to clean all conflicts between version do nvram erase after you upgrade to the new firmware. Don't use a backup configuration to restore your settings, do it manualy.
  76. xuperman

    xuperman Addicted to LI Member

    Thx Victek! I just installed the Tomato RAF 1.25.8025.2 to my WRT54GL :) Cheers!
  77. Wolfeen

    Wolfeen Addicted to LI Member

    Can anybody tell my in my Tomato RAF 1.25.8515.2 ND I can not use more then 2 imq? I cleared nvram after install RAF version and still got this:

    # modprobe imq numdevs=3
    modprobe: symbol for parameter numdevs not found
    # insmod imq numdevs=3
    insmod: symbol for parameter numdevs not found
    # insmod imq
  78. GhaladReam

    GhaladReam Network Guru Member

    Thanks vic! can't wait to use the new RAF.
  79. natf

    natf LI Guru Member

    Hello to all! This is my first post here...

    I'd like to install your modded tomato firmware on a Linksys WRT54GL 1.1 with DD-WRT v24 SP1 already installed on it. Some questions:
    1. Can I upgrade from web interface of DD-WRT?
    2. To clear nvram after upgrading is right to perform a reset with the reset button on the rear?
    3. My router has wl0_corerev=9; what is the right version of your firmware to install? 1.25.8025.2 or 1.25.8515.2 ND? What are the differences between them?
    4. The linksys router connects in wireless client mode to another wifi modem router with Broadcom chipset and speedbooster already enabled; can I have speedbooster on the linksys in wireless client mode with your firmware installed?

    Many thanks in advance
  80. Victek

    Victek Network Guru Member

  81. natf

    natf LI Guru Member

    I'm somewhat surprised of this. I asked it only for confirmation...
    In DD-WRT this feature is present with name "Afterburner".
    Maybe speedbooster is disabled in Tomato because it's based on stock Linksys Firmware?
    It would be interesting to have that feature enabled...
  82. Victek

    Victek Network Guru Member

    Afterburner is also present in Tomato... but I never experienced any speed improvement, did you in dd-wrt? .. me neither.
  83. natf

    natf LI Guru Member

    Only a little speed-up, but is present.

    A problem... if I try to flash with Tomato_RAF_1.25.8515.2-ND.trx, DD-WRT web interface says "wrong image file". Is the solution to simply rename .trx into .bin?

  84. gogubeb

    gogubeb LI Guru Member

    Yes, you can rename into ".bin"
  85. natf

    natf LI Guru Member

    I flashed my WRT54GL with modded tomato with your instructions.
    It was impossible to connect the linksys as a wireless client to my wifi modem router; furthermore I noticed that in client mode you can't use WPA2 personal. While the linksys has been reported as connected in web interface it was impossible to ping the modem router, neither surf the internet.
    I reverted back to the unmodded tomato with old driver but, again, it was impossible to connect to modem router, so I had to flash with DD-WRT I was using before.
    Is this a known bug?
  86. TexasFlood

    TexasFlood Network Guru Member

    I don't know much about client mode so maybe this is a known issue, I can't say. Once question though, did you do a nvram reset as recommended after flashing to a different build? Doing so can avoid a lot of weird problems.
  87. natf

    natf LI Guru Member

    Yes, I did nvram reset as first thing after having entered in web interface, just as vic told me a few of posts ago... so I don't know how to do... very strange behaviour
  88. TexasFlood

    TexasFlood Network Guru Member

    OK, guess I'm no help then. I have used client mode very little and stick with WPA cause it's been solid for me.
  89. forkicks

    forkicks Addicted to LI Member


    Did you stumble into any last minute bug with the new version? You have a waiting crowd here for it :).

    Sorry for nagging, just eager to get my hands on it.

  90. Victek

    Victek Network Guru Member

    No, just waiting for oficial 1.26 release and meantime thinking something interesting to add.
  91. forkicks

    forkicks Addicted to LI Member

    I'd suggest a way to use ipkg on top of cifs mount. (if im not mistaken, this has already either been on your firmware or at least was mentioned for it. I remember stumbling upon version 1.19 and reading something to that effect).

    But thats just wishful thinking, not really expecting it to happen.

    Thanks for your time,
  92. natf

    natf LI Guru Member

    Hello Victek... is there any plan to have WPA2 available in wireless modes other than AP mode only?
  93. GhaladReam

    GhaladReam Network Guru Member

    While I'd love to see it, I don't think any of us are in dire need of a new RAF at the moment... I think it's wise that Vic is waiting until official 1.26 release so he can integrate all the changes from that into RAF + his modifications. For the time being, 1.25.8025/8515.2 is deliciously stable and serves all functionality that I, and probably most others, require :)

    Why do you think RAF is so stable? a)because it's Tomato and b)because Vic (and Jon) are 2 very skilled programmers!

    We should all stop nagging (me included!) and know that it will be released when it's done.
  94. Azuse

    Azuse LI Guru Member

    Still, tidying up the handful of bugs will be good. My connections now refuse to reclassify after editing my rules without a reboot :(
  95. GhaladReam

    GhaladReam Network Guru Member

    Of course it's still not perfect, but it's close! :)
  96. Solid-State

    Solid-State Network Guru Member

    I'm about to rollout a bunch of Buffalo HP routers using this firmware and wish to know what is the best most STABLE and COMPATIBLE wireless modes to set the radio to?
  97. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Given they are going to be "out there" I would stay with regular Tomato and not victek's mod. Victek's mod is stable but with its customization that also means folks can mess it up.

    I say regular Tomato 1.25 and then if the folks who have their hands on the routers want to go to Victek's mod, that's their call.
  98. Toastman

    Toastman Super Moderator Staff Member Member

    And use the ND wireless driver version. It works with Intel and some other troublesome cards. Many of us find original Tomato to be less stable than Teddy Bear and Victek releases, by the way.
  99. darthboy

    darthboy LI Guru Member

    wow, has it been that long since Victek released the last RAF mod? Been too busy to mess with router stuff and just noticed this today!

    Tomato Firmware v1.25.8515 .2RAF ND

    Name	buffalo
    Model	Buffalo WHR-HP-G54
    Time	Sat, 07 Nov 2009 22:37:51 +0800
    Uptime	[b]93 days[/b], 06:11:10
    CPU Load (1 / 5 / 15 mins)	0.00 / 0.00 / 0.00
    Total / Free Memory	14.14 MB / 4,748.00 KB (32.80%)
    CPU Frequency (MHz)	200
    And this's my ddwrt VPN server.
    Firmware: DD-WRT v24-sp1 (07/26/08) std
    Time: 22:40:21 up [b]93 days[/b], 6:53, load average: 0.00, 0.00, 0.00
    WAN: Disabled
  100. tstrike2000

    tstrike2000 Network Guru Member

    I would also agree with that assessment. I've been using Vic's ND mod on my 54G-TM since it came out and it's been the most stable out of everything I've used. The ND drivers solved reboot problems I had in years past with regular Tomato and I was up close to 90 days uptime until we had a power outage in the middle of the night.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice