Newbie NTP failure

Discussion in 'Tomato Firmware' started by Philstix, May 26, 2009.

  1. Philstix

    Philstix Addicted to LI Member


    I'm a newbie with a new Linksys WRT54GL, and I updated the firmware to Tomato 1.24.

    I'm using the WRT54GL as a wireless access point only (ip, connected to a lan port ( on a PC running Smoothwall (running as a firewall, static dns, and web proxy - ip, which in turn is connected to the internet.

    As an access point the WRT54GL works perfectly, with the Tomato 'Default Gateway' and 'Static DNS' values set to, and I can access the internet from my laptop without any problem.

    The trouble is getting the WRT54GL to get the time from any NTP server - the time display in the admin gui always indicates 'not available'.

    I've read through all of the posts I could find on the subject, and nothing I've read there works for me, although much of it doesn't relate to my setup (and I haven't a clue what 'WET mode' means.)

    I've tried using different ntp servers, either pool addresses or specific ip addresses (eg, and it's always the same. By comparison, I can do a ntp update with Cyberkit on my XP machine ( wired to the Smoothwall box, and that works using the same NTP servers.

    I've telneted into the WRT54GL and tried the ntpsync command with all the different ntp servers, but nothing changed in the gui and there was no response in the telnet session (should there be a response?):

    # date
    Thu Jan 1 10:25:12 STD 1970
    # ntpsync

    On the Smoothwall firewall, I've enabled access to ports 37 (Time) and 123 (NTP) for both TCP and UDP from the WRT54GL ip, although I don't think that should make any difference.

    I've tried with the WAN port disabled, and also using it as the LAN connection.

    I've been at this for the best part of a day now, and I'm just about ready to give up, but I thought I'd risk annoying everyone with a plea for help. I've tried to give all the relevant info, but if there's anything more required please let me know.
  2. Philstix

    Philstix Addicted to LI Member

    Doh! I just realised (finally!) that I'd made a stupid mistake, setting the wrong ip for the default gateway - I should have been using, not - once that's fixed it all works ok.

    Sorry for my tunnel vision. Maybe it's time for a nap.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice