newbie problem: vpn - firewall

Discussion in 'Other Linksys Equipment' started by rdumee, Sep 14, 2004.

  1. rdumee

    rdumee Guest

    I have recently bought the wag54g. After installing it and seting up all the security issues it works perfect (I use an older firmware).
    I have a home netwerk with a desktop xp-pro (wired) and a laptop xp-pro (wireless).

    My problem is:
    Before I used the WAG54G I could make a vpn connection to my work, but now it doesn't work anymore. I use the vpn connection wizard of WinXP. When I turn off the firewall of the WAG54G the vpn connection works fine, but how will it work when I turn on the firewall.

    Can anyone help me. I have searched the internet everywhere, but I can't find any solution. Maybe I look at the wrong places.
  2. Toxic

    Toxic Administrator Staff Member

  3. komUnec8

    komUnec8 Network Guru Member

    I have the same issue. Tried my Cisco VPN client in my laptop over in-built wireless.11b client to the WAG54G, then over the ADSL link to my office network (PIX firewall). While this works fine over my previous dial-up modem/router (ACCTON IG1004) and aCisco 340 AP, it didn't work on the WAG54G with Firewall Protection enabledl (couldn't even contact my work gateway IP), but it 'sort of' did with the firewall protection off (tho' performance didn't seem too flash. Maybe an MTU issue?)

    I'd have thought I shouldn't need to configure a VPN tunnel on the WAG54G if I have IPSec passthrough enabled? I really need to terminate the VPN tunnel on my work laptop (policy!), not on the router. (By the by, the WAG54G seems to have both PPTP- and IPSec-Passthrough enabled at the same time by default. Is this correct?)

    Am going to do some more testing soon. Will advise results when known. In the meantime, tips/suggestions/tests to try welcome.
  4. komUnec8

    komUnec8 Network Guru Member

    Okay, here's what I've discovered.

    The "Block WAN Requests" tick box on the Security/Firewall page has to be cleared (i.e enable ICMP?) , then a VPN connection through the WAG54G/firewall to a client on the inside of your network works, even with Firewall Protection enabled. Great!

    However, what was also interesting is that it seems that when toggling between Block WAN requests ticked and unticked during my testing, it wasn't enough to just "Save Settings" between changes of that tick box. I also needed to "Disable the Firewall protection", (Save the settings), then re-enable the Firewall Protection (and save the settings again) to make the Block WAN requests changes stick. Don't know why, but it worked for me!?

    I have tested this both with a wireless (802.11b) client, and a wired client, and both work fine now. I was running Cisco VPN client 4.0.4 (D) on Win XP (without SP2 applied yet).
  5. komUnec8

    komUnec8 Network Guru Member

    Oh, and BTW, I am running firmware version 1.02.5 on the WAG54G!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice