NEWBIE PROBLEM - WAG54G LAN Ports not working.

Discussion in 'Other Linksys Equipment' started by craighann, Jul 30, 2005.

  1. craighann

    craighann Guest


    I'm a newbie to this forum, and i've had a look around and done a search but can't find any info about the problem I'm having.

    I've had a linksys wga54g wireless adsl router for around 18 months or so now. I used to have the problem other users have mentioned about the wireless connections dropping, and also Xbox live being unreliable, but I found these were fixed by upgrading the firmware to 1.02.1.

    The problem I've been having in the last few days is very odd. I was having trouble with XBox live, telling me the network cable was unplugged. So - I try a new cable. Still the same problem. I try a different port on the router. Same problem. My wireless was working OK from the 2 pcs in the house that use it, so I thought it was a problem with the NIC on my Xbox.

    I've just tried my laptop using the cat5 cable normally plugged into the xbox, and it doesn't pick up a connection. I'm not getting any lights either on the NIC of my laptop, or the router. I've tried another, completely different cable, into each of the 4 ports on the router, and I cannot get a wired connection to work into the LAN ports of the router!

    As I said, my wireless (802.11b) is working fine. I haven't made any configuration changes to the router (at least, not deliberately) so I can't see why the LAN ports aren't working.

    I'm reluctant to do a factory reset, or a firmware upgrade, as if it doesn't work, I'm not sure if I could then access the router wirelessly.

    Has anyone come across this problem? It's very frustrating - and I don't want to have to buy a new rounter!

    Not that it makes much difference - but my setup consists of WAG54G router on 1/2 meg PlusNet connection; PS2 and XBOX connected to LAN ports, Laptop connecting via 802.11b, Desktop PC connecting via 802.11g.

  2. BoomAM

    BoomAM Network Guru Member

    I had a similar problem the other day.
    Ive had my WAG54G since March 2004, i asume with how long ive had it, that its a Rev1.0, as the ways ive found to identify it, dont work.
    I had unplugged everything in my room, because i was doing an en-mass clean out, and after getting everything back up and running, my main PC struggled to connect for more than a few seconds at a time, most of the time not at all. Same with my iBook. But wireless connectivity was fine. Also, it wouldnt detect my ADSL line at all.
    After a few hours though, it went back to normal, and touch wood, its been fine ever since.

    If someone could explain what caused it, it'd be appriciated by me as well. :)
  3. frogmanxl

    frogmanxl Network Guru Member

    I have the same problem... Any additional tips?
  4. ddahaa

    ddahaa Network Guru Member

    Mine has suddenly stopped working too, just over the last couple of weeks! Wireless is fine but nothing can connect on the wired ports. Occasionally an activity light will give a quick flash but that's all. Think it's time to throw it in the bin unless anyone knows how to fix this?! I've tried a master reset but made no difference.
  5. DavidC

    DavidC Network Guru Member

    Don't forget these sweet little blue boxes have a THREE year warranty period!!!
  6. ddahaa

    ddahaa Network Guru Member

    I didn't know that but I've emailed linksys today so I'll see what happens!
  7. I have had the same problem since the begining of December. The one thing I have had sucess is forcing my laptop to connect to the LAN port at 10Mps instead of 100 or 1000. This works fine, but still does not solve my problem trying to connect an XBox 360 which does not allow me to switch the connection speed.

    I would be interested in any reply you get from Linksys, otherwise I will have to buy a new version of the unit.
  8. ddahaa

    ddahaa Network Guru Member

    Had a few emails from Linksys tech support and they advised me to try assigning a static ip to a pc with a wired connection, then upgrade the firmware which should sort it out. The static IP didn't work so I tried forcing the network card to run at 10Mbps half duplex and it connected ok.
    I have now tried 2 firmware upgrades but neither of them have been saved to the router! When upgrading I browse to the file and click upgrade, the bar goes across the screen twice, then on the third time I get page cannot be displayed and the router just sits there with the power and port 1 lights flashing. Power the router off and back on and it still shows the original firmware. Tried a factory reset but still the same. Any other ideas on how I can get this to upgrade?
  9. ddahaa

    ddahaa Network Guru Member

    I managed to get the firmware to upgrade after turning off my firewall, doing a factory reset the upgrading straight away. Still hasn't fixed the fault though so I guess it will be going back for a warranty return. I'll let you know what they say.
  10. Baldwing

    Baldwing Guest


    I thought I was the only one!! I've had my WAG54G since March 2004, all has been rosy - until about 8 weeks ago.

    The wireless part still works perfectly but the wired connections have really started to play up. I've had to upgrade the firmware several times (using the wireless via laptop) just to get the thing working again. It then works fine for a while and then stops talking on the wired ports...

    Also when the wired ports are working and I copy files from one machine to another it's pot luck as to what speed it will use.... a 170MB file could take 30sec, 8 minutes or 187 minutes.... I think it's time for a new one. Bought one of those new 'square silver' models for my parents and that works a treat, don't like to give up but have spent far too long trying to get it going!!

    I don't think it's a firmware issue, just something getting too hot maybe... oh well.. :thumbdown:

  11. DavidC

    DavidC Network Guru Member

    It has been widely recognised since V1.2 the WAG has a bit of a heat issue, V2 is however better than V1.2.
    I've had my V2 over a year now it is mounted on its side and hasn't skipped a beat, run on factory firmware until 2 months ago when I flashed the .22 firmware.
    Perhaps you could Try yours on it's side - if it isn't already of course!

    I would push for a replacement unit under warranty and stick with the WAG for a bit longer. The reason for this is Wireless kit is advancing quickly and in 6 months to a year we should have 'N' kit propper available. If you need advanced router functions you could use the wag as modem only (V2 is ADSL2+) and opt for a WRT type router with all the benefits it provides. This is what I will do - may be a Linksys router may not, I'll wait to see what is available at the time.
  12. ddahaa

    ddahaa Network Guru Member

    Mine is a V1, but I have it mounted so that air can circulate both underneath and above it. Tried it on it's side in the past but no better. It had been stable for a while until a few weeks before xmas. They have said they will replace it if this doesn't work, (and it hasn't) so I will contact them again later today to organise a replacement.
  13. Simon

    Simon Network Guru Member

    same porblem has just started with mine will not connect to the ports on the back either keeps dropping the line and pc reports cable unplugged. Have reset upgraded/downgraded firmware reset/reset/reset/reset/reset/reset/reset still the same. Did not know it had a three year warranty will be looking into that hopefully get shot of the useless piece of crap and get a newer model.
  14. 7ttman

    7ttman Network Guru Member

    Ethernet ports not working

    I had that problem and fixed it by setting my PC's and Mac's to 10mb full duplex. It seems that the autodetect of the speed stopped working.

    Now I've given up on two boxes due to the modem's dying. perhaps I should send them back, but after 2 years, I just can't find the purchase receipts.
  15. i get the same problem

    ive now got a 4 port hub between the router and the wired pc and a static ip address.

    ive got a connection, wether its constant or not is another matter, but the pc doesnt keep saying 'cable not connected' or whatever

    i'll try putting the wag on its side.

    quick question :
    has anybody had a look inside their router , seen if anything has burnt out?
  16. -BA-

    -BA- Network Guru Member

    Well I found this thread today and thought "Oh my god it's not just me!!!" I have never been truly happy with my WAG54G. The main problem I had was that I couldn't log into the router via the browser all the time. Sometimes it would bring up a "page cannot be loaded" screen and would require a hard reboot to sort it.

    However over the last two weeks my server on number 2 port started dropping the connection every now and then. Today my main machine decided to do it and a hard reboot of the router killed it for good. I rang Linksys and they too said set the machines to 10mbit half duplex. This has seemd to sort the problem but I can only feel it is a compromise. Things don't seem smooth and trying to install a small application over the network took forever.

    I was extremely pleased to see someone type that there is a 3 yr warranty on linksys products and I have found my emailed receipt/order confirmation. Would I have had to actually registered the product for warranty with Linksys to qualify?

    Whilst it is working for the time being I can't help but feel that the end is somewhat nigh for this router. Let's hope I can get it exchanged for a version 2.0 (current is 1.2)
  17. dannyboy1121

    dannyboy1121 Network Guru Member

    eeek .. that doesn't sound good. Surely nobody wants to be running on half duplex 10mb. Component burnout surely?

    I'll never forget at work about a year after we rolled out some servers we started getting resets all over the shop. We crawled all over the OS and firmware looking for clues - only to find out that a component of the motherboard was leaking electrolyte in each case. As I understand it - the manufacturer had sourced a whole batch of components from a company who - unknown to the board manufacturer - had actually pinched the design of the component and got it wrong - hence the malfuction.

    Anyway - in this case, if the ports keep playing up (after having worked well for a number of months) then I'm not sure I would waste any time playing with the firmware.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice