No default routes in RV082 with public IP subnet of

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by andypg, Apr 5, 2008.

  1. andypg

    andypg Addicted to LI Member

    I have am200s (19.02 firmware) in half bridge mode connected to rv082s (1.3.6 firmware). The RV82 gets a public IP/subnet, default gateway, DNS ok but does not create default routes in the routing table so cannot access the internet.

    RV082 gets from BT Broadband line (PPPoA so I have to use AM200 half bridge?) a dynamic IP etc:

    Public IP:
    Subnet Mask:
    Default Gateway
    DNS 194…. and 62…..

    It then produces a Routing Table List with NO default entries, ie:

    Destination IP Subnet Mask Default Gateway Hop Count Interface * 50 ixp0 * 40 ixp2

    If I connect to a pipex service with a subnet (or a BT test login with subnet the rv082 gets:

    Public IP:
    Subnet Mask:
    Default Gateway
    DNS 212…. and 212….

    and produces a routing table like:

    Destination IP Subnet Mask Default Gateway Hop Count Interface * 50 Ixp0
    default * 40 ixp1
    default 40 ixp1

    The problem appears to be due to the subnet mask on the public IP address being and I’ve seen posts about routers expecting the gateway to be within the ‘network’ defined by the public IP and its subnet mask.

    Does anyone know a solution to this?
    Is it possible to get the AM200 to send the RV082 a subnet of whatever the ISP sends out?
    Is there any fixes for the RV082 or any way of adding the default routes?

    Any help will be much appreciated.
  2. blake_

    blake_ LI Guru Member

    Well isn't a valid subnet mask for starters, is it?
  3. andypg

    andypg Addicted to LI Member

    I am most definitely not a network expert (didn't know what a subnet mask was till about a week ago) just trying to get the service up and running so apologies for any errors/misconceptions.

    The rv082 shows a subnet of both in the log/system statistics table and in the routing table for the pipex service which works ok and I also saw it with the BT test login which worked to some extent.

    I have seen several posts on this forum eg 56954 and others about problems on linksys and netgear routers working with modems in half bridge mode on PPPoA lines particularly when they get a subnet mask and the WAN gateway isn't in the network defined by the public IP and netmask.
  4. mstombs

    mstombs Network Guru Member

    Yes, sorry, I can't help posting about this! It is about time Linksys router firmware engineers spoke to their modem colleagues. The full netmask is the correct netmask for a single IP at the end of a tunnel, and is not a problem with windows XP or recent Linux distros. In Linux based routers it can easily be fixed by the addition of a route command in the right place.

    On BT broadband you can try using the modem in pppoe full bridge, it may work.
  5. blake_

    blake_ LI Guru Member

    Can't you just view the routing table of your modem when it's connected on its own and then just add static routes into the Linksys to match?
  6. andypg

    andypg Addicted to LI Member

    Thanks, yes I've seen a lot of posts of people with similar problems in the UK and NZ (a good number you've [mstombs] helped!) with PPPoA going back a long time and I suspect the Linksys engineers would have fixed it by now if they lived in either country?? I tried a WRVS4400N before this where Linksys Support thought the latest firmware fixed the problem but it didn't. Got it working with an AM200 with their help using a DMZ connection but you then can't create VPN gateway to gateway tunnels (my main abjective) because it takes the modem IP instead of the public IP in the VPN tunnel setup and its not editable.

    I've tried the full bridge + PPPoE on the RV082 several times and it won't work. The rv082 will not connect/get a public IP even though the AM200 still seems to connect by itself as the internet light is on. I don't know whether that is uk wide now (as BT say the don't support PPPoA) or particular to the exchange.

    With help from this forum I have managed to Telnet into the RV082 console OpenRG command line also BusyBox shell?, so would it be possible to fix it with some programming?

    You can view the routing table on the modem and you can add static routes but I'm not sure what to put in. I don't think it would work because I believe the whole reason for the half bridge mode on the modem is to get the public IP address on the wan port of the RV082 which you have to do if you want to get VPN gateway to gateway tunnels to work. As above, the IP is not editable in the VPN tunnel set up so if you end up with the modem IP instead of the public IP your scuppered.
  7. mstombs

    mstombs Network Guru Member

    I don't know anything about RV042/82 or openrg, but I can fix the routing issue in a WRT54GL range router running Hyperwrt Thibor and/or Tomato with scripts in this thread.

    In dual WAN not sure you can dual default gateways?

    It the WRT54GL case the router firmware tries to run the default route command without first defining a route to the gateway, hence my comment that they need to add one route command in the right place (someday I will try to pach the c-code, but the firewall script is a 100% fix for me)

    These are the important lines adding the route and repeating the default

    route add -host $GW dev $IF
    route add default gw $GW
    where $GW is the Ip address of the gateway, $IF is the WAN interface name which appear to be "ixp2" in your example above.

    The other bits are to make sure the route table is cleaned up if the gateway changes.

    [I can also workaround the problem by "spoofing" the netmask and/or gateway in my Linux adsl 'router' running RouterTech firmware].
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice