No DHCP with WEP activated

Discussion in 'Cisco/Linksys Wireless Routers' started by Kurso, Jan 2, 2006.

  1. Kurso

    Kurso Network Guru Member

    I have a very odd issue with my WRT54GS v2 (Linksys Firmware 4.70.6)

    Everything on the wired LAN receives DHCP just fine. But I have 3 wireless laptops, 2 of which can't receive DHCP.

    The first laptop is a Thinkpad with a Cisco wireless card running the latest ACU. The wireless is handled by ACU rather than windows and works just fine.

    The two other laptops are Compaq and Dell. These two have G cards in the where as the Thinkpad is B only. The wireless config is handled by Windows. These two machines can't get DHCP via wireless but can via wired.

    I tried running the two laptops in G and B. They connect to the wireless network with very good strength but never get an IP address. I triple checked the WEP key but seeing how I connect to the AP I don't think the key itself is the issue.

    If I disable wireless security I get DHCP to all three just fine.

    All three of these machines were running fine on a Netgear router with WEP running earlier today.

    Anyone else seen this issue?
  2. Chuck_IV

    Chuck_IV Network Guru Member

    I had this same issue with my Compaq Laptop. If I allowed windows to do the connecting, without security, I could connect and get an ip just fine, but as soon as I enabled WEP, while I could connect, it would never receive an ip address.

    To fix it, I loaded the broadcom wireless utility(since I have a broadcom G card) and let it handle the connection, instead of windows. As soon as I did that, it worked fine. It also gives me the option to use WPA(PSK) security and thus what I use now.
  3. Kurso

    Kurso Network Guru Member

    Thanks for the reply. I'll try to use the wireless card manufacturors software on both machines.

    If this actually helps then thier is an obvious next question. What is causing the issue? Linksys or Microsoft?

    If WEP was working on these two machines with Netgear and now does not work with Linksys then I would assume this is a Linksys issue. But you never know with Microsoft, they could be doing something slightly non-standard and mucking things up.

    Maybe it's time to break out Ethereal and crack open some packets. :(
  4. Kurso

    Kurso Network Guru Member


    The problem was between the chair and the keyboard. :(

    I swore I wrote down the WEP key in Index 3 but I wrote down the Index 4 key. The mismatch Key Index cause it.

    When the authentication takes place it was using the right key, which is why I could connect to the access point, but once past the authentication phase all packets coming back were labeled with key index 4 (which was a blank entry in my config). I switched the Key Index and it's working great now.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice