No DHCP with wep enabled v5

Discussion in 'Cisco/Linksys Wireless Routers' started by Joburgtaxi, Jan 15, 2006.

  1. Joburgtaxi

    Joburgtaxi Network Guru Member


    I have just replaced my wrt54g v4 with the new v5.

    nothing on the network has changed except the replacement v5 router but now if I enable WEP I am unable to get a DHCP address from my windows 2003 server or from the DHCP on the router. Even the wired workstations connected to the router dont get a DHCP address when WEP is enabled.

    I have tried to disable/enable DHCP on the router but still the same no DHCP address if WEP is enabled.

    I do get a connection to the router but just no IP address is issued.

    please help !!!
  2. Kurso

    Kurso Network Guru Member

    Make sure your WEP key index that you are using on the router is the same key index as the one configured on the machine.
  3. Joburgtaxi

    Joburgtaxi Network Guru Member

    Thanks for the reply

    I have made sure that the key is the same on both the riuter and on the workstaion, I have also tried all keys 1 to 4 with the same results.
  4. Subah

    Subah Network Guru Member

    Do you upgrade the router ?
  5. jgutz20

    jgutz20 Network Guru Member

    So does the DHCP work when WEP is disabled? or the wireless broadcasting in general disabled?
  6. Joburgtaxi

    Joburgtaxi Network Guru Member

    Thanks again for the replies.

    Ok in answer to both questions... Yes I have re applied firmware 1.00.4 twice now and the answer to the other question is yes when WEP is disabled, DHCP works to all devices wireless and wired. As soon as WEP is enabled the workstations can connect to the router but only get a partial connection as no DHCP address is issued.

    I sent an email to Linksys tech support and got the following reply, all of which I have tried.

    Thank you for contacting Linksys Technical Support.

    The WEP will only secure the wireless connection within your network. If you input a wrong network key, the router will not provide a valid IP address to the computer. However, it should not affect the connection of the wired computers. The wired computers should still obtain an address from the router regardless of the wireless security.

    We have not received similar case with the Linksys WRT54G v5. You may consider re-flashing the router’s firmware, reset it and then reconfigure the router. You may download the latest the firmware from then select the model number with its corresponding hardware version from the list. We can upgrade the router's firmware in two ways, either using the router's web interface or by using an upgrade utility. Kindly refer to the instructions below:

    Using the web interface:
    1. With the computer that is wired directly to the router, open Internet Explorer then type in the address bar (Enter admin for password and leave the username blank. You may have changed the password if it will not accept the admin password).
    2. Go to Administration tab then click on Firmware Upgrade sub-menu.
    3. On the Firmware upgrade window, click on the firmware file (that should be the .bin file that you have downloaded from the website).

    Using upgrade utility:
    1. Go to then save it to your computer.
    2. With the computer that is wired directly to the router, run the tftp.exe program. It will ask for server (which is, and password (which is admin or the password that you set when you first install the router).
    3. For the File, click on the (...) button then browse the .bin file that you have downloaded from the website.

    It is recommended to reset the router every firmware upgrade to make sure that the firmware was loaded successfully. Be sure to make note of the current configuration for resetting the router will reset the settings back to its default settings.

    Kindly do the following to reset it:
    1. Press and hold the reset button for 10 seconds.
    2. Unplug the power.
    3. Wait for 30 seconds.
    4. Power on the router.

    To reconfigure the router, if your computer is running on windows XP, you can try configuring the router using our online tool by just going to then download NetSet Assistant. If the online tool fails, you can configure the router manually. While plugged into the provider modem unit and able to get online, visit, and search for the name of your Internet service provider for detailed instructions on manual configurations.

    Give us a feedback if the problem still occurs so that we can provide further troubleshooting if needed.

    If you have any further questions, feel free to visit our knowledge base at or send us an e-mail at so that we can assist you.

    Thank you and have a nice day.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice