No JFFS on Shibby 1.28

Discussion in 'Tomato Firmware' started by Magnumb, May 10, 2013.

  1. Magnumb

    Magnumb Reformed Router Member

    Why is there no JFFS configuration options in Shibby 1.28?
    My router is only using 34MB of the 128MB total flash.
    Can't I use the remaining free flash for JFFS?

    Thanks for the help.
  2. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

  3. shibby20

    shibby20 Network Guru Member

    128MB well it must be Netgear 3500L v2 with NAND flash. This is why JFFS is not supported by tomato installed on thid router.
  4. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    It's actually worse than that - JFFS has to live between the end of the kernel/rootfs and end of partition - mtd14 is only 28MB long. So you can't even use 100MB of it :)

    I don't think the nand flash support in Tomato is as good as it could be. For one thing, it doesn't appear to be able to detect/cope with bad blocks in the nand memory, whereas the latest Netgear firmware can. In my limited experience, this can cause the firmware upgrade page to fail. Monitoring the boot log shows nand bad blocks on my unit but worn areas are expected, in fact some are marked worn from manufacture.

    I tried to upgrade the mtd/nand support in Tomato a week or so ago, but I know so little, and this goes so far into the kernel that I just broke everything instead.

    I do wish WNR3500Lv2 support was better, it's quite mad for a router that was advertised as 'open source' to have such poor support across pretty much all the router projects out there. At least Tomato has tried.
  5. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    Also, when I save a native firmware config file I receive a 64K file, which suggests to me that up to 64K of NVram is possible.
  6. RMerlin

    RMerlin Network Guru Member

    I implemented bad block support in the mtd-erase code of Asuswrt-Merlin. This was required to format the JFFS partition on the RT-AC66U. If anyone is interested in porting this to Tomato in prevision to future RT-AC66U support as well as any other similar NAND, just let me know and I'll dig out the commits for it.

    For the kernel level support, you might need to look at the code Asus added to their kernel for the RT-AC66U. Definitely not trivial, I agree. But at least updating mtd-erase might be a starting point.
  7. shibby20

    shibby20 Network Guru Member

    i tried do jffs on 3500Lv2 once and i brick my router to dead. Even leds was not light ;) I will not do this on another router. Jffs is not "must have" things because this router has USB port. Jffs makes also problem when you want update tomato - it must be disabled.
  8. Magnumb

    Magnumb Reformed Router Member

    Third router? I don't know what this means.
  9. Magnumb

    Magnumb Reformed Router Member

    I was able to create a 17th partion (50MB) above rootfs but I could not mount a file system on it. I could read it ok though.
  10. Magnumb

    Magnumb Reformed Router Member

    My router shows nrram as 1.5MB: 0x00080000-0x00200000 : "nvram"
  11. Malitiacurt

    Malitiacurt Networkin' Nut Member

    Stick a USB HD/flash drive in it. Shibby already lost a router trying to do it, he's not gonna keep going.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice