No more Downloads after DD-WRT ! This is NOT TRUE !!!!

Discussion in 'DD-WRT Firmware' started by 4EverGreen, Jan 2, 2006.

  1. 4EverGreen

    4EverGreen Network Guru Member


    I've just bought one WRT54GS_EU v4 with stock firmware v1.05.03.
    I connected it to an ADSL modem D-Link DSL-300T.
    Tested it and everything worked OK (LAN, WLAN and Internet).

    As I need WDS to wireless link it to another wireless router, and after reading so many good things about DD-WRT in these forums, I flashed it with the DD-WRT v23 Final (25-12-05) following all the advised steps :
    - reset to factory defaults before and after every flashing.
    - First loaded the mini version of DD-WRT.
    - Only then loaded the standard version of DD-WRT.

    All the flashing went without any problems.
    After this, and with DD-WRT's default configuration, everything's working fine except for file downloads ...

    Everytime I try to download any file ( either from a wired or from a wireless box), the downloads starts but after 5 or 10 seconds (lets say after +/- 0,5 MB) there is no more network traffic and it just stays there forever .... it doesn't freeze, it doesn't hang, just stays there like it's sleeping ...

    If I cancel it and start the download again, it will start from were it was when I cancelled it, but it stops again the same way before ...
    To finish a file download I just have to repeat this procedure until it finishes.

    I've already searched this forums from back to front but found nothing similar.

    Did anyone ever run into this ?

    Maybe I'm missing something, but honestly don't have a clue of what might be ...

    I really appreciate somebody to help me on this, once I do need DD-WRT and would like to keep it instead of rolling back to the Linksys firmware.

    Many thanks.
  2. mazilo

    mazilo Network Guru Member

    Nope, but my cablemodem download speed seems to increase about 2% after flashing my WRT54GS v3 with DD-WRT+VoIP.
  3. sufrano63

    sufrano63 Network Guru Member

    two things you can do to try to narrow it down the problems.

    1. take the router out of the setup and connect directly to your modem and try the download again?

    2. try downloading a diff file from a diff location. It could be the file you're trying to download and the site itself.

    Just my .02 cent

    Sounds to me you did everything correctly with the dd-wrt flashing.

    good luck
  4. BrainSlayer

    BrainSlayer Network Guru Member

    and try to disable STP which is a common issue with various cable modem providers
  5. 4EverGreen

    4EverGreen Network Guru Member

    I'm sorry for my poor detailing ... :oops:

    My Network :

    ADSL line ( 512 Kb Downstream / 128 Upstream :sad: .... No need to say it !.. I know ... )
    ADSL Modem D-Link DSL 300T (
    WRT54GS v4 with fw DD-WRT v23 Final (12-25-05) (
    LAN & WLAN

    sufrano63 :

    1. I had already done it and noticed that the problem is fixed ... that's why I'm sure it has to do with the WRT.
    2. I also tried downloading from other sites. No success. The problem remains.

    BrainSlayer :

    Tested just now after disabling STP and the problem also remains.
    Care to explain what STP is ? (I'm new to this ...)
    Nevertheless my provider is ADSL not Cable.

    Aditional details :
    1 - When I'm connected through the ADSL modem everything's OK.

    2 - When I'm connected through the WRT54GS v4 the problem is not just the downloads .... I started a continuos ping to and I'm getting 4 to 10 timeouts in each 13 to 20 replies .

    As I know the router's good ( I tested it before loading DD-WRT ), it has to be something that I'm missing to setup properly.

    Just don't know what :sad:

    Nevertheless, many thanks for trying to help me ! :thumb:
  6. 4EverGreen

    4EverGreen Network Guru Member

    I've just bricked my WRT54GS v4 ... :sadbye:

    Don't quite know what happened ...
    I decided to start again so I reseted it to factory defaults from the Web GUI, then unpluged and then pressed the reset key for 30 seconds while pluged again.
    The power led doesn't stop blinking and the 4 port's leds + internet led stay on.

    Went through the revival guide and did the whole thing (several times).
    Just not sure what are the correct pins for the WRT54GS v4 because the guide just mentions v1.0 & v1.1. Nevertheless I tried them all !...

    It's late ... I'm tired and I must get up early and go to work!

    I'm gonna put the WRT in the box and I'm going tomorrow to the store and try to replace it.

    With some luck (and I'm not having much lately ...) maybe I'll start it all over with a new one tomorrow night.
  7. 4EverGreen

    4EverGreen Network Guru Member

    Yes ! :cheer: My luck is changing !
    I just got my bricked WRT54GS v4 replaced in the store ... I just couldn't believe that the guy didn't even open the box !!

    Yesterday's gone and today is another day !

    I'm so happy and self-confident, that I decided to start it all over again.

    I've done a lot of reading in these forums in the last couple of days.

    One thing I learned was that there is no reason for me not to trust DD-WRT v23 and BrainSlayer. On the contrary, I bet that almost all of the bricking that has been happening was due either to not following the flashing instructions properly or because trying to load incorrect firmware versions for that specific router version.

    Another thing I learned was that, probably my WRT was bricked by me when I did a reset in a wrong way (still don't know what went wrong ...). For sure it had nothing to do with DD-WRT v23 once all the flashes I made were successful and without any problems and the firmware was up and running (besides the timeouts problem ...).

    So, this night I'll give it another try because I really want my router with DD-WRT.

    When I'm there again, and because there is no reason for me not to expect the same timeouts problems, I'll try to make some tests and collect more data/details in order to troubleshoot it.

    Just one question before I do it.
    When the time comes to upgrade with DD-WRT what is the best option in the end :
    - Firmware defaults or Factory defaults ?

  8. 4EverGreen

    4EverGreen Network Guru Member

    :cheering: I'm back in business !!!

    I've just changed this topic's title immediatly after I discovered what I was doing wrong .... :wallbang:

    Like I told in my previous post, I was sure (almost at least ...) that the problem wasn't DD-WRT, but more with something that I was missing. :unsure:

    As soon I got home I took the brand new WRT54GS v4 out of the box, and started it all over again (I was hungry for it ...) ! :punch:
    After making all the flashes, started the testing.
    As expected (because I repeated all the steps taken with the bricked WRT) the timeouts were there.
    Made a deep review of all the configuration values and everything seemed to be OK (to my eyes ate least...).
    I couldn't stop looking at the perpetual ping to internet ... that strange pattern of sets of +/- 10 timeouts at the end of each set of +/- 15 successful replies ...
    Hummmmm .... :???: It started to smell to routing problems !
    Perhaps I was not setting the Modem & WRT IPs as I should ...
    Back to LinksysInfo forum and made a few more searches about routing and Modem + Router configurations.
    And it was only when I was reading a post where someone asks support because he/she can't 'see' the modem behind the router, that I suddendly remembered !!!
    How could I forget ? :knock: I had already this problem in the past ...
    The proposed IP's were for the Modem and for the router. But, last month when I tried this with the same Modem but with a WRT54G v5 (already gone to the store) it didn't work ... and I discovered at that time that if changing the WRT's IP to it worked OK ... I could reach the modem !

    So, as soon as I changed my WRT54G v4 with DD-WRT v23 Final (12725/05) to , everything started working fine, no more timeouts, no more problems ! :cheering:

    I can't believe .... I finally have my DD-WRT going ! :thumbup:

    Just a last note to apologize to all the guys that I made lose their time reading this post because a stupid mistake of mine ...

    And a special apologie to BrainSlayer for posting a misleading topic ... :bow:

    P.S. - Indeed is really awesome ! :clap:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice